You are not logged in.

#1 2010-12-07 21:52:10

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,372

[Solved] Update error "usbmuxd: requires libusb1>=1.0.8"

Atempting to upgrade fails with the following

:: Starting full system upgrade...
:: Replace libusb1 with core/libusb? [Y/n] 
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: usbmuxd: requires libusb1>=1.0.8

Happens on both x86_64 and i686 systems

Last edited by skunktrader (2010-12-07 22:32:49)

Offline

#2 2010-12-07 21:58:16

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [Solved] Update error "usbmuxd: requires libusb1>=1.0.8"

skunktrader wrote:

Atempting to upgrade fails with the following

:: Starting full system upgrade...
:: Replace libusb1 with core/libusb? [Y/n] 
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: usbmuxd: requires libusb1>=1.0.8

Happens on both x86_64 and i686 systems


forum is not the bugtracker.  somebody forgot to move the package out from testing

FIXED

Last edited by wonder (2010-12-07 22:00:49)


Give what you have. To someone, it may be better than you dare to think.

Offline

#3 2010-12-07 22:12:46

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,281

Re: [Solved] Update error "usbmuxd: requires libusb1>=1.0.8"

I experienced the same problem. Thanks for the info. For the time being removing libgpod (which requires usbmuxd) helped as a workaround.

Nevertheless, I was glad someone asked in the forum (and there was an answer). If only to know you are not alone. wink

Last edited by bernarcher (2010-12-07 22:13:24)


To know or not to know ...
... the questions remain forever.

Offline

#4 2010-12-07 22:24:03

hoobastank
Member
Registered: 2010-03-30
Posts: 86

Re: [Solved] Update error "usbmuxd: requires libusb1>=1.0.8"

But these packages is needed for rhythmbox so if you want to install rhythmbox, it enforces to install libusb1 not libusb package. on the other hand both of them are the same package, That's why there is a conflict when isntalling rhythmbox via pacman for now.

if you have rhythmbox as i have, to update entire system you have to remove rhythmbox

Offline

#5 2010-12-07 22:27:02

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [Solved] Update error "usbmuxd: requires libusb1>=1.0.8"

hoobastank wrote:

But these packages is needed for rhythmbox so if you want to install rhythmbox, it enforces to install libusb1 not libusb package. on the other hand both of them are the same package, That's why there is a conflict when isntalling rhythmbox via pacman for now.

if you have rhythmbox as i have, to update entire system you have to remove rhythmbox

stop talking none sense and wait a bit more.

rhythmbox->libgpod->libimobiledevice->usbmuxd -1.0.6-2 -> libusb 1.0.8


Give what you have. To someone, it may be better than you dare to think.

Offline

#6 2010-12-07 22:32:18

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,372

Re: [Solved] Update error "usbmuxd: requires libusb1>=1.0.8"

Fixed now.  Thank you very much wonder.  You are wonderful

Offline

#7 2010-12-07 23:00:08

hoobastank
Member
Registered: 2010-03-30
Posts: 86

Re: [Solved] Update error "usbmuxd: requires libusb1>=1.0.8"

wonder wrote:

stop talking none sense and wait a bit more.

rhythmbox->libgpod->libimobiledevice->usbmuxd -1.0.6-2 -> libusb 1.0.8

I'm waiting but why am i still getting this error

pacman -Sy usbmuxd

....
usbmuxd: requires libusb1>=1.0.8

i've already libusb 1.0.8 not libusb1

pacman -Ss libusb
core/libusb 1.0.8-1 [installed]

Do u have an idea? I want to install rhythmbox but i cant do because of usbmuxd and libusb.
is it still nonsense? i appreciate your working but u can be more polite.

Last edited by hoobastank (2010-12-07 23:10:36)

Offline

#8 2010-12-07 23:10:33

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,372

Re: [Solved] Update error "usbmuxd: requires libusb1>=1.0.8"

Your mirror has not yet updated.  Either switch to an up to date mirror or wait a while

Offline

#9 2010-12-07 23:12:07

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: [Solved] Update error "usbmuxd: requires libusb1>=1.0.8"

Update your mirrors. usbmuxd 1.0.6-2 should require libusb not libusb1.

Offline

#10 2010-12-07 23:39:00

hoobastank
Member
Registered: 2010-03-30
Posts: 86

Re: [Solved] Update error "usbmuxd: requires libusb1>=1.0.8"

Thanks, approximately 15 mirror servers which are frequently updated were enabled in my mirrorlist. anyway i added new mirror server from Romania because of wonder and problem was solved.

Offline

#11 2010-12-07 23:42:41

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [Solved] Update error "usbmuxd: requires libusb1>=1.0.8"

hoobastank wrote:

Thanks, approximately 15 mirror servers which are frequently updated were enabled in my mirrorlist. anyway i added new mirror server from Romania because of wonder and problem was solved.

doesn't matter if you have 10000000 servers enabled or one. the only that matters is the first entry.

Last edited by wonder (2010-12-07 23:43:07)


Give what you have. To someone, it may be better than you dare to think.

Offline

#12 2010-12-08 00:26:07

hoobastank
Member
Registered: 2010-03-30
Posts: 86

Re: [Solved] Update error "usbmuxd: requires libusb1>=1.0.8"

my mistake sorry .. i misunderstood wonder's saying above.

Last edited by hoobastank (2010-12-08 01:33:50)

Offline

#13 2010-12-08 00:28:59

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: [Solved] Update error "usbmuxd: requires libusb1>=1.0.8"

wonder is talking about the entries in the mirrorlist.

Offline

#14 2010-12-08 01:29:54

hoobastank
Member
Registered: 2010-03-30
Posts: 86

Re: [Solved] Update error "usbmuxd: requires libusb1>=1.0.8"

Well, so why was the problem solved when i enabled new mirror from Romania, you know Romania begins with R which isnt first entry in the mirrorlist?
does it consider first entry and then so on or last changed package between all the mirrors?

i just want to learn how it's working?

Offline

#15 2010-12-08 01:39:27

Allan
Member
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,919
Website

Re: [Solved] Update error "usbmuxd: requires libusb1>=1.0.8"

I guess the mirror that you were using synced during the time period you added the new mirror...

Offline

#16 2010-12-08 02:54:41

Sarai
Member
From: Alaska
Registered: 2010-02-20
Posts: 62

Re: [Solved] Update error "usbmuxd: requires libusb1>=1.0.8"

Thanks for the quick fix, you guys are great!

Offline

#17 2010-12-08 16:56:02

brk3
Member
Registered: 2010-12-08
Posts: 2

Re: [Solved] Update error "usbmuxd: requires libusb1>=1.0.8"

(Deleted post, needed to run pacman -Syu)

Last edited by brk3 (2010-12-08 17:02:34)

Offline

Board footer

Powered by FluxBB