You are not logged in.

#1 2010-12-13 06:04:13

Kirodema
Member
Registered: 2010-01-08
Posts: 81

[kinda SOLVED] Impressive stopped working a while ago

Hi,

a few weeks ago, impress!ve was updated and last week I wanted to use it, but somehow it is broken (I installed it from the community-repo and I am not sure if its really the update from that package but python?). Sometimes I make presentations with the LaTeX-beamer class and to present them, I normally use impress!ve, but somehow it doesnt recognice any pages? Here the message:

db@kirodema ~/Schule/D/brenner $ impressive presentation.pdf 
Welcome to Impressive version 0.10.3
Detected screen size: 1280x800 pixels
Warning: The input file `presentation.pdf' could not be analyzed.
The presentation doesn't have any pages, quitting.

Additional Info: a friend of mine uses Ubuntu and it works fine (same pdf, but impress!ve 0.10.2). I copied his impress!ve binary to my laptop because as far as I know it really just consists of one file + dependencies, corrected the first line to "#! /usr/bin/env python2" and got the same error after using it.

Last edited by Kirodema (2010-12-14 05:56:55)

Offline

#2 2010-12-13 07:38:34

Vrob
Member
Registered: 2007-12-07
Posts: 34

Re: [kinda SOLVED] Impressive stopped working a while ago

I have the very same problem. I think it's related to our LaTeX package, producing incompatible binaries (which does not mean, that TexLive is broken, but just, that the two might be incompatible). I tried a freshly created PDF File created with LaTeX Beamer, which produces the same error as you got, but when I tried an old PDF (also LaTeX Beamer) that was still flying around on my harddisk, it worked fine.

It seams that our TexLive produces PDF v 1.5, while it used to produce PDF  1.4, with the latter one working with impressive.

Greets,
Vrob

Offline

#3 2010-12-13 09:32:31

Jamesbond
Member
Registered: 2007-09-29
Posts: 7

Re: [kinda SOLVED] Impressive stopped working a while ago

I had the same problem as you but I found a workaround. One can define the PDF Version that shall be produced via TexLive. To do so you only have to add the following code on top of your beamer tex file:

\pdfminorversion=4

This tells TexLive what PDF version shall be produced. In this case PDF v 1.4 is produced. If you want PDF v 1.5 just replace number 4 by 5.

By this I got impress!ve working with my beamer presentation.

Greetings,
Markus

Last edited by Jamesbond (2010-12-13 12:32:28)

Offline

#4 2010-12-13 10:27:12

Kirodema
Member
Registered: 2010-01-08
Posts: 81

Re: [kinda SOLVED] Impressive stopped working a while ago

Cool, that works, thank you. But it doesnt explain, why my friend can use impress!ve with my 1.5 pdfs?

Offline

#5 2010-12-13 11:06:00

Jamesbond
Member
Registered: 2007-09-29
Posts: 7

Re: [kinda SOLVED] Impressive stopped working a while ago

I guess that depends on the images that are being used in the beamer presentation.

I was working on a presentation, tested it with impressive and it worked (compiled with PDF v 1.5). Then same days later I continued working on that presentation, adding new slides and some pictures. After compilation (still  PDF v 1.5) it didn't work with impressive anymore.

My assumption is that the compability between the PDF Version of the presentation and impressive depends on the images used in the presentation.

If the images are PDF files (build with PDF v 1.4) and the presentation is build with PDF v 1.5 then it will work with impressive. But if only one PDF image is build with PDF v 1.5 then it won't work with impressive.

Last edited by Jamesbond (2010-12-13 11:10:08)

Offline

#6 2010-12-13 12:14:11

Vrob
Member
Registered: 2007-12-07
Posts: 34

Re: [kinda SOLVED] Impressive stopped working a while ago

Hey,

if you want to use pdflatex and beamer (which is my case), the pdfminorversion-command does not work.
But you can still get compatibility with impressive if you load the pdf14 Package _before_ the documentclass is set, eg.

\RequirePackage{pdf14}
\documentclass[]{beamer}

Greets,
Markus

Offline

#7 2010-12-13 12:31:57

Jamesbond
Member
Registered: 2007-09-29
Posts: 7

Re: [kinda SOLVED] Impressive stopped working a while ago

Actually I am using pdflatex and beamer with the pdfminorversion-command and it does work fine here.

The placement is the same as in your code example Vrob, the command has also to be placed _before_ the declaration of the documentclass as the first command in the *.tex file.

\pdfminorversion=4
\documentclass[...]{beamer}

Greetings,
Vrob

Last edited by Jamesbond (2010-12-13 12:33:37)

Offline

#8 2013-05-01 04:34:40

joon
Member
Registered: 2013-05-01
Posts: 2

Re: [kinda SOLVED] Impressive stopped working a while ago

I'm not using arch, but in both openSUSE and Windows cases this problem seems to be caused by a bug in pdftk. Specifically, 1.45 version has this bug. If you downgrade pdftk to 1.44, the problem should go away. (Verified in both openSUSE and Windows)

Offline

#9 2013-05-01 05:43:44

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 6,774

Re: [kinda SOLVED] Impressive stopped working a while ago

Closing as being very old. Frankly if pdftk still hasn't been fixed by now (2 years later) you may want to consider alternatives.


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

Board footer

Powered by FluxBB