You are not logged in.

#1 2008-09-28 15:40:24

From: France
Registered: 2007-07-02
Posts: 25

[OpenBox] making an exception to the ToggleShowDesktop command


I put Urxvt in the background of my desktop, just as it is said in the Tips and Tricks part of the openbox' s wiki page.

But when I use the ToggleShowDesktop command, it minimizes the Urxvt window too, thing that I don't want it to be.

Is there a way to make this window persistent to the ShowDesktop command ?

Thanks a lot !


#2 2008-11-04 18:54:59

From: Bassano del Grappa, ITALY
Registered: 2006-01-11
Posts: 913

Re: [OpenBox] making an exception to the ToggleShowDesktop command

I would be highly interested to know this. Actually ToggleShowDesktop minimizes also the panel (at least lxpanel), including the button which would be expected to deminimize everything. If someone is using an app which escapes from the massive minimizations perhaps we could have an hint.

Last edited by patroclo7 (2008-11-04 18:55:54)

Mortuus in anima, curam gero cutis


#3 2008-11-04 20:20:29

Registered: 2007-05-20
Posts: 1,411

Re: [OpenBox] making an exception to the ToggleShowDesktop command

xfce-panel is not minimized when ToggleShowDesktop is used, neither is conky.

From conky config:

own_window yes
own_window_transparent no
own_window_type desktop
own_window_hints below,undecorated,sticky,skip_taskbar

One idea would be to use something like devilspie to assign different roles to terminal (like "dock") to see if this changes how it is affected by ToggleShowDesktop action.

Last edited by fwojciec (2008-11-04 20:28:01)


#4 2008-11-30 16:20:10

Registered: 2007-04-18
Posts: 22

Re: [OpenBox] making an exception to the ToggleShowDesktop command

Bumpy bump.

I'm also having this problem, has anyone made any progress on this? I'm using devilspie like suggested above, trying all the 'wintype's, including desktop - which is what my conky uses (works fine), but it doesn't stop gnome-terminal from minimising when ToggleShowDesktop is used. Surely there are people who have overcome this? I thought having a terminal stuck to the desktop is a pretty common thing. Thanks for any help.

This is my devilspie config. It's doing everything else I'm asking of it correctly.

    (matches (window_name) "MPDdesktop")
        (wintype "desktop")

Last edited by ilovefridge (2008-11-30 16:23:59)


#5 2009-06-13 01:39:27

From: Germany
Registered: 2009-06-03
Posts: 87

Re: [OpenBox] making an exception to the ToggleShowDesktop command

I'm sorry to ressurect this, but i have been looking for this feature for so long. Has anyone found a way?

Update: I'm getting really desperate here. As I noticed that yeahconsole is another application that can circumvent this, I tried to force it to the "below" layer and use it as a terminal-on-desktop replacement. But 'xprop WM_CLASS' reports that it doesn't have this property, so I don't know how to use a per-application setting. I tried to set up a 'ToggleAlwaysOnBottom' keybinding in rc.xml, but it doesn't adhere to that either.

Update2: Well, two months and countless hours spent googling later, I gave up on this. It's weird that conky and panels can do this but no custom application.

Last edited by Malstrond (2009-08-13 20:22:53)


#6 2010-12-14 20:45:57

From: The Netherlands
Registered: 2010-01-18
Posts: 70

Re: [OpenBox] making an exception to the ToggleShowDesktop command

Sorry for resurrecting this again, but has anyone made any progress with this?


#7 2010-12-14 23:39:05

From: Massachusetts
Registered: 2009-06-28
Posts: 362

Re: [OpenBox] making an exception to the ToggleShowDesktop command

I'm not sure that this can be done with urxvt. If you go here: … #id2551529

You'll notice that the _NET_WM_WINDOW_TYPE property can only be set before the window is mapped, and that there is no way (via the standard) to change that property on the fly. Of course, you could use devilspie or xprop:


However, while this is successful in changing the property, the window manager doesn't necessarily have to acknowledge this request (due to the standard). And apparently, Openbox doesn't.

So... You're left with what seems to be changing this property before the window is mapped. I did some digging, and downloaded the urxvt source. I modified it, and successfully got urxvt into the background, and the window still shows even when the ToggleDesktop command is issued. If you'd really like this, I've outlined how I did that. (Note that this should probably be presented with a patch and what not.)

First, download the urxvt source: … 10.tar.bz2

Extract, and cd into the src directory. Open init.C and go to line 1526, which should say "_NET_WM_WINDOW_TYPE is NORMAL, which is the default." Below that, add:

Atom desktop = XInternAtom(dpy, "_NET_WM_WINDOW_TYPE_DESKTOP", false);
  XChangeProperty (dpy, top,
                   XInternAtom(dpy, "_NET_WM_WINDOW_TYPE", false),
                   XA_ATOM, 32,
                   (unsigned char *) &desktop,

Now cd back up one directory and run

./ && ./configure && make

To test, you can run


Which should open a urxvt terminal in "desktop" mode. I cp'd it to my bin directory:

sudo cp src/rxvt /usr/bin/urxvt-destop

Please note: Making a window into a "DESKTOP" does some strange things, where normal window operations might not work. For example, you'll probably need to set the geometry (size/position) of your background terminal using the -geometry flag when launching urxvt-desktop.

Education is favorable to liberty. Freedom can exist only in a society of knowledge. Without learning, men are incapable of knowing their rights, and where learning is confined to a few people, liberty can be neither equal nor universal.

Tu ne cede malis sed contra audentior ito


#8 2010-12-15 12:32:19

From: The Netherlands
Registered: 2010-01-18
Posts: 70

Re: [OpenBox] making an exception to the ToggleShowDesktop command

Hey thanks, great. I'll try this sometime soon.


Seems to work well smile Too bad urxvt seems to use up so much memory. But that's just the way it is, I suppose.

Here's how I made it look:

Last edited by STEELBAS (2010-12-15 20:11:30)


#9 2011-04-06 19:09:05

Registered: 2011-04-06
Posts: 17

Re: [OpenBox] making an exception to the ToggleShowDesktop command

This seems to be only way to keep urxvt at desktop in openbox. I had some problems with LXDE. LXDE still hides even the patched urxvt, when I click somewhere at the desktop, anyone have idea how to avoid this? I just used geometry to fullfill screen, <maximized> and <fullscreen> options in rc.xml won't work with patched version so it was quite pain in the ass to get few pixels hole hidden smile
I made patch and PKGBUILD based on rxvt-unicode-patched here is the rxvt-desktop.patch
not really sure are everything ok in there, haven't played with this stuff much. And not really sure does anyone have any use for this.

# Maintainer: Daniel Micay <>
# Contributor: tobias <>
# Contributor: dibblethewrecker

pkgdesc="urxvt with desktop patch"
arch=(i686 x86_64)
depends=('gcc-libs' 'libxft' 'gdk-pixbuf2')
makedepends=('ncurses' 'perl>=5.12.2' 'pkgconfig')
optdepends=('perl: lots of utilities' 'gtk2-perl: to use the urxvt-tabbed')
source=(${_pkgname}-${pkgver}.tar.bz2 \
        ${_pkgname}.desktop ${_pkgname}.png popup-menu-hang.diff \
        font-width-fix.patch layoutgaps.patch rxvt-desktop.patch)

build() {
  cd "${srcdir}/${_pkgname}-${pkgver}"
  patch -p0 < ../popup-menu-hang.diff
  patch -p0 -i ../font-width-fix.patch
  patch -p0 -i ../layoutgaps.patch
  patch -p0 -i ../rxvt-desktop.patch

  ./configure --prefix=/usr \
    --with-terminfo=/usr/share/terminfo \
    --enable-256-color \
    --enable-font-styles \
    --enable-xim \
    --enable-keepscrolling \
    --enable-selectionscrolling \
    --enable-smart-resize \
    --enable-pixbuf \
    --enable-transparency \
    --enable-utmp \
    --enable-wtmp \
    --enable-lastlog \

package() {
  cd "${srcdir}/${_pkgname}-${pkgver}"
  install -Dm 755 src/rxvt "/usr/bin/urxvt-desktop"


Board footer

Powered by FluxBB