You are not logged in.

#1 2005-05-08 18:59:03

Registered: 2004-12-31
Posts: 100

[Solved]LVM metadata recovery

Hi everyone,

I'm a huge idiot :oops:

I decided to convert my slackware fileserver to arch (since it has much better package management). On my fileserver I was using lvm and when I put arch over slack it didn't even cross my mind to backup my lvm config files. Now on arch I have lvm running and I can see all my drives and volumes, but when I try to activate it I get:

Volume group vg00 metadata is inconsistent
Volume group for uuid not found: fhRVK5ZTwTOdTQpgF8oyAESEj8LYNRJy1P1jjdkNCV1WhYwfv9rxpnExXvNu13T6
0 logical volume(s) in volume group "vg00" now active

If I run pvscan I get:
PV /dev/hda3   VG vg00   lvm2 [128.54 GB / 0    free]
PV /dev/hdd1   VG vg00   lvm2 [74.52 GB / 0    free]
PV /dev/hdb1   VG vg00   lvm2 [186.30 GB / 29.36 GB free]
Total: 3 [389.36 GB] / in use: 3 [389.36 GB] / in no VG: 0 [0   ]

and vgscan returns:
Reading all physical volumes.  This may take a while...
Found volume group "vg00" using metadata type lvm2

What are my options if any?



#2 2005-05-11 20:22:09

Registered: 2004-12-31
Posts: 100

Re: [Solved]LVM metadata recovery

I got a solution to this from a nice person on the lvm mailing list, maybe it will help someone:

I've had this problem as well: The volume group existed and all of its
PVs existed, but the volume group wanted different UUIDs than the PVs

The solution is kind of scary but seems to work, I got it from a Fedora
discussion site, where someone said they had this problem but just
backed up & resotred the config:

$ vgcfgbackup -f cfg_backup vg00
$ vgcfgrestore -f cfg_backup vg00


Board footer

Powered by FluxBB