You are not logged in.

#326 2011-01-08 14:21:05

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.6

@ Primoz
no, you don't need kde-l10n-* 4.5.5 localization because they are for 4.5 and I don't package kde-l10n in [kde-unstable].

Offline

#327 2011-01-08 15:52:02

Primoz
Member
From: Ljubljana-Slovena-EU
Registered: 2009-03-04
Posts: 661

Re: [kde-unstable] KDE 4.6

bash wrote:

@ Primoz
no, you don't need kde-l10n-* 4.5.5 localization because they are for 4.5 and I don't package kde-l10n in [kde-unstable].

Well I don't know I lost my native (Slovenian) language with removing the kde-l10n and when I still had it installed it was working. Now if I go to locale to see the language options the System Settings just crash.
I'll see once I'll reboot if this will still be so.

Plus before I removed the I10n everything worked just fine... So yeah.


Arch x86_64 ATI AMD APU KDE frameworks 5
---------------------------------
Whatever I do, I always end up with something horribly mis-configured.

Offline

#328 2011-01-08 18:37:03

Wu
Member
Registered: 2009-12-27
Posts: 61

Re: [kde-unstable] KDE 4.6

@all

do you have new mail notification with  kmail 4.6 beta4?
I checked "detailed new mail notification" in kmail settings but i don't see any notification when a new mail arrives.

Offline

#329 2011-01-08 18:54:40

stavallo
Member
Registered: 2010-05-28
Posts: 34

Re: [kde-unstable] KDE 4.6

SteveK wrote:
kevku wrote:

works ok but kwin hangs on window previews (prob intel driver issues again)

Hey - Try this - I even got direct rendering working with the blur effect on my little aspire one netbook!

http://forum.kde.org/viewtopic.php?f=111&t=91663

I also had freezes on window previews with Intel G45. I solved this issues by changing System Settings->Desktop Effects->Advanced->Scale method from "Accurate" to "Smooth" (as suggested by the tooltip itself)

Offline

#330 2011-01-08 23:16:20

tuxador
Member
From: algeria
Registered: 2010-07-08
Posts: 45

Re: [kde-unstable] KDE 4.6

i created a new user with a clean /home: this solved almost all the issues:
-still have the consolekit error when kdm runs
- strigi indexed well and now is working \O/
- my usb sticks and CD/DVD work too, even k3b (2.0.80) now burns CD's smile
- didn't try kmail yet
by the way kde is much faster now ...


laptop LENOVO Ideapad Z570 i7 / 6GO RAM/GeForce 540
ARCHLINUX+KDE frameworks 5.3 (working great !)

Offline

#331 2011-01-09 02:24:44

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: [kde-unstable] KDE 4.6

Well with K3b git and RC2 my drive is recognized without HAL running.

I also have that problem mentioned in the thread with the networkmanager applet asking me to confirm my WPA password for my Wi-Fi connection at every reconnection.

Offline

#332 2011-01-09 03:13:27

philacorns
Member
From: Beijing
Registered: 2009-01-25
Posts: 21

Re: [kde-unstable] KDE 4.6

sometimes kwin would freeze with the intel-dri and libgl in testing, with extra it's ok.

Offline

#333 2011-01-09 12:27:44

venky80
Member
Registered: 2007-05-13
Posts: 996

Re: [kde-unstable] KDE 4.6

why is there a hard dependency between gnome lib and gstreamer0.10-good-plugins and kde??
also why is phonon-gstreamer a hard dependency of kde


DELL XPS 1640 with ATI Mobility Radeon  HD 3670. Arch Linux KDE Minimal Install

Offline

#334 2011-01-09 12:32:58

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.6

venky80 wrote:

also why is phonon-gstreamer a hard dependency of kde

phonon-gstreamer is not an hard dependence of KDE; you can install which backend you want (gstreamer, xine and vlc are in [extra], mplayer in AUR)

Name           : phonon
Depends On     : qt  phonon-backend  libpulse

Name           : phonon-gstreamer
Provides       : phonon-backend

Name           : phonon-xine
Provides       : phonon-backend

Name           : phonon-vlc
Provides       : phonon-backend

Offline

#335 2011-01-09 13:43:31

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: [kde-unstable] KDE 4.6

zephyr wrote:

I also have that problem mentioned in the thread with the networkmanager applet asking me to confirm my WPA password for my Wi-Fi connection at every reconnection.

It is an upstream bug with Plain text storage in the networkmanagement applet.

https://bugs.kde.org/show_bug.cgi?id=257777

Offline

#336 2011-01-09 14:51:40

newgargamel
Member
From: PL, CZ
Registered: 2005-08-28
Posts: 156

Re: [kde-unstable] KDE 4.6

bash wrote:

BTW, I switched back to xine-lib (with pulse support) + phonon-xine + PA in this way I avoided ~50MB of extra packages and libgnome stuff!

I did the same but I still don't have software mixer so I can't play for example amarok and youtube at the same time. On 4.5 xine backend was working with unlimited streams. I have usb sound card. Any recomendations?

Edit: with VLC backend I can play amarok+mplayer but not youtube. Are there specific settings for flashplayer with PA?

Last edited by newgargamel (2011-01-09 15:52:07)

Offline

#337 2011-01-09 15:42:11

josephk
Member
Registered: 2011-01-09
Posts: 96
Website

Re: [kde-unstable] KDE 4.6

Hello everybody,

dear Bash,

I wish to install phonon-gstreamer without unnecessary gnome dependencies pulled in since gstreamer-plugins relies on an unnecessary hard dependency on libcanberra: is it possible to get rid of it in the next build?

thanks all for the good work,
KDE + ARCH ROCKS!

Offline

#338 2011-01-09 16:09:20

agapito
Member
From: Spain
Registered: 2008-11-13
Posts: 495

Re: [kde-unstable] KDE 4.6

K3b from extra works without HAL. You don't need k3b-git.


Excuse my poor English.

Offline

#339 2011-01-09 16:16:43

mangus
Member
From: Bologna, Italy
Registered: 2007-04-07
Posts: 289

Re: [kde-unstable] KDE 4.6

newgargamel wrote:
bash wrote:

BTW, I switched back to xine-lib (with pulse support) + phonon-xine + PA in this way I avoided ~50MB of extra packages and libgnome stuff!

I did the same but I still don't have software mixer so I can't play for example amarok and youtube at the same time. On 4.5 xine backend was working with unlimited streams. I have usb sound card. Any recomendations?

Edit: with VLC backend I can play amarok+mplayer but not youtube. Are there specific settings for flashplayer with PA?


I'm using right now youtube , skype and clementine simultaneously , using phonon-mplayer *without* pulseaudio , no exotics configurations , internal soundcard. HTH

Offline

#340 2011-01-09 16:56:16

venky80
Member
Registered: 2007-05-13
Posts: 996

Re: [kde-unstable] KDE 4.6

bash wrote:
venky80 wrote:

also why is phonon-gstreamer a hard dependency of kde

phonon-gstreamer is not an hard dependence of KDE; you can install which backend you want (gstreamer, xine and vlc are in [extra], mplayer in AUR)

Name           : phonon
Depends On     : qt  phonon-backend  libpulse

Name           : phonon-gstreamer
Provides       : phonon-backend

Name           : phonon-xine
Provides       : phonon-backend

Name           : phonon-vlc
Provides       : phonon-backend

ok but kde has a hard dependency with gstreamer...why is that? if i have just vlc backend why does kde want gstreamer package?


DELL XPS 1640 with ATI Mobility Radeon  HD 3670. Arch Linux KDE Minimal Install

Offline

#341 2011-01-09 18:41:06

newgargamel
Member
From: PL, CZ
Registered: 2005-08-28
Posts: 156

Re: [kde-unstable] KDE 4.6

mangus wrote:
newgargamel wrote:
bash wrote:

BTW, I switched back to xine-lib (with pulse support) + phonon-xine + PA in this way I avoided ~50MB of extra packages and libgnome stuff!

I did the same but I still don't have software mixer so I can't play for example amarok and youtube at the same time. On 4.5 xine backend was working with unlimited streams. I have usb sound card. Any recomendations?

Edit: with VLC backend I can play amarok+mplayer but not youtube. Are there specific settings for flashplayer with PA?


I'm using right now youtube , skype and clementine simultaneously , using phonon-mplayer *without* pulseaudio , no exotics configurations , internal soundcard. HTH

thanks mate but internal soundcard is a different story wink

Edit: the problem was solved by following a wiki page about PA setup - x86_64 can be tricky sometimes wink

Last edited by newgargamel (2011-01-09 20:59:35)

Offline

#342 2011-01-09 23:30:35

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.6

venky80 wrote:

ok but kde has a hard dependency with gstreamer...why is that? if i have just vlc backend why does kde want gstreamer package?

That's libcanberra, vote for the feature request FS#21996.

Offline

#343 2011-01-10 00:19:02

SS4
Member
From: !Rochford, Essex
Registered: 2010-12-05
Posts: 699

Re: [kde-unstable] KDE 4.6

I've not had any problems with anything except the old Kwin/X/nvidia CPU killer


Rauchen verboten

Offline

#344 2011-01-10 01:26:31

agapito
Member
From: Spain
Registered: 2008-11-13
Posts: 495

Re: [kde-unstable] KDE 4.6

When i try uninstall gtk2 with pacman -Rc it wants uninstall all kde packages because of libcanberra... i don 't have phonon-gstreamer installed.


Excuse my poor English.

Offline

#345 2011-01-10 06:09:49

rowp
Member
Registered: 2010-04-12
Posts: 12

Re: [kde-unstable] KDE 4.6

I have a couple of problems - Not complaining but just wondering if anyone else has seen similar occurances? Maybe a forewarning to anyone wanting to try the RC out.

Keeping in mind i do have [testing] + [kde-unstable] enabled

1) The 'plasma-network-management-applet' has some strange bug. I can see items, initially when i click them it brings up a configuration box. If i add a new item (i.e. wireless network), then click on that item in the plasmoid nothing happens.

I tried restarting networkmanager, DBUS and restarted X. After this i was able to connect by clicking on the item in the network-management-applet.

I guess this is a bug?...I havn't noticed anthing strange on the logs

2) Every now and then KDED will go crazy and consume at least 50% of cpu. This usually happens when i do something (i.e. log in / out or manually kill my session.....however i have noticed this upon system restart and normal login. Stopping these processes fixes this issue.

Offline

#346 2011-01-10 06:29:18

Xabre
Member
From: Serbia
Registered: 2009-03-19
Posts: 596

Re: [kde-unstable] KDE 4.6

rowp wrote:

2) Every now and then KDED will go crazy and consume at least 50% of cpu. This usually happens when i do something (i.e. log in / out or manually kill my session.....however i have noticed this upon system restart and normal login. Stopping these processes fixes this issue.

Explanation on what KDED is, and what it does can be found here:
http://websvn.kde.org/trunk/KDE/kdelibs … iew=markup

If you feel that it performs it's tasks too often, you may wanna try tweaking it's config file .kde4/share/config/kdedrc as described in linked document.

Offline

#347 2011-01-10 17:43:49

venky80
Member
Registered: 2007-05-13
Posts: 996

Re: [kde-unstable] KDE 4.6

bash wrote:
venky80 wrote:

ok but kde has a hard dependency with gstreamer...why is that? if i have just vlc backend why does kde want gstreamer package?

That's libcanberra, vote for the feature request FS#21996.

yeah I just saw that, that is quite annoying that because of libcanberra which is dependent on kdebase-runtime we have to pull gstreamer and gtk2 into kde
Hey you are assigned to work on it...so what do you think ? Dont you feel it is quite annoying to have gstreamer and gtk2 in a minimal KDE install?

Last edited by venky80 (2011-01-10 17:47:52)


DELL XPS 1640 with ATI Mobility Radeon  HD 3670. Arch Linux KDE Minimal Install

Offline

#348 2011-01-10 18:16:40

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.6

venky80 wrote:

Hey you are assigned to work on it...so what do you think ? Dont you feel it is quite annoying to have gstreamer and gtk2 in a minimal KDE install?

Unfortunately I can't do anything here. I talked with GNOME maintainers and they won't to break existing packages. They'll move gtk2 and gstreamer as optdependence in libcanberra (or something like that), but with the next gnome update (so they can update the dependencies). You have to wait. Maybe a solution could be a "libcanberra-nognome" package in AUR until then.

Offline

#349 2011-01-10 19:03:39

marconato
Member
Registered: 2009-07-02
Posts: 12
Website

Re: [kde-unstable] KDE 4.6

rowp wrote:

I have a couple of problems - Not complaining but just wondering if anyone else has seen similar occurances? Maybe a forewarning to anyone wanting to try the RC out.

Keeping in mind i do have [testing] + [kde-unstable] enabled

1) The 'plasma-network-management-applet' has some strange bug. I can see items, initially when i click them it brings up a configuration box. If i add a new item (i.e. wireless network), then click on that item in the plasmoid nothing happens.

I tried restarting networkmanager, DBUS and restarted X. After this i was able to connect by clicking on the item in the network-management-applet.

I guess this is a bug?...I havn't noticed anthing strange on the logs

2) Every now and then KDED will go crazy and consume at least 50% of cpu. This usually happens when i do something (i.e. log in / out or manually kill my session.....however i have noticed this upon system restart and normal login. Stopping these processes fixes this issue.

I think the plasma-network-management-applet issue could be due a bug in the applet using a WPA key, as I read in ubuntu forums....

Offline

#350 2011-01-10 20:46:58

tuxador
Member
From: algeria
Registered: 2010-07-08
Posts: 45

Re: [kde-unstable] KDE 4.6

that's why i prefer wicd (with kde-integration wink ) than network-manager.


laptop LENOVO Ideapad Z570 i7 / 6GO RAM/GeForce 540
ARCHLINUX+KDE frameworks 5.3 (working great !)

Offline

Board footer

Powered by FluxBB