You are not logged in.

#1 2011-01-11 18:09:25

Forum Fellow
Registered: 2008-08-01
Posts: 5,026

No xrandr with Nvidia 260.19.29-2 + Xorg

Can anyone confirm not working xrandr with the xorg in testing? I'm using it only to change screen rotation, since nvidia doesn't support anything else.

% xrandr -o left

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  154 (RANDR)
  Minor opcode of failed request:  2 (RRSetScreenConfig)
  Value in failed request:  0x780
  Serial number of failed request:  15
  Current serial number in output stream:  15

ᶘ ᵒᴥᵒᶅ


#2 2011-01-13 05:05:37

Registered: 2011-01-13
Posts: 1

Re: No xrandr with Nvidia 260.19.29-2 + Xorg

Hi, same problem here on gentoo with xorg-server (no rotation working, resolution change worked, e.g.: xrandr -s 1280x1024)

downgrade to xorg-server 1.9.2 solved the rotation problem for me

(tryed different nvidia-drivers, currently running with 260.19.26)

Last edited by BennY-G4 (2011-01-13 05:08:34)


#3 2011-01-13 05:44:00

Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 6,869

Re: No xrandr with Nvidia 260.19.29-2 + Xorg

Same thing here, but I've never used it before so no comment smile

Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.


#4 2011-02-28 19:26:00

Registered: 2008-03-30
Posts: 57

Re: No xrandr with Nvidia 260.19.29-2 + Xorg

Did anyone solve it? I'm waiting for xorg/nvidia drivers update since few weeks and it still doesn't works.

Last edited by ciembor (2011-02-28 19:27:04)


#5 2011-03-24 03:17:55

Registered: 2006-01-11
Posts: 4

Re: No xrandr with Nvidia 260.19.29-2 + Xorg

It seems this was fixed[1] on the 1.7 branch of xorg-xserver, but not on the 1.9 branch that Arch tracks.

Adding that patch to my xorg-xserver PKGBUILD allows me to rotate again.

I asked[2] on, and was told it's an xorg problem, so I filed a bug[3] on the xorg tracker.  No response so far.  I hope I did it properly.

[1]: … id=d77ffa9


Board footer

Powered by FluxBB