You are not logged in.

#26 2011-01-16 21:38:36

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,604
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

@JokerBoy - I can add one for you.  Gimme about 20 min.

EDIT1: Got distracted.  Building now and will upload soon.
EDIT2: Okay, it's sync'ed and files are online.  Please let me know.

Last edited by graysky (2011-01-16 22:23:19)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#27 2011-01-16 22:39:01

JokerBoy
Member
From: România
Registered: 2009-09-24
Posts: 641
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

seems to be a problem with your repo..

lsr /var/lib/pacman/sync/kernel26-ck/
/var/lib/pacman/sync/kernel26-ck/

0 directories, 0 files

Offline

#28 2011-01-16 23:35:08

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,604
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

@all - had to rebuild it with a slightly different path - see the first post of the thread for the new one and edit your /etc/pacman.conf accordingly!
@JokerBoy - Go ahead and modify the server entry and try again.

Last edited by graysky (2011-01-16 23:36:20)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#29 2011-01-17 09:47:05

o1911
Member
From: Hobart, Australia
Registered: 2009-04-28
Posts: 106

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Hey graysky, cool stuff you got here.  I've been building kernel26-ck from the AUR for ages now, just wondering how exactly these -core2 optimisations would be included in the AUR's PKGBUILD if possible.

Cheers!

edit: upon re-reading the OP there's no BFQ in the kernel26-ck repo packages.

Last edited by o1911 (2011-01-17 12:33:56)


Arch x86_64

Offline

#30 2011-01-17 16:38:30

Labello
Member
From: Germany
Registered: 2010-01-21
Posts: 315
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

runs fine!

now i can run my cpu on low ferquencies even more often. thanks for that!


"They say just hold onto your hope but you know if you swallow your pride you will choke"
Alexisonfire - Midnight Regulations

Offline

#31 2011-01-17 20:00:00

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,604
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

o1911 wrote:

just wondering how exactly these -core2 optimisations would be included in the AUR's PKGBUILD if possible.

All you need to do is to enable the nconfig option, then go to processors>processor family and select it there.

o1911 wrote:

upon re-reading the OP there's no BFQ in the kernel26-ck repo packages.

Correct, I want them to be as close to the ARCH packages as possible.  So they just get the CK1 patchset and optionally, the processor family-specific optimizations.

Labello wrote:

now i can run my cpu on low ferquencies even more often. thanks for that!

No idea how my packages are allowing you to do that but I'm glad you're happy smile


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#32 2011-01-18 02:05:53

disastrophe
Member
From: pdx
Registered: 2010-10-08
Posts: 91

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Happy to hear about this. I recently started using kernel26-ck and have been very favorably impressed. Already did mine the old fashioned way but this will certainly make updates much more convenient and faster. Thanks!


"If we believe absurdities, we shall commit atrocities." ~ Voltaire

Offline

#33 2011-01-19 13:30:49

biniou
Member
From: France
Registered: 2009-07-07
Posts: 33

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Hi, thanks for all your work !
I installed kernel26-ck-atom without any glitch but I can't use it : when my netbook (Samsung NC10) turns off the screen (for powersaving), it never go back to light no matter what I do. :-/
Do you have a solution for me ? smile

PS: Sorry if my english sux.

Offline

#34 2011-01-19 20:03:45

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,604
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

@biniou - is this the case w/ the kernel26 package from [testing] which is also 2.6.37?  Thought that I read about this somewhere as an issue with the version bump.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#35 2011-01-19 22:21:26

Falcata
Member
From: Michiana
Registered: 2008-01-23
Posts: 501
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

I attempted to use kernel26-ck, but when I did it mysteriously failed when I booted up.  If my memory serves correctly, it tried to load my hard drive by UUID, failed to find it, and then tried to create a new HD entry (also by UUID), and failed.  I tried this with both the prebuilt one from the repo and with one I built by PKGBUILD, but no luck.

Offline

#36 2011-01-19 22:27:07

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,604
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

@falcata - grub or grub2?  Can you post two things:

1) ls -l /boot
2) cat /boot/grub/menu.lst # if grub or cat /boot/grub/grub.cfg # if grub2


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#37 2011-01-19 22:33:37

Falcata
Member
From: Michiana
Registered: 2008-01-23
Posts: 501
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

I'm using grub.  Here's the output for the commands you gave:

[zauber@myhost ~]$ ls -l /boot
total 25869
drwxr-xr-x 2 root root    1024 Jan 17 14:51 grub
-rw-r--r-- 1 root root 8419213 Jan 17 16:04 kernel26-ck-fallback.img
-rw-r--r-- 1 root root 1687528 Jan 17 16:03 kernel26-ck.img
-rw-r--r-- 1 root root 8267153 Jan 11 19:39 kernel26-fallback.img
-rw-r--r-- 1 root root 1680157 Jan 11 19:39 kernel26.img
drwx------ 2 root root   12288 Aug  2 14:05 lost+found
-rw-r--r-- 1 root root 1132740 Jan  8 08:20 System.map26
-rw-r--r-- 1 root root 1148940 Jan 17 15:53 System.map26-ck
-rw-r--r-- 1 root root 2004848 Jan  8 08:20 vmlinuz26
-rw-r--r-- 1 root root 2017136 Jan 17 15:53 vmlinuz26-ck
[zauber@myhost grub]$ cat /boot/grub/menu.lst
# Config file for GRUB - The GNU GRand Unified Bootloader
# /boot/grub/menu.lst

# DEVICE NAME CONVERSIONS 
#
#  Linux           Grub
# -------------------------
#  /dev/fd0        (fd0)
#  /dev/sda        (hd0)
#  /dev/sdb2       (hd1,1)
#  /dev/sda3       (hd0,2)
#

#  FRAMEBUFFER RESOLUTION SETTINGS
#     +-------------------------------------------------+
#          | 640x480    800x600    1024x768   1280x1024
#      ----+--------------------------------------------
#      256 | 0x301=769  0x303=771  0x305=773   0x307=775
#      32K | 0x310=784  0x313=787  0x316=790   0x319=793
#      64K | 0x311=785  0x314=788  0x317=791   0x31A=794
#      16M | 0x312=786  0x315=789  0x318=792   0x31B=795
#     +-------------------------------------------------+
#  for more details and different resolutions see
#  http://wiki.archlinux.org/index.php/GRUB#Framebuffer_Resolution 

# general configuration:
timeout   5
default   0
color light-blue/black light-cyan/blue

# boot sections follow
# each is implicitly numbered from 0 in the order of appearance below
#
# TIP: If you want a 1024x768 framebuffer, add "vga=773" to your kernel line.
#
#-*

# (0) Arch Linux
title  Linux-CK
root   (hd0,0)
kernel /vmlinuz26 root=/dev/disk/by-uuid/a0e2582d-71ff-44d1-8747-f55dabb82cb0 ro
initrd /kernel26-ck.img

# (1) Arch Linux
title  Linux-CK Fallback
root   (hd0,0)
kernel /vmlinuz26 root=/dev/disk/by-uuid/a0e2582d-71ff-44d1-8747-f55dabb82cb0 ro
initrd /kernel26-ck-fallback.img

# (2) Arch Linux
title  Arch Linux
root   (hd0,0)
kernel /vmlinuz26 root=/dev/disk/by-uuid/a0e2582d-71ff-44d1-8747-f55dabb82cb0 ro
initrd /kernel26.img

# (3) Arch Linux
title  Arch Linux Fallback
root   (hd0,0)
kernel /vmlinuz26 root=/dev/disk/by-uuid/a0e2582d-71ff-44d1-8747-f55dabb82cb0 ro
initrd /kernel26-fallback.img

# (2) Windows
#title Windows
#rootnoverify (hd0,0)
#makeactive
#chainloader +1

Last edited by Falcata (2011-01-19 22:34:04)

Offline

#38 2011-01-19 23:08:09

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,604
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Check the error in your kernel line for -cks

You're calling the standard ARCH kernel when you need to call the /vmlinuz26-ck


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#39 2011-01-19 23:21:46

Falcata
Member
From: Michiana
Registered: 2008-01-23
Posts: 501
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

I was able to get it to boot, but xorg failed to start when it tried to load the nvidia module, and I have nvidia-ck installed.  Are there any additional steps that need to be taken?

Offline

#40 2011-01-19 23:25:21

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Falcata wrote:

I was able to get it to boot, but xorg failed to start when it tried to load the nvidia module, and I have nvidia-ck installed.  Are there any additional steps that need to be taken?

After you install the kernel and nvidia-ck,reboot and try again.
If it doesn't work, post the logs.

Offline

#41 2011-01-19 23:29:16

Falcata
Member
From: Michiana
Registered: 2008-01-23
Posts: 501
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

EDIT: wrong log file, need to reboot.

Last edited by Falcata (2011-01-19 23:30:18)

Offline

#42 2011-01-19 23:32:22

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Did you reboot?

Edit: OK, I'll hold ;-)

Last edited by karol (2011-01-19 23:32:49)

Offline

#43 2011-01-19 23:46:30

Falcata
Member
From: Michiana
Registered: 2008-01-23
Posts: 501
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Here's my Xorg.0.log file:

[   172.896] 
X.Org X Server 1.9.2
Release Date: 2010-10-30
[   172.896] X Protocol Version 11, Revision 0
[   172.896] Build Operating System: Linux 2.6.35-ARCH i686 
[   172.896] Current Operating System: Linux myhost 2.6.37-ck #1 SMP PREEMPT Sat Jan 15 15:14:10 EST 2011 i686
[   172.896] Kernel command line: root=/dev/disk/by-uuid/a0e2582d-71ff-44d1-8747-f55dabb82cb0 ro
[   172.896] Build Date: 01 November 2010  10:35:30PM
[   172.896]  
[   172.896] Current version of pixman: 0.20.0
[   172.896]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[   172.896] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   172.896] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Jan 19 18:30:22 2011
[   172.907] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   172.908] (==) No Layout section.  Using the first Screen section.
[   172.908] (==) No screen section available. Using defaults.
[   172.908] (**) |-->Screen "Default Screen Section" (0)
[   172.908] (**) |   |-->Monitor "<default monitor>"
[   172.908] (==) No device specified for screen "Default Screen Section".
    Using the first device section listed.
[   172.908] (**) |   |-->Device "Default nvidia Device"
[   172.908] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[   172.908] (==) Automatically adding devices
[   172.908] (==) Automatically enabling devices
[   172.909] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[   172.909]     Entry deleted from font path.
[   172.909] (==) FontPath set to:
    /usr/share/fonts/misc/,
    /usr/share/fonts/TTF/,
    /usr/share/fonts/Type1/,
    /usr/share/fonts/100dpi/,
    /usr/share/fonts/75dpi/
[   172.909] (==) ModulePath set to "/usr/lib/xorg/modules"
[   172.909] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[   172.909] (II) Loader magic: 0x81f1f80
[   172.909] (II) Module ABI versions:
[   172.909]     X.Org ANSI C Emulation: 0.4
[   172.909]     X.Org Video Driver: 8.0
[   172.909]     X.Org XInput driver : 11.0
[   172.909]     X.Org Server Extension : 4.0
[   172.911] (--) PCI:*(0:1:0:0) 10de:0605:19f1:0bd2 rev 162, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xfa000000/33554432, I/O @ 0x0000d800/128, BIOS @ 0x????????/131072
[   172.911] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   172.911] (II) LoadModule: "extmod"
[   172.912] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[   172.912] (II) Module extmod: vendor="X.Org Foundation"
[   172.912]     compiled for 1.9.2, module version = 1.0.0
[   172.912]     Module class: X.Org Server Extension
[   172.912]     ABI class: X.Org Server Extension, version 4.0
[   172.912] (II) Loading extension MIT-SCREEN-SAVER
[   172.912] (II) Loading extension XFree86-VidModeExtension
[   172.912] (II) Loading extension XFree86-DGA
[   172.912] (II) Loading extension DPMS
[   172.912] (II) Loading extension XVideo
[   172.912] (II) Loading extension XVideo-MotionCompensation
[   172.912] (II) Loading extension X-Resource
[   172.912] (II) LoadModule: "dbe"
[   172.913] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[   172.913] (II) Module dbe: vendor="X.Org Foundation"
[   172.913]     compiled for 1.9.2, module version = 1.0.0
[   172.913]     Module class: X.Org Server Extension
[   172.913]     ABI class: X.Org Server Extension, version 4.0
[   172.913] (II) Loading extension DOUBLE-BUFFER
[   172.913] (II) LoadModule: "glx"
[   172.913] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   172.972] (II) Module glx: vendor="NVIDIA Corporation"
[   172.972]     compiled for 4.0.2, module version = 1.0.0
[   172.972]     Module class: X.Org Server Extension
[   172.972] (II) NVIDIA GLX Module  260.19.29  Wed Dec  8 12:25:40 PST 2010
[   172.972] (II) Loading extension GLX
[   172.972] (II) LoadModule: "record"
[   172.972] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[   172.973] (II) Module record: vendor="X.Org Foundation"
[   172.973]     compiled for 1.9.2, module version = 1.13.0
[   172.973]     Module class: X.Org Server Extension
[   172.973]     ABI class: X.Org Server Extension, version 4.0
[   172.973] (II) Loading extension RECORD
[   172.973] (II) LoadModule: "dri"
[   172.973] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[   172.973] (II) Module dri: vendor="X.Org Foundation"
[   172.973]     compiled for 1.9.2, module version = 1.0.0
[   172.974]     ABI class: X.Org Server Extension, version 4.0
[   172.974] (II) Loading extension XFree86-DRI
[   172.974] (II) LoadModule: "dri2"
[   172.974] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   172.974] (II) Module dri2: vendor="X.Org Foundation"
[   172.974]     compiled for 1.9.2, module version = 1.2.0
[   172.974]     ABI class: X.Org Server Extension, version 4.0
[   172.974] (II) Loading extension DRI2
[   172.974] (II) LoadModule: "nvidia"
[   172.974] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[   172.975] (II) Module nvidia: vendor="NVIDIA Corporation"
[   172.975]     compiled for 4.0.2, module version = 1.0.0
[   172.975]     Module class: X.Org Video Driver
[   173.033] (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
[   173.033] (EE) NVIDIA:     system's kernel log for additional error messages.
[   173.033] (II) UnloadModule: "nvidia"
[   173.033] (II) Unloading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[   173.033] (EE) Failed to load module "nvidia" (module-specific error, 0)
[   173.033] (EE) No drivers available.
[   173.033] 
Fatal server error:
[   173.033] no screens found
[   173.033] 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[   173.034] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   173.034]

Not very much to go on, so I checked /var/log/errors.log, and found this:

Jan 19 18:30:22 localhost kernel: nvidia: version magic '2.6.37-ck SMP preempt mod_unload K7 ' should be '2.6.37-ck SMP preempt mod_unload 686 '

Offline

#44 2011-01-19 23:49:38

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

/var/log/errors.log says you've installed the AMD K7 version, not an i686 one.

Offline

#45 2011-01-19 23:52:15

Falcata
Member
From: Michiana
Registered: 2008-01-23
Posts: 501
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Yeah, and I have the normal nvidia-ck version installed:

[zauber@myhost Documents]$ yaourt -Ss nvidia-ck | grep installed
kernel26-ck/nvidia-ck 260.19.29-2 [installed]

Looks like the K7 version was accidentally packaged as the normal 686 one.

Offline

#46 2011-01-19 23:58:21

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

To see the contents of the repo, just search

[karol@black ~]$ pacman -Sl kernel26-ck
kernel26-ck kernel26-ck 2.6.37-1
kernel26-ck kernel26-ck-atom 2.6.37-1
kernel26-ck kernel26-ck-atom-headers 2.6.37-1
kernel26-ck kernel26-ck-headers 2.6.37-1
kernel26-ck kernel26-ck-k7 2.6.37-1
kernel26-ck kernel26-ck-k7-headers 2.6.37-1
kernel26-ck kernel26-ck-p4 2.6.37-1
kernel26-ck kernel26-ck-p4-headers 2.6.37-1
kernel26-ck nvidia-ck 260.19.29-2

it's '-Sl', not '-Ss'. I've fixed it in the wiki, you can fix it in your first post if you like, graysky.

Offline

#47 2011-01-20 00:38:12

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,604
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

@karol - fixed, thanx.
@Falcata - fixed and updated.  Thanks for catching the mistake, guys.  Please give it a try and let me know if it's good.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#48 2011-01-20 01:28:41

Falcata
Member
From: Michiana
Registered: 2008-01-23
Posts: 501
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

Reinstalled after doing pacman -Scc and pacman -Syy, and it's still K7.

Offline

#49 2011-01-20 01:56:41

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,604
Website

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

@Falcata - I booted into my i686 using the pacakges from the repo and everything is fine.  Not sure how to why you're getting that K7 error.  Can someone else running i686 confirm?


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#50 2011-01-20 06:34:19

philanecros
Member
Registered: 2010-10-03
Posts: 2

Re: unofficial linux-ck repo with cpu optimized packages is ONLINE

@Falcata - I guess your nvidia problem is caused by kernel module dependencies. Run depmod once when booted from kernel-ck. I met this problem as well and it is solved. Maybe this also applies to @kinhodder's wl problem.

Now using core2 and it works fine. Thanks for the repo!

Offline

Board footer

Powered by FluxBB