You are not logged in.

#1 2011-01-22 16:46:06

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,535
Website

nvidia package wo/ kernel26-headers - makepkg chokes

When I modify a single line in nvidia's PKGBUILD, makepkg dies in the following error.  What is really odd is that I can manually execute the build function and I do not get an error.  The error only happens when makepkg tries.  Can someone explain?

Error:

==> Starting build()...
Creating directory NVIDIA-Linux-x86_64-260.19.36-no-compat32
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 260.19.36.....................................................................................................................
The kernel you are installing for is a Xen kernel!

The NVIDIA driver does not currently work on Xen kernels. If 
you are using a stock distribution kernel, please install 
a variant of this kernel without Xen support; if this is a 
custom kernel, please install a standard Linux kernel.  Then 
try installing the NVIDIA kernel module again.

*** Failed Xen sanity check. Bailing out! ***

make[1]: *** [build-sanity-checks] Error 1
make: *** [module] Error 2
    Aborting...

The only modification is to change this line:

make SYSSRC=/lib/modules/${_kernver}/build module

to:

make SYSSRC=$startdir/tar/lib/modules/${_kernver}/build module

I have manually extracted the contents of kernel26-headers.tar.xz to the $startdir/tar.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#2 2011-01-22 18:01:58

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: nvidia package wo/ kernel26-headers - makepkg chokes

there is nothing about the headers.

"The NVIDIA driver does not currently work on Xen kernels."

period.


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

Board footer

Powered by FluxBB