You are not logged in.

#1 2005-05-17 09:51:50

tmadhavan
Member
From: Wales :D
Registered: 2004-03-26
Posts: 441

Nvidia FATAL module error on post-kernel-upgrade install

Hi all

following on from a similar post over in the kernel forum, I'm also having issues with nvidia.

Just upgraded my kernel to 2.6.11.9-ARCH, went to reinstall nvidia with 'pacman -S nvidia' and get an error

 FATAL: module nvidia not found 

.

So I have no nvidia module, there is no NVmakedevices script anywhere - what's going on? Obviously it can't find the nvidia module as it's in the process of installing it!???!

WTF?

Offline

#2 2005-05-17 10:08:06

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: Nvidia FATAL module error on post-kernel-upgrade install

i have no problem on 2.6.11.10,
install new kernel
reboot
after boot, leave X and run pacman -S nvidia again
uh and btw don't use gcc4,glibc and binutils from testing

Offline

#3 2005-05-17 10:20:54

Kern
Member
From: UK
Registered: 2005-02-09
Posts: 460

Re: Nvidia FATAL module error on post-kernel-upgrade install

had similar a few days back. also ran the nvidia package externally tho and it sorted itself out. running 2.6.11.7 .

Offline

#4 2005-05-17 10:32:45

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: Nvidia FATAL module error on post-kernel-upgrade install

please check your /var/log/nvidia-installer.log on errors

Offline

#5 2005-05-17 12:17:45

Pierluigi
Member
Registered: 2004-04-10
Posts: 90
Website

Re: Nvidia FATAL module error on post-kernel-upgrade install

here the same error after upgrading to kernel 2.6.11.9.
Seems that the kernel was built with gcc 3.4.2, instead of gcc 4 in the testing repository.

From nvidia-installer.log:

You appear to be compiling the NVIDIA kernel module with a different compile
   r than the one that was used to compile the running kernel.  This may be fin
   e, but there are cases where this can lead to instability.  The compiler use
   d to compile the kernel was gcc 3.4; the current compiler is gcc 4.0.

so it stops.

Offline

#6 2005-05-17 12:21:36

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: Nvidia FATAL module error on post-kernel-upgrade install

shall i quote:
btw don't use gcc4,glibc and binutils from testing smile

Offline

#7 2005-05-17 12:54:25

Pierluigi
Member
Registered: 2004-04-10
Posts: 90
Website

Re: Nvidia FATAL module error on post-kernel-upgrade install

tpowa wrote:

shall i quote:
btw don't use gcc4,glibc and binutils from testing smile

sorry, thank you, now (with gcc3 glibc and binutils from current) it works... smile

Offline

#8 2005-05-17 14:12:17

tmadhavan
Member
From: Wales :D
Registered: 2004-03-26
Posts: 441

Re: Nvidia FATAL module error on post-kernel-upgrade install

Umm so what's my solution? Downgrade binutils, gcc and glibc? I haven't installed any of them from testing.

Here's my nvidia installer log:

Using built-in stream user interface
-> The file '/tmp/.X0-lock' exists... an X server appears to be running
ERROR: You appear to be running an X server; please exit X before installing.
       For further details, please see the section INSTALLING THE NVIDIA DRIVER
       in the README available on the Linux driver download page at
       www.nvidia.com.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.

That appears to be the wrong error so I'll kill X and try again now...

Offline

#9 2005-05-17 14:24:05

tmadhavan
Member
From: Wales :D
Registered: 2004-03-26
Posts: 441

Re: Nvidia FATAL module error on post-kernel-upgrade install

Ah, now I have the gcc problem.

So, do I need to reinstall and old gcc? Won't this bugger up some of my other things?

And I did have gcc4 installed from testing?! I'm sure I didn't have testing stuff in there before, evidently I do, heh.

Where next?

Offline

#10 2005-05-17 15:32:58

Blaasvis
Member
Registered: 2003-01-17
Posts: 467

Re: Nvidia FATAL module error on post-kernel-upgrade install

the best solution is to rebuild the kernel with gcc 4.


Freedom is what i love

Offline

#11 2005-05-17 16:06:25

tmadhavan
Member
From: Wales :D
Registered: 2004-03-26
Posts: 441

Re: Nvidia FATAL module error on post-kernel-upgrade install

Wouldn't it just be easier to downgrade the kernel with pacman rather than recompiling it?

I've never compiled my own kernel with Arch before, can't really be arsed to be honest.

Offline

#12 2005-05-17 16:13:19

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Nvidia FATAL module error on post-kernel-upgrade install

Blaasvis wrote:

the best solution is to rebuild the kernel with gcc 4.

as far as I know, you can't yet without some pretty heavy patching

Offline

#13 2005-05-17 16:20:39

tmadhavan
Member
From: Wales :D
Registered: 2004-03-26
Posts: 441

Re: Nvidia FATAL module error on post-kernel-upgrade install

Erm my ivtv module is fucked as well?!?

How come? Can't watch TV, and if you've seen the mythtv post in AUR requests, you'll know how ridiculously long it's taken to get working!

BOLLOCKS.

Offline

#14 2005-05-17 16:26:40

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: Nvidia FATAL module error on post-kernel-upgrade install

phrakture wrote:
Blaasvis wrote:

the best solution is to rebuild the kernel with gcc 4.

as far as I know, you can't yet without some pretty heavy patching

It's not so heavy, and a patch(16kB) for our stock kernel26 is here:
http://bbs.archlinux.org/viewtopic.php?p=87720#87720

-neri

Offline

#15 2005-05-18 09:49:59

tmadhavan
Member
From: Wales :D
Registered: 2004-03-26
Posts: 441

Re: Nvidia FATAL module error on post-kernel-upgrade install

Hmm I'm not getting anywhere... after patching my kernel, I should be able to install the gcc4 stuff, no?

Offline

#16 2005-05-22 21:17:32

potentials
Member
Registered: 2004-01-04
Posts: 130

Re: Nvidia FATAL module error on post-kernel-upgrade install

I'm having the same problem but with kernel 2.6.11.7-1, gcc 3.4.3-2 and binutils 2.15-1.

Running pacman -S nvidia from console got me the same error

 FATAL: module nvidia not found

So I downloaded the installer from nvidia.com, ran it and got the same error.

Here's /var/log/nvidia-installer.log

http://www.thepastebin.com/potentials_nvidia/

Offline

#17 2005-05-27 16:47:22

tmadhavan
Member
From: Wales :D
Registered: 2004-03-26
Posts: 441

Re: Nvidia FATAL module error on post-kernel-upgrade install

Is this fixable then?

Offline

#18 2005-05-28 12:50:22

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: Nvidia FATAL module error on post-kernel-upgrade install

Try downloading the driver form nvidia.com and run something like this:

sh NVIDIA-Linux-x86-1.0-7174-pkg1.run -k $(uname -r)

Offline

#19 2005-05-28 19:53:55

tmadhavan
Member
From: Wales :D
Registered: 2004-03-26
Posts: 441

Re: Nvidia FATAL module error on post-kernel-upgrade install

Did that and the module built alright, I think.

Now I get another gcc error sad

FATAL: Error inserting nvidia (/lib/modules/2.6.12-rc5-mm1-ARCH/kernel/drivers/video/nvidia.ko): Invalid module format

There was something about '2.6.12.... gcc-4 should be 2.6.12.... gcc-3.4' when I tried to modprobe outside X...

Offline

#20 2005-05-28 19:55:43

tmadhavan
Member
From: Wales :D
Registered: 2004-03-26
Posts: 441

Re: Nvidia FATAL module error on post-kernel-upgrade install

Ah dmesg reveals it:

[17180229.896000] nvidia: version magic '2.6.12-rc5-mm1-ARCH SMP preempt 686 gcc-4.0' should be '2.6.12-rc5-mm1-ARCH SMP preempt 686 gcc-3.4'

T.

Offline

#21 2005-05-29 14:04:23

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: Nvidia FATAL module error on post-kernel-upgrade install

So you have kernel compiled with gcc4 but you're using gcc3 on this system?
I think you should recompile or reinstall kernel compiled with gcc3.

Offline

#22 2005-05-29 19:09:35

tmadhavan
Member
From: Wales :D
Registered: 2004-03-26
Posts: 441

Re: Nvidia FATAL module error on post-kernel-upgrade install

Hmm just compiled my own stock kernel, nvidia seems to have installed OK, I get direct rendering, but there is no logo and the 'NoLogo' switch is off as far as I know.

Also got some weird font issues with my lcd monitor, maybe something to do with that autohinter or whatever it was I saw the other day

Offline

Board footer

Powered by FluxBB