You are not logged in.

#1 2011-01-01 09:09:51

wmt
Member
Registered: 2010-03-13
Posts: 2

USB mouse causing audio dropouts (USB sound card)

After setting up my external usb DAC, I am experiencing audio dropouts ("noise") whenever my USB mouse is transmitting input (e.g. movement, scroll wheel, clicking). This does not occur on my Windows 7 partition. I am using ALSA.

$cat /proc/interrupts
            CPU0       CPU1       
   0:         50          0   IO-APIC-edge      timer
   1:          2          0   IO-APIC-edge      i8042
   6:          3          0   IO-APIC-edge      floppy
   7:          1          0   IO-APIC-edge    
   8:        138          0   IO-APIC-edge      rtc0
   9:          1          0   IO-APIC-fasteoi   acpi
  12:          4          0   IO-APIC-edge      i8042
  14:          0          0   IO-APIC-edge      pata_amd
  15:        112          0   IO-APIC-edge      pata_amd
  16:        638          0   IO-APIC-fasteoi   nvidia
  20:          4          0   IO-APIC-fasteoi   ehci_hcd:usb1
  21:      39349          0   IO-APIC-fasteoi   eth0
  22:       2000          0   IO-APIC-fasteoi   sata_nv
  23:      22867          0   IO-APIC-fasteoi   sata_nv, ohci_hcd:usb2
 NMI:         32         27   Non-maskable interrupts
 LOC:      33295      29993   Local timer interrupts
 SPU:          0          0   Spurious interrupts
 PMI:         32         27   Performance monitoring interrupts
 PND:          0          0   Performance pending work
 RES:       5182       7488   Rescheduling interrupts
 CAL:         25        157   Function call interrupts
 TLB:       6897       8399   TLB shootdowns
 TRM:          0          0   Thermal event interrupts
 THR:          0          0   Threshold APIC interrupts
 MCE:          0          0   Machine check exceptions
 MCP:          2          2   Machine check polls
 ERR:          2
 MIS:          0
   
$lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 1532:0017 Razer USA, Ltd 
Bus 002 Device 003: ID 045e:00dd Microsoft Corp. Comfort Curve Keyboard 2000 V1.0
Bus 002 Device 004: ID 1852:7022 GYROCOM C&C Co., LTD
$cat /proc/asound/cards                
 0 [U0x18520x7022  ]: USB-Audio - USB Device 0x1852:0x7022
                      USB Device 0x1852:0x7022 at usb-0000:00:0b.0-4, full speed

Here is a thread about a problem /very/ similar to mine, although none of the suggestions seemed to work. I've also tried reinstalling Arch and using nouveau drivers.
https://bbs.archlinux.org/viewtopic.php?id=95574

Offline

#2 2011-01-01 10:47:24

brebs
Member
Registered: 2007-04-03
Posts: 3,426

Re: USB mouse causing audio dropouts (USB sound card)

Is there any difference if you physically swap the cables around?

Maybe some useful info here.

Offline

#3 2011-01-23 21:56:11

wmt
Member
Registered: 2010-03-13
Posts: 2

Re: USB mouse causing audio dropouts (USB sound card)

Thanks, this worked.

Why did it work?

Offline

#4 2011-01-27 03:13:49

brebs
Member
Registered: 2007-04-03
Posts: 3,426

Re: USB mouse causing audio dropouts (USB sound card)

Well, I would probably mutter something vague about electrical shielding and cable positioning.

Offline

Board footer

Powered by FluxBB