You are not logged in.

#1 2003-10-27 12:22:34

sud_crow
Member
From: Argentina
Registered: 2003-06-30
Posts: 545

Pacman, Oh Pacman.

Hi again....

Im back with more pacman and dial up issues. he....


This is the thing:

[root@archcrow crow]# pacman -Syu
:: Synchronizing package databases...
current.db.tar.gz        [####################################] 100% |     34K
unofficial.db.tar.gz     [####################################] 100% |     69K
unstable.db.tar.gz       [####################################] 100% |      0K
:: replace libgail-gnome with gail from "current"? [Y/n] n
:: replace at-spi with gail from "current"? [Y/n] n
:: replace gtk-thinice-engine with gnome-themes from "current"? [Y/n] n
:: replace bonobo-activation with libbonobo from "current"? [Y/n] n
:: replace fontilus with nautilus from "current"? [Y/n] n
:: replace xfree86 with xfree86 from "current"? [Y/n] n
:: fontconfig conflicts with xfree86. Remove xfree86? [Y/n] n

error: package conflicts detected

As i always say in my pacman related posts, i just run -Syu to see whats updated, and then select them manually while seeing the whole "list". This means that when i run pacman -Syu i answer n to everything.

I already "pacmaned" gail, gnome-themes, libbonobo and nautilus, but it keeps asking to replace the packages shown above, also, now there is that thing with XFree86 and fontconfig that wont let me see the new updates (i know i can look at them in Archs Homepage... but i still want to be able to do it from pacman)


Also, i was thinking, when will be the option to update "categories" available? something like pacman -S base for ex.

Thanks!


Leonardo Andrés Gallego
www.archlinux-es.org || Comunidad Hispana de Arch Linux

Offline

#2 2003-10-27 18:18:51

apeiro
Daddy
From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771
Website

Re: Pacman, Oh Pacman.

sud_crow wrote:

also, now there is that thing with XFree86 and fontconfig that wont let me see the new updates (i know i can look at them in Archs Homepage... but i still want to be able to do it from pacman)

See here: http://bbs.archlinux.org/viewtopic.php?t=1633

Also, i was thinking, when will be the option to update "categories" available? something like pacman -S base for ex.

Well, we have group support now, so I can just flag all the packages in the base category as part of the 'base' group.  The two are not synonymous though.  Categories within ABS are just for organization.  Pacman doesn't pay attention to them at all.

Offline

#3 2003-10-28 03:34:34

sud_crow
Member
From: Argentina
Registered: 2003-06-30
Posts: 545

Re: Pacman, Oh Pacman.

Ok,
anyway i wont update xfree86, as its working just fine for now....
but i would like to solve the issues surrounding the "replace questions" because i already installed the pkgs... i didnt removed the old one though... should i do pacman -Rd to the old pkgs and then reinstall the new ones??


Leonardo Andrés Gallego
www.archlinux-es.org || Comunidad Hispana de Arch Linux

Offline

#4 2003-10-29 04:54:25

sud_crow
Member
From: Argentina
Registered: 2003-06-30
Posts: 545

Re: Pacman, Oh Pacman.

i will have to run a full update if i want pacman -Syu to work again??

damn.


Leonardo Andrés Gallego
www.archlinux-es.org || Comunidad Hispana de Arch Linux

Offline

#5 2003-10-29 05:03:17

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: Pacman, Oh Pacman.

Remove the old packages.  The idea of something replacing something else is that you remove the old one.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

Board footer

Powered by FluxBB