You are not logged in.

#1 2005-05-24 15:00:11

viniosity
Member
From: Washington, DC
Registered: 2005-01-22
Posts: 377
Website

Thinkpad X41 wireless woes [solved]

I'm trying to get wireless working on my thinkpad X41 without much luck.  I've been through the wiki and several other posts but can't get it working.  Here's what I've done so far:

installed (via pacman) hwd, ng-lan26, ipw2200
I've done modprobe ipw and set up eth1 in rc.conf as "dhcp"

ifconfig shows only my eth1 and lo
lshwd shows my Network controller as: (ipw2200) but when I modprobe ipw2200 I get a FATAL: module not found. error.  modprobe as ipw worked.

I'm guessing (based on lshwd) that I have the right module but can't be sure. dmesg and lspci don't provide any other details.  I imagine I might have to set up the interface using iwconfig but I have no idea which interface to use. I guessed it was eth1 but there's no eth1 or wlan under /dev.  (there's no eth0 either but that seems to work..

Any help would be much appreciated.. can't really start to use the laptop without wireless...

Offline

#2 2005-05-24 15:06:04

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Thinkpad X41 wireless woes [solved]

do a "pacman -Ql ipw2200" and check "uname -r" - maybe the ipw module is for the wrong kernel version

Offline

#3 2005-05-24 17:21:59

viniosity
Member
From: Washington, DC
Registered: 2005-01-22
Posts: 377
Website

Re: Thinkpad X41 wireless woes [solved]

Here is the output from that command:

 pacman -Ql ipw2200
ipw2200 /lib/
ipw2200 /lib/firmware/
ipw2200 /lib/firmware/LICENSE-ipw2200
ipw2200 /lib/firmware/ipw-2.3-boot.fw
ipw2200 /lib/firmware/ipw-2.3-bss.fw
ipw2200 /lib/firmware/ipw-2.3-bss_ucode.fw
ipw2200 /lib/firmware/ipw-2.3-ibss.fw
ipw2200 /lib/firmware/ipw-2.3-ibss_ucode.fw
ipw2200 /lib/firmware/ipw-2.3-sniffer.fw
ipw2200 /lib/firmware/ipw-2.3-sniffer_ucode.fw
ipw2200 /lib/modules/
ipw2200 /lib/modules/2.6.11.10-ARCH/
ipw2200 /lib/modules/2.6.11.10-ARCH/kernel/
ipw2200 /lib/modules/2.6.11.10-ARCH/kernel/drivers/
ipw2200 /lib/modules/2.6.11.10-ARCH/kernel/drivers/net/
ipw2200 /lib/modules/2.6.11.10-ARCH/kernel/drivers/net/wireless/
ipw2200 /lib/modules/2.6.11.10-ARCH/kernel/drivers/net/wireless/ipw2200/
ipw2200 /lib/modules/2.6.11.10-ARCH/kernel/drivers/net/wireless/ipw2200/ieee80211.ko
ipw2200 /lib/modules/2.6.11.10-ARCH/kernel/drivers/net/wireless/ipw2200/ieee80211_crypt.ko
ipw2200 /lib/modules/2.6.11.10-ARCH/kernel/drivers/net/wireless/ipw2200/ieee80211_crypt_ccmp.ko
ipw2200 /lib/modules/2.6.11.10-ARCH/kernel/drivers/net/wireless/ipw2200/ieee80211_crypt_tkip.ko
ipw2200 /lib/modules/2.6.11.10-ARCH/kernel/drivers/net/wireless/ipw2200/ieee80211_crypt_wep.ko
ipw2200 /lib/modules/2.6.11.10-ARCH/kernel/drivers/net/wireless/ipw2200/ipw2200.ko

uname -r shows

uname -r
2.6.11.10-ARCH

not sure where to go from here..

Offline

#4 2005-05-24 17:56:01

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Thinkpad X41 wireless woes [solved]

run "depmod -ae" and then try modporbing it again

Offline

#5 2005-05-24 18:00:32

viniosity
Member
From: Washington, DC
Registered: 2005-01-22
Posts: 377
Website

Re: Thinkpad X41 wireless woes [solved]

ok, I ran depmod -ae and got no output. Then I ran modprob ipw2200 and got no output either. I assume those are both good things since there was no error.  ifconfig still only shows lo and eth0 though.  Where do I go from there?

Also, do I just need to run depmod-ae once or is there something I should do so that when I put ipw2200 in my rc.conf that I don't get an error?

Thanks..

Offline

#6 2005-05-24 18:59:32

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Thinkpad X41 wireless woes [solved]

ok, couple of things:
the kernel doesn't search for files when loading a module... it keeps a file which contains a list of modules and their path (blah.map files)... depmod -ae simply rewrites these files.  You need to do this whenever a module is added.  Technically the ipw2200 package should have ran it on install (notify the maintainer, please)

if modprobe produced no error, run "lsmod" just to verify that ipw2200 is loaded (i'm assuming it is)

now you can add it to your modules array

as for wireless, the simplest, most straight-forward way to get it up and running is like so:
first run "ifconfig -a" and look for either eth1 or wlan0... this depends on the module, and I'm not sure which one ipw2200 uses... I'll call this "$interface" below:

modprobe ipw2200 <--- done
iwconfig $interface essid "My AP Essid"
ifconfig $interface up
dhcpcd $interface <--- or use static if ya want

that should work...

Offline

#7 2005-05-24 19:20:37

viniosity
Member
From: Washington, DC
Registered: 2005-01-22
Posts: 377
Website

Re: Thinkpad X41 wireless woes [solved]

Wow -- so I rebooted my system and wireless is working.  Only snag is that it's taking the eth0 interface which was previously my ethernet connection.  I changed the eth0 to eth1 for ethernet but that didn't seem to work..

Anyway, I'm typing this wirelessly on my arch thinkpad!  I'm going to post my rc.conf file.. maybe you can give me a hint as to how to get my ethernet back.  Can I have both interfaces active at once?

# /etc/rc.conf - Main Configuration for Arch Linux
#

#
# Localization
#
# HARDWARECLOCK: set to "UTC" or "localtime"
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: fount in /usr/share/kbd/consolefonts (only needed for non-us)
# USECOLOR: use ANSI color sequences in startup messages
#
HARDWARECLOCK="localtime"
TIMEZONE=America/New_York
KEYMAP=us
CONSOLEFONT=
USECOLOR="yes"

# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

#
# Networking
#
HOSTNAME="archer"

#
# Module to load at boot-up (in this order)
#   (prefix a module with a ! to disable it)
#
MODULES=(usbserial !ide-scsi videodev snd-mixer-oss snd-pcm-oss usb-storage speedstep-centrino ipw2200 cpufreq_powersave cpufreq_userspace freq_table)

#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   (prefix an interface in INTERFACES with a ! to disable it)
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
eth1="eth0 192.168.1.72 netmask 255.255.255.0 broadcast 192.168.1.255"
INTERFACES=(lo eth0)
eth0="dhcp"
#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   (prefix a route in ROUTES with a ! to disable it)
#
gateway="default gw 192.168.1.1"
ROUTES=(gateway)

#
# Daemons to start at boot-up (in this order)
#   (prefix a daemon with a ! to disable it)
#
DAEMONS=(syslog-ng hotplug pcmcia portmap fam network netfs crond dbus mono hal sshd cups acpid cpufreqd)

Offline

#8 2005-05-24 19:24:35

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Thinkpad X41 wireless woes [solved]

ummm how do you set your essid? I don't see anything to do that (I don't think)

to fix the eth0/1 thing, add an alias to modprobe.conf... I always get these backwards... but it's either:
alias wlan0 ipw2200
or
alias ipw2200 wlan0

(you can use something else, but I like wlan0 for wireless)

Offline

#9 2005-05-24 19:38:43

viniosity
Member
From: Washington, DC
Registered: 2005-01-22
Posts: 377
Website

Re: Thinkpad X41 wireless woes [solved]

I haven't been setting essid.. it just attached automatically.  This is an unsecured network (in a secure location..) that I'm using just for testing.  Probably once passwords and WEP come into play I'll have some difficulty.  But that's an issue for another thread. smile

Regarding the eth0, eth1 thing, I found a few typo's in my rc.conf (Interfaces was missing eth1 and eth1 was defined as eth0) which I fixed.  I've got both working now but I'll look into that alias thing.

Thanks for the help!

Offline

#10 2005-05-24 19:54:31

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Thinkpad X41 wireless woes [solved]

viniosity wrote:

I haven't been setting essid.. it just attached automatically.  This is an unsecured network (in a secure location..) that I'm using just for testing.  Probably once passwords and WEP come into play I'll have some difficulty.  But that's an issue for another thread. smile

Well, an essid has nothing to do with encryption... it's the name of the wireless network.  I've never known any wireless drivers to auto-connect without specifying an essid... but then again I never tried...

Offline

#11 2005-05-24 21:13:04

viniosity
Member
From: Washington, DC
Registered: 2005-01-22
Posts: 377
Website

Re: Thinkpad X41 wireless woes [solved]

I went through the man pages for iwconfig and there is an option to use essid=any which might be why it is autoconnecting...

The problem with that is, back at the apartment, it automatically attaches to somebody else's router. I used iwconfig eth0 essid "viniosity ap" to attach to my access point, and iwconfig eth0 key s:password to get my password in but I still don't have access.  Typing ifconfig shows eth1 and lo but not my wireless (eth0).

Is there any way to bring that up?  What's the equivalent of ifup to bring eth0 back alive?

Offline

#12 2005-05-24 21:45:54

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Thinkpad X41 wireless woes [solved]

use "ifconfig eth0 up" after the iwconfig lines, then run dhcp/whatever

Offline

#13 2005-05-24 21:48:30

viniosity
Member
From: Washington, DC
Registered: 2005-01-22
Posts: 377
Website

Re: Thinkpad X41 wireless woes [solved]

Sweet. Ok, I had to set essid and then set the password. then /etc/rc.d/network ifup eth0 and it all works.  Thanks very much!

Offline

Board footer

Powered by FluxBB