You are not logged in.

#1 2005-05-23 15:06:01

napoleon
Member
Registered: 2005-04-03
Posts: 176

can't play dvd after totem and hal upgrade

5 mins ago i was happily watching a DVD using totem. Them i upgraded to totem 1.0.3-1 and hal 0.4.8-1. The dvd stopped playing and now when i try to play a dvd totem i get the message "Totem could not play 'dvd://', No URI handler implemented for 'dvd://'". Xine gives me

"There is no input plugin to handle dvd:/ Maybe MRI syntax is wrong or file/system source doesn't exist

The source can't be read
Maybe u don't have enough roghts for this or source doesn't contain data (eg no disc in drive)"

Whats all this about.   :x

below is my fstab if its any help:

# This file is edited by fstab-sync - see 'man fstab-sync' for details
#
# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
none                   /dev/pts      devpts    defaults            0      0
none                   /dev/shm      tmpfs     defaults            0      0
tmpfs                  /tmp          tmpfs     defaults            0      0
usbfs                  /proc/bus/usb usbfs  defaults            0      0

/dev/cdroms/cdrom0     /mnt/cd   iso9660   ro,user,noauto,unhide   0      0
/dev/cdroms/cdrom0     /mnt/dvd  udf       ro,user,noauto,unhide   0      0
/dev/floppy/0          /mnt/fl   vfat      user,noauto             0      0

/dev/discs/disc1/part2 swap swap defaults 0 0
/dev/discs/disc1/part1 / ext3 defaults 0 1
/dev/discs/disc1/part3 /home reiserfs defaults 0 0
/dev/discs/disc1/part4 /windows vfat defaults 0 0


thnx :x


A good friend will come and bail you out of jail...BUT a true friend will be sitting next to you saying, "Damn...that was fun!"

Offline

#2 2005-05-24 20:23:42

napoleon
Member
Registered: 2005-04-03
Posts: 176

Re: can't play dvd after totem and hal upgrade

i have downgraded both hal and totem to the revious versions and now i can play dvds again. What i don't understand is why shoud an upgrade from version say 1.0.2 to 1.0.3 break a system? Nothing is straight forward in linux. I know the average linux user doesn't mind tweaking things but sometime you just want things to work you know!  :x


A good friend will come and bail you out of jail...BUT a true friend will be sitting next to you saying, "Damn...that was fun!"

Offline

#3 2005-05-25 10:27:11

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: can't play dvd after totem and hal upgrade

totem changed from GStreamer in our 1.0.3. You need the gst-plugins-dvd plugin to play DVDs with GStreamer.

When gst-plugins-0.8.9 and gst-ffmpeg 0.8.5 are released, totem will get an upgrade to 1.1.2 to get rid of the shortcomings in the subtitles support for totem/gstreamer.

Offline

Board footer

Powered by FluxBB