You are not logged in.

#151 2011-02-22 08:30:17

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: Ayatana Project on Archlinux - official thread

jarryson wrote:

Seems there is no indicator-appmenu in dcc24's repo?

I'm trying to package all the latest versions and latest indicator-appmenu is broken. It'll be included when I can get it to compile smile Till then, use AUR or ballo's stable package.


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#152 2011-02-22 12:53:58

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: Ayatana Project on Archlinux - official thread

I build libdbusmenu with introspection support successfully. Need ubuntu patches to compile glib2, gtk2, and gdk-pixbuf2.

and thanks to zephyr and Zom, indicator-appmenu works fine now.

Offline

#153 2011-02-22 12:56:39

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: Ayatana Project on Archlinux - official thread

jarryson wrote:

Need ubuntu patches to compile glib2, gtk2, and gdk-pixbuf2.

Yeah this seems to be the case. Repo will be updated soon.


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#154 2011-02-23 04:56:29

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: Ayatana Project on Archlinux - official thread

@dcc24: why not just use -bzr packages? it will be much easier to update. Just a suggestion, wink

Offline

#155 2011-02-23 05:41:59

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: Ayatana Project on Archlinux - official thread

If I use bzr packages, they can break without me knowing it smile At least when I'm using a specific version, I know 100% that it works with the other packages. With bzr packages, I can't guarantee that.


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#156 2011-02-23 08:08:35

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: Ayatana Project on Archlinux - official thread

@dcc24, can you provide ubuntu patched qt (qt-appmenu) package and appmenu-qt, too?

Thanks again.

Offline

#157 2011-02-23 11:53:20

Majkhii
Member
Registered: 2007-07-29
Posts: 53

Re: Ayatana Project on Archlinux - official thread

@dcc24: Hi, will be there x86_64 support for ayatana? I can lend a hand if you need x86_64 machine


Proud to be ArchLinux64 user.

configs: http://github.com/Mihairu/config-files/tree/master
current desktop: here

Offline

#158 2011-02-23 12:01:38

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: Ayatana Project on Archlinux - official thread

@jarryson: Added them to my list. I'll get to them when I can. Currently City-busz and I are working on combining our repos. New packages will come afterwards.

@Majkhii: I'd love to have x86_64 packages but I don't have a 64 bit build box. If you can help, you can grab the sources [1] and try to compile them. If all of them compile successfully, we can make those into a 64 bit repo.

[1] http://sources.ayatana.info/

Last edited by dcc24 (2011-02-23 20:14:29)


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#159 2011-02-23 12:53:56

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: Ayatana Project on Archlinux - official thread

Notice: I'm migrating the repo to to a new domain, so it might disappear for a few minutes.

EDIT: Repo URL has been changed! See the original post: https://bbs.archlinux.org/viewtopic.php … 00#p894100

Also, here's the new project homepage: http://ayatana.info/

Last edited by dcc24 (2011-02-23 13:19:32)


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#160 2011-02-23 17:29:19

Majkhii
Member
Registered: 2007-07-29
Posts: 53

Re: Ayatana Project on Archlinux - official thread

I compiled almost everything except gnome-control-center,gnome-screensaver,gnome-user-share  and some indicators which i dont need, but after I add indicator applet to panel i have

** (gnome-panel:10901): WARNING **: Failed to load applet OAFIID:GNOME_IndicatorApplet:
System exception: IDL:Bonobo/GeneralError:1.0 : Child process did not give an error message, unknown failure occurred

any ideas?


Proud to be ArchLinux64 user.

configs: http://github.com/Mihairu/config-files/tree/master
current desktop: here

Offline

#161 2011-02-23 17:47:11

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: Ayatana Project on Archlinux - official thread

Majkhii wrote:

I compiled almost everything except gnome-control-center,gnome-screensaver,gnome-user-share  and some indicators which i dont need, but after I add indicator applet to panel i have

** (gnome-panel:10901): WARNING **: Failed to load applet OAFIID:GNOME_IndicatorApplet:
System exception: IDL:Bonobo/GeneralError:1.0 : Child process did not give an error message, unknown failure occurred

any ideas?

Hmm, I did a quick google search and there are tons of ancient stuff about this. Still, I've seen several bug reports that indicated a corrupted openssl package was the culprit. Can you try to rebuild openssl from abs? Also, if that doesn't fix it, maybe it needs the older openssl, so "openssl-compatibility" from AUR might help.


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#162 2011-02-23 18:37:38

Majkhii
Member
Registered: 2007-07-29
Posts: 53

Re: Ayatana Project on Archlinux - official thread

@dcc24...i built openssl-compatibility but nothing changed


Proud to be ArchLinux64 user.

configs: http://github.com/Mihairu/config-files/tree/master
current desktop: here

Offline

#163 2011-02-23 20:13:16

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: Ayatana Project on Archlinux - official thread

Well, I'm out of ideas smile I'll try to replicate it on i686. Btw, did you alter the PKGBUILDs in any way?


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#164 2011-02-23 20:19:14

Majkhii
Member
Registered: 2007-07-29
Posts: 53

Re: Ayatana Project on Archlinux - official thread

@dcc24...no I didn't touch any of PKGBUILDS but i can't build some of them (indicators evolution etc.) because they cant download sources and if you want i could paste errors from gnome-* PKGBUILDS (maybe there is problem?)


Proud to be ArchLinux64 user.

configs: http://github.com/Mihairu/config-files/tree/master
current desktop: here

Offline

#165 2011-02-23 20:41:31

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: Ayatana Project on Archlinux - official thread

It'd be great if you can post the errors on http://aur.pastebin.com and give the links here.


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#166 2011-02-23 21:15:16

Majkhii
Member
Registered: 2007-07-29
Posts: 53

Re: Ayatana Project on Archlinux - official thread

@dcc24:

gnome-control-center: http://aur.pastebin.com/fv0Fx4B7 i had libgnomekbd from aur...with extra it compiles OK
gnome-screensaver: http://aur.pastebin.com/JwZfmbAN compiled successfully
indicator-diodon: http://aur.pastebin.com/VjLNCjV0
indicator-evolution & indicator-thundebird: cannot fetch sources found sources on net

I recompiled all packages and indicators now working...dont know exactly why smile

Last edited by Majkhii (2011-02-24 18:00:26)


Proud to be ArchLinux64 user.

configs: http://github.com/Mihairu/config-files/tree/master
current desktop: here

Offline

#167 2011-02-24 05:06:55

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: Ayatana Project on Archlinux - official thread

Wow, great work Majkhii! I'll add libgnomekbd to the dependencies of gnome-control-center.

I'll send you the source URL's for indicator-evolution, and then we can put those packages in the repo smile


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#168 2011-02-24 17:54:48

Majkhii
Member
Registered: 2007-07-29
Posts: 53

Re: Ayatana Project on Archlinux - official thread

@dcc24:
http://dl.dropbox.com/u/8473341/ayatana.tar.gz
some packages missing as I see...ejecter, diodon and evolution

I found sources for evolution, but i think it should be upgraded to newer version
ejecter and diodon ends with same error Checking for appindicator-0.1: not found

btw: can you add some indicators? 
Indicator-Weather - https://launchpad.net/weather-indicator
indicator-virtualbox - https://launchpad.net/indicator-virtualbox
indicator-sound - https://wiki.ubuntu.com/SoundMenu - https://launchpad.net/indicator-sound
indicator-cpufreq - https://launchpad.net/indicator-cpufreq
indicator-xchat - https://launchpad.net/xchat-indicator

and can you 'merge' notify-osd with aur/notify-osd-customizable because of notifyconf? smile thx

Last edited by Majkhii (2011-02-24 21:53:52)


Proud to be ArchLinux64 user.

configs: http://github.com/Mihairu/config-files/tree/master
current desktop: here

Offline

#169 2011-02-24 21:55:08

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: Ayatana Project on Archlinux - official thread

All right, I'll do all of those tomorrow. Thanks!


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#170 2011-02-26 01:29:38

Kosava
Member
From: Serbia
Registered: 2008-08-19
Posts: 127

Re: Ayatana Project on Archlinux - official thread

I have little error with installing ayatana

# pacman -S ayatana
resolving dependencies...
warning: cannot resolve "python-keybinder", a dependency of "indicator-lookit"
:: the following package(s) cannot be upgraded due to unresolvable dependencies:
      indicator-lookit

i think you need to put libkeybinder python-keybinder to deppendens.

Offline

#171 2011-02-26 05:32:31

City-busz
Trusted User (TU)
From: Budapest, Hungary
Registered: 2010-12-27
Posts: 162
Website

Re: Ayatana Project on Archlinux - official thread

Now (2011-02-26) I added my stable packages to [ayatana] repo also. If you've used [ayatana] repo before that, then you have to do the following steps:

  1. Clean up your pacman cache from packages that installed from [ayatana] repo:

    # rm `pacman -Sl ayatana | awk '/\[/ {print "/var/cache/pacman/pkg/"$2"-"$3"-*.pkg.tar.gz"}'`
  2. Some packages renamed, you have to remove them if you had installed before update:

    # pacman -Rs indicator-evolution indicator-pidgin indicator-thunderbird plasma-message-indicator
  3. Reinstall all packages that installed from ayatana repo:

    # pacman -Syu `pacman -Sl ayatana | awk '/\[/ {print $2}'`
  4. Install some useful packages. You can see all available packages in this repo:
    pacman -Qg ayatana

And now, you can found indicator-virtualbox, indicator-weather and notifyosdconfig both in [ayatana] and [ballo] repo.

Last edited by City-busz (2011-02-26 06:40:55)


My packages | My PGP Key: 0x0901C163

Online

#172 2011-02-26 07:03:37

hellnest
Member
From: $ dmesg | grep ATA
Registered: 2010-11-11
Posts: 194
Website

Re: Ayatana Project on Archlinux - official thread

Hai, i've got this error

The panel encountered a problem while loading "OAFIID:GNOME_IndicatorApplet".

Use all package from ayatana in a clean state smile


roll Snapping my own life roll
hmmgithubhmm
coolMyBlogcool

Offline

#173 2011-02-26 07:30:21

City-busz
Trusted User (TU)
From: Budapest, Hungary
Registered: 2010-12-27
Posts: 162
Website

Re: Ayatana Project on Archlinux - official thread

hellnest wrote:

Hai, i've got this error

The panel encountered a problem while loading "OAFIID:GNOME_IndicatorApplet".

Use all package from ayatana in a clean state smile

This may caused by a broken or incompatible indicator. You could find the error message from ~/.xsession-errors file. You could also try to run indicators individually. For this, run the following command on each file in  /usr/lib/indicators/4/ folder:

$ /usr/lib/indicator-loader /usr/lib/indicators/4/filename_here

My packages | My PGP Key: 0x0901C163

Online

#174 2011-02-26 18:57:30

Majkhii
Member
Registered: 2007-07-29
Posts: 53

Re: Ayatana Project on Archlinux - official thread

@dcc24: i found some updates on sources.ayatana.info, but downloading source gives me error 403...


Proud to be ArchLinux64 user.

configs: http://github.com/Mihairu/config-files/tree/master
current desktop: here

Offline

#175 2011-02-26 19:01:56

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: Ayatana Project on Archlinux - official thread

Majkhii wrote:

@dcc24: i found some updates on sources.ayatana.info, but downloading source gives me error 403...

Sorry, that was a server permissions error. Should be fixed now.


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

Board footer

Powered by FluxBB