You are not logged in.

#1 2005-05-27 06:26:14

nggalai
Member
From: Switzerland
Registered: 2004-08-01
Posts: 215
Website

Updated gst-plugins -> Robot Sound!

Hi there,

I updated the gst-plugins yesterday--and since after the reboot, all applications using gstreamer for sound playback (rhythmbox, totem) can't play ogg files correctly. It sounds like it's filtered through a synthesizer, or as if an orchestra of robots was playing the music. mp3 files don't play at all, or rather, there's just silence coming.

I did run gst-register as both user and root. No change. Xine and mplayer play the files correctly.

Any ideas?

93,
-Sascha.rb

Offline

#2 2005-05-27 07:40:39

JGC
Developer
Registered: 2003-12-03
Posts: 1,660

Re: Updated gst-plugins -> Robot Sound!

What output plugin are you using when running gstreamer-properties? Could be that you're using Alsa, which is broken from time to time. OSS is much more error free in my experience.

Offline

#3 2005-05-27 07:44:19

nggalai
Member
From: Switzerland
Registered: 2004-08-01
Posts: 215
Website

Re: Updated gst-plugins -> Robot Sound!

Yes, I'm using Alsa for sound output. Switching to OSS fixes the issues. Thanks for the hint!

Offline

#4 2005-05-29 09:37:13

leeghoofd
Member
From: the Netherlands
Registered: 2005-04-28
Posts: 61

Re: Updated gst-plugins -> Robot Sound!

Hello,

I just wanted to say I have the same problems.  I get two or three strange ticks in the sound per second when I use gstreamer with alsa output.

If I use another program that doesn't use gstreamer it sounds fine also if I switch gstreamer to use OSS instead of ALSO it sounds fine. So the problem is the combination of gstreamer and alsa. I think that this happened after upgrading the gstreamer plugins.

Offline

#5 2005-05-29 09:56:45

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Updated gst-plugins -> Robot Sound!

<robot sound>
"Intergalactic Planetary, Planetary Intergalactic ..."
</robot sound>

Offline

#6 2005-06-03 01:31:25

Jedi Stannis
Member
Registered: 2004-09-10
Posts: 65

Re: Updated gst-plugins -> Robot Sound!

I had the same problem.  however, using OSS stops dmix from working and now I dont have audio mixing, so multiple programs cant make sound at once.  Whats the best way around this?  any way to make gstreamer and ALSA play nicely together?

Offline

#7 2005-06-03 08:01:27

leeghoofd
Member
From: the Netherlands
Registered: 2005-04-28
Posts: 61

Re: Updated gst-plugins -> Robot Sound!

Since the new alsa version (0.9) the problem is fixed by me. This new version also support software mixing by default.

So what I would do if I were you is type
pacman -Syu (so you have alsa 0.9)
rm /etc/asound.conf (the dmix settings are not needed anymore)
reboot (I don't know what I have to restart smile)
and set gstreamer to use alsa again

This worked for me but of course I don't know if this works for you.

Cheers,
David

Offline

#8 2005-06-03 16:52:04

Jedi Stannis
Member
Registered: 2004-09-10
Posts: 65

Re: Updated gst-plugins -> Robot Sound!

Thank you, that worked perfectly!

Offline

Board footer

Powered by FluxBB