You are not logged in.

#1 2011-02-27 17:08:29

rapidcyclist
Member
Registered: 2011-02-27
Posts: 4

xfce4 app windows open pegged to topleft of screen, no window buttons

Good Morn from a pretty green arch user

after installing a lovely stable xfce environment, on mounting an external ntfs hard drive and not having it plugged in on startup again, all windows opened by the DE appear in the topleft overlayi panel 1, have no buttons to manipulate (eg resize/minimise) and cannot be dragged or given focus by clicking with the mouse pointer. Also, despite setting for 4 workspaces, only one is present now.

I have tried a search and also looked on the wiki and have not found this being reproduced. My workaround at present is to open htop and kill processes to remove them. Harsh I know, I don't like killing much also.

I am an old amiga user and love the simplicity and minimlistic feel of arch with xfce smile

Thank you!

Offline

#2 2011-02-27 21:29:10

stqn
Member
Registered: 2010-03-19
Posts: 1,189
Website

Re: xfce4 app windows open pegged to topleft of screen, no window buttons

I've never seen or heard of that behaviour... Is xfwm actually running? ("ps x | grep xfwm" to check)
Why do you think your external NTFS drive has something to do with this?
Have you done something else before the problem occured?
You can look at your logs in /var/log/ for error messages...

Offline

#3 2011-02-28 08:20:40

rapidcyclist
Member
Registered: 2011-02-27
Posts: 4

Re: xfce4 app windows open pegged to topleft of screen, no window buttons

hm... that command returns:
1949 pts/0    S+     0:00 grep xfwmexit
and the errors.log file has:
Feb 27 17:28:10 localhost kernel: sd 6:0:0:0: [sdb] Assuming drive cache: write through
Feb 27 17:28:10 localhost kernel: sd 6:0:0:0: [sdb] Assuming drive cache: write through
Feb 27 17:28:10 localhost kernel: sd 6:0:0:0: [sdb] Assuming drive cache: write through
I think it might have been the external drive because that was just before the problem started. shutdown would not complete.
may be a red herring

of interest, all daughter windows opened up by firefox do not have sliders, but the first window does. and do not permit mouse middle button scrolling

Anything else that may point to the problem?

Offline

#4 2011-02-28 12:42:38

stqn
Member
Registered: 2010-03-19
Posts: 1,189
Website

Re: xfce4 app windows open pegged to topleft of screen, no window buttons

I'm not sure why there is "exit" at the end of the output, but anyway it looks like xfwm4 is not running.

If shutdown was stuck and you forced it, maybe some files didn't get written to disk and that caused your problem.

Unfortunately, I have no idea how xfwm4 is started normally... BTW, does it work if you just run it once you're under X?

The drive cache messages are nothing to be worried about. I get them for all my USB drives.

Middle mouse button scrolling in Firefox has to be enabled in about:config (the default setting under Linux is to paste selected text with the MMB.) Unless you're talking about rotating the wheel...

Offline

#5 2011-02-28 22:51:34

rapidcyclist
Member
Registered: 2011-02-27
Posts: 4

Re: xfce4 app windows open pegged to topleft of screen, no window buttons

thank you stqn !
yes running xfwm4 from a terminal window after X has started fixes all the windows opening after, and gives 4 workspaces now.
smile

Offline

#6 2011-02-28 23:02:15

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,321

Re: xfce4 app windows open pegged to topleft of screen, no window buttons

Perhaps you have a corrupted saved session that causes xfwm4 to not start when it should.

Offline

#7 2011-03-03 05:06:32

rapidcyclist
Member
Registered: 2011-02-27
Posts: 4

Re: xfce4 app windows open pegged to topleft of screen, no window buttons

I've added xwfm4 to daemons on rc.conf and that has fixed the issue

thanks stqn and skunktrader smile

Offline

#8 2011-03-03 15:59:29

stqn
Member
Registered: 2010-03-19
Posts: 1,189
Website

Re: xfce4 app windows open pegged to topleft of screen, no window buttons

Even if it solves your problem, that's really not a good way to start Xfwm. I've looked at Xfce's startup scripts (starting from /usr/bin/startxfce4) and ended up at the end of /etc/xdg/xfce4/xinitrc, where there is an "IMPORTANT NOTE" which explains that if you're using xfce4-session, this is how stuff gets started (including xfwm).

I suggest that you look at this notice, and/or check xfce4-session's man page, and go from there.

If you want to follow skunktrader's idea, here's an interesting snippet:

man xfce4-session wrote:

xfce4-session uses the contents of the ~/.cache/sessions/ directory for
starting previously saved sessions.

Please note that I'm still using Xfce 4.6 (4.8 is the current version), so there may be differences on your system.

Offline

#9 2011-03-04 11:26:34

Behemot
Member
Registered: 2010-12-10
Posts: 96

Re: xfce4 app windows open pegged to topleft of screen, no window buttons

That's quite common problem in XFCE 4.8 now. Whenever saving session breaks, the xfwm4 do not start next time. I usually get some kind of I/O error and lost connection to session manager.

Offline

#10 2011-03-04 15:30:28

stqn
Member
Registered: 2010-03-19
Posts: 1,189
Website

Re: xfce4 app windows open pegged to topleft of screen, no window buttons

I found this related bug report:
http://bugzilla.xfce.org/show_bug.cgi?id=7324

And something which may help with session saving...
http://bugzilla.xfce.org/show_bug.cgi?id=7320

Offline

#11 2011-03-21 10:12:34

benke
Member
Registered: 2010-08-31
Posts: 54

Re: xfce4 app windows open pegged to topleft of screen, no window buttons

Happened to me too:

http://forum.xfce.org/viewtopic.php?pid=21010

I deleted ~/.cache/sessions and all works now.

Offline

Board footer

Powered by FluxBB