You are not logged in.

#1 2011-03-07 09:25:44

brazzmonkey
Member
From: between keyboard and chair
Registered: 2006-03-16
Posts: 818
Website

[PPC] yaboot failed to install. Help needed with partition scheme

Hi,

I'm trying to setup  ArchPPC on an old iMac G3. Yaboot failed to install and I suspect I did something wrong while configuring my partition scheme.

A small summary of what I did, as far as I can remember:

in mac-fdisk
- initialized disk
- created a 32 Mb bootstrap partition (sda2)
- created swap partition (sda3)
- created root partition (sda4)
- created home partition (sda5)
- wrote partition table

Then I'm getting a bit lost...
Am I supposed to create another partition for /boot, or can the boostrap partition be used for this mountpoint? If not, how large should bootstrap partition be?
Yaboot is supposed to be installed on sda2, is it right?

In my case, Yaboot failed. I rebooted on Arch live CD, but mac-fdisk doesn't see any of the previously created partitions.

Any guidance would be appreciated, especially on what a typical partition scheme should be (bear in mind that my HD is only 9.5 Gb).

Thanks.


what goes up must come down

Offline

#2 2011-03-08 10:00:15

brazzmonkey
Member
From: between keyboard and chair
Registered: 2006-03-16
Posts: 818
Website

Re: [PPC] yaboot failed to install. Help needed with partition scheme

Ok, looks like I had a problem with my bootstrap partition. Did a clean install with no dedicated /boot partition and yaboot got installed.
I got another issue upon rebooting, please see https://bbs.archlinux.org/viewtopic.php … 03#p900803


what goes up must come down

Offline

Board footer

Powered by FluxBB