You are not logged in.

#1 2011-03-14 13:30:47

egan
Member
From: Mountain View, CA
Registered: 2009-08-17
Posts: 273

No more Xorg Mousekeys [Solved]

After today's updates (dozens of xorg packages and drivers) I am no longer able to enable mousekeys in X11 with Shift-NumLk. Do I have to do some configuration or install another xorg-* package?
This functionality is very important as it is the only way I can "click" when I need to.

Last edited by egan (2011-03-19 19:51:27)

Offline

#2 2011-03-14 14:24:12

Awebb
Member
Registered: 2010-05-06
Posts: 4,164

Re: No more Xorg Mousekeys [Solved]

EDIT: Forget what I said. The Shift+Num is broken after a reboot, as well as my TwinView for my dual monitor setup. Curious.

Last edited by Awebb (2011-03-14 14:36:16)

Offline

#3 2011-03-14 16:08:42

LeCrayonVert
Member
Registered: 2010-09-01
Posts: 133

Re: No more Xorg Mousekeys [Solved]

It is not the only way you can enable mousekeys : open gnome-keyboard-properties and in "Mouse Keys" check "Pointer can be controlled using the keypad".


I believe in a world I can and do understand. A rational universe, explained through rational means.

Offline

#4 2011-03-14 17:35:42

egan
Member
From: Mountain View, CA
Registered: 2009-08-17
Posts: 273

Re: No more Xorg Mousekeys [Solved]

I don't use a desktop environment. I want an agnostic method to enable mouse keys.

Offline

#5 2011-03-14 23:47:34

TempusFugit
Member
Registered: 2011-03-14
Posts: 1

Re: No more Xorg Mousekeys [Solved]

The problem is with xkeyboard-config, version 2.1-1 is broken.
A possible workaround is to downgrade it.

cd /var/cache/pacman/pkg
pacman -U xkeyboard-config-2.0-1-any.pkg.tar.xz

Offline

#6 2011-03-15 00:20:17

haroldw
Member
Registered: 2011-03-15
Posts: 5

Re: No more Xorg Mousekeys [Solved]

pacman -U /var/cache/pacman/pkg/xkeyboard-config-2.0-1-any.pkg.tar.xz
did the trick for me.
Suppose there will be an update shortly for this package smile
I used to do Alt+Shift+Numlock, till I found out that Shift+Numlock does the same thing wink

Offline

#7 2011-03-15 02:48:22

egan
Member
From: Mountain View, CA
Registered: 2009-08-17
Posts: 273

Re: No more Xorg Mousekeys [Solved]

Ah, thanks for locating the source of the problem (there are so many xorg packages nowadays!).

Hopefully it gets resolved soon. [Bug report filed].

In the meantime, I can try to become truly mouse free (and use xdotool in extreme cases).

Last edited by egan (2011-03-15 02:56:58)

Offline

#8 2011-03-15 07:16:35

Falstaff
Member
Registered: 2008-11-03
Posts: 76

Re: No more Xorg Mousekeys [Solved]

Glad to see that I'm not the only one having this problem.

Offline

#9 2011-03-16 14:41:59

haroldw
Member
Registered: 2011-03-15
Posts: 5

Re: No more Xorg Mousekeys [Solved]

I think the file /usr/share/X11/xkb/symbols/pc is missing a piece.
Changing the following line:
key <NMLK> { [ Num_Lock ] };
back to as it was in version 2.0.1:
key <NMLK> { [ Num_Lock, Pointer_EnableKeys ] };
brings back the mousekeys functionality for me.
Reported as bug to bugs.freedesktop.org, xkeyboard-config

Offline

#10 2011-03-16 15:09:04

Falstaff
Member
Registered: 2008-11-03
Posts: 76

Re: No more Xorg Mousekeys [Solved]

haroldw wrote:

I think the file /usr/share/X11/xkb/symbols/pc is missing a piece.
Changing the following line:
key <NMLK> { [ Num_Lock ] };
back to as it was in version 2.0.1:
key <NMLK> { [ Num_Lock, Pointer_EnableKeys ] };
brings back the mousekeys functionality for me.
Reported as bug to bugs.freedesktop.org, xkeyboard-config

This fixed it for me. Thanks.

Offline

#11 2011-03-18 10:10:41

haroldw
Member
Registered: 2011-03-15
Posts: 5

Re: No more Xorg Mousekeys [Solved]

Received feedback from freedesktop development.
It says:
- mousekeys are disabled by default now
- use keypad:pointerkeys xkb option to enable

So, I added following section to /etc/X11/xorg.conf:

Section "InputClass"
    Identifier "Logitech Logitech USB Keyboard"
    MatchIsKeyboard "yes"
    Option "XkbOptions" "keypad:pointerkeys"
EndSection

And the mousekey functionality is back
(with the latest xkeyboard-config-2.1-1)

--- Comment #1 from Sergey V. Udaltsov 2011-03-16 14:36:27 PDT ---
It is disabled by default now. Use keypad:pointerkeys xkb option

Offline

#12 2011-03-18 10:14:38

Awebb
Member
Registered: 2010-05-06
Posts: 4,164

Re: No more Xorg Mousekeys [Solved]

Very well done, haroldw *thumbup*

Offline

#13 2011-03-19 19:51:01

egan
Member
From: Mountain View, CA
Registered: 2009-08-17
Posts: 273

Re: No more Xorg Mousekeys [Solved]

Thanks for the information, haroldw.

I can't believe they are doing this. First they removed Ctrl-Alt-Bkspc and now mousekeys...

Offline

#14 2012-01-21 20:00:25

Falstaff
Member
Registered: 2008-11-03
Posts: 76

Re: No more Xorg Mousekeys [Solved]

Another method for those who don't have an xorg.conf file can put in ~/.xinitrc the following command:

setxkbmap -option keypad:pointerkeys

Offline

Board footer

Powered by FluxBB