You are not logged in.

#1 2011-03-17 10:35:17

Hund
Member
From: Sweden
Registered: 2010-03-22
Posts: 386
Website

"error while loading shared libraries: libnotify.so.1: cannot open.."

This is what happend after I rebooted the computer today.

[ ~ ]$ pino
pino: error while loading shared libraries: libnotify.so.1: cannot open shared object file: No such file or directory

[ ~ ]$ gnome-gmail-notifier
gnome-gmail-notifier: error while loading shared libraries: libnotify.so.1: cannot open shared object file: No such file or directory

[ ~ ]$ liferea
liferea: error while loading shared libraries: libnotify.so.1: cannot open shared object file: No such file or directory

[ ~ ]$ linuxdcpp
linuxdcpp: error while loading shared libraries: libnotify.so.1: cannot open shared object file: No such file or directory

Im guessing Im not the only one? Dunno what to do?


Not all change is progress

Offline

#2 2011-03-17 10:38:24

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 6,816

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

Are you fully updated? Are you using testing (there's a new libnotify in testing currently)? Does /usr/lib/libnotify.so.1 exist?


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

#3 2011-03-17 10:40:01

Army
Member
Registered: 2007-12-07
Posts: 1,784

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

Looks like you have to rebuild those packages yourself! They are all taken from the AUR, right? It's your own responsibility to update them after a soname update.

Offline

#4 2011-03-17 10:49:16

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

just don't do symlinks. Ask for help if you have compilation problem

Last edited by wonder (2011-03-17 10:50:39)


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#5 2011-03-17 11:19:59

habtool
Member
From: Ireland, on the West Coast
Registered: 2007-02-17
Posts: 14

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

I don't want to hijack this thread, but this one seems  to be having the same issue:
alarm-clock-applet from AUR

If I try re-complied it I get:
alarm-applet.h:46:14: warning: array ‘supported_sound_mime_types’ assumed to have one element
  CCLD   alarm-clock-applet
ui.o: In function `alarm_applet_notification_show':
ui.c:(.text+0x51d): undefined reference to `notify_notification_new_with_status_icon'
collect2: ld returned 1 exit status
make[3]: *** [alarm-clock-applet] Error 1

If I try run from terminal:
$ alarm-clock-applet
alarm-clock-applet: error while loading shared libraries: libnotify.so.1: cannot open shared object file: No such file or directory

Any pointers where I am going wrong?

PS
Just to test, I did make a quick symlink from libnotify.so.1 to libnotify.so.4.0.0 and alarm-clock-applet then works
The missing missing libnotify.so.1 in /usr/lib seems to be the issue.

I did try sudo pacman -S libnotify to see if that would help or say there is a issue, but it installed with no errors etc.

Last edited by habtool (2011-03-17 11:25:15)

Offline

#6 2011-03-17 11:53:54

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

@habtool are you familiar with creating patches? here are some examples  on how to fix the code: http://pkgbuild.com/~ioni/libnotify-0.7/

let me know if you want to me to create the patch.

"the missing libnotify.so.1" is not that missing. now is libnotify.so.4 and a rebuild is needed to make the application link to the proper soname


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#7 2011-03-17 11:56:42

habtool
Member
From: Ireland, on the West Coast
Registered: 2007-02-17
Posts: 14

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

@wonder , I have not made a patch before, sorry, that is probably above my pay grade.

Offline

#8 2011-03-17 14:59:13

pingviin
Member
From: Estonia
Registered: 2009-11-05
Posts: 37
Website

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

This seems to be a bigger problem. I installed fresh arch today, so far no AUR packages and testing repos at all.
Can't run nm-applet:

$ nm-applet 
nm-applet: error while loading shared libraries: libnotify.so.4: cannot open shared object file: No such file or directory

PS.
I installed arch a couple of days ago, but today I already needed to update my package list (pacman -Syy), because it didn't find the correct networkmanager file. So my guess is that networmanager was updated and the new version is causing the problems.


edit:
Sorry, didn't notice you had trouble with libnotify.so.1. Anyway I updated every thing and my problem is now solved.

Last edited by pingviin (2011-03-17 15:05:43)

Offline

#9 2011-03-17 16:52:13

habtool
Member
From: Ireland, on the West Coast
Registered: 2007-02-17
Posts: 14

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

The maintainer @alessandro_ufms  fixed the alarm-clock-applet AUR package.
He added a patch for libnotify:
Snippet from his PKGBUILD:
build() {
    cd "${srcdir}/${pkgname}-${pkgver}"
   
    patch -Np1 -i ${srcdir}/01_libnotify_0_7.patch

Really liking Arch, thanks all smile

Offline

#10 2011-03-17 17:27:17

Hund
Member
From: Sweden
Registered: 2010-03-22
Posts: 386
Website

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

ngoonee wrote:

Are you fully updated? Are you using testing (there's a new libnotify in testing currently)? Does /usr/lib/libnotify.so.1 exist?

Yes, I am and Im not using the testing repo.

wonder wrote:

@habtool are you familiar with creating patches? here are some examples  on how to fix the code: http://pkgbuild.com/~ioni/libnotify-0.7/

let me know if you want to me to create the patch.

"the missing libnotify.so.1" is not that missing. now is libnotify.so.4 and a rebuild is needed to make the application link to the proper soname

I'd love to get help with writing some patches for pino, gnome-gmail-notifier, liferea-ext4, linuxdcpp and notify-osd-normal-position. smile


Not all change is progress

Offline

#11 2011-03-17 20:51:56

ancleessen4
Member
From: Luxembourg
Registered: 2009-11-22
Posts: 120
Website

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

I am having this issue with Vagalume (http://vagalume.igalia.com/)
I see that libnotify.so.4 is now installed in /usr/lib.

What steps must I do now to get Vagalume working again?

Offline

#12 2011-03-17 21:52:04

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

Hund wrote:
ngoonee wrote:

Are you fully updated? Are you using testing (there's a new libnotify in testing currently)? Does /usr/lib/libnotify.so.1 exist?

Yes, I am and Im not using the testing repo.

wonder wrote:

@habtool are you familiar with creating patches? here are some examples  on how to fix the code: http://pkgbuild.com/~ioni/libnotify-0.7/

let me know if you want to me to create the patch.

"the missing libnotify.so.1" is not that missing. now is libnotify.so.4 and a rebuild is needed to make the application link to the proper soname

I'd love to get help with writing some patches for pino, gnome-gmail-notifier, liferea-ext4, linuxdcpp and notify-osd-normal-position. smile

For  liferea-ext4, try the patch that is used by the liferea in the repo.

Offline

#13 2011-03-17 21:58:29

mcmillan
Member
Registered: 2006-04-06
Posts: 688

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

ancleessen4 wrote:

I am having this issue with Vagalume (http://vagalume.igalia.com/)
I see that libnotify.so.4 is now installed in /usr/lib.

What steps must I do now to get Vagalume working again?

Read what Army already said:

Looks like you have to rebuild those packages yourself! They are all taken from the AUR, right? It's your own responsibility to update them after a soname update.

Offline

#14 2011-03-17 22:03:57

Hund
Member
From: Sweden
Registered: 2010-03-22
Posts: 386
Website

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

I cant compile any package from AUR, it just leaves me with this:

make[4]: Leaving directory `/tmp/clyde-johan/liferea-ext4/liferea-ext4/src/liferea-1.7.4/src/parsers'
Making all in notification
make[4]: Entering directory `/tmp/clyde-johan/liferea-ext4/liferea-ext4/src/liferea-1.7.4/src/notification'
  CC     libnotify_a-libnotify.o
libnotify.c: In function ‘notif_libnotify_callback_show_details’:
libnotify.c:161:3: error: too many arguments to function ‘notify_notification_new’
/usr/include/libnotify/notification.h:114:21: note: declared here
libnotify.c: In function ‘notif_libnotify_node_has_new_items’:
libnotify.c:252:2: error: too many arguments to function ‘notify_notification_new’
/usr/include/libnotify/notification.h:114:21: note: declared here
make[4]: *** [libnotify_a-libnotify.o] Error 1
make[4]: Leaving directory `/tmp/clyde-johan/liferea-ext4/liferea-ext4/src/liferea-1.7.4/src/notification'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/tmp/clyde-johan/liferea-ext4/liferea-ext4/src/liferea-1.7.4/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/tmp/clyde-johan/liferea-ext4/liferea-ext4/src/liferea-1.7.4/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/clyde-johan/liferea-ext4/liferea-ext4/src/liferea-1.7.4'
make: *** [all] Error 2
    Aborting...
error: Build failed

Not all change is progress

Offline

#15 2011-03-18 08:29:34

Hund
Member
From: Sweden
Registered: 2010-03-22
Posts: 386
Website

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

Does anyone have the previous version of libnotify so I can downgrade?


Not all change is progress

Offline

#16 2011-03-18 08:49:16

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

@Hund downgrading is not a solution. be a little smart and think about it. If liferea from extra works that means it has the patch.

http://projects.archlinux.org/svntogit/ … -0.7.patch


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#17 2011-03-18 08:56:40

Hund
Member
From: Sweden
Registered: 2010-03-22
Posts: 386
Website

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

How do I apply the patch thos this PKGBUILD? smile

http://aur.archlinux.org/packages.php?ID=31409


Not all change is progress

Offline

#18 2011-03-18 09:11:13

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

Hund wrote:

How do I apply the patch thos this PKGBUILD? smile

http://aur.archlinux.org/packages.php?ID=31409

look at liferea PKGBUILD?


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#19 2011-03-18 09:14:08

Hund
Member
From: Sweden
Registered: 2010-03-22
Posts: 386
Website

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

wonder wrote:
Hund wrote:

How do I apply the patch thos this PKGBUILD? smile

http://aur.archlinux.org/packages.php?ID=31409

look at liferea PKGBUILD?

Where do I find it?


Not all change is progress

Offline

#20 2011-03-18 09:16:29

z0id
Member
From: Romania
Registered: 2010-02-02
Posts: 121

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

Use ABS


/usr/bin/drinking

Offline

#21 2011-03-18 09:30:16

Hund
Member
From: Sweden
Registered: 2010-03-22
Posts: 386
Website

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

Thanks!

This is how the PKGBUILD looks like:

[...]
build() {
  cd "${srcdir}/liferea-${pkgver}"
  patch -Np1 -i "$srcdir/libnotify-0.7.patch"
  ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-schemas-install
  make
}
[...]

This is how my PKGBUILD looks like:

[...]
build() {
  cd "${srcdir}/${_pkgrealname}-${pkgver}"
  patch -Np1 -i $srcdir/libnotify-0.7.patch || return 1
  patch -Np1 -i ../getenv_sync.patch || return 1
  ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-schemas-install || return 1
  make || return 1
[...]

But it doesnt work:

[ ~/pkgbuilds/liferea-ext4 ]$ makepkg -csi
==> Making package: liferea-ext4 1.7.4-1 (Fri Mar 18 11:27:45 CET 2011)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
  -> Found liferea-1.7.4.tar.gz
  -> Found getenv_sync.patch
  -> Found libnotify-0.7.patch
==> Validating source files with md5sums...
    liferea-1.7.4.tar.gz ... Passed
    getenv_sync.patch ... Passed
    libnotify-0.7.patch ... Passed
==> Extracting Sources...
  -> Extracting liferea-1.7.4.tar.gz with bsdtar
==> Removing existing pkg/ directory...
==> Entering fakeroot environment...
==> Starting build()...
patching file src/notification/libnotify.c
Hunk #1 FAILED at 150.
Hunk #2 FAILED at 244.
2 out of 2 hunks FAILED -- saving rejects to file src/notification/libnotify.c.rej
==> ERROR: A failure occurred in build().
    Aborting...
[ ~/pkgbuilds/liferea-ext4 ]$ 

What am I doing wrong?

Last edited by Hund (2011-03-18 09:30:55)


Not all change is progress

Offline

#22 2011-03-18 09:39:32

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

the patch needs modifications because in extra liferea is 1.6.something and you build 1.7.4

if you are so clueless, why don't you use liferea from extra?

Last edited by wonder (2011-03-18 09:40:55)


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#23 2011-03-18 14:37:38

Hund
Member
From: Sweden
Registered: 2010-03-22
Posts: 386
Website

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

wonder wrote:

the patch needs modifications because in extra liferea is 1.6.something and you build 1.7.4

if you are so clueless, why don't you use liferea from extra?

I have never have to care about patches before, thats why I dont now shit about it. What about the rest of the packages? Just give me a older version of libnotify so I can use all of my apps again, until someone solves the problem.


Not all change is progress

Offline

#24 2011-03-18 14:41:59

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,319

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

Hund wrote:

Just give me a older version of libnotify so I can use all of my apps again, until someone solves the problem.

That wont help because all the other packages have been rebuilt against the new version

Offline

#25 2011-03-18 14:44:59

Hund
Member
From: Sweden
Registered: 2010-03-22
Posts: 386
Website

Re: "error while loading shared libraries: libnotify.so.1: cannot open.."

So I'm basicly screwed then? This is redicilious, why couldnt they make a more smooth update of libnotify?

Last edited by Hund (2011-03-18 14:50:25)


Not all change is progress

Offline

Board footer

Powered by FluxBB