You are not logged in.

#1 2011-03-22 22:23:46

fax8
Member
From: Italy
Registered: 2006-03-14
Posts: 104
Website

[SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

Hi guys,

I used to have thunderbird open links with firefox but after the today update to firefox 4 the links on Thunderbird emails aren't opened anymore with Firefox.
Basically, when I click on a link of thunderbird nothing happens..

Any idea?


Thanks,

Fabio Varesano

Last edited by fax8 (2011-03-24 11:30:30)

Offline

#2 2011-03-22 23:27:13

lives2evil
Member
From: GMT+7
Registered: 2010-03-21
Posts: 244

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

Try changing the option in Firefox>Preferences>Applications>mailto:


tsujeruplive, tnarongisi... ... ... ... ɥsılƃuǝ sı sıɥʇ

Offline

#3 2011-03-23 07:21:46

fax8
Member
From: Italy
Registered: 2006-03-14
Posts: 104
Website

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

@lives2evil I need to do the opposite, link on Thunderbird to open by Firefox

Offline

#4 2011-03-23 08:20:57

lives2evil
Member
From: GMT+7
Registered: 2010-03-21
Posts: 244

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

oops sorry, I miss read it. maybe because firefox have just updated make me confuse.


tsujeruplive, tnarongisi... ... ... ... ɥsılƃuǝ sı sıɥʇ

Offline

#5 2011-03-23 08:38:07

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

the only case is because the location changed to /usr/lib/firefox-4.0/firefox and maybe in the thunderbird or in system, the default browser still has the old path.


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#6 2011-03-23 08:53:43

lives2evil
Member
From: GMT+7
Registered: 2010-03-21
Posts: 244

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

That's probably true.
So here's how to fixed. It's pretty similiar to firefox.
Edit>Preferences>Attachments>
In the lists change the application use to open (http, https) to "path to your firefox binary".


tsujeruplive, tnarongisi... ... ... ... ɥsılƃuǝ sı sıɥʇ

Offline

#7 2011-03-23 09:42:05

fax8
Member
From: Italy
Registered: 2006-03-14
Posts: 104
Website

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

Sorry guys, but I don't see any http/https entry in the attachment association window. Picture of what I have: http://img35.imageshack.us/i/thunderbirdfirefox.png

Offline

#8 2011-03-23 10:45:18

lives2evil
Member
From: GMT+7
Registered: 2010-03-21
Posts: 244

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

This is strange. Try one of these methods
- Try upgrade your whole system to see if it's fixed.
- Also, if you don't mind reconfiguring your mail client, try "rm -r ~/.thunderbird". (Seriously not recommended)
- Perhaps this could help finding where the problem is: running "grep firefox ~/.thunderbird/*.default -R", post the output here.


tsujeruplive, tnarongisi... ... ... ... ɥsılƃuǝ sı sıɥʇ

Offline

#9 2011-03-23 11:33:12

marduk
Member
Registered: 2007-07-18
Posts: 12

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

Same here, and grep as suggested in the post above shows nothing interesting..

Offline

#10 2011-03-23 11:35:42

fax8
Member
From: Italy
Registered: 2006-03-14
Posts: 104
Website

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

My system is updated. Sorry can't remove my thunderbird config.. 10 email addresses configured there and thousands of mails stored..

I made the grep, but filtered out the Mail and ImapMail folders which would otherwise generate hundreds of matches (I'm a web and ff theme developer so the world "firefox" matches many emails).

[fabio@gamma ~]$ grep firefox ~/.thunderbird/*.default -R | grep -v /Mail/ | grep -v /ImapMail/
grep: /home/fabio/.thunderbird/js17qstd.default/lock: No such file or directory
Binary file /home/fabio/.thunderbird/js17qstd.default/global-messages-db.sqlite matches
/home/fabio/.thunderbird/js17qstd.default/prefs.js:user_pref("network.protocol-handler.app.ftp", "/usr/lib/firefox-4.0/firefox");
/home/fabio/.thunderbird/js17qstd.default/prefs.js:user_pref("network.protocol-handler.app.http", "/usr/lib/firefox-4.0/firefox");
/home/fabio/.thunderbird/js17qstd.default/prefs.js:user_pref("network.protocol-handler.app.https", "/usr/lib/firefox-4.0/firefox");
/home/fabio/.thunderbird/js17qstd.default/extensions.rdf:                   NS1:homepageURL="https://addons.mozilla.org/en-US/firefox/addon/3497">
/home/fabio/.thunderbird/js17qstd.default/blocklist.xml:    <emItem id="langpack-vi-VN@firefox.mozilla.org">
/home/fabio/.thunderbird/js17qstd.default/blocklist.xml:    <emItem id="support@update-firefox.com"/>
/home/fabio/.thunderbird/js17qstd.default/extensions/en-US@dictionaries.addons.mozilla.org/install.rdf:    <em:homepageURL>https://addons.mozilla.org/en-US/firefox/addon/3497</em:homepageURL>
Binary file /home/fabio/.thunderbird/js17qstd.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome/calendar.jar matches
Binary file /home/fabio/.thunderbird/js17qstd.default/training.dat matches

Offline

#11 2011-03-23 11:40:05

myrlin
Member
Registered: 2010-06-11
Posts: 271

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

I upgraded yesterday, and I have this problem too.

I have downgraded to FF3.5 until it's fixed.

Offline

#12 2011-03-23 11:43:57

Ramses de Norre
Member
From: Leuven - Belgium
Registered: 2007-03-27
Posts: 1,289

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

In thunderbird under Edit>Preferences>Attachments I changed the entry for HTML to firefox and now links open as usual again.

Last edited by Ramses de Norre (2011-03-23 11:54:14)

Offline

#13 2011-03-23 11:48:45

marduk
Member
Registered: 2007-07-18
Posts: 12

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

Ramses de Norre wrote:

In the preferred applications I changed the entry for HTML to firefox and now links open as usual again.

You are more lucky than many of us smile Where did you set that? In thunderbird? Can't seem to find the preferred applications tab in my Preferences.

Offline

#14 2011-03-23 11:53:50

Ramses de Norre
Member
From: Leuven - Belgium
Registered: 2007-03-27
Posts: 1,289

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

marduk wrote:
Ramses de Norre wrote:

In the preferred applications I changed the entry for HTML to firefox and now links open as usual again.

You are more lucky than many of us smile Where did you set that? In thunderbird? Can't seem to find the preferred applications tab in my Preferences.

Oh I meant in Edit>Preferences>Attachments in thunderbird, I'll edit my post smile

Offline

#15 2011-03-23 11:56:01

lives2evil
Member
From: GMT+7
Registered: 2010-03-21
Posts: 244

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

Edit>Preferences>Attachments>
It's here, but I thought it didn't worked?


tsujeruplive, tnarongisi... ... ... ... ɥsılƃuǝ sı sıɥʇ

Offline

#16 2011-03-23 12:03:03

marduk
Member
Registered: 2007-07-18
Posts: 12

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

I don't see any http/https entry in the attachment association window. I have a list of extensions similar to that of the poster above. Note: I use windowmaker.

Offline

#17 2011-03-23 12:08:05

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,273

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

lives2evil wrote:

- Also, if you don't mind reconfiguring your mail client, try "rm -r ~/.thunderbird". (Seriously not recommended).

Seriously, do not delete any information you'll need later on. Just rename: "mv ~/.thunderbird ~/.thunderbird.old" or the like.
Then try again with a new setup.
If this works then copy your accounts setup and stored mails back one by one.

Last edited by bernarcher (2011-03-23 12:10:51)


To know or not to know ...
... the questions remain forever.

Offline

#18 2011-03-23 12:09:04

lives2evil
Member
From: GMT+7
Registered: 2010-03-21
Posts: 244

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

Well, I think changing the property of "HTML" file would also work but, action is already show as "Always ask" so instead of nothing happens, it should at least open the choosing application dialog.
But could you try changing it to use firefox instead. Never hurt to try. big_smile

@bernarcher: Well, removing is really not a good move but it's pretty hard to move your configuration to a new ones so as I said "if you don't mind". And I'm going to recommend backing up .thunderbird folder and run thunderbird to test anyway. big_smile

Last edited by lives2evil (2011-03-23 12:19:59)


tsujeruplive, tnarongisi... ... ... ... ɥsılƃuǝ sı sıɥʇ

Offline

#19 2011-03-23 13:04:08

fax8
Member
From: Italy
Registered: 2006-03-14
Posts: 104
Website

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

Setting HTML to open with FF doesn't seem to work here. Personally, I think this is more a configuration relative to gnome.. Which if I recall correctly TB uses as configuration when handling external protocols. But, as I'm not a gnome user (KDE4 here) I don't really know how to change it.

Offline

#20 2011-03-23 13:15:13

lives2evil
Member
From: GMT+7
Registered: 2010-03-21
Posts: 244

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

Then perhaps you should follow bernarcher's advice.
Backup .thunderbird folder and run thunderbird, add an account, open some mails and test if http links worked.


tsujeruplive, tnarongisi... ... ... ... ɥsılƃuǝ sı sıɥʇ

Offline

#21 2011-03-23 15:09:35

darose
Member
Registered: 2004-04-13
Posts: 120

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

fax8 wrote:

Setting HTML to open with FF doesn't seem to work here. Personally, I think this is more a configuration relative to gnome.. Which if I recall correctly TB uses as configuration when handling external protocols. But, as I'm not a gnome user (KDE4 here) I don't really know how to change it.

This worked for me.  I logged into Gnome, updated my preferred applications, and then TBird began responding to HTML links correctly again.

Offline

#22 2011-03-23 17:01:12

ninian
Member
From: United Kingdom
Registered: 2008-02-24
Posts: 696
Website

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

I don't use any of the big DEs, just Openbox as a WM with extra utilities. The solution for me was:

1) Saved my Thunderbird profile under a different name, and let Thunderbird create a new profile. Then I copied the mimeTypes.rdf file from the fresh profile into my original profile, junked the new profile and renamed my real profile back to its usual name.

2) Ran Thunderbird, went to Preferences / Config Editor and set all of these preferences to 'true':
network.protocol-handler.warn-external.http
network.protocol-handler.warn-external.https
network.protocol-handler.warn-external.ftp

3) Sent myself an email with links to http, https and ftp websites. Clicked on each link and Thunderbird prompted for which program I wanted to use to open the protocol. I did not choose the suggested 'firefox' but selected /usr/bin/xdg-open instead from the file dialogue. (I'm sure you could select /usr/bin/firefox too and it should work.) Ticked the box not to be asked again.

4) Restarted Thunderbird and all links opened correctly.

Got the idea from the bottom half of the section: See http://kb.mozillazine.org/Default_brows … rd_-_Linux
Hope this helps.

Online

#23 2011-03-23 17:44:31

Fingel
Member
Registered: 2009-02-28
Posts: 88

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

I had the same problem, I am using gnome. The solution was as simple as going to the gnome preferred applications settings (system->preferences->preferred applications) and changing "Web Browser" to firefox. It was set to a custom command that was pointing to firefox 3.

Offline

#24 2011-03-23 18:32:10

sweetthdevil
Member
Registered: 2009-10-20
Posts: 328

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

Like many of you since the Update those links weren't opening any more, I fix my issue by going to the preferences => advanced => general and then select Config Editor.

Search for "network.protocol"

those following three were false, turn then to true, and then Thunderbird will ask you when clicking on liks which application to use. Select /usr/bin/firefox and do not forgot to select remember my choice wink

network.protocol-handler.warn-external.ftp
network.protocol-handler.warn-external.http
network.protocol-handler.warn-external.https

Simple as that,

Last edited by sweetthdevil (2011-03-23 18:34:07)

Offline

#25 2011-03-24 03:22:27

zodmaner
Member
Registered: 2007-07-11
Posts: 653

Re: [SOLVED] ff4: Thunderbid doesn't open email links in ff anymore

sweetthdevil wrote:

Like many of you since the Update those links weren't opening any more, I fix my issue by going to the preferences => advanced => general and then select Config Editor.

Search for "network.protocol"

those following three were false, turn then to true, and then Thunderbird will ask you when clicking on liks which application to use. Select /usr/bin/firefox and do not forgot to select remember my choice wink

network.protocol-handler.warn-external.ftp
network.protocol-handler.warn-external.http
network.protocol-handler.warn-external.https

Simple as that,

Thanks sweetthdevil! I followed your advise and that fixed it for me. smile


Memento mori

Offline

Board footer

Powered by FluxBB