You are not logged in.

#1 2008-02-26 05:55:15

Registered: 2004-12-31
Posts: 31

shift + numpad behavior

I have a laptop with a full keypad and the easiest way for me to use Home and End is to disable numlock and use the keys on the numpad. This is preferable to the awkward Fn+PgUp/PgDn combo the manufacturer inflicted on me, especially when using shift to modify selections.

However, the default behavior in X11/Linux/whatever seems to be that shift temporarily toggles numlock. That is, if the numpad is behaving like arrow keys, pressing shift has it output numbers, and vice-versa. Since I use shift extensively for modifying selections, this would be a deal-breaker, as far as my laptop is concerned.

Anyway, I found this simple answer, to be added to xorg.conf in the InputDevice Section for the keyboard:

  Option "XkbOptions" "numpad:microsoft"

(If you use Gnome (unlike me), there's a preference for this: Preferences > Keyboard > Layout Options > Miscellaneous compatibility options > Shift with numpad keys work as in MS Windows.)

I hope that saves someone else all the trouble I went through to find it!


#2 2008-02-26 20:02:18

From: Chicago, IL US
Registered: 2006-07-02
Posts: 183

Re: shift + numpad behavior

Adding /appending to the wiki would be the best way to share the knowledge smile


#3 2011-03-22 01:13:15

Registered: 2011-03-22
Posts: 1

Re: shift + numpad behavior

Here's an updated description of how to set the Gnome option for anyone googling this.

Go to System | Preferences | Keyboard, click the Layouts tab, click Options..., expand 'Miscellaneous compatibility options', and check both "Shift does not cancel NumLock, chooses 3rd level instead" and "Shift with numeric keypad keys works as in MS Windows". Click Close. You'll probably want to apply this change system-wide, so click that button and authenticate. Also make sure that 'Pointer can be controlled using the keypad' is not checked under the 'Mouse Keys' tab.


#4 2011-03-23 19:17:20

Registered: 2008-06-23
Posts: 106

Re: shift + numpad behavior

If you are using KDE, you can find the same settings in Systemsettings -> Input Devices -> Keyboard -> Advanced tab -> Miscellaneous compatibility options


Board footer

Powered by FluxBB