You are not logged in.

#1 2011-03-23 23:02:36

Bordee
Member
Registered: 2011-01-03
Posts: 23

[SOLVED] kde 4.6 and Udisks mounting problems with Dolphin

Hello,

I have a problem with Dolphin in KDE 4.6 where it displays my non-Arch partitions (a / and /home used for Opensuse) as well as a CD-Rom or usb if inserted, but registers an error when I click on the device/partition icon. Specifically, I get the following error displayed at the bottom of Dolphin:

An error occurred while accessing Hard Drive, the system responded: org.freedesktop.UDisks.Error.Failed: Error creating mount point: No such file or directory.

Because of this error, I am unable to mount usb pendrives, access CDs, or access the non-Arch partitions. I'm not sure if this is a KDE error or if it related to Arch as I never encountered this error running KDE 4.6 in Opensuse.

My daemons running in /etc/rc.conf
DAEMONS=(syslog-ng dbus networkmanager netfs crond alsa kdm)

My /etc/fstab
#/dev/cdrom             /media/cd   auto    ro,user,noauto,unhide   0      0
#/dev/dvd               /media/dvd  auto    ro,user,noauto,unhide   0      0
#/dev/fd0               /media/fl   auto    user,noauto             0      0

/dev/sda1 / ext4 defaults,noatime 0 1
/dev/sda5 swap swap defaults 0 0
/dev/sda6 /home ext4 defaults,noatime 0 1

tmpfs   /tmp            tmpfs defaults,nodev,nosuid,mode=1777                   0 0
tmpfs   /var/lock       tmpfs defaults,nodev,nosuid,noexec,mode=1777,size=10M   0 0
tmpfs   /var/run        tmpfs defaults,nodev,nosuid,noexec,mode=0755,size=10M   0 0


Now, I don't have hal running as a daemon as I have read that it is no longer needed in KDE 4.6. Similarly, I don't have my CD-Rom drive mounted as I read in the udev wiki that Udisks automatically mounts devices and partitions. The wiki also indicates that Udisks is supposed to require little configuration.

I've searched the forum and Google, and I have not been able to find any information documenting a Dolphin and UDisks mounting error in KDE 4.6.

I installed KDE through the # pacman -S kde    command, but is there some other package that I need to install in order to get Udisks working properly?

Thanks.

Last edited by Bordee (2011-03-24 16:09:25)

Offline

#2 2011-03-24 05:06:28

Xabre
Member
From: Serbia
Registered: 2009-03-19
Posts: 575

Re: [SOLVED] kde 4.6 and Udisks mounting problems with Dolphin

Check the Wiki on how to hide unnecesarry partitions,
The same goes for mounting external drives (disk, usb flash etc.): you need to change udev rule so that you be able to mount/umount partitions as non-root user.
https://bbs.archlinux.org/viewtopic.php … 84#p884384 read the entire page, there's more info few messages after that one

Offline

#3 2011-03-24 07:51:36

Bordee
Member
Registered: 2011-01-03
Posts: 23

Re: [SOLVED] kde 4.6 and Udisks mounting problems with Dolphin

Xabre,

Thank you for the response. I checked the KDE (unstable) thread that you referenced. I tried adding a
/etc/polkit-1/localauthority.conf.d/60-localauthority.conf    and
/etc/polkit-1/localauthority/50-local.d/my-polkit-udisks.pkl     file as suggested. It didn't change the error message that I was getting.

I also tried changing permissions in /usr/share/polkit-1/actions/org.freedesktop.udisks.policy . That didn't get rid of the error message either.

I'm not getting any permission denied messages in Dolphin either or prompts to enter a root password. It seems that that error is that UDisks isn't properly mounting the usb drives and the other partitions.

I read the Wiki on Udev, and I'm not entirely clear on how to define a mounting policy since the wiki states that KDE 4.6 should auto-mount all media. Would a possible solution be to change the udev rules?

Offline

#4 2011-03-24 09:03:23

Xabre
Member
From: Serbia
Registered: 2009-03-19
Posts: 575

Re: [SOLVED] kde 4.6 and Udisks mounting problems with Dolphin

Well, first thing that comes to my mind is : are you (user) a member of "storage" group?

"Error creating mount point: " in most of cases usually means that there is some kind of a problem with permissions.

Offline

#5 2011-03-24 16:05:33

Bordee
Member
Registered: 2011-01-03
Posts: 23

Re: [SOLVED] kde 4.6 and Udisks mounting problems with Dolphin

When I enter   $ groups in a terminal I get the following

sys adm disk lp wheel games video audio optical storage power users

So I'm definitely part of the storage group.


I think I found a solution. I created a /data mountpoint in fstab and a /data folder in my root directory. Now, I'm able to mount and access the contents of the /home partition from Opensuse. The reason I wanted to do this was to access music and photos and transfer them onto my Arch /home partition.

I uncommented the cdrom, dvd, and fd0 devices in fstab and I created /media/cd, /media/dvd, and /media/fl. After inputting a # mount -a, my CDROM drive reads properly as does my USB.

So once again, thank, you for pointing me in the right direction.

One final thought. I was under the impression from reading the UDisks information that it automatically detected and mounted other partitions and devices without them being explicitly mounted in fstab. Was the assumption wrong? In other words, for UDisks and Dolphin to work together properly in KDE 4.6, do all of the devices that appear have to first be mounted in fstab?

Offline

#6 2011-03-24 18:06:28

Xabre
Member
From: Serbia
Registered: 2009-03-19
Posts: 575

Re: [SOLVED] kde 4.6 and Udisks mounting problems with Dolphin

I'm glad I could help, though, to be honest, I wasn't much of a help. smile

Yes, you should not need those extra lines in fstab. I do not have them (only entries for /, /home and /var partitions), and KDE+UDisk works just as it's supposed to (only  modified rules to mount external devices as user and hided sistem partions, as described above).
So I'm a bit confused about what exactly happened in your case...but as long as the solution works. smile

Offline

#7 2011-03-24 20:25:12

draugdel
Member
Registered: 2008-08-12
Posts: 44

Re: [SOLVED] kde 4.6 and Udisks mounting problems with Dolphin

Bordee wrote:

One final thought. I was under the impression from reading the UDisks information that it automatically detected and mounted other partitions and devices without them being explicitly mounted in fstab. Was the assumption wrong? In other words, for UDisks and Dolphin to work together properly in KDE 4.6, do all of the devices that appear have to first be mounted in fstab?

No, they shouldn´t need to be in fstab: There are two actions from udisk for internal and external storage. If you have allowed these actions for you (or a group you are in) using a pkla, mounting should work.

IMHO, your solution is merely a workaround: you should try to find out why it tries to mount to /data and fix that. It´s probably a wrong udev configuration.

Offline

#8 2011-03-25 01:34:29

Bordee
Member
Registered: 2011-01-03
Posts: 23

Re: [SOLVED] kde 4.6 and Udisks mounting problems with Dolphin

Draugdel,

Thanks for your insight. I mounted the other partition into /data because it wouldn't mount through Udisks automatically. In other words, there was no default mount to /data; it was just my work around. I tried to edit/create some pkla files, as I illustrated above, but had no success. Do you any insight into which pkla I would have to edit?

Offline

#9 2011-03-26 13:08:27

draugdel
Member
Registered: 2008-08-12
Posts: 44

Re: [SOLVED] kde 4.6 and Udisks mounting problems with Dolphin

Hmmm, i don´t think that "org.freedesktop.UDisks.Error.Failed: Error creating mount point: No such file or directory." can be fixed by editing a pkla file. Does any logfile contain information which directory could not be created? When you have fixed that error and get permission errors instead, then you have to edit a pkla file.

This is my /etc/polkit-1/localauthority/50-local.d/mount.pkla:

[Mount system internal media for group storage]
Identity=unix-group:storage
Action=org.freedesktop.udisks.filesystem-*
ResultAny=yes
ResultInactive=yes
ResultActive=yes

Offline

#10 2011-03-28 00:02:19

Bordee
Member
Registered: 2011-01-03
Posts: 23

Re: [SOLVED] kde 4.6 and Udisks mounting problems with Dolphin

Draugdel,

Thank you again for your help. You pointed me to the magic pkla file that was the source of my problems. For some reason, my /etc/polkit-1/localauthority/50-local.d/mount.pkla was empty. I added the text you provided to the pkla file, and voila, Udisks is now mounting everything. I uncommented my other drives from fstab, and Udisks is now doing the job without a problem. Thanks again.

Offline

#11 2011-03-28 18:04:44

draugdel
Member
Registered: 2008-08-12
Posts: 44

Re: [SOLVED] kde 4.6 and Udisks mounting problems with Dolphin

Nice, but I don't really understand why this fixed it. smile

AFAIK arch does not provide a default pkla file for allowing mounting to the storage group. You shouldn´t have had an empty file but no file at all. As a point of interest for me: where does UDisk mount the partitions and what´s the permission of that folder?

Offline

#12 2011-03-28 19:46:03

Andrenas
Member
From: Coimbra, Portugal
Registered: 2011-03-14
Posts: 19

Re: [SOLVED] kde 4.6 and Udisks mounting problems with Dolphin

Hello all.

I had the same problem. However I do not have the file /etc/polkit-1/localauthority/50-local.d/mount.pkla on my system.

I solved the problem by creating the folder "media" on /, which did not exist.

Regards

Edit:  I think I've found the reason why there was no media folder on my system.

I had installed hal and, apparently, when you remove the hal deletes the folder media.

After some research I found this bug: https://bugs.archlinux.org/task/23089.

I hope not delete anything else ...

Last edited by Andrenas (2011-03-28 20:38:52)

Offline

#13 2011-03-29 03:11:55

Bordee
Member
Registered: 2011-01-03
Posts: 23

Re: [SOLVED] kde 4.6 and Udisks mounting problems with Dolphin

Draugel and Adrenas,

To clarify, I should have said that my pkla file was non-existent, rather than empty. So what I did was really create a new /etc/polkit-1/localauthority/50-local.d/mount.pkla file.

Offline

#14 2011-12-29 12:21:52

koja
Member
Registered: 2011-12-29
Posts: 2

Re: [SOLVED] kde 4.6 and Udisks mounting problems with Dolphin

Thanks a million for this hint. Have not found it anywhere else.
It actually saved my day on xfce box.

draugdel wrote:

Hmmm, i don´t think that "org.freedesktop.UDisks.Error.Failed: Error creating mount point: No such file or directory." can be fixed by editing a pkla file. Does any logfile contain information which directory could not be created? When you have fixed that error and get permission errors instead, then you have to edit a pkla file.

This is my /etc/polkit-1/localauthority/50-local.d/mount.pkla:

[Mount system internal media for group storage]
Identity=unix-group:storage
Action=org.freedesktop.udisks.filesystem-*
ResultAny=yes
ResultInactive=yes
ResultActive=yes

Offline

Board footer

Powered by FluxBB