You are not logged in.

#1 2011-04-10 09:24:14

dedanna1029
Member
From: Cheyenne, WY, US
Registered: 2010-10-01
Posts: 98

[solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

I had a situation wherein my speaker tests in both Gnome and KDE (fully updated) failed all of a sudden after the update to libnotify0.7.1-1.1 (from their respective control centers, in Sound or Multimedia). At the same time, when this began happening, notification-daemon also quit working in both Gnome and KDE. Upon further inspection, I also noticed that I now have no input from my Audigy 2 card; however, have output.

notification-daemon requires libnotify>=0.7.1; however, without the libnotify.so.1, it is not working properly. This is an essential daemon for me, as I rely on it quite a bit.

If one takes a look at the previous version of libnotify, 0.5.2-1, libnotify.so.1 is included in the package (which I extracted earlier):
screenshotlibnotify0521.th.png

The current version, extracted, does not include libnotify.so.1:
screenshotlibnotify0711.th.png

There are packages for pulseaudio in AUR which depend on libnotify.so.1, such as padevchooser (granted, it has been deprecated, but yet always worked with the previous version of libnotify). There is also the fact that I do not have input from my sound card, and notification-daemon is not working at all sound-wise.

pacman -Ss libnotify
extra/libnotify 0.7.1-1.1 [0.03 MB] ------>[installed]
    Desktop notification library
extra/python-notify 0.1.1-10 [0.01 MB] ------->[installed]
    Python bindings for libnotify
padevchooser
padevchooser: error while loading shared libraries: --->libnotify.so.1: cannot open shared object file: No such file or directory<-----

(Starting the avahi daemon then trying padevchooser does not work)

I have tried downgrading to previous version of libnotify; however, there are too many things which depend on it that can not be uninstalled with it, and that process failed. I have tried symlinking for libnotify.so.1 from each one of these in /usr/lib:

# ls /usr/lib | grep libnotify
libnotify.so
libnotify.so.4
libnotify.so.4.0.0

(This did not work either)

I also tried copying over libnotify.so.1 from the previous version of libnotify extracted, but this failed as well.

I am wondering if the omission of libnotify.so.1 was deliberate from the current version of libnotify (0.7.1-1.1), or not? If so, then are there any ideas for getting notification-daemon working again?

Thank you for any light you can shed on this in advance.

Last edited by dedanna1029 (2011-07-20 14:24:31)

Offline

#2 2011-04-10 09:38:27

Ramses de Norre
Member
From: Leuven - Belgium
Registered: 2007-03-27
Posts: 1,289

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

Did you try rebuilding your AUR stuff that depends on libnotify?

Offline

#3 2011-04-10 09:39:43

dedanna1029
Member
From: Cheyenne, WY, US
Registered: 2010-10-01
Posts: 98

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

I *could* try it, but I don't think I would get anywhere. These things have been installed for a long time, and have not been updated in AUR. I checked for that earlier.

Thanks.

Offline

#4 2011-04-10 09:41:23

dedanna1029
Member
From: Cheyenne, WY, US
Registered: 2010-10-01
Posts: 98

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

It also still doesn't do anything for the current notification-daemon issue, which is in regular repos (and was updated right along with libnotify). Thanks.

I did just try rebuilding padevchooser, just for the example, and now when I try to start it, I get another error:

:) padevchooser

** (padevchooser:3920): WARNING **: pa_browser_new() failed.

Starting avahi-daemon does not resolve the issue.

Last edited by dedanna1029 (2011-04-10 09:45:03)

Offline

#5 2011-04-10 09:50:24

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

the "omission" is not quite an omission. a soname bump reflects the ABI and upstream bumps the number when ABI changes.

here is a patch to add support for libnotify 0.7 in padevchooser

http://pkgbuild.com/~ioni/libnotify-0.7 … -0.7.patch


Give what you have. To someone, it may be better than you dare to think.

Offline

#6 2011-04-10 10:06:33

dedanna1029
Member
From: Cheyenne, WY, US
Registered: 2010-10-01
Posts: 98

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

Thank you. smile

Would this help the notification-daemon issue as well?

Offline

#7 2011-04-10 10:41:40

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

maybe, if you say more than "doesn't work properly"


Give what you have. To someone, it may be better than you dare to think.

Offline

#8 2011-04-10 20:57:32

dedanna1029
Member
From: Cheyenne, WY, US
Registered: 2010-10-01
Posts: 98

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

Actually, it's not working at all. I described it in the original post here. Along with the issue of not having any input on my sound card at all, this is also causing no sound in notification-daemon, for either Gnome or KDE4.6.2-1 (and hasn't for the last two versions of KDE at least). This is what originally alerted me to the situation, is that notification-daemon had quit working on the last update of it, and I rely on it a lot.

Last edited by dedanna1029 (2011-04-10 21:01:42)

Offline

#9 2011-04-11 15:02:57

dedanna1029
Member
From: Cheyenne, WY, US
Registered: 2010-10-01
Posts: 98

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

I meant to mention that this is also not a hardware issue. On my Fedora box, notification-daemon works fine with their latest of libnotify, and I have had no issues with speaker tests or anything.

rpm -qa | grep libnotify
libnotify-0.5.1-1.fc14.i686
ls /usr/lib | grep libnotify
libnotify.so.1
libnotify.so.1.2.3

Now with that having been said, I do realize they are not on to libnotify.so.4 yet or libnotify.so.4.0.0. When they do update it however, I will check to see what they've left and not of it.

Offline

#10 2011-04-11 18:02:16

oupsemma
Member
Registered: 2010-01-01
Posts: 70

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

libnotify.so.1 missing prevents launching Freetuxtv too, which is a pity.  :sad:

Offline

#11 2011-04-13 01:29:21

dedanna1029
Member
From: Cheyenne, WY, US
Registered: 2010-10-01
Posts: 98

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

I'm sure there are a number of programs that are suffering without it. Just try reinstalling - or just uninstalling libnotify, and see how many programs want to go with it. Any number of those could be needing the libnotify.so.1, and not working because of it, or suffering in some way without it. It's great the upgrade to libnotify.so.4, yeah, but the problem is, we then have to make the packages that depend on it get rebuilt for it, and it doesn't appear that's been done (at least not the entire list; maybe portion of it). The list of packages is long.

So, for now, I have to play in the Fedora sandbox. Will return to the Arch sandbox when it's ready.

Last edited by dedanna1029 (2011-04-13 01:33:10)

Offline

#12 2011-04-18 03:53:42

dedanna1029
Member
From: Cheyenne, WY, US
Registered: 2010-10-01
Posts: 98

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

wonder wrote:

the "omission" is not quite an omission. a soname bump reflects the ABI and upstream bumps the number when ABI changes.

here is a patch to add support for libnotify 0.7 in padevchooser

http://pkgbuild.com/~ioni/libnotify-0.7 … -0.7.patch

Is there anyone who can tell me please, step by step, how to apply this patch? I'm sorry, but patches confuse me on a VERY high level... I've looked at the wiki here, and am confused now on an even higher level.

Thanks so much.

Last edited by dedanna1029 (2011-04-18 03:54:31)

Offline

#13 2011-04-20 19:18:06

TioDuke
Member
Registered: 2009-08-06
Posts: 24

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

Re-installing the fore mentioned packages will not solved the problem. You need to rebuild all your AUR packages that depend on libnotify regardless of whether the PKGBUILDs themselves have been modified by their respective maintainers.

What you need to do with the patch, is to use it while rebuilding the package it is meant for. In order to do this, you need to appropriately edit your PKGBUILD and then issue the infamous makepkg command.

Hpe this clears it up a little.


[img]http://boincstats.com/signature/-1/user/2670943/sig.png[/img]

Offline

#14 2011-04-23 07:14:55

dedanna1029
Member
From: Cheyenne, WY, US
Registered: 2010-10-01
Posts: 98

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

Thanks, but I guess I'm confused on PKGBUILD and makepkg in general. Never really learned how to do that stuff. Pity. Thank you, though.

Offline

#15 2011-04-23 09:10:30

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 7,255

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

dedanna1029 wrote:

Thanks, but I guess I'm confused on PKGBUILD and makepkg in general. Never really learned how to do that stuff. Pity. Thank you, though.

Time to learn, then. man makepkg and the wiki are your friend.


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

#16 2011-04-25 19:18:03

dedanna1029
Member
From: Cheyenne, WY, US
Registered: 2010-10-01
Posts: 98

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

Each patch is applied differently. I have a whole how-to on how to apply a kernel patch at a forum I hang out at, worked just fine. This is applied differently. The next one will be, too. The wiki is confusing on it, as I already stated, I am not a package builder, other than rpm, and even that I've done very little of. I'm sorry, but I think when people send out patches, they should state how to apply them too, for the dumb and ignorant like me. Some people's brains just are not geared that way in the tech world to be able to do everything, and mine's one of them. Either that, or when there is an upgrade such as this (which I haven't seen on another distro yet) to something like libnotify, then the old stuff should be included along with it for compatibility with other packages that are not being upgraded as well.

Just my opinion, sorry.

Last edited by dedanna1029 (2011-04-25 19:25:38)

Offline

#17 2011-04-25 22:12:12

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 7,255

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

dedanna1029 wrote:

Each patch is applied differently. I have a whole how-to on how to apply a kernel patch at a forum I hang out at, worked just fine. This is applied differently. The next one will be, too. The wiki is confusing on it, as I already stated, I am not a package builder, other than rpm, and even that I've done very little of. I'm sorry, but I think when people send out patches, they should state how to apply them too, for the dumb and ignorant like me. Some people's brains just are not geared that way in the tech world to be able to do everything, and mine's one of them. Either that, or when there is an upgrade such as this (which I haven't seen on another distro yet) to something like libnotify, then the old stuff should be included along with it for compatibility with other packages that are not being upgraded as well.

Just my opinion, sorry.

No, they should not, because at least around here (Arch) you're expected to know how to apply patches (or know how to figure it out). Glancing through the patch will most often give you an idea of the depth level you need to apply anyway, or if its a small patch you could even try to do it by hand.

You are using an AUR package which has not been updated, because the upstream project is deprecated. If you want to do that, you should get used to the idea that you WILL need to at least apply patches, or even mess with the code yourself. Or you could take the easy way out and not use padevchooser, like the pulseaudio devs have been recommending for at least half a year already.


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

#18 2011-04-25 23:42:12

dedanna1029
Member
From: Cheyenne, WY, US
Registered: 2010-10-01
Posts: 98

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

It isn't *just* for that though. There are other things which still depend on libnotify.so.1. I'm not the only one who posted to this thread about it. Freetuxtv above, and there may be more. It's libnotify that's the problem, not the padevchooser.

I've also tried several other things to get libnotify to work, and it's still not working. I don't know what else to do.

The padevchooser patch was just to try to get padevchooser to work with the new libnotify. What about the other things? notification-daemon isn't working at all, among other things.

Last edited by dedanna1029 (2011-04-25 23:43:50)

Offline

#19 2011-04-26 01:37:48

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 7,255

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

dedanna1029 wrote:

It isn't *just* for that though. There are other things which still depend on libnotify.so.1. I'm not the only one who posted to this thread about it. Freetuxtv above, and there may be more. It's libnotify that's the problem, not the padevchooser.

I've also tried several other things to get libnotify to work, and it's still not working. I don't know what else to do.

The padevchooser patch was just to try to get padevchooser to work with the new libnotify. What about the other things? notification-daemon isn't working at all, among other things.

libnotify is not the problem. All the applications mentioned are AUR apps, and for some reason or other don't link against the latest libnotify version (in padevchooser's case, because its deprecated). In some cases, depending on what the apps do, simple patching is possible.

For notification-daemon, if it doesn't work you should file a bug. Looking at the current versions in [extra], yes there may be a mismatch there.

When the soname of a library changes its because the library has changed. Applications must be updated or rebuilt at that point. The 'problem', if you wish to call it that, is with the individual applications, not the library.


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

#20 2011-07-20 14:23:07

dedanna1029
Member
From: Cheyenne, WY, US
Registered: 2010-10-01
Posts: 98

Re: [solved] libnotify.so.1 is missing from libnotify 0.7.1-1.1

This has been resolved with updates, and with a reset of a setting in gconf-editor, which evidently got turned off with those updates. I got playing around in gconf-editor, and found it:

gconf-editor

See where this is highlighted? Make sure it's ticked, and turned on.
screenshotinputmethodme.th.png

Also check these, and make sure they're on (ticked):
screenshoteventsoundsgn.th.png

Thanks.

Last edited by dedanna1029 (2011-07-20 14:23:35)

Offline

Board footer

Powered by FluxBB