You are not logged in.

#1 2011-04-12 16:52:03

init0
Member
Registered: 2011-04-12
Posts: 33

GNOME3: Ugly mouse cursors

Hi everyone!
I have a small issue with my Gnome3 desktop: It uses the default (ugly) X mouse cursors.
Am I missing some package or setting?

Edit: It's even more weird because it may suddenly change to the correct cursors during a session until i logout.

Last edited by init0 (2011-04-12 17:33:46)

Offline

#2 2011-04-12 18:20:08

eldragon
Member
From: Buenos Aires
Registered: 2008-11-18
Posts: 1,026

Re: GNOME3: Ugly mouse cursors

it could be related to gnome-settings-daemon suddenly using a lot of cpu usage.

check that first, and then try killing it. see if you get your pretty cursors back

Last edited by eldragon (2011-04-12 18:20:34)

Offline

#3 2011-04-12 19:04:56

init0
Member
Registered: 2011-04-12
Posts: 33

Re: GNOME3: Ugly mouse cursors

gnome-settings-daemon cpu time is less than 1 sec.
Killing it had no effect on the cursors.

Offline

#4 2011-04-16 07:46:50

xiaq
Member
From: somewhere in China...
Registered: 2011-03-06
Posts: 88

Re: GNOME3: Ugly mouse cursors

Same here.

Offline

#5 2011-04-16 10:05:38

espace.ariane
Member
Registered: 2010-07-02
Posts: 18

Re: GNOME3: Ugly mouse cursors

Is there a special package needed to install the default gnome cursors ? You said that sometimes you get the correct cursors, but it never happens here =/

Offline

#6 2011-04-16 11:46:07

init0
Member
Registered: 2011-04-12
Posts: 33

Re: GNOME3: Ugly mouse cursors

No, the package is just testing/gnome-themes-standard and the cursors should be installed to /usr/share/icons/Adwaita/cursors/

Like I said before, my Gnome3 _sometimes_ uses the Adwaita cursors until the end of a session - but that's rare and not reproducible sad

Offline

#7 2011-04-19 18:58:05

kylecarey
Member
From: Ohio, USA
Registered: 2011-04-12
Posts: 8
Website

Re: GNOME3: Ugly mouse cursors

I'm having this same problem... sort of. tongue

I did a clean install of Arch and installed Gnome 3 according do a guide on the wiki. My problem is Gnome 3 uses the default X cursors all the time with one exception: Whenever I open the file manager Gnome switches to the pretty cursors. hmm

I have no clue why, any insight would be helpful. smile


live long and prosper...

kc

Offline

#8 2011-04-19 23:56:46

Mike V
Member
From: Somewhere I belong
Registered: 2011-02-12
Posts: 10

Re: GNOME3: Ugly mouse cursors

Have you tried editing the following file?

/usr/share/themes/Adwaita/index.theme

and adding/changing the cursor line to the following:

CursorTheme=DMZ-White

obviously if you are using other than DMZ-White (Ubuntu defaults) you need to change it accordingly, I had the same problem but forgot to document my change sad hope is that file...

PS: you will need to log out/in to take effect.

Offline

#9 2011-04-21 16:44:52

Silversun
Member
Registered: 2011-04-21
Posts: 14

Re: GNOME3: Ugly mouse cursors

Same problem here.

Offline

#10 2011-04-21 21:43:43

Silversun
Member
Registered: 2011-04-21
Posts: 14

Re: GNOME3: Ugly mouse cursors

I found a solution.
Create a folder .icons/default in your home and link the Adwaita cursor theme with it.

mkdir -p .icons/default
 ln -s /usr/share/icons/Adwaita/ ~/.icons/default/

Offline

#11 2011-04-21 22:05:40

sironitomas
Member
From: Cordoba, Argentina
Registered: 2009-11-28
Posts: 174
Website

Re: GNOME3: Ugly mouse cursors

That's one of the things that cause me headaches! Looks like GNOME3 has a long way to go... This made me remind KDE 4.0. What a disaster!

Last edited by sironitomas (2011-04-21 22:06:20)

Offline

#12 2011-04-23 05:19:53

Padfoot
Member
Registered: 2010-09-03
Posts: 381

Re: GNOME3: Ugly mouse cursors

I have found a lot of customisation options which normally have a corresponding ~/.xxx folder for user specific config (eg /usr/share/themes, /usr/share/icons etc.) are not currently working in Gnome 3 by default. I am sure it is the $XDG_DATA_DIRS (or similar) environment variables not being set to look in /home first (I am sure this will be corrected as Gnome 3 matures and the devs add user config options).

I have found my cursors work correcty (in all but firefox) (using custom Silver-3D cursors). One thing that may help (it has helped solve my "some windows use my cursors and some don't" issue)

in /usr/share/icons create a folder called default. In that folder, create a file called index.theme and populate as follows:

[Icon Theme]
Inherits=xxxxxxx

Where xxxxxx is the name of your theme of choice. The added bonus of doing this is that GDM will use your selected cursor theme as well.

GDM is actually what I have been working on theming today. I have customised the background, cursors, icons, sound theme (I'll admit it, I like a system-ready sound when GDM comes up) and GTK3 themes for it. Now I just have to translate that to my shell.

Cheers.

Offline

#13 2011-04-24 05:42:22

kylecarey
Member
From: Ohio, USA
Registered: 2011-04-12
Posts: 8
Website

Re: GNOME3: Ugly mouse cursors

@Silversun: I tried your solution with no luck. Thanks anyways. smile

@Padfoot: This works wonderfully! It makes sense if you think about it. tongue

Thanks all.


live long and prosper...

kc

Offline

#14 2011-04-24 15:21:01

Ledti
Member
Registered: 2010-07-31
Posts: 122
Website

Re: GNOME3: Ugly mouse cursors

An alternative way to fix it locally is to add this to your .Xresources (install xorg-xrdb) or .Xdefaults file:

!cursor theme
Xcursor.theme: Adwaita

Though this won't theme the icon for GDM, you'll have to use Padfoot's approach if you want that.

Offline

#15 2011-04-24 16:15:32

wickedlester
Member
Registered: 2004-07-22
Posts: 133

Re: GNOME3: Ugly mouse cursors

I changed the "cursor-theme" settings in dconf-editor to the cursor theme I wanted to use. open dconf-editor and look under "org-desktop-interface"
This allows me to have my cursor in windows like firefox also.

Last edited by wickedlester (2011-04-24 16:16:30)

Offline

#16 2011-04-24 17:58:48

init0
Member
Registered: 2011-04-12
Posts: 33

Re: GNOME3: Ugly mouse cursors

Thanks for the solutions! smile
I applied Padfoots' one and can confirm it.

Offline

#17 2011-05-02 17:04:57

init0
Member
Registered: 2011-04-12
Posts: 33

Re: GNOME3: Ugly mouse cursors

I still see this issue with gnome [extra] (all) when doing a fresh install.
On Fedora 15 you will not have this trouble cus they ship Gnome3 with the following:

$cat /usr/share/icons/default/index.theme
[Icon Theme]
Inherits=Adwaita

So is it an Arch or upstream problem and can someone fix it or file a bug?

Offline

#18 2011-05-07 05:22:24

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,535
Website

Re: GNOME3: Ugly mouse cursors

Moved to Applications & Desktop Environments


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

#19 2011-05-26 21:51:52

dradius
Member
Registered: 2011-05-26
Posts: 3

Re: GNOME3: Ugly mouse cursors

I did not have a /usr/share/icons/default folder, all I had to do was copy the folder for the theme I wanted to /usr/share/icons/default.

Offline

#20 2011-05-29 04:04:27

bigelow13
Member
Registered: 2011-05-29
Posts: 3

Re: GNOME3: Ugly mouse cursors

I tried every solution proposed here, but only dradius one worked for me

Offline

#21 2011-05-29 16:33:19

init0
Member
Registered: 2011-04-12
Posts: 33

Re: GNOME3: Ugly mouse cursors

Copying is probably not a good idea, why no symlink?!

ln -s /usr/share/icons/Adwaita /usr/share/icons/default

Offline

#22 2011-07-08 22:35:58

dennymallow
Member
Registered: 2011-07-08
Posts: 10

Re: GNOME3: Ugly mouse cursors

I just would like to notify that the only solution that worked for me, among all those proposed, is simlinking "default" to the theme folder I wanted to use!
(copying the files seemed a bit brutal to me too... tongue)
I have ARCH 2.6.39 and Gnome3 all up-to-date...

Last edited by dennymallow (2011-07-08 23:08:47)


A good Arch can hold any weight!

Offline

#23 2011-08-08 02:59:08

MetaMan
Member
Registered: 2011-08-08
Posts: 43

Re: GNOME3: Ugly mouse cursors

Padfoot's solution worked for me. Thanks!


http://localhost/signature.txt
Error 403: Forbidden

Offline

#24 2011-10-09 20:32:41

intgr
Member
Registered: 2009-10-02
Posts: 42

Re: GNOME3: Ugly mouse cursors

FYI I have reported a feature request about this: https://bugs.archlinux.org/task/26362

Please vote smile

Offline

#25 2011-10-09 23:22:43

hooya
Member
Registered: 2011-10-09
Posts: 95

Re: GNOME3: Ugly mouse cursors

Even with the index.theme file my cursors are inconsistent at best. Text select, hoverover link, move, icons all work, but the regular pointer stays default ugly black pointer.

Sometimes it decides to start working randomly though. There seems to be no reasoning when the selected theme cursor decides to work.

By changing the Inherits line to my mouse cursor theme though, it'll work correctly (after a shell restart)

Last edited by hooya (2011-10-09 23:24:17)

Offline

Board footer

Powered by FluxBB