You are not logged in.

#1 2005-06-09 21:38:15

jota_dominguez
Member
Registered: 2005-06-08
Posts: 18

power off -- power down

When shut down my laptop it doesnt turn off automatically. I have to press & hold the power button for aprox. 4 sec.

what can i do to fix this?

Offline

#2 2005-06-09 21:42:44

topito
Member
From: Catalonia
Registered: 2004-03-25
Posts: 118
Website

Re: power off -- power down

Try loading apm module, without it my computer does not turn off either

Offline

#3 2005-06-09 22:54:47

jota_dominguez
Member
Registered: 2005-06-08
Posts: 18

Re: power off -- power down

when i do:
   modprobe apm   
it says:
   FATAL: Module apm not found

also when i do:
   apm or xapm
it says:
   No APM support in kernel

Offline

#4 2005-06-09 23:41:24

Dusty
Schwag Merchant
From: Medicine Hat, Alberta, Canada
Registered: 2004-01-18
Posts: 5,986
Website

Re: power off -- power down

Did you compile your kernel yourself?

Offline

#5 2005-06-09 23:45:33

jota_dominguez
Member
Registered: 2005-06-08
Posts: 18

Re: power off -- power down

No i didn't.  I had a friend helping me

Offline

#6 2005-06-10 01:41:22

Dusty
Schwag Merchant
From: Medicine Hat, Alberta, Canada
Registered: 2004-01-18
Posts: 5,986
Website

Re: power off -- power down

lol, that still doesn't answer my question; is it the ArchLinux stock kernel, or one that you (or your friend or somebody) compiled from source?

If its not the stock kernel, you may have to recompile with apm support added to the kernel. If its the stock kernel, then its probably some other problem.

Dusty

Offline

#7 2005-06-10 02:37:37

jota_dominguez
Member
Registered: 2005-06-08
Posts: 18

Re: power off -- power down

it is a stock kernel. and recently updated

Offline

#8 2005-06-10 03:04:19

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: power off -- power down

I used to have to pass "apm=power-off" to the kernel at boot, via appending it to a line in my grub config file. Sold that laptop though.
*shrug*
Maybe it will work for you too.


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#9 2005-06-20 16:49:54

Ecco
Member
Registered: 2005-01-23
Posts: 13

Re: power off -- power down

I used to have a similar problem with my laptop. The problem was that ACPI was working fine, except when powering off. It just didn't.
The fix for me was to turn off the local APIC support in the kernel.
Hope this helps! You'll need to recompile the kernel to see if it's see same problem though, or I think you can append "noapic" or "disableapic" to your kernel line in your bootloader.

Offline

Board footer

Powered by FluxBB