You are not logged in.

#1 2011-04-14 13:46:15

dinkydarko
Member
From: Glasgow, Scotland
Registered: 2005-01-28
Posts: 35
Website

[Gnome 3] how to set the default keyboard for GDM

Hello again,

  second problem.  I use a UK keyboard and some of the passwords for my accounts use symbols which aren't the same on a US keyboard. I cant find the setting to default GDM to UK layout. Any ideas?

David

Offline

#2 2011-04-15 08:51:36

killajoe
Member
From: Berlin Planet Earth
Registered: 2007-07-04
Posts: 164
Website

Re: [Gnome 3] how to set the default keyboard for GDM

The question is "How to configure GDM [Gnome3]?"
wink

I try configuring with:

 cp -t /usr/share/gdm/autostart/LoginWindow/ /usr/share/applications/gnome-tweak-tool.desktop  /usr/share/applications/gconf-editor.desktop

but the changes would not be  applied...

Last edited by killajoe (2011-04-15 08:57:41)


Cancel me not -- for what then shall remain?
Abscissas, some mantissas, modules, modes, A root or two, a torus and a node:
The inverse of my verse, a null domain.
-- Stanislaw Lem, The Cyberiad

Offline

#3 2011-04-15 09:05:32

frontwheelskid
Member
Registered: 2009-04-10
Posts: 5

Re: [Gnome 3] how to set the default keyboard for GDM

Not sure if this is the best way. But I added the bolded bit to my /etc/X11/xorg.conf.d/10-evdev.conf

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbLayout" "gb"
EndSection

Offline

#4 2011-04-25 09:19:58

Wikimig
Developer
From: France
Registered: 2004-12-10
Posts: 77
Website

Re: [Gnome 3] how to set the default keyboard for GDM

frontwheelskid wrote:

I added the bolded bit to my /etc/X11/xorg.conf.d/10-evdev.conf
Section
        ...
        Option "XkbLayout" "gb"
        ...
EndSection

That makes it here. Thanks.

Offline

#5 2011-05-01 19:17:35

ghen
Member
From: Belgium
Registered: 2010-08-31
Posts: 98
Website

Re: [Gnome 3] how to set the default keyboard for GDM

GDM 2.32 allowed for keyboard layout selection per-user, this is no longer possible with GDM 3?

Offline

#6 2011-05-02 13:20:32

Rob2
Member
Registered: 2011-05-02
Posts: 1

Re: [Gnome 3] how to set the default keyboard for GDM

ghen wrote:

GDM 2.32 allowed for keyboard layout selection per-user, this is no longer possible with GDM 3?

Same question.

Offline

#7 2011-05-02 16:22:18

erm67
Member
From: Europe
Registered: 2007-08-01
Posts: 123

Re: [Gnome 3] how to set the default keyboard for GDM

I followed this steps from the wiki:


# su - gdm -s /bin/bash
$ dbus-launch

This command will print DBUS_SESSION_BUS_ADDRESS and DBUS_SESSION_BUS_PID. We need to export them

$ export DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-Jb433gMQHS,guid=fc14d4bf3d000e38276a5a2200000d38
$ export DBUS_SESSION_BUS_PID=4283

Check to see if dconf-service is running and if not, start it like this

$ /usr/lib/dconf/dconf-service &

Than used both dconf-editor and gconf-editor to set any key related to the keyboard, but it didn't worked, I also used gnome-control-center but it failed too. It seems there is no way to set the keyboard for gdm :-)

Initially I thought it worked but I was wrong ....

Last edited by erm67 (2011-05-02 17:02:39)

Offline

#8 2011-05-02 22:12:23

Pai Mei
Member
From: Marilia SP Brazil
Registered: 2011-05-02
Posts: 2

Re: [Gnome 3] how to set the default keyboard for GDM

When I upgrade my system, my keyboard lost the character map (I use the brazil-abnt2 map), and gdm lost the "keyboard button".

So I went to /etc/X11/xorg.conf and write (the xorg lost my old keyboard map, because of the upgrade):

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
    Option "CoreKeyboard"   
        Option      "XkbRules"        "xorg"
        Option      "XkbModel"        "abnt2"
        Option      "XkbLayout"       "br"
        Option      "XkbVariant"      "abnt2"
    Option "XkbOptions" "abnt2"
EndSection

That works for my terminal, but inside the X (Gnome, LXDE, etc) the map was lost. So I do in a terminal:

$ setxkbmap br

And I have the keyboar map set to brazil-abnt2 again.

I think if you change the keyboard map (in xorg) from abnt to gb, and do a:
$ setkbmap gb

it could work.


"Its the wood that should fear your hand, not the other way around. No wonder you cant do it, you acquiesce to defeat before you even begin."

System: ArchLinux x86_64 - Kernel 2.6.38-ARCH - LXDE - OpenBox - XFCE - Gnome 3
Hardware: Motherboard GA-G31M-S2L -  Processor Pentium(R) Dual-Core  CPU E5700  @ 3.00GHz -  2Gb DDR2 - Geforce GTX9800 -  LCD 22" LG W2252TQ - Epson TX115

Offline

#9 2011-05-05 06:16:51

grandtheft
Member
Registered: 2010-10-05
Posts: 26

Re: [Gnome 3] how to set the default keyboard for GDM

Workaround:

I've put "setxkbmap de" (replace de with your layout code) in the last line of /etc/gdm/Init/Default. Works.

gt

Offline

#10 2011-05-05 08:41:34

raymondcal
Member
Registered: 2010-06-16
Posts: 47

Re: [Gnome 3] how to set the default keyboard for GDM

Offline

#11 2011-05-06 06:23:54

eanderalx
Member
From: Berlin/Germany
Registered: 2010-01-10
Posts: 20
Website

Re: [Gnome 3] how to set the default keyboard for GDM

raymondcal wrote:

Seems to work only with gdm 2.x


"Man kann ein Problem nicht mit den gleichen Denkstrukturen lösen, die zu seiner Entstehung beigetragen haben." (Albert Einstein)
"A problem cannot be solve at the same level of thinking at which it was created." (Albert Einstein)

Offline

#12 2011-05-07 04:57:41

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,064
Website

Re: [Gnome 3] how to set the default keyboard for GDM

Moved to Applications and Desktop Environments


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB