You are not logged in.

#1 2005-06-12 02:56:25

nkw
Member
Registered: 2004-03-26
Posts: 80

Need to start X before logon

I put the xdm in the MODULES = (...) of rc.conf. But it doesn't start X and I tried login and "startx" the log file shows:

        .......
        ATI Radeon X800PRO (R423) UI (PCIE),
        ATI Radeon X800LE (R423) UJ (PCIE),
        ATI Radeon X800SE (R423) UK (PCIE),
        ATI FireGL V7200 (R423) UQ (PCIE), ATI FireGL V5100 (R423) UR (PCIE),
        ATI FireGL V7100 (R423) UT (PCIE),
        ATI Radeon X800XT (R423) 5D57 (PCIE)
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(EE) No devices detected.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support 
         at http://wiki.X.Org
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Offline

#2 2005-06-12 03:44:25

Dusty
Schwag Merchant
From: Medicine Hat, Alberta, Canada
Registered: 2004-01-18
Posts: 5,986
Website

Re: Need to start X before logon

did you look in /var/log/Xorg.0.log? for errors?

Dusty

Offline

#3 2005-06-12 04:01:19

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Need to start X before logon

you want it in the DAEMONS array, not modules.
And it looks like you haven't configured X yet. You need to do that.
Install and configure xorg


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#4 2005-06-12 05:42:54

nkw
Member
Registered: 2004-03-26
Posts: 80

Re: Need to start X before logon

Thanks. I got the following error in Xorg.0.log after I run xorgconf.

(==) ATI(0): Write-combining range (0xf5000000,0x800000)
(II) ATI(0): Largest offscreen areas (with overlaps):
(II) ATI(0):    1024 x 3327 rectangle at 0,768
(II) ATI(0):    512 x 3328 rectangle at 0,768
(II) ATI(0): Using XFree86 Acceleration Architecture (XAA)
        Screen to screen bit blits
        Solid filled rectangles
        8x8 mono pattern filled rectangles
        Indirect CPU to Screen color expansion
        Solid Lines
        Offscreen Pixmaps
        Setting up tile and stipple cache:
                32 128x128 slots
                18 256x256 slots
                6 512x512 slots
(==) ATI(0): Backing store disabled
(==) ATI(0): Silken mouse enabled
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(**) Option "Protocol" "Auto"
(**) Mouse1: Device: "/dev/mouse"
(**) Mouse1: Protocol: "Auto"
(**) Option "CorePointer"
(**) Mouse1: Core Pointer
(**) Option "Device" "/dev/mouse"
(EE) xf86OpenSerial: Cannot open device /dev/mouse
        No such file or directory.
(EE) Mouse1: cannot open input device
(EE) PreInit failed for input device "Mouse1"
(II) UnloadModule: "mouse"
(**) Option "CoreKeyboard"
(**) Keyboard1: Core Keyboard
(**) Option "Protocol" "standard"
(**) Keyboard1: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Keyboard1: XkbRules: "xorg"
(**) Option "XkbModel" "pc101"
(**) Keyboard1: XkbModel: "pc101"
(**) Option "XkbLayout" "us"
(**) Keyboard1: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) Keyboard1: CustomKeycodes disabled
(WW) No core pointer registered
(II) XINPUT: Adding extended input device "Keyboard1" (type: KEYBOARD)
No core pointer

Fatal server error:
failed to initialize core devices

Please consult the The X.Org Foundation support 
         at http://wiki.X.Org
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Offline

#5 2005-06-12 06:16:34

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Need to start X before logon

hmmm...try the alternate step on the bottom of that page then, using hwd..
the error you are showing is no core pointer..that is a mouse config issue..


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#6 2005-06-12 06:35:26

scarecrow
Member
From: Greece
Registered: 2004-11-18
Posts: 714

Re: Need to start X before logon

Yep, try "hwd -x"
Don't run xdm as daemon either, just change /etc/inittab


Microshaft delenda est

Offline

#7 2005-06-12 07:25:10

nkw
Member
Registered: 2004-03-26
Posts: 80

Re: Need to start X before logon

Thanks for the hwd -x. It's really a good thing for Linux world. Finally my fear to configure X has gone. Can I un-plug in a mouse and a keyboard and set up X remotely via ssh?

However, I still cannot start vncserver:
vncserver: couldn't find "Xvnc" on your PATH.

Offline

#8 2005-06-12 07:40:27

nkw
Member
Registered: 2004-03-26
Posts: 80

Re: Need to start X before logon

And all X program shows (i am using ssh -X):
Error: Can't open display:
or
display: unable to open X server `'.

However, ps -A shows X and xdm....

Offline

Board footer

Powered by FluxBB