You are not logged in.

#1 2005-05-20 09:54:12

fdrebin
Member
Registered: 2005-04-25
Posts: 152

printer installed but doesn't print

i downloaded the "driver" file for my hp printer then after starting cups as root i added the new printer through kcontrol. everything seemed to work fine but when it cam to the point of printing a test page nothing happend (a dialog: wait until test page is printed).

Offline

#2 2005-05-20 14:54:28

clank
Member
Registered: 2005-04-11
Posts: 35

Re: printer installed but doesn't print

If you're using the stock kernel, are the printer modules loaded?


=> Now known as jb

Offline

#3 2005-05-20 16:28:01

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: printer installed but doesn't print

you can switch the debug level to "debug" in the cups config file and restart the cups daemon.  Try printing the test page again and you should see alot of info in the logs.
Maybe this will help:
http://bbs.archlinux.org/viewtopic.php?t=12418

Offline

#4 2005-05-20 16:48:41

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: printer installed but doesn't print

Turn the printer on and don't forget to connect the cable.

(If you want a more helpful reply then post some more info like lsmod, dmesg or /var/log/cup/error_logs output.)

Offline

#5 2005-05-21 00:52:30

fdrebin
Member
Registered: 2005-04-25
Posts: 152

Re: printer installed but doesn't print

how can i check if printer modules are loaded?

Offline

#6 2005-06-13 13:47:06

fdrebin
Member
Registered: 2005-04-25
Posts: 152

Re: printer installed but doesn't print

i switched the mode to debug - the only error message i get in the error log is
"E [13/Jun/2005:15:45:32 +0200] PID 7263 stopped with status 22!"
when i want to print hte test page.
what to do now ?

Offline

#7 2005-06-13 22:21:54

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: printer installed but doesn't print

did you switch it to debug2? It will give you a hell of a lot more output but, you'll more than likely find the problem.

For me it was in a bash file. I had to set prefix=/ to /usr It's there in the link I provided above.

Offline

#8 2005-06-14 00:01:01

Cam
Member
From: Brisbane, Aus
Registered: 2004-12-21
Posts: 658
Website

Re: printer installed but doesn't print

I spent almost an hour trying to get my printer to print that stupid test page until I realised I didn't have the ghostscript package installed...

Offline

#9 2005-06-15 16:43:13

fdrebin
Member
Registered: 2005-04-25
Posts: 152

Re: printer installed but doesn't print

so whats the best package to install anyway - ghostscript ?

Offline

#10 2005-06-15 20:40:25

Wubbeneezer
Member
From: Northern California
Registered: 2005-03-12
Posts: 13

Re: printer installed but doesn't print

I had a problem getting my HP printer to work. I had looked at the linked Wiki page and had installed CUPS, ghostscript, and foomatic. However, I had forgotten to install HPIJS (an HP driver package). DUH! Once this was installed, printing worked fine.

You said you started CUPS as root...which leads me to believe that you don't have the CUPS daemon automatically set to start at boot time. Just add "CUPS" to the daemon section in /etc/rc.conf. HTH.


When all is said and done,
There's nothing left to say or do.

Offline

#11 2005-06-16 19:10:09

fdrebin
Member
Registered: 2005-04-25
Posts: 152

Re: printer installed but doesn't print

this happens when i want to install the hpijs package:

root@arch frankdrebin]# pacman -S hpijs

Targets: foomatic-filters-3.0.2-1 hpijs-1.7.1-1

Total Package Size:   1.4 MB

Proceed with upgrade? [Y/n] Y

checking package integrity... done.
loading package data... done.
checking for file conflicts...
error: the following file conflicts were found:
  foomatic-filters: /etc/foomatic/filter.conf: exists in filesystem
  foomatic-filters: /usr/bin/foomatic-gswrapper: exists in filesystem
  foomatic-filters: /usr/man/man1/foomatic-gswrapper.1.gz: exists in filesystem


errors occurred, no packages were upgraded.

Offline

Board footer

Powered by FluxBB