You are not logged in.

#1 2011-05-19 20:54:51

altercation
Member
From: Seattle
Registered: 2011-05-15
Posts: 135
Website

[SOLVED] Wacom on Lenovo x220 tablet - present but not working

Hoping for some feedback on best procedure to get the built in Wacom (stylus+multitouch) working in a Lenovo x220 tablet convertible tablet/laptop.

Problem Summary

Wacom shows up in lsusb but not in /dev/input or X.

(as an aside, I've tested in a new Ubuntu install just as a quick "make sure the hardware is working" test and both stylus and touchscreen are active there, so hw is functional and can be made to work smile

Best guess

I'm guessing that the current wacom.ko doesn't have the correct model number for this tablet? I note that there is a recent patch for this builtin Wacom model, but I'm not sure it's in the current AUR wacom-drivers.

I'm a little new to the linuxwacom business and so would appreciate a spot check on this before I continue to troubleshoot, test, etc.

Relevant details
lsusb

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 0a5c:217f Broadcom Corp. Bluetooth Controller
Bus 001 Device 004: ID 04f2:b217 Chicony Electronics Co., Ltd 
Bus 002 Device 003: ID 056a:00e6 Wacom Co., Ltd 
ls /dev/input

event0 event1 event10 event2 event3 event4 event5
event6 event7 event8 event9 mice mouse0 mouse1
find / -name '*wacom*' -print

/var/lib/pacman/local/wacom-drivers-0.11.0-1
/usr/share/man/man1/xsetwacom.1.gz
/usr/share/man/man4/wacom.4.gz
/usr/src/linux-2.6.38-ARCH/include/config/tablet/usb/wacom.h
/usr/src/linux-2.6.38-ARCH/include/config/touchscreen/wacom
/usr/src/linux-2.6.38-ARCH/include/config/hid/wacom.h
/usr/src/linux-2.6.38-ARCH/include/config/hid/wacom
/usr/lib/pkgconfig/xorg-wacom.pc
/usr/lib/xorg/modules/input/wacom_drv.so
/usr/bin/xsetwacom
/usr/include/xorg/wacom-properties.h
/usr/include/xorg/Xwacom.h
/lib/modules/2.6.38-ARCH/updates/wacom.ko
/lib/modules/2.6.38-ARCH/updates/wacom_w8001.ko
/lib/modules/2.6.38-ARCH/kernel/drivers/input/tablet/wacom.ko.gz
/lib/modules/2.6.38-ARCH/kernel/drivers/input/touchscreen/wacom_w8001.ko.gz
/lib/modules/2.6.38-ARCH/kernel/drivers/hid/hid-wacom.ko.gz
/etc/X11/xorg.conf.d/50-wacom.conf
/etc/udev/rules.d/10-wacom.rules
Steps taken so far
  1. Extensive search on arch forum, wiki pages for data

  2. Successful test on ubuntu 11.04 to confirm hw working

  3. Base install Arch off current dev ISOs; lsusb shows Wacom, no /dev/input

  4. Installed wacom-drivers from AUR; still no /dev/input

  5. Modified /etc/udev/10-wacom.rules to include correct model number (as per this section on the wiki page); no success

Possible next steps
  1. Check with AUR package maintainer to see if it can be updated?

  2. Build or modify source from the linux wacom project myself? Updated wacom.ko?

Relevant Links
  1. Arch wiki Wacom page

  2. AUR wacom-drivers

  3. Forum post on wacom-drivers from Giniu

  4. Linux Wacom Project

  5. Patch for this Wacom model?

Last edited by altercation (2011-05-20 07:58:29)


Ethan Schoonover
Precision Colors - http://ethanschoonover.com/solarized

Offline

#2 2011-05-19 21:36:03

Giniu
Trusted User (TU)
From: Wrocław/Poland
Registered: 2007-04-02
Posts: 61
Website

Re: [SOLVED] Wacom on Lenovo x220 tablet - present but not working

Hi,

the patch you linked to is officially in 0.11 release, so it's included in wacom-driver package. I have not included the udev rule yet, but there is generic rule that catches all devices - at least

ATTRS{idVendor}=="056a", ENV{ID_PATH}=="?*", SYMLINK="input/by-path/$env{ID_PATH}-wacom"

should fire and create /dev/input/by-path/...-wacom even if no line for specific device is present, so you can rule out both patch and udev rule.

What it looks to me is that this patch is only for X driver, not for Kernel driver, the input-wacom (not xf86-input-wacom) - it was posted on https://lkml.org/lkml/2011/3/31/402 and I guess Ubuntu uses it but it's not yet official. I might try merging it for now, but I'd rather ask on linuxwacom mailing list if it will be added to input-wacom soon and if this patch is correct, there was some talk about resolution in that thread.

Try wacom-drivers 0.11.0-2 to see if this is kernel driver that you were missing.

Andrzej.


My GPG fingerprint: 7170 26A9 D477 9FC5 3940  7266 40F5 57B7 3149 6106

Offline

#3 2011-05-19 23:07:32

altercation
Member
From: Seattle
Registered: 2011-05-15
Posts: 135
Website

Re: [SOLVED] Wacom on Lenovo x220 tablet - present but not working

Andrzej –

Thanks for that reply. I did a quick update of wacom-drivers with no luck, but I'm going to try again from a base install to see.

Do you see any issue running this on 2.6.38? The linuxwacom project site is unclear to me in this regard.

-es


Ethan Schoonover
Precision Colors - http://ethanschoonover.com/solarized

Offline

#4 2011-05-19 23:12:37

Giniu
Trusted User (TU)
From: Wrocław/Poland
Registered: 2007-04-02
Posts: 61
Website

Re: [SOLVED] Wacom on Lenovo x220 tablet - present but not working

Did you restarted after update?

Anyway, if you want to try default kernel driver you can also give it a show, just remove wacom-driver and install xf86-input-wacom-git (because stable isn't updated to 0.11 yet). Anyway I believe it should be working more reliably with input-wacom driver, which have some stuff ported from kernel 2.6.39.


My GPG fingerprint: 7170 26A9 D477 9FC5 3940  7266 40F5 57B7 3149 6106

Offline

#5 2011-05-19 23:26:56

altercation
Member
From: Seattle
Registered: 2011-05-15
Posts: 135
Website

Re: [SOLVED] Wacom on Lenovo x220 tablet - present but not working

Giniu wrote:

Did you restarted after update?

Yes, restarted. After installing wacom-drivers I added wacom/wacom-w8001 to rc.conf MODULES and then did the reboot. Still no joy...

Giniu wrote:

Anyway, if you want to try default kernel driver you can also give it a show, just remove wacom-driver and install xf86-input-wacom-git (because stable isn't updated to 0.11 yet). Anyway I believe it should be working more reliably with input-wacom driver, which have some stuff ported from kernel 2.6.39.

I've tried xf86-input-wacom-git prior to this as well, but will give it another shot now. To clarify my test procedure:

update

Not working either...

Thanks for guidance on this, apologies if I'm missing some obvious step...!

Last edited by altercation (2011-05-19 23:32:49)


Ethan Schoonover
Precision Colors - http://ethanschoonover.com/solarized

Offline

#6 2011-05-20 05:03:59

altercation
Member
From: Seattle
Registered: 2011-05-15
Posts: 135
Website

Re: [SOLVED] Wacom on Lenovo x220 tablet - present but not working

Giniu wrote:

Did you restarted after update?

Anyway, if you want to try default kernel driver you can also give it a show, just remove wacom-driver and install xf86-input-wacom-git (because stable isn't updated to 0.11 yet). Anyway I believe it should be working more reliably with input-wacom driver, which have some stuff ported from kernel 2.6.39.

IT'S WORKING!

Did a full reinstall from an archboot iso, same procedure, got it working. I suspect that the previously failed attempt after your last update may have been due to a cached version of the packaged on my local LAN/caching proxy. Just a guess. In any case, modinfo wacom now reports my device ID properly, /dev/input now shows the touch and wacom variants.

And, best of all, booting into X results in active touch and stylus. Touch is wonky, but this is all trivial and configurable.

Many many thanks!


Ethan Schoonover
Precision Colors - http://ethanschoonover.com/solarized

Offline

#7 2011-05-20 05:50:15

Giniu
Trusted User (TU)
From: Wrocław/Poland
Registered: 2007-04-02
Posts: 61
Website

Re: [SOLVED] Wacom on Lenovo x220 tablet - present but not working

No problem, I'm glad it's working smile


My GPG fingerprint: 7170 26A9 D477 9FC5 3940  7266 40F5 57B7 3149 6106

Offline

Board footer

Powered by FluxBB