You are not logged in.

#1 2011-05-25 17:30:02

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

[kde-unstable] KDE 4.7

Hi all,
the first beta of the new major release of KDE 4.7 is out and is already packaged in [kde-unstable].

As you already know KDE is (slowly) moving to GIT; with this transition some KDE module has been splitted into subprojects, others modules will be splitted during this beta cycle and others modules will be splitted before KDE 4.8.

The result of this is that some package (e.g. kdegraphics-libs) is now splitted in several packages and each conflicts with the old, so you have to remove it when pacman asks for its removal during the update.

See the KDE announcement for upstream changes.

Arch Linux Changes:
- kdegraphics-libs is now splitted in: kdegraphics-ksaneplugin, kdegraphics-strigi-analyzer, kdegraphics-svgpart, kdegraphics-thumbnailers, libkdcraw, libkexiv2, libkipi, libksane
- kdebindings-csharp is now splitted in: kdebindings-qyoto, kdebindings-kimono
- kdebindings-ruby is now splitted in: kdebindings-qtruby, kdebindings-korundum
- kdebindings-smoke is now splitted in: kdebindings-smokegen, kdebindings-smokeqt, kdebindings-smokekde
- New packages: kdebindings-kimono, kdebindings-kross-java, kdebindings-kross-python, kdebindings-korundum, kdebindings-perlkde, kdebindings-perlqt, kdebindings-qtruby, kdebindings-qyoto, kdebindings-smokegen, kdebindings-smokekde, kdebindings-smokeqt, kdebase-konq-plugins, kde-wallpapers
- kdeedu-libkdeedu and kdeedu-data are both replaced by libkdeedu
- kdeaccessibility-colorschemes is replaced by kdeartwork-colorschemes
- kdeaccessibility-iconthemes is replaced by kdeartwork-iconthemes
- kdenetwork-kopete built with Google Talk Jingle support

The following packages depend on kdegraphics-libs and thus are now broken:
- digikam (now depends on 'libkexiv2')
- kipi-plugins (now depends on 'libkexiv2' 'libkdcraw' 'libkipi' 'libksane')
- koffice-krita (now depends on 'libkdcraw')
- skanlite (now depends on 'libksane')
- tellico (now depends on 'libksane')
- kphotoalbum (now depends on 'libkdcraw' 'libkipi')

Read the wiki page[1] about [kde-unstable] if you want to use these packages, please remember [testing] is needed and follow arch-dev-public.

Also, the first beta of the Calligra Suite is in [kde-unstable] since May 19th and packages are built to replace the KOffice suite. Please use the thread about Calligra to report packaging bugs.

Please report any packaging bug to https://bugs.archlinux.org.
KDE bugs to https://bugs.kde.org.

[1] https://wiki.archlinux.org/index.php/De … repository

Last edited by ilpianista (2011-06-25 15:17:32)

Offline

#2 2011-05-25 17:35:21

syms
Member
Registered: 2008-12-25
Posts: 292

Re: [kde-unstable] KDE 4.7

Thanks! I'm so happy that im using a system which has so many amazing developers smile

Offline

#3 2011-05-25 18:31:03

SS4
Member
From: !Rochford, Essex
Registered: 2010-12-05
Posts: 699

Re: [kde-unstable] KDE 4.7

Excellent work Bash! I'll be upgrading as soon as my mirror syncs (and I've grabbed more tea)


Rauchen verboten

Offline

#4 2011-05-25 18:55:51

alessandro_ufms
Member
From: Campo Grande, MS - Brazil
Registered: 2008-06-25
Posts: 153

Re: [kde-unstable] KDE 4.7

Thank you!!! Are you have plans to remove gconf and libsoup-gnome dependencies on gstreamer good plugin?

Last edited by alessandro_ufms (2011-05-25 21:37:06)

Offline

#5 2011-05-25 22:08:34

reflexing
Member
Registered: 2009-03-25
Posts: 58
Website

Re: [kde-unstable] KDE 4.7

Wow. Just wow. Compositor works smoother than ever. I'm using Catalyst.

Offline

#6 2011-05-25 22:17:38

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [kde-unstable] KDE 4.7

alessandro_ufms wrote:

Thank you!!! Are you have plans to remove gconf and libsoup-gnome dependencies on gstreamer good plugin?

no. gstreamer needs it


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#7 2011-05-25 22:24:26

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.7

kdebase-konq-plugins has a missing dependence on tidyhtml. this will be fixed in the next build.

Offline

#8 2011-05-25 22:36:28

KlavKalashj
Member
Registered: 2008-10-09
Posts: 357

Re: [kde-unstable] KDE 4.7

reflexing wrote:

Wow. Just wow. Compositor works smoother than ever. I'm using Catalyst.

Not for me, using Intel. It's actually a lot choppier now. But it's worth it, I love it. The new shadows are fantastic.

Offline

#9 2011-05-25 23:00:15

jxy
Member
Registered: 2008-12-03
Posts: 133

Re: [kde-unstable] KDE 4.7

So what is the best way to use digikam and kipi-plugins along with this KDE 4.7 beta?  Should I force it to ignore dependencies?

Offline

#10 2011-05-25 23:06:11

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.7

jxy wrote:

So what is the best way to use digikam and kipi-plugins along with this KDE 4.7 beta?  Should I force it to ignore dependencies?

you have to remove and rebuild them

Offline

#11 2011-05-25 23:07:07

SS4
Member
From: !Rochford, Essex
Registered: 2010-12-05
Posts: 699

Re: [kde-unstable] KDE 4.7

jxy wrote:

So what is the best way to use digikam and kipi-plugins along with this KDE 4.7 beta?  Should I force it to ignore dependencies?

Change the dependencies using ABS, I've successfully re-compiled kipi-plugins using the deps in the OP (and removing opencv and libgpod from makedeps)


Rauchen verboten

Offline

#12 2011-05-26 05:40:21

sumski
Member
From: Zagreb, Croatia
Registered: 2011-04-30
Posts: 114

Re: [kde-unstable] KDE 4.7

Andrea , is libgles  really needed for kdebase-workspace? I saw in PKGBUILD that you disabled KWin's mobile effects. Or you can compile with GL ES , but without mobile effects?

Offline

#13 2011-05-26 09:00:13

Gianfrix
Member
From: Locorotondo (BA) - Italy
Registered: 2009-10-21
Posts: 40
Website

Re: [kde-unstable] KDE 4.7

Because of some glitches caused by the latest version of nvidia blobs and xorg I have to use xserver 1.9 and nvidia 260.19, but KDE does not start, seems like part of it (such as kwin!) are returning me a SIGSEGV. Any solution to this?

EDIT: If I run kwin using gdb it has no problems! WTF!!

Last edited by Gianfrix (2011-05-26 09:35:19)


~ Gianfrix
There's no place like 127.0.0.1

Offline

#14 2011-05-26 09:58:19

Wu
Member
Registered: 2009-12-27
Posts: 61

Re: [kde-unstable] KDE 4.7

KlavKalashj wrote:

Not for me, using Intel. It's actually a lot choppier now. But it's worth it, I love it. The new shadows are fantastic.

same here (nvidia blob).

edit: btw the culprit seems to be oxygen, it is much much smoother with qtcurve, can you confirm?

Last edited by Wu (2011-05-26 11:07:13)

Offline

#15 2011-05-26 10:55:07

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.7

sumski wrote:

Andrea , is libgles  really needed for kdebase-workspace? I saw in PKGBUILD that you disabled KWin's mobile effects. Or you can compile with GL ES , but without mobile effects?

Hi, why do we need the effects for mobile devices?
I'm testing kdebase-workspace with KWIN_BUILD_WITH_OPENGLES=ON now

EDIT: forgot that. too slow with Open GL ES

Offline

#16 2011-05-26 12:17:47

sumski
Member
From: Zagreb, Croatia
Registered: 2011-04-30
Posts: 114

Re: [kde-unstable] KDE 4.7

When i compile kdebase-workspace with gles , and after i remove libgles i can't use kwin with catalyst. I'm asking are mobile effects/GL ES really needed on desktop. I don't see the benefits/usage but i see the downsides.

Offline

#17 2011-05-26 13:25:43

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.7

sumski wrote:

When i compile kdebase-workspace with gles , and after i remove libgles i can't use kwin with catalyst. I'm asking are mobile effects/GL ES really needed on desktop. I don't see the benefits/usage but i see the downsides.

OpenGL ES disabled in kdebase-workspace 4.6.80-2, test it and let we know. thanks

Offline

#18 2011-05-26 16:06:46

stavallo
Member
Registered: 2010-05-28
Posts: 33

Re: [kde-unstable] KDE 4.7

Unfortunately I have to disable kwin effects with the r300g gallium driver on a X300 ATI card. Upon logging in, the screen becomes black and I can do nothing. So, I had to configure OpenGLIsUnsafe=true in kwinrc to be able to login. Then, I can activate desktop effects by deselecting "Use OpenGL 2 shaders", but I get no window decorations then...

I don't know if reporting this bug upstream would be useful (to kde? xorg?)...

BTW I will test kdebase-workspace 4.6.80-2 as soon as it is available in my mirror

Last edited by stavallo (2011-05-26 16:07:35)

Offline

#19 2011-05-26 16:19:25

venky80
Member
Registered: 2007-05-13
Posts: 996

Re: [kde-unstable] KDE 4.7

wonder wrote:
alessandro_ufms wrote:

Thank you!!! Are you have plans to remove gconf and libsoup-gnome dependencies on gstreamer good plugin?

no. gstreamer needs it

Refer to how Chakra has split these packages, in Chakra installing gstreamer packages does not bring any gtk/gnome dependencies.


DELL XPS 1640 with ATI Mobility Radeon  HD 3670. Arch Linux KDE Minimal Install

Offline

#20 2011-05-26 16:27:16

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.7

venky80 wrote:

Refer to how Chakra has split these packages, in Chakra installing gstreamer packages does not bring any gtk/gnome dependencies.

Chakra do its best to avoid GTK stuff. We are not Chakra and GTK isn't the devil.

Offline

#21 2011-05-26 17:01:37

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: [kde-unstable] KDE 4.7

Well, gconf is not needed and useless on KDE anyway. But you'll probably need it when using gstreamer on Gnome.

Offline

#22 2011-05-26 17:24:24

sumski
Member
From: Zagreb, Croatia
Registered: 2011-04-30
Posts: 114

Re: [kde-unstable] KDE 4.7

bash wrote:

OpenGL ES disabled in kdebase-workspace 4.6.80-2, test it and let we know. thanks

I think we misunderstood ourselves.

1.) I didn't try kde-unstable packages until few minutes ago, i compiled entire KDE from git -
          a)compiled with libgles present , and with KWIN_BUILD_WITH_OPENGLES=ON flag ; resulting in working KWin with r600g , but not working after installing catalyst and removing libgles
           b) compiled wth KWIN_BUILD_WITH_OPENGLES=OFF witch resulted in working KWin with both OSS and catalyst drivers
(thats why i asked should libgles really be dependancy to kdebase-workspace - seeing that you packaged it with -DKWIN_MOBILE_EFFECTS=OFF flag ; ie. i considered these 2 flags to be equivalent)

2.) Installed kdebase-workspace 4.6.80-1 from kde-unstable -- removed libgles and tried  with catalyst , and everything is working as it should,  will try 4.6.80-2 , but should be the same.

Offline

#23 2011-05-27 06:07:02

sumski
Member
From: Zagreb, Croatia
Registered: 2011-04-30
Posts: 114

Re: [kde-unstable] KDE 4.7

Tried -2 , and it also works great witch catalyst . As i'm no expert , i guess that with -DKWIN_MOBILE_EFFECTS=OFF  flag libgles isn't "hardcoded" , and thats why i could use 4.6.80-1 without problems ; and with KWIN_BUILD_WITH_OPENGLES=ON flag libgles is "hardcoded" ? Am i wrong?
So , i'm really sorry for the unnecessary(?) trouble sad

@Gianfrix
You should report this to bugs.kde.org. Thats the point of beta's, rc's , etc.
Martin Graesslin is very quick , and helpfull with responses for bugs reported against KWin. But i would suggest you to rebuild kdebase-workspace with dubug information.

@reflexing
For me too big_smile

Last edited by sumski (2011-05-27 06:08:33)

Offline

#24 2011-05-27 11:58:38

RazrFalcon
Member
From: Ukraine
Registered: 2011-05-18
Posts: 37

Re: [kde-unstable] KDE 4.7

What about downgrade to 4.6.3 after installing 4.7?

Offline

#25 2011-05-27 12:12:32

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.7

RazrFalcon wrote:

What about downgrade to 4.6.3 after installing 4.7?

# pacman -Suu
and restore your .kde4

Offline

Board footer

Powered by FluxBB