You are not logged in.

#26 2011-05-27 15:09:45

RazrFalcon
Member
From: Ukraine
Registered: 2011-05-18
Posts: 37

Re: [kde-unstable] KDE 4.7

Thank. I'm return at 4.6.3. On 4.6.80 didn't work opengl for me.

Offline

#27 2011-05-27 15:09:59

damdim
Member
Registered: 2010-03-13
Posts: 42

Re: [kde-unstable] KDE 4.7

Kate and kwrite always crash. Is it a known issue?

Offline

#28 2011-05-27 15:17:00

SS4
Member
From: !Rochford, Essex
Registered: 2010-12-05
Posts: 699

Re: [kde-unstable] KDE 4.7

damdim wrote:

Kate and kwrite always crash. Is it a known issue?

I don't have kate installed but kwrite is working fine. Kate was crashing yesterday for me but that was a version mismatch


Rauchen verboten

Offline

#29 2011-05-27 19:15:04

damdim
Member
Registered: 2010-03-13
Posts: 42

Re: [kde-unstable] KDE 4.7

I have just reinstalled kwrite and now both programs work. It must have been a corrupted installation...

Offline

#30 2011-05-28 12:23:06

KlavKalashj
Member
Registered: 2008-10-09
Posts: 359

Re: [kde-unstable] KDE 4.7

Wu wrote:
KlavKalashj wrote:

Not for me, using Intel. It's actually a lot choppier now. But it's worth it, I love it. The new shadows are fantastic.

same here (nvidia blob).

edit: btw the culprit seems to be oxygen, it is much much smoother with qtcurve, can you confirm?

Yes, it's a bit smoother, but Oxygen in 4.6 was still smoother.

Offline

#31 2011-05-28 13:51:24

George
Member
Registered: 2011-05-11
Posts: 165

Re: [kde-unstable] KDE 4.7

@bash

Would you be able to add a seperate kwin package which has GLES enabled? Martin Graesslin has suggested that distributions should package two versions of kwin as it is a complie time switch .
http://blog.martin-graesslin.com/blog/2 … er-in-4-7/

Offline

#32 2011-05-28 16:36:38

EspaÑaks
Member
From: Spain
Registered: 2011-05-28
Posts: 4
Website

Re: [kde-unstable] KDE 4.7

RazrFalcon wrote:

Thank. I'm return at 4.6.3. On 4.6.80 didn't work opengl for me.


I may be mistaken, but I have this problem too. If you log in in failsafe mode, and then change the renderinng engine from OpenGL to XRender it will run, but without some plugins such as blur. I think this is because 4.7 now uses OpenGL 3.x, which was released on 2008, and my card is waaay more old than that :(. As I haven't seen any way of changing it back to OpenGL 2, I'm out of luck, and I don't think this is could be reported as a bug either (Even if i'm left behind, i still think supporting better new hardware and dropping old tech is good for everyone)

Last edited by EspaÑaks (2011-05-28 16:37:08)

Offline

#33 2011-05-28 17:03:07

RazrFalcon
Member
From: Ukraine
Registered: 2011-05-18
Posts: 37

Re: [kde-unstable] KDE 4.7

I switched OpenGL to XRender and can't return it back too.

Offline

#34 2011-05-28 17:58:48

George
Member
Registered: 2011-05-11
Posts: 165

Re: [kde-unstable] KDE 4.7

Actually kwin is only just switching to GL 2 since support is only just becoming widespread in drivers, you can disable GL 2 features under the OpenGL options on the advanced panel. There are more details in the blog post I linked to previously.

Offline

#35 2011-05-29 06:08:32

sumski
Member
From: Zagreb, Croatia
Registered: 2011-04-30
Posts: 114

Re: [kde-unstable] KDE 4.7

KWin does not use OpenGL 3 , because there's no mesa support for it.

@RazrFalcon
Try deleting kwinrc. What does it say if you type

kwin --replace

in konsole?

Last edited by sumski (2011-05-29 06:10:13)

Offline

#36 2011-05-29 08:36:14

RazrFalcon
Member
From: Ukraine
Registered: 2011-05-18
Posts: 37

Re: [kde-unstable] KDE 4.7

Sorry, but I already downgraded.

Offline

#37 2011-05-29 12:40:45

adee
Member
From: The Moon
Registered: 2009-11-10
Posts: 107

Re: [kde-unstable] KDE 4.7

I have a little performance problem on my 8600GT with the Nvidia 270.41.19 driver. When the popup menu shadows, tooltips are appering/disappearing the screen becomes a little jerky.I updated to the beta 275.09 which solves this problem, but adds a new one: in oxygen-gtk the shadows are now totally messed up (but oxygen-qt is fine):
bug1.png

Also I wanted to try it with nouveau, so I removed the nvidia driver, installed xf86-video-nouveau, nouveau-dri, libgl. But (after a reboot) the nouveau module won't load (not in -ARCH nor -ck kernel):
$ modprobe nouveau
FATAL: Error running install command for nouveau

The logs contains nothing....  weird.

EDIT:
Hmm, I just removed systemd, initscripts-systemd, systemd-arch-units and now the nouveau module is loading fine again... bizarre.

Last edited by adee (2011-05-29 18:37:20)

Offline

#38 2011-05-30 21:58:05

ov1d1u
Member
Registered: 2011-05-30
Posts: 5

Re: [kde-unstable] KDE 4.7

There's a problem with kdebindings-python, any Plasma widgets based on Python crashes on start. For example:

ovidiu@archlinux:~$ plasmawallpaperviewer -p clock
plasmawallpaperviewer(22148)/python (plugin): Failed to import module 
Traceback (most recent call last):
  File "/usr/share/apps/plasma_scriptengine_python/pywallpaper.py", line 21, in <module>
    from PyQt4.QtCore import *
ImportError: /usr/lib/python2.7/site-packages/PyQt4/QtCore.so: undefined symbol: PyBool_Type

Downgrading this package to version 4.6.3 solved the issue.

Offline

#39 2011-05-31 09:00:31

Zom
Member
From: Sweden
Registered: 2007-10-27
Posts: 406

Re: [kde-unstable] KDE 4.7

adee wrote:

I have a little performance problem on my 8600GT with the Nvidia 270.41.19 driver. When the popup menu shadows, tooltips are appering/disappearing the screen becomes a little jerky.I updated to the beta 275.09 which solves this problem, but adds a new one: in oxygen-gtk the shadows are now totally messed up (but oxygen-qt is fine):
http://adee.neobase.hu/sites/adee.neoba … s/bug1.png

Also I wanted to try it with nouveau, so I removed the nvidia driver, installed xf86-video-nouveau, nouveau-dri, libgl. But (after a reboot) the nouveau module won't load (not in -ARCH nor -ck kernel):
$ modprobe nouveau
FATAL: Error running install command for nouveau

The logs contains nothing....  weird.

EDIT:
Hmm, I just removed systemd, initscripts-systemd, systemd-arch-units and now the nouveau module is loading fine again... bizarre.

Did you check /etc/modprobe.d/? There's a file there to blacklist nouveau.

Also, systemd blacklists the modules listed as blacklisted in /etc/rc.conf. The file is /etc/modprobe.d/rc.conf, and it probably looked something like this:

install nouveau /bin/false

which would explain why you couldn't modprobe it earlier.

(technically OT, but I thought you'd might like to know)

Offline

#40 2011-06-01 13:07:14

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,305
Website

Re: [kde-unstable] KDE 4.7

Anybody else having issues with kscd?

It's starting but not playing anything...

I even checked kscd in kdebugdialog to see what's happening, and then ran kscd from konsole - i can see it's connecting to MusicBrainz to get tracklist, it's getting list succesfully, then window appear, and if i'll hit "Play" - nothing happens, and in konsole i can only see:

kscd(2852) KscdWindow::changePicture: "play" "over"

I did never started kscd from konsole with older kde and now i don't have time to downgrade, but i believe that there should be something more than just changePicture...

Offline

#41 2011-06-01 13:45:29

sumski
Member
From: Zagreb, Croatia
Registered: 2011-04-30
Posts: 114

Re: [kde-unstable] KDE 4.7

I can't start kscd:

kscd
socket(): Address family not supported by protocol
KCrash: Application 'kscd' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/test/.kde4/socket-shumarija/kdeinit4__0
unnamed app(5398): Communication problem with  "kscd" , it probably crashed. 
Error message was:  "org.freedesktop.DBus.Error.ServiceUnknown" : " "The name org.kde.kscd was not provided by any .service files" " 

test ~ $ QSocketNotifier: Invalid socket 11 and type 'Read', disabling...

Offline

#42 2011-06-02 06:11:30

Kirurgs
Member
Registered: 2008-10-20
Posts: 141

Re: [kde-unstable] KDE 4.7

Hi!

Is there a place where I can look at the PKGBUILD's for kde-unstable?
Thanks.

regards
Kiruurgs

Offline

#43 2011-06-02 08:50:03

sumski
Member
From: Zagreb, Croatia
Registered: 2011-04-30
Posts: 114

Re: [kde-unstable] KDE 4.7

abs

Offline

#44 2011-06-03 15:50:20

mangus
Member
From: Bologna, Italy
Registered: 2007-04-07
Posts: 289

Re: [kde-unstable] KDE 4.7

ok , now I'm really pissed off...akonadi and kmail2 is pure [insert whatuwant here]
the migration is painful, all folder messed up, can't have back my old important mails , mysqld 100% cpu all the time after kmail usage,
this bug , annoying as hell , opened 6 month ago ffs!
https://bugs.kde.org/show_bug.cgi?id=261788
surely I'm rude ,but I hoped things were in better shape , now that I'm *forced* to use it.
How am I supposed to work like that?
I'm not really confident things will improve in next betas..
Andrea please , is there a way to compile and have in repo the old version of kmail?
sorry for the rant

Last edited by mangus (2011-06-04 08:38:03)

Offline

#45 2011-06-03 19:12:04

bwat47
Member
Registered: 2009-10-07
Posts: 637

Re: [kde-unstable] KDE 4.7

I just upgraded. Is dolphin horrible slow for anyone else? Since I upgraded to the beta opening any dir with mp3's in it takes like 10 seconds.

I am also a little disappointed with the kwin improvements. I am using gl2 and don't really notice any difference. Animations are still rigid and laggy compared to compiz (corei5 460m, intel arrandale graphics)

EDIT: my dolphin issue taking forever to open folders in my music dir seems to only happen if I turn previews ON in that dir, very strange.

Last edited by bwat47 (2011-06-03 19:21:15)

Offline

#46 2011-06-05 22:55:08

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.7

mangus wrote:

Andrea please , is there a way to compile and have in repo the old version of kmail?

Uhm...I don't know if you can use the 4.4 branch from both kdepim and kdepim-runtime git repos with kdebase-workspace in [extra] which will be built with kdepim-runtime 4.6.

Your best option is to report/vote for the upstream bugs.

Offline

#47 2011-06-07 07:21:33

Wu
Member
Registered: 2009-12-27
Posts: 61

Re: [kde-unstable] KDE 4.7

does anybody know why beta2 hasn't been tagged yet?

Offline

#48 2011-06-07 07:24:52

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.7

Wu wrote:

does anybody know why beta2 hasn't been tagged yet?

For betas they usually tag and release them in the same day and release date of beta2 is tomorrow.

Offline

#49 2011-06-07 08:35:11

Wu
Member
Registered: 2009-12-27
Posts: 61

Re: [kde-unstable] KDE 4.7

thanks, the release schedule was misleading:
http://techbase.kde.org/Schedules/KDE4/ … e_Schedule

Offline

#50 2011-06-07 17:21:56

splashy
Member
Registered: 2010-08-21
Posts: 128

Re: [kde-unstable] KDE 4.7

@mangus: IN the terminal type: akonadi
This will start akonadi and you will see your mails, I add the same issue and it's work!
(if you try to launch akonadi graphicaly it will crash).

Offline

Board footer

Powered by FluxBB