You are not logged in.

#1 2011-06-16 20:40:30

Registered: 2011-06-16
Posts: 3

problems running Dropbox as a regular user [solved]

I've been wrestling with Dropbox for two days and I'm about to pull my hair out. I run Dropbox (with Arch) from my home directory (as per the website) on a desktop and a laptop. The setup for the users on both machines are (I thought) identical. Yesterday I ran pacman -Syu on my desktop. After rebooting to load the new kernel, Dropbox won't start any more; it pops up a box with a vague message about the permissions probably being messed up. I was curious (and wanting to live on the edge) so I went ahead and updated my laptop so that the two machines are running exactly the same versions of everything. More mysteriously, Dropbox will still run on my laptop.

Back on the problem machine, I tried running Dropbox as root. That works. I made sure that everything in my Dropbox/ folder, .dropbox, and .dropbox-dist are read writable for my user. That looks just fine. I deleted the .dropbox and the .dropbox-dist and re-installed fresh from the website: no joy. When it asks me if I have an existing account it makes no difference if I link to my existing account or create a new on: as soon as the application gets to the stage when it would start to sync it dies. It leaves a tmp file with this:

pid:    8301
ppid:    7097
uid:    1000
user_info:    ('sarah', 'x', 1000, 100, '', '/home/sarah', '/bin/bash')
effective_user_info:    ('sarah', 'x', 1000, 100, '', '/home/sarah', '/bin/bash')
euid:    1000
gid:    100
egid:    100
group_info:    ('users', 'x', 100, [])
effective_group_info:    ('users', 'x', 100, [])
appdata:    u'/home/sarah/.dropbox'
    mode=040700    uid=1000    gid=100
parent    mode=040775    uid=1000    gid=10
dropbox_path:    u'/home/sarah/Dropbox'
    not found
parent    mode=040775    uid=1000    gid=10
HOME:    /home/sarah
tempdir:    '/tmp'
    mode=041777    uid=0    gid=0
parent    mode=040755    uid=0    gid=0
Traceback (most recent call last):
  File "core/", line 564, in authentication_thread
  File "core/", line 60, in handle_register
  File "core/", line 567, in load_dropbox_filecache
  File "core/", line 870, in __init__
  File "core/", line 852, in _create_connhub
Exception: Not a valid FileCache file

That's from my attempt to install from AUR rather than just using it from my home directory.

What am I missing?

Last edited by cheeserby (2011-06-16 22:46:54)


#2 2011-06-16 22:46:32

Registered: 2011-06-16
Posts: 3

Re: problems running Dropbox as a regular user [solved]

Okay, I feel totally dumb now. The update filled up my /var and dropbox couldn't write the /var/tmp files.

Last edited by cheeserby (2011-06-16 22:50:52)


#3 2011-08-09 22:40:05

Mr. Pjer
From: Zagreb, Croatia
Registered: 2010-05-10
Posts: 18

Re: problems running Dropbox as a regular user [solved]

Thanks a lot!
Your post saved me a lot of frustration as I encountered the exact same problem!


Board footer

Powered by FluxBB