You are not logged in.

#1 2011-05-17 15:33:59

fernando_costa
Member
Registered: 2011-02-03
Posts: 31

Virtualbox: Failed to access USB subsystem

Details:

Result Code: 
NS_ERROR_FAILURE (0x00004005)
Component: 
Host
Interface: 
IHost {35b004f4-7806-4009-bfa8-d1308adba7e5}
Callee: 
IMachine {662c175e-a69d-40b8-a77a-1d719d0ab062}

More details:
   I'm running a Windows XP guest under Arch x86_64 (Why? because it was taking me too long to make MS Office to work with Crossover)
   virtualbox version 4.0.6-1 (installed accordingly to wiki https://wiki.archlinux.org/index.php/Virtualbox)
   also installed virtualbox-ext-oracle-4.0.8-1

The error doesn't give me too much to work, so, any helps are welcome.

Offline

#2 2011-05-17 16:17:57

voidux
Member
Registered: 2010-02-03
Posts: 31

Re: Virtualbox: Failed to access USB subsystem

You have to install Windows Guest Additions to be able to access USB:
https://wiki.archlinux.org/index.php/Vi … ows_guests

Offline

#3 2011-05-17 16:37:51

fernando_costa
Member
Registered: 2011-02-03
Posts: 31

Re: Virtualbox: Failed to access USB subsystem

Thanks. I don't get the error anymore. I just thought it was strange for that error to pop up with the VM turned off.

Offline

#4 2011-05-23 21:08:55

fowler
Member
Registered: 2009-01-26
Posts: 152

Re: Virtualbox: Failed to access USB subsystem

I still get this error with a similar setup.  Guest additions are installed but it shouldn't matter.  I get the try to configure the vm when it's off.

Offline

#5 2011-05-23 21:44:28

eDio
Member
From: Ukraine, Kyiv
Registered: 2008-12-02
Posts: 415

Re: Virtualbox: Failed to access USB subsystem

Make sure, your user is in vboxusers group. If it is not, you'll get this error.
(you can try run vbox as root, to check if it is a permissions problem)

Offline

#6 2011-05-24 13:11:59

fowler
Member
Registered: 2009-01-26
Posts: 152

Re: Virtualbox: Failed to access USB subsystem

I'm in the vboxusers group.  Virtual box has worked fine for me in the past.  I did a 'pacman -Qdt' and removed the following packages.  Could I have accidentally removed something that virtualbox needed?

[2011-05-23 14:17] Running 'pacman -Rns autoconf2.13 bigreqsproto cloog-ppl cmake docutils eggdbus gnome-common gnome-desktop-sharp gnome-pilot gnome-python-desktop gnuplot graphviz gtk-doc gtkimageview help2man intltool kdelibs3 libbeagle libgsf liboil libsexy libunique libxfontcache libxxf86misc live-media nickle perl-dbix-sqlite-simple perl-net-packet-target pycrypto pygtksourceview2 python-brasero python-evince python-gtksourceview python-mediaprofiles python-pysqlite pywebkitgtk raptor resourceproto rpmextract syslinux texi2html vbetool vcdimager vlc xcmiscproto xcursor-themes xf86driproto xorg-server-xvfb xorg-util-macros xorg-xkb-utils xtrans yasm'
[2011-05-23 14:17] removed yasm (1.1.0-1)
[2011-05-23 14:17] removed xtrans (1.2.6-1)
[2011-05-23 14:17] removed xorg-xkb-utils (7.6-1)
[2011-05-23 14:17] removed xorg-xkbutils (1.0.3-2)
[2011-05-23 14:17] removed xorg-xkbevd (1.1.2-2)
[2011-05-23 14:17] removed xorg-util-macros (1.13.0-1)
[2011-05-23 14:17] removed xorg-server-xvfb (1.10.1-1)
[2011-05-23 14:17] removed xf86driproto (2.1.1-1)
[2011-05-23 14:17] removed xcursor-themes (1.0.2-1)
[2011-05-23 14:17] removed xcmiscproto (1.2.1-1)
[2011-05-23 14:17] removed vlc (1.1.9-1)
[2011-05-23 14:17] removed zvbi (0.2.33-3)
[2011-05-23 14:17] Updating font cache... done.
[2011-05-23 14:17] removed ttf-freefont (20100919-1)
[2011-05-23 14:17] removed sdl_image (1.2.10-2)
[2011-05-23 14:17] removed libmpeg2 (0.5.1-1)
[2011-05-23 14:17] removed libmatroska (1.1.0-1)
[2011-05-23 14:17] removed libebml (1.2.0-1)
[2011-05-23 14:17] removed libdvbpsi (0.1.7-1)
[2011-05-23 14:17] removed fribidi (0.19.2-1)
[2011-05-23 14:17] removed fluidsynth (1.1.3-2)
[2011-05-23 14:17] removed vcdimager (0.7.23-7)
[2011-05-23 14:17] removed vbetool (1.1-1)
[2011-05-23 14:17] removed libx86 (1.1-2)
[2011-05-23 14:17] removed texi2html (5.0-1)
[2011-05-23 14:17] removed syslinux (4.04-1)
[2011-05-23 14:17] removed rpmextract (1.0-4)
[2011-05-23 14:17] removed resourceproto (1.1.1-1)
[2011-05-23 14:18] removed raptor (2.0.2-1)
[2011-05-23 14:18] removed pywebkitgtk (1.1.7-5)
[2011-05-23 14:18] removed libwebkit (1.4.0-1)
[2011-05-23 14:18] removed python-pysqlite (2.6.0-2)
[2011-05-23 14:18] removed python-mediaprofiles (2.32.0-4)
[2011-05-23 14:18] removed python-gtksourceview (2.32.0-4)
[2011-05-23 14:18] removed gtksourceview (1.8.5-3)
[2011-05-23 14:18] removed python-evince (2.32.0-4)
[2011-05-23 14:18] removed python-brasero (2.32.0-4)
[2011-05-23 14:18] removed pygtksourceview2 (2.10.1-3)
[2011-05-23 14:18] removed pycrypto (2.3-1)
[2011-05-23 14:18] removed perl-net-packet-target (1.01-1)
[2011-05-23 14:18] removed perl-net-packet (3.27-1)
[2011-05-23 14:18] removed perl-net-write (1.05-1)
[2011-05-23 14:18] removed perl-net-pcap (0.16-1)
[2011-05-23 14:18] removed perl-socket6 (0.23-2)
[2011-05-23 14:18] removed perl-net-libdnet (0.92-1)
[2011-05-23 14:18] removed perl-net-ipv6addr (0.2-5)
[2011-05-23 14:18] removed perl-net-ipv4addr (0.10-5)
[2011-05-23 14:18] removed perl-dbix-sqlite-simple (0.34-1)
[2011-05-23 14:18] removed perl-class-gomor (1.20.0-1)
[2011-05-23 14:18] removed perl-dbd-sqlite (1.31-1)
[2011-05-23 14:18] removed perl-dbi (1.616-1)
[2011-05-23 14:18] removed nickle (2.70-1)
[2011-05-23 14:18] removed live-media (2011.03.14-1)
[2011-05-23 14:18] removed libxxf86misc (1.0.2-1)
[2011-05-23 14:18] removed xf86miscproto (0.9.3-1)
[2011-05-23 14:18] removed libxfontcache (1.0.5-1)
[2011-05-23 14:18] removed fontcacheproto (0.1.3-1)
[2011-05-23 14:18] removed libunique (1.1.6-4)
[2011-05-23 14:18] removed libsexy (0.1.11-2)
[2011-05-23 14:18] removed liboil (0.3.17-1)
[2011-05-23 14:18] removed libgsf (1.14.21-1)
[2011-05-23 14:18] removed libbeagle (0.3.9-2)
[2011-05-23 14:18] removed kdelibs3 (3.5.10-11)
[2011-05-23 14:18] removed qt3 (3.3.8-20)
[2011-05-23 14:18] removed intltool (0.41.1-2)
[2011-05-23 14:18] removed help2man (1.39.2-1)
[2011-05-23 14:18] removed gtkimageview (1.6.4-1)
[2011-05-23 14:18] removed gtk-doc (1.17-1)
[2011-05-23 14:18] removed gnome-doc-utils (0.20.6-1)
[2011-05-23 14:18] removed graphviz (2.28.0-1)
[2011-05-23 14:18] removed gnuplot (4.4.3-1)
[2011-05-23 14:18] removed gnome-python-desktop (2.32.0-6)
[2011-05-23 14:18] removed python-totem-plparser (2.32.0-6)
[2011-05-23 14:18] removed python-rsvg (2.32.0-6)
[2011-05-23 14:18] removed python-metacity (2.32.0-6)
[2011-05-23 14:18] removed python-gtop (2.32.0-6)
[2011-05-23 14:18] removed python-gnomeprint (2.32.0-6)
[2011-05-23 14:18] removed libgnomeprintui (2.18.6-1)
[2011-05-23 14:18] removed libgnomeprint (2.18.8-2)
[2011-05-23 14:18] removed libgnomecups (0.2.3-8)
[2011-05-23 14:18] removed python-evolution (2.32.0-6)
[2011-05-23 14:18] removed python-bugbuddy (2.32.0-6)
[2011-05-23 14:18] removed gnome-python (2.28.1-7)
[2011-05-23 14:18] removed python2-libgnome (2.28.1-7)
[2011-05-23 14:18] removed gnome-pilot (2.91.92-1)
[2011-05-23 14:18] removed pilot-link (0.12.5-2)
[2011-05-23 14:18] removed gnome-desktop-sharp (2.26.0-6)
[2011-05-23 14:18] removed gtksourceview2 (2.10.5-1)
[2011-05-23 14:18] removed gtkhtml (3.32.2-2)
[2011-05-23 14:18] removed gnome-sharp (2.24.2-1)
[2011-05-23 14:18] removed gconf-sharp-peditors (2.24.2-1)
[2011-05-23 14:18] removed gconf-sharp (2.24.2-1)
[2011-05-23 14:18] removed libgnome-sharp (2.24.2-1)
[2011-05-23 14:18] removed gnome-vfs-sharp (2.24.2-1)
[2011-05-23 14:18] removed art-sharp (2.24.2-1)
[2011-05-23 14:18] removed gtk-sharp-2 (2.12.10-1)
[2011-05-23 14:18] removed mono (2.10.2-1)
[2011-05-23 14:18] removed libgdiplus (2.10-1)
[2011-05-23 14:18] removed gnome-common (2.34.0-1)
[2011-05-23 14:18] removed eggdbus (0.6-6)
[2011-05-23 14:18] removed docutils (0.7-5)
[2011-05-23 14:18] removed cmake (2.8.4-1)
[2011-05-23 14:18] removed cloog-ppl (0.15.10-2)
[2011-05-23 14:18] removed bigreqsproto (1.1.1-1)
[2011-05-23 14:18] removed autoconf2.13 (2.13-1)

And I upgraded virtualbox again with no errors. 

[2011-05-23 16:39] Running 'pacman -U /tmp/yaourt-tmp-rick/PKGDEST.ppr/virtualbox_bin-4.0.8-1-x86_64.pkg.tar.xz'
[2011-05-23 16:40] :: Unloading VirtualBox kernel modules    [BUSY]    [DONE] 
[2011-05-23 16:40] :: Stopping VirtualBox Web Service    [BUSY]    [DONE] 
[2011-05-23 16:40] :: Removing VirtualBox kernel modules    [BUSY]    [DONE] 
[2011-05-23 16:40] :: Removing VirtualBox kernel modules    [BUSY]    [DONE] 
[2011-05-23 16:40] :: Compiling VirtualBox kernel modules    [BUSY]    [DONE] 
[2011-05-23 16:40] 
[2011-05-23 16:40] ==> Remember to add allowed users to the vboxusers group:
[2011-05-23 16:40] ==> # gpasswd -a USERNAME vboxusers
[2011-05-23 16:40] ==>
[2011-05-23 16:40] ==> To load virtualbox modules automatically you can add vboxdrv in your DAEMONS
[2011-05-23 16:40] ==> To start virtualbox web service automatically you can add vboxweb in your DAEMONS
[2011-05-23 16:40] ==>
[2011-05-23 16:40] ==> To fix missing usb devices, you can call rc.d fixusb vboxdrv or reboot your computer
[2011-05-23 16:40] upgraded virtualbox_bin (4.0.8-1 -> 4.0.8-1)
[2011-05-23 16:45] Running 'pacman -U /tmp/yaourt-tmp-rick/PKGDEST.kpd/virtualbox-ext-oracle-4.0.8-1-any.pkg.tar.xz'
[2011-05-23 16:45] 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
[2011-05-23 16:45] 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
[2011-05-23 16:45] upgraded virtualbox-ext-oracle (4.0.8-1 -> 4.0.8-1)

Offline

#7 2011-05-26 13:06:46

fowler
Member
Registered: 2009-01-26
Posts: 152

Re: Virtualbox: Failed to access USB subsystem

bump

I totally removed virtualbox, and all the configs.  I reinstalled virtualbox_bin and virtualbox-ext-oracle and everything seems fine but I'm still getting the USB subsystem warning when I try to configure anything.  Everything else works as normal.  I don't have a /dev/vboxusb either.  The following is in my rc.conf: MODULES=(fuse vboxdrv vboxnetflt vboxnetadp...

What else could be the issue?  It works fine on another laptop with a similar configuration.

Offline

#8 2011-05-26 16:41:59

hermes
Member
From: Lucca, Italy
Registered: 2010-05-19
Posts: 99

Re: Virtualbox: Failed to access USB subsystem

Try installing virtualbox-sun from aur.


Linux Registered User #362737

Offline

#9 2011-05-26 21:23:23

fowler
Member
Registered: 2009-01-26
Posts: 152

Re: Virtualbox: Failed to access USB subsystem

what's the difference?

Offline

#10 2011-05-30 01:09:00

anthonyclark
Member
From: NY
Registered: 2007-10-07
Posts: 45
Website

Re: Virtualbox: Failed to access USB subsystem

Same issue here with Virtualbox downloaded from oracle, though I am not getting any errors, USB is simply not recognized. Tried all of the methods above (adding user to vboxusers,etc). I also installed the plugin for USB as directed. Hope there is a solution soon.

Last edited by anthonyclark (2011-05-30 01:13:10)


w00tz

Offline

#11 2011-05-30 03:25:03

fowler
Member
Registered: 2009-01-26
Posts: 152

Re: Virtualbox: Failed to access USB subsystem

adding the following to /etc/fstab forced it to work for me... although I shouldn't have to...

none /proc/bus/usb usbfs auto,busgid=108,busmode=0775,devgid=108,devmode=0664 0 0

Last edited by fowler (2011-05-30 03:25:25)

Offline

#12 2011-06-19 21:14:07

adalgiso
Member
Registered: 2011-06-19
Posts: 1

Re: Virtualbox: Failed to access USB subsystem

I think the issue is that Virtualbox OSE does not support the USB subsystem at all, but gives no helpful error message when you try to use it.  Supposedly the Virtualbox PUEL version, the version from Sun, supports USB devices.  This is the case for the Windows versions, so I'm assuming it's the same here.

The package is virtualbox-bin from the AUR, and make sure you run it as

$ VirtualBox

virtualbox-sun conflicts with virtualbox so make sure you uninstall virtualbox first or else pacman will run into filename conflicts.

Ensure you are in the vboxusers group by doing

usermod -G vboxusers <username>

And if USB doesn't work out of the box, add this to fstab:

none /proc/bus/usb usbfs auto,busgid=108,busmode=0775,devgid=<gid of group usb>,devmode=0664 0 0

All of this is from the post-install notes for virtualbox-sun.

Note, you might also need the Sun virtualbox extension pack, which is in the AUR: virtualbox-ext-oracle

EDIT: Apparently this has been solved in this thread.

Last edited by adalgiso (2011-06-19 21:32:01)

Offline

#13 2011-09-01 06:13:20

made_in_nz
Member
From: Wellington, New Zealand
Registered: 2010-01-04
Posts: 53

Re: Virtualbox: Failed to access USB subsystem

adalgiso wrote:
usermod -G vboxusers <username>

The command above will also remove the user from any groups they belong to other than vboxusers.  Instead use:

usermod -aG vboxusers <username>

Offline

#14 2011-12-15 05:23:56

Heo Rung
Member
From: Viet Nam
Registered: 2011-08-08
Posts: 18
Website

Re: Virtualbox: Failed to access USB subsystem

I'm having the same error...
tried everything mentioned, and I'm able to get USB working if I run virtualbox as root...
but still nothing as user... and yes i am a member of vboxusers
any idea what else could cause this... I assume it's permissions

Offline

Board footer

Powered by FluxBB