You are not logged in.

#1 2003-11-15 22:12:43

ipqw
Member
From: Denmark
Registered: 2003-11-02
Posts: 24
Website

Request for Grip

Does any of you have tried to compile Grip for Arch?

I've got it to compile, by the following PKGBUILD, but it fails when executing. See error msg below...  Any ideas?

pkgname=grip
pkgver=3.1.2
pkgrel=1
pkgdesc="Program for ripping audio cd to mp3 or ogg files"
url="http://www.nostatic.org/grip"
#HUSK LAME
depends=('atk' 'audiofile' 'cdparanoia' 'esd' 'expat' 'fontconfig' 'freetype2' 'gcc' 'gconf' 'glib2' 'glibc' 'gnome-vfs' 'gtk2' 'libart-lgpl' 'libbonobo' 'libbonoboui' 'libghttp' 'libgnome' 'libgnomecanvas' 'libgnomeui' 'libjpeg' 'libxml2' 'linc' 'ncurses' 'openssl' 'orbit2' 'pango' 'popt' 'vte' 'xfree86' 'zlib')
source=(http://belnet.dl.sourceforge.net/sourceforge/grip/grip-3.1.2.tar.gz)
md5sums=('ab41f4eb6624397c2bb4fe17a68c1e33')

build() {
        cd $startdir/src/$pkgname-$pkgver
        ./configure
        make || return 1
        make prefix=$startdir/pkg/usr install || return 1
}


[error]
ks@helene:~/build/grip/pkg/usr/bin
$ ./grip

(process:5922): GLib-GObject-WARNING **: [Invalid UTF-8] gobject.c:782: object class `GnomeProgram' has no property named `t'
Error: Unable to initialize [/dev/cdrom1]
[/error]

Offline

#2 2003-11-15 23:11:33

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: Request for Grip

Hi,


once I posted a grip to incoming. The revise PKGBUILD I use is that:

# Contributor: Tobias Kieslich <tobias@justdreams.de>
[ "$GNOMEDIR" = "" ] && source /etc/profile.d/gnome.sh

pkgname=grip
pkgver=3.1.2
pkgrel=1
pkgdesc="grip is a cd ripper frontend for the GNOME desktop"
depends=('glib' 'gtk' 'orbit2' 'libglade' 'libghttp' 'pango'
         'libgnomeui' 'libgnomeprint' 'libgnomeprintui' 'libgnome'
         'gnome-vfs' 'libbonobo' 'libbonoboui' 'id3lib')
source=(http://nostatic.org/grip/$pkgname-$pkgver.tar.gz)

build() {
    # PATH=/opt/gnome/bin:$PATH; export PATH
    cd $startdir/src/$pkgname-$pkgver
    ./configure --prefix=/opt/gnome
    #./configure --help
    make || return 1
    make DESTDIR=$startdir/pkg install
}

Your problem refers to a the default settings in grip. try grip --help. Among others, an option for setting the device (/dev/cdroms/cdrom0 should it be,
I think) will be displayed. check tis post:
http://bbs.archlinux.org/viewtopic.php? … light=grip

The other problem with it, that you can rip only one cd then close it and
reopen it before you can rip another one is in grip it self. It might be fixed in
the latest version. Check it out.

bye neri

Offline

#3 2003-11-15 23:19:11

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: Request for Grip

Hi,

I just saw that 3.1.3 is out. After a longer break development seems to
become faster.

bye neri

Offline

#4 2003-11-16 11:17:46

ipqw
Member
From: Denmark
Registered: 2003-11-02
Posts: 24
Website

Re: Request for Grip

Okay .. it was just the --device I missed. Anyway I have uploaded the new version to incoming now. See the New Packages forum for PKGBUILD.

Offline

Board footer

Powered by FluxBB