You are not logged in.

#1 2011-07-09 14:27:09

Master One
Member
From: Austria
Registered: 2007-01-21
Posts: 242

Gnome3: "Disable touchpad while typing" delay

I've always used that option in Ubuntu before, but it is totally unusable in Gnome3 on my Arch test-setup, because the delay after typing before the touchpad is activated again is way to long. So when I type something and then try to move the mouse pointer or click on something, it stays frozen for about 3 seconds after typing, whereas it should be available instantly after typing without any noticeable delay.

Is there any way to configure that behavior?

Offline

#2 2011-07-09 15:09:41

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: Gnome3: "Disable touchpad while typing" delay

is not possible. the time is hardcoded in gnome-settings-daemon on 2.0 seconds.

maybe you should report this upstream as feature request.

plugins/mouse/gsd-mouse-manager.c

 534                 args[0] = "syndaemon";
 535                 args[1] = "-i";
 536                 args[2] = "2.0";
 537                 args[3] = "-K";
 538                 args[4] = "-R";
 539                 args[5] = NULL;

Give what you have. To someone, it may be better than you dare to think.

Offline

#3 2011-07-09 16:24:57

Durden
Member
Registered: 2011-06-19
Posts: 243

Re: Gnome3: "Disable touchpad while typing" delay

Yep. This is one of the main reasons I switched to KDE on my netbook using synaptiks. Gnome3 has been a disaster for me on portables. I'm sure it will get changed at some point but for now it's totally unusable.

Offline

#4 2011-07-09 16:54:29

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: Gnome3: "Disable touchpad while typing" delay

Durden wrote:

Yep. This is one of the main reasons I switched to KDE on my netbook using synaptiks. Gnome3 has been a disaster for me on portables. I'm sure it will get changed at some point but for now it's totally unusable.

i'm sure that if nobody reports it, nobody will change that. instead of switching and avoiding the problem you have the power to report, provide and incorporate changes.


Give what you have. To someone, it may be better than you dare to think.

Offline

#5 2011-07-09 17:30:33

Master One
Member
From: Austria
Registered: 2007-01-21
Posts: 242

Re: Gnome3: "Disable touchpad while typing" delay

Damned, in Gnome2 on Ubuntu everything works as expected, means the touchpad is instantly enabled again after typing. What were they thinking of setting a delay of 2 seconds (which really feel like 3 seconds here, I mean, I can slowly count to three till the touchpad freeze ends)? This can't be a feature, but a bug, means a bug report would be more appropriate than a feature request. Maybe someone reading this want to file a bugreport upstream, because I neither have the time, nor do I intend to stick with Gnome (just testing this on my good old ThinkPad, but I am not convinced at all).

Offline

#6 2011-07-09 18:52:33

Durden
Member
Registered: 2011-06-19
Posts: 243

Re: Gnome3: "Disable touchpad while typing" delay

wonder wrote:
Durden wrote:

Yep. This is one of the main reasons I switched to KDE on my netbook using synaptiks. Gnome3 has been a disaster for me on portables. I'm sure it will get changed at some point but for now it's totally unusable.

i'm sure that if nobody reports it, nobody will change that. instead of switching and avoiding the problem you have the power to report, provide and incorporate changes.

But it isn't usable. What good is forcing myself to use it while it's broken? I did make a report as many have but the gnome developers aren't known for their nurturing community. I'd rather have a usable desktop than a broken one. I don't see what the problem with that is.

Offline

#7 2011-08-10 20:54:21

Dumbledore
Member
From: Mumbai, India
Registered: 2011-04-27
Posts: 56

Re: Gnome3: "Disable touchpad while typing" delay

Apologize for posting to an old thread. But I found a solution which seems to work. At least on my machine. I thought it may be helpful. I've never worked with the Arch wiki, so I was hoping someone can tell me how to add this to the wiki.

You can use syndaemon to add this functionality. First uncheck the option from the gnome-settings interface. Now read "man syndaemon" and change accordingly. The particular fix that I've been using is this:

syndaemon -d -k -i 0.2s

Hope this helps someone. I've added this as a script to gnome-session-properties, but I guess there must be a better way to do this (put this $HOME/.profile perhaps?).
I found this here, which may be more helpful: http://en.gentoo-wiki.com/wiki/Synaptics_Touchpad

Last edited by Dumbledore (2011-08-10 20:54:52)


GNU/Linux: Keep your options "open".

Offline

Board footer

Powered by FluxBB