You are not logged in.

#1 2011-07-12 07:21:27

subatomic
Member
From: Berlin
Registered: 2005-06-26
Posts: 180

mkinitcpio > err: command not found [solved]

I rebuilt fbsplash yesterday and get this error when running 'mkinitcpio -p kernel26'

  -> Parsing hook: [fbsplash]
/lib/initcpio/install/fbsplash: line 90: err: command not found

Line 90 reads

err "Theme invalid or not found: '$theme'"

The maintainer of fbsplash reported that 'err' is a function in /lib/initcpio/init_functions which is part of the package mkinitcpio.
However looking through the other scripts in /lib/initcpio/install/ this is the only one which uses this command and thus the only one producing the error.
Is it not valid?

Last edited by subatomic (2011-07-13 08:51:42)

Offline

#2 2011-07-12 08:56:16

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: mkinitcpio > err: command not found [solved]

Moved from Kernel & Hardware to Pacman & Package Updates.


ᶘ ᵒᴥᵒᶅ

Offline

#3 2011-07-12 11:09:08

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,740

Re: mkinitcpio > err: command not found [solved]

Maybe he haven't updated it for the latest release of mkinitcpio? There have been quite a lot of changes to it recently. Check if you have the latest mkinitcpio, and if you do, see what helper funcs you have for it. (I would do it myself, but sadly are stuck on a silly locked down windows setup atm)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#4 2011-07-12 11:12:29

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: mkinitcpio > err: command not found [solved]

pacman -Qo /lib/initcpio/install/fbsplash

now you see from where the bug comes.


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#5 2011-07-12 13:13:00

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,097
Website

Re: mkinitcpio > err: command not found [solved]

Mr.Elendig wrote:

Maybe he haven't updated it for the latest release of mkinitcpio

This. The 'err' function no longer exists.

http://projects.archlinux.org/mkinitcpi … 88108eb385

Offline

#6 2011-07-12 16:57:02

cyberpatrol
Member
From: Germany
Registered: 2006-11-22
Posts: 68

Re: mkinitcpio > err: command not found [solved]

falconindy wrote:
Mr.Elendig wrote:

Maybe he haven't updated it for the latest release of mkinitcpio

This. The 'err' function no longer exists.

http://projects.archlinux.org/mkinitcpi … 88108eb385

Yes, I have updated to the latest release of mkinitcpio in [core]. It's 0.7.2-1. And the function 'err' is still in /lib/initcpio/init_functions which is part of mkinitcpio 0.7.2-1 and used by the file /lib/initcpio/init, the hook 'net' which is also included in mkinitcpio 0.7.2-1 and by the hook 'encrypt' which is part of cryptsetup 1.3.1-2.

Just run:

grep -Rw err /lib/initcpio

And I didn't get the 'command not found' error. Nevertheless I have replaced the 'err' calls by 'error' calls in the fbsplash hook.

Btw., is there a documentation about the mkinitcpio API?

Offline

#7 2011-07-12 18:33:13

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,097
Website

Re: mkinitcpio > err: command not found [solved]

I made an effort to document the API for the install hooks as well as I could in /lib/initcpio/functions. The runtime hook API is yet to be documented, but I can add that to my list.

Offline

#8 2011-07-13 08:51:07

subatomic
Member
From: Berlin
Registered: 2005-06-26
Posts: 180

Re: mkinitcpio > err: command not found [solved]

Looks like this got sorted out quickly. Thanks everyone and @cyberpatrol for the quick fix!

Offline

Board footer

Powered by FluxBB