You are not logged in.

#1 2011-07-17 05:04:45

vikramr
Member
Registered: 2009-09-22
Posts: 27

kmail slow to initialize after upgrading to 2.1.1

I use kmail as an gmail imap client. After I recently upgraded to kmail 2.1.1 the applicaiton is very slow to initialize. The GUI comes up but no messages for several seconds. this is much worse than kmail 1.x

I have already unchecked [Gmail] and clicked on identies to resolve the issues surrounding multiple notifications and can now send and receive mails.

Is there a setting or configuration I am missing that can speed this up or is it inevitable with the move to akonadi or nepomuk etc.

thanks for reading

Offline

#2 2011-07-17 16:55:51

karper
Member
Registered: 2008-08-10
Posts: 49

Re: kmail slow to initialize after upgrading to 2.1.1

kmail is slower now than before (I imagine they didn't spend much time optimizing akonadi yet), but I don't think it's "several seconds" slower. I use it on my netbook (slowest machine I have) and loading my 14K strong All Mails folder with grouping and threading enabled takes a couple of seconds. I imagine if I disable threads it'll be even quicker.

Kmail prepares the message list in two steps — first, it fetches the mails, then, it threads them into conversations. The first step, you can't do much about, but you can try disabling threads if it's taking too long for it to be usable. This might especially be true if you have a crazy huge number of emails in your folder(s). To disable threading, go into Settings > Configure KMail > Appearance > Message List and choose a non-threaded version for aggregation.

See if that helps...

Offline

#3 2011-07-17 21:31:13

vikramr
Member
Registered: 2009-09-22
Posts: 27

Re: kmail slow to initialize after upgrading to 2.1.1

I timed it and it took 3 mins and 6 seconds for the messages to appear after the list of folders appears on the left. I am using the default flat non threaded view. i have msqld running at 25-30% of the cpu running the whole time if it helps.

thanks

Offline

#4 2011-07-18 02:03:06

karper
Member
Registered: 2008-08-10
Posts: 49

Re: kmail slow to initialize after upgrading to 2.1.1

Hmm, that doesn't sound right at all. Here I was complaining about a couple of seconds of wait time...

mysqld using resources sounds like the mail folder sync hasn't yet completed. Is that the case?

Another thought, perhaps this is because akonadi's talking to nepomuk and indexing your emails instead of displaying them. Do you see the following two processes also run at high CPU:

  • virtuoso-t (the backend server where nepomuk stores all its data)

  • akonadi_nepomuk_email_feeder (the process that akonadi uses to feed your emails into nepomuk)

If this is the case, when this happens, shut down the nepomuk server. There are two ways of doing it. The GUI way is to go to the desktop search kcm in system settings and disable the nepomuk server (not just the strigi indexer, mind you). The CLI way is to use dbus to talk to nepomuk like this:

qdbus org.kde.NepomukServer /nepomukserver quit

You can later start nepomukserver at your convenience from the CLI by just typing

nepomukserver &

I had a pretty rough transition over to the new kmail and ended up just deleting all configurations and starting fresh... It wasn't pretty, but at least everything works now. If all else fails, maybe you'd need to do the same. I'm (rather slowly) putting together a simple start guide for setting up a gmail account with akonadi that I intend to put up on userbase when done...

Offline

#5 2011-07-18 04:13:32

vikramr
Member
Registered: 2009-09-22
Posts: 27

Re: kmail slow to initialize after upgrading to 2.1.1

I didnt find the process virtuoso-t among running processes. I also got a  notification

Nepomuk Indexing Agents Have Been Disabled
The Nepomuk service is not available or fully operational and attempts to rectify this have failed. Theref…

The following problems were detected:
Calling the Nepomuk storage service failed: 'The name org.kde.NepomukStorage was not provide…
Additional help can be found here: userbase.kde.org/Akonadi

so I tried the commands you mentioned to restart Nepomuk.

[vikram ~]$ nepomukserver &
[1] 18749
[vikram ~]$ [/usr/bin/nepomukservicestub] Using Virtuoso Version: "6.1.3.3127-pthreads" 
Using Virtuoso Version: "6.1.3.3127-pthreads" 
void Soprano::VirtuosoController::writeConfigFile(const QString&, const BackendSettings&) "/tmp/virtuoso_k18752.ini" 
Starting Virtuoso server: "/usr/bin/virtuoso-t" ("+foreground", "+configfile", "/tmp/virtuoso_k18752.ini", "+wait")
[/usr/bin/nepomukservicestub] "
" 
"               Sun Jul 17 2011
"
[/usr/bin/nepomukservicestub] "21:07:41 OpenLink Virtuoso Universal Server
" 
"21:07:41 Version 06.01.3127-pthreads for Linux as of Apr 12 2011
" 
"21:07:41 uses parts of OpenSSL, PCRE, Html Tidy
"
[/usr/bin/nepomukservicestub] "21:08:04 Database version 3126
"
[/usr/bin/nepomukservicestub] "21:08:05 Entering Lite Mode
"
[/usr/bin/nepomukservicestub] "21:08:05 SQL Optimizer enabled (max 1000 layouts)
"
[/usr/bin/nepomukservicestub] "21:08:09 Compiler unit is timed at 0.001573 msec
"
[/usr/bin/nepomukservicestub] "21:08:14 Roll forward started
"
[/usr/bin/nepomukservicestub] "21:08:14 The transaction log file has been produced by server version '06.01.3126'. The version of this server is '06.01.3127'. If the transaction log is empty or you do not want to replay it then delete it and start the server again. Otherwise replay the log using the server of version '06.01.3126' and make checkpoint and shutdown to ensure that the log is empty, then delete it and start using new version.
"
[/usr/bin/nepomukservicestub] "21:08:14 Server exiting
"
[/usr/bin/nepomukservicestub] Virtuoso server stopped: 3
[/usr/bin/nepomukservicestub] "/usr/bin/nepomukservicestub(18752)" Soprano: "Failed to start Virtuoso"
[/usr/bin/nepomukservicestub] "/usr/bin/nepomukservicestub(18752)" Soprano: "Failed to start Virtuoso"
Application '/usr/bin/nepomukservicestub nepomukstorage' exited normally...

[1]+  Done                    nepomukserver

Not sure where the transaction log file is stored and if I will loose data if I delete it.

Offline

#6 2011-07-18 06:22:59

karper
Member
Registered: 2008-08-10
Posts: 49

Re: kmail slow to initialize after upgrading to 2.1.1

This just gets more and more interesting, huh.

I had a corrupted nepomuk database once and the only way to fix it (that I knew) was to delete the stored data and force nepomuk to start fresh. This does mean you lose all your ratings, comments and tags, but if that's not particularly meaningful to you (everything else can be rescanned), you'll find the nepomuk data storage in .kde4/share/apps/nepomuk. First, stop the nepomuk server. Wait for it to complete its tasks and exit cleanly. Then, rm -r the nepomuk directory. Now, when you restart nepomukserver, it will start with an empty semantic database and start repopulating it by scanning your files etc.

Since nepomukserver seems to flood your terminal with debug messages, it's probably better if you start it like I do: type nepomukserver into krunner and launch it that way. You should now see a virtuoso-t process show up in your running processes. It's extremely well behaved and runs with a niceness of 19 — meaning it will usually wait for all other processes to be idle before hogging resources.

This should take care of all problems with nepomuk. Hopefully, that might also clear up your akonadi issues as well?

Offline

#7 2011-07-19 04:18:55

vikramr
Member
Registered: 2009-09-22
Posts: 27

Re: kmail slow to initialize after upgrading to 2.1.1

thanks Karper. appreciate your help.

I deleted all my Nepomuk data and now Kmail opens in about 45 seconds or so. which is a painfully slow but the deal breaker is that akonadi_nepomuk process now takes upto 900MB of RAM ! I post this not for further help but an FYI for any one else looking for answers. I'll be working with the web client for GMAIL its not worth it IMHO. As a long time KDE user it makes me sad to see the amount of bloat. perhaps its time to look for a lightweight window manger and email client.

Offline

#8 2011-07-19 15:07:07

karper
Member
Registered: 2008-08-10
Posts: 49

Re: kmail slow to initialize after upgrading to 2.1.1

Hmm, in a way that's better news, but the startup time is still surprisingly long.

Your decision to use the webclient is totally understandable. I'd planned for that as my backup in case I just couldn't get kmail to work. I played with thunderbird, but the gmail webclient is just miles ahead of anything on the desktop.

The feeder process taking the ridiculous amounts of RAM (basically it seems to take all the RAM it can get on the system) is paradoxically good news. The actual resource usage is definitely the result of some bad design upstream, but it indicates that nepomuk is working fine and akonadi is trying to get it to index all your emails. This period is a royal pain to get through, but it's a one-time only deal. Once it finishes indexing all your emails, it will not do this anymore.

Technically, I think it's a good idea to centralize all pim storage, but the technology clearly has rough edges. Upstream is still playing the it's-a-development-release tune and I feel like I can't blame them too much. Progress on the kdepim suite has been almost painfully slow and there's some hope that a release will attract more hands to fix, polish and optimize the subsystem. For now, I'm guessing the next year will basically go into fixing bugs in kdepim.

Offline

Board footer

Powered by FluxBB