You are not logged in.

#1 2011-07-18 17:25:02

Tsynique
Member
Registered: 2010-05-19
Posts: 37

[SOLVED] Symbol lookup error after update

Hello,

I have recently updated a 32-bit Arch system and right after update certain apps stopped working:

kate: symbol lookup error: /usr/lib/libnepomukutils.so.4: undefined symbol: _ZNK19QAbstractProxyModel8itemDataERK11QModelIndex
dolphin: symbol lookup error: /usr/lib/libQtSvg.so.4: undefined symbol: _ZN15QGraphicsObject16staticMetaObjectE
kmix: symbol lookup error: /usr/lib/libnepomukutils.so.4: undefined symbol: _ZNK19QAbstractProxyModel8itemDataERK11QModelIndex

What can I do to solve these errors?

Thanks!

Last edited by Tsynique (2011-07-26 09:31:36)

Offline

#2 2011-07-18 17:54:57

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [SOLVED] Symbol lookup error after update

can you paste the output of pacman -Q kdelibs kdebase-dolphin?

Offline

#3 2011-07-18 18:12:52

Tsynique
Member
Registered: 2010-05-19
Posts: 37

Re: [SOLVED] Symbol lookup error after update

$ pacman -Q kdelibs kdebase-dolphin
kdelibs 4.6.5-2
kdebase-dolphin 4.6.5-1

Offline

#4 2011-07-18 18:21:09

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [SOLVED] Symbol lookup error after update

nm -D /usr/lib/libnepomukutils.so.4 | grep _ZNK19QAbstractProxyModel8itemDataERK11QModelIndex
                 U _ZNK19QAbstractProxyModel8itemDataERK11QModelIndex

the symbol is there, backup your .kde4, .config, .local, and try with a clean configuration.
or login with a new user.

Offline

#5 2011-07-18 18:26:53

Tsynique
Member
Registered: 2010-05-19
Posts: 37

Re: [SOLVED] Symbol lookup error after update

Nothing changed (except for some configs defaulting) :\

Offline

#6 2011-07-18 18:40:14

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [SOLVED] Symbol lookup error after update

Can you paste the ouput of pacman -Qm? Did you try with a new user?

Offline

#7 2011-07-18 18:46:46

Tsynique
Member
Registered: 2010-05-19
Posts: 37

Re: [SOLVED] Symbol lookup error after update

$ pacman -Qm
axkb 0.4.2-3
cloog-ppl 0.15.10-2
firefox-nightly-tm 6.0a1-1
gen-init-cpio 2.6.36-1
libjpeg6 6b-9
libtowitoko2 2.0.7-2
ndiswrapper 1.56-9
ndiswrapper-utils 1.56-2
openct 0.6.20-1
opensc 0.12.1-1
perl-xyne-arch 2011.02.06.1-2
perl-xyne-common 2011.02.03.3-2
phonon-xine 4.4.4-1
pkiclient 5.00.28-1
powerpill 2010.08.26.1-1
skype-kit 0.1-2
strigi-git 20110718-1
xmms-wma 1.0.5-5
xorg-res-utils 1.0.3-3

Created a new blank user and still the same.

Offline

#8 2011-07-18 18:50:58

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [SOLVED] Symbol lookup error after update

could be related to strigi-git, try with strigi from [extra], also remove phonon-xine and switch to phonon-(gstreamer or vlc)

Offline

#9 2011-07-18 19:31:44

Tsynique
Member
Registered: 2010-05-19
Posts: 37

Re: [SOLVED] Symbol lookup error after update

$ pacman -Qm
axkb 0.4.2-3
cloog-ppl 0.15.10-2
firefox-nightly-tm 6.0a1-1
gen-init-cpio 2.6.36-1
libjpeg6 6b-9
libtowitoko2 2.0.7-2
ndiswrapper 1.56-9
ndiswrapper-utils 1.56-2
openct 0.6.20-1
opensc 0.12.1-1
perl-xyne-arch 2011.02.06.1-2
perl-xyne-common 2011.02.03.3-2
pkiclient 5.00.28-1
powerpill 2010.08.26.1-1
skype-kit 0.1-2
xmms-wma 1.0.5-5
xorg-res-utils 1.0.3-3

Didn't help sad

Offline

#10 2011-07-19 05:04:15

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: [SOLVED] Symbol lookup error after update

I see you have powerpill installed. How did you update the system? By using powerpill and building from source, or just pacman -Syu?

Offline

#11 2011-07-19 05:19:54

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,406
Website

Re: [SOLVED] Symbol lookup error after update

You are not fully up to date...   I can tell as you have cloog-ppl 0.15.10-2 installed.

Offline

#12 2011-07-19 06:43:41

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [SOLVED] Symbol lookup error after update

Can you paste somewhere the output of tail -n 100 /var/log/pacman.log?

Offline

#13 2011-07-19 08:12:29

Tsynique
Member
Registered: 2010-05-19
Posts: 37

Re: [SOLVED] Symbol lookup error after update

@Allan I don't know when and why I installed cloog-ppl, probably was a dependancy of some other package. I just removed it, it seemed to be an orphan anyway.

@JGC I just did pacman -Syu.

@bash I am pasting a snip of pacman.log. From what I can recall, something happened before the day 2011-07-16 because that day I turned off the computer and had it on only on Sunday when I noticed that things are not working.

[2011-07-15 11:09] Running 'pacman -Syu'
[2011-07-15 11:09] synchronizing package lists
[2011-07-15 11:09] starting full system upgrade
[2011-07-15 11:10] upgraded chromium (12.0.742.112-1 -> 12.0.742.124-1)
[2011-07-15 13:32] Running 'pacman -Syu'
[2011-07-15 13:32] synchronizing package lists
[2011-07-15 13:33] starting full system upgrade
[2011-07-15 15:04] Running 'pacman -Syu'
[2011-07-15 15:04] synchronizing package lists
[2011-07-15 15:04] starting full system upgrade
[2011-07-15 15:05] upgraded python (3.2-2 -> 3.2.1-1)
[2011-07-15 15:27] Running 'pacman -S kdebase-dolphin samba kdenetwork-filesharing kdebase-runtime'
[2011-07-15 15:28] Running 'pacman -S --needed kdebase-dolphin samba kdenetwork-filesharing kdebase-runtime'
[2011-07-15 15:28] installed samba (3.5.9-2)
[2011-07-15 15:42] Running 'pacman -S smbnetfs'
[2011-07-15 15:42] -- To use rc-script you should:
[2011-07-15 15:42] --   * set user_allow_other option in /etc/fuse.conf
[2011-07-15 15:42] installed smbnetfs (0.5.3a-3)
[2011-07-15 15:53] Running 'pacman -S proftp'
[2011-07-15 15:53] Running 'pacman -S proftpd'
[2011-07-15 15:54] installed proftpd (1.3.3e-2)
[2011-07-15 17:16] Running 'pacman -Syu'
[2011-07-15 17:16] synchronizing package lists
[2011-07-15 17:16] starting full system upgrade
[2011-07-15 19:49] Running 'pacman -Syu'
[2011-07-15 19:49] synchronizing package lists
[2011-07-15 19:50] starting full system upgrade
[2011-07-15 19:50] >>> Updating module dependencies. Please wait ...
[2011-07-15 19:50] >>> MKINITCPIO SETUP
[2011-07-15 19:50] >>> ----------------
[2011-07-15 19:50] >>> If you use LVM2, Encrypted root or software RAID,
[2011-07-15 19:50] >>> Ensure you enable support in /etc/mkinitcpio.conf .
[2011-07-15 19:50] >>> More information about mkinitcpio setup can be found here:
[2011-07-15 19:50] >>> http://wiki.archlinux.org/index.php/Mkinitcpio
[2011-07-15 19:50] 
[2011-07-15 19:50] >>> Generating initial ramdisk, using mkinitcpio.  Please wait...
[2011-07-15 19:50] ==> Building image from preset: 'default'
[2011-07-15 19:50]   -> -k 2.6.32-lts -c /etc/mkinitcpio.conf -g /boot/kernel26-lts.img
[2011-07-15 19:50] ==> Starting build: 2.6.32-lts
[2011-07-15 19:50]   -> Parsing hook: [base]
[2011-07-15 19:50]   -> Parsing hook: [udev]
[2011-07-15 19:50]   -> Parsing hook: [autodetect]
[2011-07-15 19:50]   -> Parsing hook: [pata]
[2011-07-15 19:50]   -> Parsing hook: [scsi]
[2011-07-15 19:50]   -> Parsing hook: [sata]
[2011-07-15 19:50]   -> Parsing hook: [filesystems]
[2011-07-15 19:50]   -> Parsing hook: [usbinput]
[2011-07-15 19:50] ==> Generating module dependencies
[2011-07-15 19:50] ==> Creating gzip initcpio image: /boot/kernel26-lts.img
[2011-07-15 19:50] 6500 blocks
[2011-07-15 19:50] ==> Image generation successful
[2011-07-15 19:51] ==> Building image from preset: 'fallback'
[2011-07-15 19:51]   -> -k 2.6.32-lts -c /etc/mkinitcpio.conf -g /boot/kernel26-lts-fallback.img -S autodetect
[2011-07-15 19:51] ==> Starting build: 2.6.32-lts
[2011-07-15 19:51]   -> Parsing hook: [base]
[2011-07-15 19:51]   -> Parsing hook: [udev]
[2011-07-15 19:51]   -> Parsing hook: [pata]
[2011-07-15 19:51]   -> Parsing hook: [scsi]
[2011-07-15 19:51]   -> Parsing hook: [sata]
[2011-07-15 19:51]   -> Parsing hook: [filesystems]
[2011-07-15 19:51]   -> Parsing hook: [usbinput]
[2011-07-15 19:51] ==> Generating module dependencies
[2011-07-15 19:51] ==> Creating gzip initcpio image: /boot/kernel26-lts-fallback.img
[2011-07-15 19:51] 20451 blocks
[2011-07-15 19:51] ==> Image generation successful
[2011-07-15 19:51] upgraded kernel26-lts (2.6.32.42-1 -> 2.6.32.43-1)
[2011-07-15 19:51] upgraded kernel26-lts-headers (2.6.32.42-1 -> 2.6.32.43-1)
[2011-07-15 22:22] Running 'pacman -S ccid'
[2011-07-15 22:22] installed pcsclite (1.7.4-1)
[2011-07-15 22:22] installed ccid (1.4.4-1)
[2011-07-15 22:35] Running 'pacman -S pcsc-tools'
[2011-07-15 22:35] installed pcsc-perl (1.4.12-2)
[2011-07-15 22:35] installed glib-perl (1.223-3)
[2011-07-15 22:35] installed cairo-perl (1.061-4)
[2011-07-15 22:35] installed pango-perl (1.221-4)
[2011-07-15 22:35] installed gtk2-perl (1.222-3)
[2011-07-15 22:35] installed pcsc-tools (1.4.17-4)
[2011-07-16 00:12] Running 'pacman -S --asdeps --needed extra/rpmextract'
[2011-07-16 00:12] installed rpmextract (1.0-4)
[2011-07-16 00:13] Running 'pacman -U --asdeps /tmp/yaourt-tmp-root/PKGDEST.KP5/openct-0.6.20-1-i686.pkg.tar.xz'
[2011-07-16 00:13] installed openct (0.6.20-1)
[2011-07-16 00:17] Running 'pacman -U /tmp/yaourt-tmp-root/PKGDEST.R87/pkiclient-5.00.28-1-i686.pkg.tar.xz'
[2011-07-16 00:18] installed pkiclient (5.00.28-1)
[2011-07-16 00:24] Running 'pacman -U /tmp/yaourt-tmp-root/PKGDEST.h6C/libtowitoko2-2.0.7-2-i686.pkg.tar.xz'
[2011-07-16 00:24] installed libtowitoko2 (2.0.7-2)
[2011-07-16 00:28] Running 'pacman -U /tmp/yaourt-tmp-root/PKGDEST.V6N/opensc-0.12.1-1-i686.pkg.tar.xz'
[2011-07-16 00:28] installed opensc (0.12.1-1)
[2011-07-16 01:15] Running 'pacman -Syu'
[2011-07-16 01:15] synchronizing package lists
[2011-07-16 01:15] starting full system upgrade
[2011-07-18 15:05] Running 'pacman -Syu'
[2011-07-18 15:05] synchronizing package lists
[2011-07-18 15:05] starting full system upgrade
[2011-07-18 15:12] upgraded aspell (0.60.6-5 -> 0.60.6.1-1)
[2011-07-18 15:12] upgraded cheese (3.0.1-2 -> 3.0.2-1)
[2011-07-18 15:12] upgraded device-mapper (2.02.85-3 -> 2.02.86-1)
[2011-07-18 15:12] upgraded file (5.07-3 -> 5.07-4)
[2011-07-18 15:12] upgraded libproxy (0.4.6-7 -> 0.4.7-1)
[2011-07-18 15:12] upgraded lvm2 (2.02.85-3 -> 2.02.86-1)
[2011-07-18 15:12] upgraded pygtk (2.24.0-1 -> 2.24.0-2)
[2011-07-18 15:12] upgraded python2-numpy (1.5.1-2 -> 1.6.0-1)
[2011-07-18 15:12] upgraded system-config-printer-common (1.3.3-1 -> 1.3.4-1)
[2011-07-18 15:12] ===> You must reload vboxdrv module before starting VirtualBox:
[2011-07-18 15:12] ===> # modprobe vboxdrv
[2011-07-18 15:12] ===>
[2011-07-18 15:12] ===> You must reload vboxnetflt for Host Interface Networking:
[2011-07-18 15:12] ===> # modprobe vboxnetflt
[2011-07-18 15:12] ===>
[2011-07-18 15:12] ===> You must reload vboxnetadp for Host-Only networking:
[2011-07-18 15:12] ===> # modprobe vboxnetadp
[2011-07-18 15:12] ===>
[2011-07-18 15:12] ===> To load it automatically, add vboxdrv module
[2011-07-18 15:12] ===> to the MODULES array in /etc/rc.conf.
[2011-07-18 15:12] 
[2011-07-18 15:12] *** To recompile the modules do /etc/rc.d/vboxdrv setup ***
[2011-07-18 15:12] upgraded virtualbox (4.0.10-2 -> 4.0.12-1)
[2011-07-18 15:12] upgraded virtualbox-additions (4.0.10-1 -> 4.0.12-1)
[2011-07-18 15:12] upgraded virtualbox-guest-modules (4.0.10-2 -> 4.0.12-1)
[2011-07-18 15:12] upgraded virtualbox-guest-additions (4.0.10-2 -> 4.0.12-1)
[2011-07-18 15:13] upgraded vlc (1.1.10-6 -> 1.1.11-1)

Offline

#14 2011-07-19 18:40:37

MoonSwan
Member
From: Great White North
Registered: 2008-01-23
Posts: 873

Re: [SOLVED] Symbol lookup error after update

Get a new mirror list from the Arch Mirrors list (sorry I don't have the link handy) and re-sync the system is what Allan is hinting at (I think).


I'm torn apart between worlds. Basically, using vim in a highly visual environment with a lot of mouse features feels like soldering a lose wire to a motherboard with a Zippo and a needle, while working with ANY TEXT AT ALL with a "modern GUI" text editor feels like joining the London Philharmonic Orchestra with a Fisher-Price Laugh and Learn Magical Musical Mirror.  --Awebb

Offline

#15 2011-07-19 19:40:43

Tsynique
Member
Registered: 2010-05-19
Posts: 37

Re: [SOLVED] Symbol lookup error after update

I have tested earlier today (and re-tested now) about 10 most recently sync'ed mirrors. I do that all the time if there's any glitch after an update and I update at least five times a day (provided there are any new packages). What I'm trying to say is that this can't be a problem with my system being not up to date. There must be something with some particular configuration concerning a recent kdelibs update or something.

Last night I tried downgrading kdelibs to 4.6.3 and building qt-static package from AUR. It didn't help. KDE itself doesn't start as well because there is a symbol missing in one of the QT libs.

My guess, but just a guess is that KDE has some problems with QT because the only apps that don't work are either KDE (Kmix, Kate, Kmines, etc) or QT (transmission-qt, qtemu, qtconfig). BTW transmission-gtk and other GTK apps work fine.

Also, I should probably mention that I even though I have KDE installed I don't use it, I just use some of it's apps while running Openbox.

I guess that is all I can say to describe the situation better at the moment. Thanks for the help so far guys and more suggestions for attempts to solve this are more than welcome, I'm willing to experiment.

Last edited by Tsynique (2011-07-19 19:41:18)

Offline

#16 2011-07-19 23:33:26

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [SOLVED] Symbol lookup error after update

try putting

export QT_PLUGIN_PATH=$HOME/.kde4/lib/kde4/plugins/:/usr/lib/kde4/plugins/

in your ~/.profile

Offline

#17 2011-07-22 15:53:38

Tsynique
Member
Registered: 2010-05-19
Posts: 37

Re: [SOLVED] Symbol lookup error after update

Nothing :\ However $HOME/.kde4/lib doesn't exist.

$ ls -la /home/tsynique/.kde4/
total 16
drwx------  7 tsynique users  115 Jun 12 13:25 .
drwx------ 62 tsynique users 4096 Jul 22 18:51 ..
drwxr-xr-x  2 tsynique users   27 Jan 13  2011 Autostart
lrwxrwxrwx  1 tsynique users   26 Jan 13  2011 cache-myhost -> /var/tmp/kdecache-tsynique
drwxr-xr-x  2 tsynique users    6 Jan 13  2011 env
drwx------  6 tsynique users   57 Jan 13  2011 share
drwxr-xr-x  2 tsynique users    6 Jan 13  2011 shutdown
lrwxrwxrwx  1 tsynique users   21 Jan 13  2011 socket-myhost -> /tmp/ksocket-tsynique
drwx------  2 tsynique users 4096 Jul 16 00:10 tmp-myhost

Offline

#18 2011-07-22 16:00:48

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [SOLVED] Symbol lookup error after update

It's ok. Don't install qt-$something packages from AUR. Keep using qt from [extra], unfortunately I don't know what breaks your system.

Please post the output of pacman -Q

Offline

#19 2011-07-25 11:53:34

Tsynique
Member
Registered: 2010-05-19
Posts: 37

Re: [SOLVED] Symbol lookup error after update

Yesterday I also tried reinstalling all the packages from `pacman -Q`.

Here is the output from `pacman -Q`.

$ pacman -Q
a52dec 0.7.4-5
aalib 1.4rc5-8
abiword 2.8.6-4
abiword-plugins 2.8.6-4
acl 2.2.51-1
aiksaurus 1.2.1-2
akonadi 1.5.3-2
alsa-lib 1.0.24.1-1
alsa-utils 1.0.24.2-1
amarok 2.4.1-3
apache 2.2.19-1
apr 1.4.5-1
apr-util 1.3.12-2
archlinux-themes-slim 1.2-2
aria2 1.12.0-1
arora-git 20110630-1
aspell 0.60.6.1-1
ati-dri 7.10.3-1
atk 2.0.1-1
atkmm 2.22.4-1
attica 0.2.0-1
attr 2.4.46-1
audacity 1.3.13-1
audiofile 0.2.7-1
autoconf 2.68-1
automake 1.11.1-2
automoc4 0.9.88-2
avahi 0.6.30-4
avidemux-cli 2.5.5-2
avidemux-gtk 2.5.5-2
avogadro 1.0.3-2
axkb 0.4.2-3
babl 0.1.4-1
bash 4.2.010-1
bchunk 1.2.0-2
bigreqsproto 1.1.1-1
bin86 0.16.18-1
binutils 2.21.1-1
bison 2.5-1
blas 3.3.1-2
blender 2:2.58a-1
bless 0.6.0-2
bluez 4.95-1
boost-libs 1.46.1-3
bzip2 1.0.6-1
cabextract 1.4-1
ca-certificates 20110421-3
ca-certificates-java 20110426-4
cairo 1.10.2-2
cairomm 1.10.0-1
cairo-perl 1.061-4
c-ares 1.7.4-1
ccd2iso 0.3-6
ccid 1.4.4-1
cdparanoia 10.2-3
cdrdao 1.2.3-5
cfitsio 3.280-1
cheese 3.0.2-1
chmlib 0.40-2
chromium 12.0.742.124-1
cifs-utils 4.9-3
cinelerra-cv 20110618-1
cln 1.3.2-1
cloog 0.16.2-1
clucene 2.3.3.4-1
clutter 1.6.16-1
clutter-gst 1.3.12-1
clutter-gtk 1.0.0-1
cmake 2.8.5-1
compositeproto 0.4.2-1
consolekit 0.4.5-1
coreutils 8.12-3
cracklib 2.8.18-1
cryptsetup 1.3.1-2
ctags 5.8-2
cups 1.4.7-2
curl 7.21.7-1
curlftpfs 0.9.2-2
cyrus-sasl-plugins 2.1.23-5
damageproto 1.2.1-1
dash 0.5.6.1-2
db 5.2.28-1
dbus 1.4.12-1
dbus-core 1.4.12-1
dbus-glib 0.94-2
dbus-python 0.84.0-1
dbus-qt3 0.62-4
dconf 0.7.5-1
dcron 4.5-2
ddrescue 1.14-1
desktop-file-utils 0.18-1
device-mapper 2.02.86-1
dhcpcd 5.2.12-1
dialog 1.1_20110302-1
diffutils 3.0-2
directfb 1.4.11-1
dirmngr 1.1.0-1
djvulibre 3.5.24-1
dmd 1.066-1
dmenu 4.4-1
dmidecode 2.11-1
dmxproto 2.3.1-1
dnsmasq 2.57-1
docbook-xml 4.5-4
docbook-xsl 1.76.1-1
dotconf 1.3-2
downgrade 2.0.2-1
dri2proto 2.3-1
dvdrtools 0.3.1-2
dvd+rw-tools 7.1-2
e2fsprogs 1.41.14-1
ebook-tools 0.2.1-2
ed 1.5-2
eigen2 2.0.16-1
eject 2.1.5-5
elfutils 0.152-1
emovix 0.9.0-4
enca 1.13-1
enchant 1.6.0-3
esound 0.2.41-2
ethtool 1:2.6.39-1
eventlog 0.2.12-2
evolution-data-server 3.0.2.1-2
exiv2 0.21.1-2
exo 0.6.2-1
expat 2.0.1-6
extremetuxracer 0.4-2
extundelete 0.2.0-1
faac 1.28-2
faad2 2.7-2
fakeroot 1.16-1
fam 2.7.0-15
farsight2 0.0.29-1
fbpanel 6.1-2
fcgi 2.4.0-6
ffmpeg 20110724-1
fftw 3.2.2-2
file 5.07-4
filesystem 2011.04-1
findutils 4.4.2-3
firefox 5.0-1
firefox-nightly-tm 6.0a1-1
fixesproto 5.0-1
flac 1.2.1-2
flashplugin 10.3.181.34-1
flex 2.5.35-4
fluidsynth 1.1.3-2
fontconfig 2.8.0-1
fontsproto 2.1.1-1
foomatic-db 1:4.0.7_20110707-1
foomatic-db-engine 1:4.0.7_20110707-1
foomatic-db-nonfree 1:4.0.7_20110707-1
foomatic-filters 1:4.0.7_20110707-1
freealut 1.1.0-3
freeciv 2.2.7-1
freeglut 2.6.0-1
freetype2 2.4.4-2
fribidi 0.19.2-1
fuse 2.8.5-1
garcon 0.1.8-1
gawk 4.0.0-1
gcc 4.6.1-2
gcc-libs 4.6.1-2
gconf 2.32.4-1
gd 2.0.36RC1-3
gdb 7.2-2
gdbm 1.8.3-8
gdk-pixbuf2 2.23.5-1
gdome2 0.8.1-3
geany 0.20-1
gegl 0.1.6-1
gen-init-cpio 2.6.36-1
gettext 0.18.1.1-3
ggz-client-libs 0.0.14.1-2
ghostscript 9.02-2
giflib 4.1.6-4
gimp 2.6.11-6
git 1.7.6-1
glew 1.6.0-1
glib 1.2.10-8
glib2 2.28.8-1
glibc 2.14-4
glibmm 2.28.2-1
glib-networking 2.28.7-1
glib-perl 1.223-3
glproto 1.4.14-1
gmetadom 0.2.6-2
gmp 5.0.2-2
gnome-desktop 3.0.2-1
gnome-disk-utility 3.0.2-1
gnome-icon-theme 3.0.0-2
gnome-icon-theme-symbolic 3.0.0-1
gnome-menus 3.0.1-1
gnome-mime-data 2.18.0-5
gnome-panel 3.0.2-1
gnome-vfs 2.24.4-3
gnome-video-effects 0.3.0-1
gnugo 3.8-2
gnu-netcat 0.7.1-3
gnupg 1.4.11-3
gnupg2 2.0.17-1
gnutls 2.12.7-2
gobject-introspection 0.10.8-1
goffice 0.8.15-1
gparted 0.9.0-2
gpgme 1.3.0-1
gpicview 0.2.1-3
gpm 1.20.6-6
gpsd 2.96-1
grantlee 0.1.9-1
grep 2.9-1
groff 1.21-1
grub 0.97-17
gsettings-desktop-schemas 3.0.1-2
gsfonts 1.0.7pre44-2
gsl 1.15-1
gsm 1.0.13-6
gstreamer0.10 0.10.34-1
gstreamer0.10-bad 0.10.22-1
gstreamer0.10-bad-plugins 0.10.22-1
gstreamer0.10-base 0.10.34-1
gstreamer0.10-base-plugins 0.10.34-1
gstreamer0.10-good 0.10.29-1
gstreamer0.10-good-plugins 0.10.29-1
gstreamer0.10-python 0.10.21-1
gtk 1.2.10-10
gtk2 2.24.5-2
gtk2-perl 1.222-3
gtk3 3.0.11-1
gtk-aurora-engine 1.5.1-2
gtk-chtheme 0.3.1-6
gtk-engines 2.20.2-1
gtkmathview 0.8.0-2
gtkmm 2.24.2-1
gtk-sharp-2 2.12.10-1
gtkspell 2.0.16-1
gtk-theme-switch2 2.1.0-1
gtk-update-icon-cache 2.24.5-2
gutenprint 5.2.7-2
gvfs 1.8.2-1
gzip 1.4-2
hal 0.5.14-6
hal-info 0.20091130-1
heirloom-mailx 12.5-1
hicolor-icon-theme 0.12-1
hplip 3.11.5-1
hspell 1.1-1
hunspell 1.3.2-1
hyphen 2.7.1-2
iana-etc 2.30-2
icedtea-web 1.1.1-1
icon-naming-utils 0.8.90-2
icoutils 0.29.1-1
icu 4.8-1
ilmbase 1.0.2-1
imagemagick 6.7.1.0-1
imlib2 1.4.4-1
inetutils 1.8-3
initscripts 2011.06.4-1
inputproto 2.0.2-1
intltool 0.41.1-2
iproute2 2.6.39-1
iptables 1.4.11.1-1
iputils 20101006-1
ircii-pana 1.1-4
isl 0.06-1
iso-codes 3.14-1
jack 0.121.2-1
jasper 1.900.1-6
jfsutils 1.1.15-2
json-glib 0.12.6-1
k3b 2.0.2-1
kaffeine 1.2.2-1
kbd 1.15.3-1
kbproto 1.0.5-1
kde-agent 20110602-1
kdebase-dolphin 4.6.5-1
kdebase-lib 4.6.5-1
kdebase-runtime 4.6.5-1
kdebase-workspace 4.6.5-1
kdebindings-python 4.6.5-1
kdeedu-libkdeedu 4.6.5-1
kdegames-libkdegames 4.6.5-1
kdegames-libkmahjongg 4.6.5-1
kdegraphics-okular 4.6.5-3
kdelibs 4.6.5-2
kde-meta-kdeaccessibility 4.6-1.2
kde-meta-kdeadmin 4.6-1.2
kde-meta-kdeartwork 4.6-1.2
kde-meta-kdeedu 4.6-1.2
kde-meta-kdegames 4.6-1.2
kde-meta-kdegraphics 4.6-1.2
kde-meta-kdemultimedia 4.6-1.2
kde-meta-kdenetwork 4.6-1.2
kde-meta-kdepim 4.6-1.2
kde-meta-kdeplasma-addons 4.6-1.2
kde-meta-kdesdk 4.6-1.2
kde-meta-kdetoys 4.6-1.2
kde-meta-kdeutils 4.6-1.2
kde-meta-kdewebdev 4.6-1.2
kdepim-libkdepim 4.6.1-1
kdepimlibs 4.6.5-1
kdepim-runtime 4.6.1-1
kdeplasma-addons-libs 4.6.5-2
kdeplasma-applets-networkmanagement 1:git20110713-1
kernel26 2.6.39.3-1
kernel26-headers 2.6.39.3-1
kernel26-lts 2.6.32.43-1
kernel26-lts-headers 2.6.32.43-1
keyutils 1.4-1
kismet 2011_03_R2-2
konversation 1.3.1-2
krb5 1.9.1-2
kwebkitpart 1.1.1-1
ladspa 1.13-2
lame 3.98.4-1
lapack 3.3.1-2
lcms 1.19-1
lcms2 2.2-1
less 444-1
lesstif 0.95.2-2
libao 1.1.0-1
libarchive 2.8.4-2
libass 0.9.12-1
libassuan 2.0.1-1
libasyncns 0.8-3
libatasmart 0.17-1
libavc1394 0.5.3-3
libbonobo 2.32.1-1
libcaca 0.99.beta17-1
libcanberra 0.28-1
libcap 2.21-1
libcdaudio 0.99.12-5
libcddb 1.3.2-2
libcdio 0.82-1
libcroco 0.6.2-1
libcups 1.4.7-2
libdaemon 0.14-1
libdatrie 0.2.4-1
libdbusmenu-qt 0.8.3-1
libdc1394 2.1.3-1
libdca 0.0.5-2
libdiscid 0.2.2-1
libdmtx 0.7.4-1
libdmx 1.1.1-1
libdrm 2.4.25-1
libdv 1.0.0-3
libdvbpsi 0.2.0-1
libdvdnav 4.1.3-2
libdvdread 4.1.3-2
libebml 1.2.1-1
libedit 20110227_3.0-1
libevent 2.0.12-1
libexif 0.6.20-1
libfetch 2.33-3
libffi 3.0.9-1
libfm 0.1.14-5
libfontenc 1.1.0-1
libftdi 0.19-1
libgadu 1.11.0-1
libgcrypt 1.5.0-1
libgdata 0.8.0-1
libgdiplus 2.10-1
libgee 0.6.1-1
libggz 0.0.14.1-2
libgl 7.10.3-1
libglade 2.6.4-2
libgme 0.6.0-1
libgnome 2.32.1-2
libgnome-data 2.32.1-2
libgnome-keyring 3.0.3-1
libgpg-error 1.10-1
libgphoto2 2.4.10.1-2
libgraphite 2.3.1-1
libgsf 1.14.21-1
libgssglue 0.1-4
libgweather 3.0.2-1
libical 0.46-1
libice 1.0.7-1
libid3tag 0.15.1b-6
libidl2 0.8.14-1
libidn 1.22-1
libiec61883 1.2.0-2
libieee1284 0.2.11-3
libindi 0.8-1
libiodbc 3.52.7-4
libirman 0.4.5-2
libjpeg6 6b-9
libjpeg-turbo 1.1.1-3
libksba 1.0.8-1
libktorrent 1.1.1-1
liblastfm 0.3.3-2
libldap 2.4.26-2
liblrdf 0.4.0-7
libmad 0.15.1b-5
libmatroska 1.2.0-1
libmcrypt 2.5.8-2
libmikmod 3.1.12-3
libmms 0.6-1
libmng 1.0.10-3
libmodplug 0.8.8.3-1
libmp4v2 1.9.1-1
libmpc 0.9-1
libmpcdec 1.2.6-2
libmpeg2 0.5.1-1
libmsn 4.1-2
libmtp 1.1.0-1
libmusicbrainz3 3.0.3-1
libmysqlclient 5.5.14-2
libnice 0.1.0-1
libnl 1.1-2
libnotify 0.7.3-1
libnova 0.13.0-1
libofa 0.9.3-3
libogg 1.2.2-1
libotr 3.2.0-2
libots 0.5.0-2
libpcap 1.1.1-2
libpciaccess 0.12.1-1
libphobos 1.066-1
libpipeline 1.2.0-1
libpng 1.4.8-1
libpng12 1.2.44-1
libpqxx 3.1-1
libproxy 0.4.7-1
libpulse 0.9.23-1
libpurple 2.9.0-2
libqalculate 0.9.7-2
libraw1394 2.0.7-1
libreoffice 3.4.1-2
libreoffice-extension-ct2n 3.4.1-2
libreoffice-extension-diagram 3.4.1-2
libreoffice-extension-hunart 3.4.1-2
libreoffice-extension-nlpsolver 3.4.1-2
libreoffice-extension-numbertext 3.4.1-2
libreoffice-extension-oooblogger 3.4.1-2
libreoffice-extension-pdfimport 3.4.1-2
libreoffice-extension-presentation-minimizer 3.4.1-2
libreoffice-extension-presenter-screen 3.4.1-2
libreoffice-extension-report-builder 3.4.1-2
libreoffice-extension-typo 3.4.1-2
libreoffice-extension-watch-window 3.4.1-2
libreoffice-extension-wiki-publisher 3.4.1-2
libreoffice-sdk 3.4.1-2
librsvg 2.34.0-1
libsamplerate 0.1.7-2
libsasl 2.1.23-6
libshout 2.2.2-3
libsigc++ 2.2.9-1
libsm 1.2.0-1
libsndfile 1.0.24-1
libsoup 2.34.2-1
libsoup-gnome 2.34.2-1
libspectre 0.2.6-2
libssh 0.5.0-1
libssh2 1.2.7-2
libtasn1 2.9-1
libtextcat 2.2-8
libthai 0.1.15-1
libtheora 1.1.1-1
libtiff 3.9.5-1
libtirpc 0.2.2-1
libtool 2.4-4
libtowitoko2 2.0.7-2
libunique3 3.0.2-1
libupnp 1.6.13-1
libusb 1.0.8-1
libusb-compat 0.1.3-1
libva 1.0.13-1
libvdpau 0.4.1-1
libvisual 0.4.0-3
libvncserver 0.9.8-2
libvorbis 1.3.2-1
libvpx 0.9.6-2
libwmf 0.2.8.4-8
libwnck 2.30.6-2
libwnck3 3.0.2-1
libwpd 0.9.2-1
libwpg 0.2.0-1
libwps 0.2.2-1
libx11 1.4.3-2
libx86 1.1-2
libxau 1.0.6-1
libxaw 1.0.9-1
libxcb 1.7-2
libxcomposite 0.4.3-1
libxcursor 1.1.12-1
libxdamage 1.1.3-1
libxdmcp 1.1.0-1
libxext 1.3.0-1
libxfce4ui 4.8.0-3
libxfce4util 4.8.1-2
libxfixes 5.0-1
libxfont 1.4.3-1
libxft 2.2.0-1
libxi 1.4.3-1
libxinerama 1.1.1-1
libxkbfile 1.0.7-1
libxklavier 5.1-1
libxml2 2.7.8-1
libxmu 1.1.0-1
libxp 1.0.1-2
libxpm 3.5.9-1
libxrandr 1.3.2-1
libxrender 0.9.6-1
libxres 1.0.5-1
libxslt 1.1.26-2
libxss 1.2.1-1
libxt 1.1.1-1
libxtst 1.2.0-1
libxv 1.0.6-1
libxvmc 1.0.6-1
libxxf86dga 1.1.2-1
libxxf86vm 1.1.1-1
libzip 0.10-1
licenses 2.8-1
lighttpd 1.4.29-1
link-grammar 4.7.4-1
links 2.3pre2-1
linux-api-headers 2.6.39.1-1
linux-atm 2.5.1-2
linux-firmware 20110512-2
lirc-utils 1:0.9.0-4
lm_sensors 3.3.1-1
logrotate 3.8.0-1
loudmouth 1.4.3-2
lpsolve 5.5.2.0-1
lsof 4.84-3
lua 5.1.4-6
lvm2 2.02.86-1
lxappearance 0.5.0-1
lxmenu-data 0.1.1-1
lxpanel 0.5.6-1
lxtask 0.1.4-1
lxterminal 0.1.9-1
lzo2 2.05-1
m4 1.4.16-1
make 3.82-3
man-db 2.6.0.2-2
man-pages 3.32-1
mcpp 2.7.2-2
mcrypt 2.6.8-1
mdadm 3.2.2-2
mediastreamer 2.7.3-3
menu-cache 0.3.2-1
mesa 7.10.3-1
mesa-demos 8.0.1-1
mhash 0.9.9.9-2
mhwaveedit 1.4.21-1
mime-types 1.0-3
mjpegtools 1.9.0-4
mkinitcpio 0.7.2-1
mkinitcpio-busybox 1.18.4-1
mlocate 0.24-1
module-init-tools 3.16-1
mono 2.10.2-1
mono-basic 2.10-1
mozilla-common 1.4-1
mpfr 3.0.1.p4-1
mpg123 1.13.3-1
mplayer 33805-1
musicbrainz 2.1.5-4
mx 1.0.4-1
mysql 5.5.14-2
mysql-clients 5.5.14-2
nano 2.2.6-1
ncurses 5.9-1
ndiswrapper 1.56-9
ndiswrapper-utils 1.56-2
neon 0.29.6-2
netbeans 7.0-1
netkit-bsd-finger 0.17-5
net-snmp 5.6.1-3
nettle 2.1-1
net-tools 1.60-18
networkmanager 0.8.9997-1
nitrogen 1.5.2-1
nspr 4.8.8-1
nss 3.12.10-1
ntfs-3g 2011.4.12-1
ntfsprogs 2011.4.12-1
ntrack 1:13-2
obconf 2.0.3-4
openal 1.13-2
openbabel 2.3.0-3
openbox 3.4.11.2-2
opencore-amr 0.1.2-1
openct 0.6.20-1
openexr 1.7.0-1
openjdk6 6.b22_1.10.3-1
openjpeg 1.3-3
opensc 0.12.1-1
openslp 1.2.1-3
openssh 5.8p2-9
openssl 1.0.0.d-1
opera 11.50-1
orbit2 2.14.19-1
orc 0.4.14-1
ortp 0.16.5-1
oss 4.2_2004-1
oxygen-icons 4.6.5-1
p7zip 9.20.1-3
package-query 0.8.1-1
pacman 3.5.3-1
pacman-mirrorlist 20110703-1
pam 1.1.3-2
pango 1.28.4-3
pangomm 2.28.1-1
pango-perl 1.221-4
parted 3.0-2
patch 2.6.1-2
pciutils 3.1.7-4
pcmanfm 0.9.8-6
pcmciautils 017-2
pcre 8.12-1
pcsclite 1.7.4-1
pcsc-perl 1.4.12-2
pcsc-tools 1.4.17-4
pdfedit 0.4.5-1
perl 5.14.1-3
perl-error 0.17016-2
perl-gtk2-trayicon 0.06-7
perl-html-parser 3.68-2
perl-html-tagset 3.20-2
perl-libwww 5.837-1
perl-uri 1.58-1
perl-xml-parser 2.41-1
perl-xml-simple 2.18-3
perl-xyne-arch 2011.02.06.1-2
perl-xyne-common 2011.02.03.3-2
phonon 4.5.0-1
phonon-vlc 0.4.0-1
php 5.3.6-5
php-apache 5.3.6-5
php-cgi 5.3.6-5
php-curl 5.3.6-5
php-gd 5.3.6-5
php-mcrypt 5.3.6-5
physfs 2.0.2-1
pidgin 2.9.0-2
pinentry 0.8.1-1
pixman 0.22.2-1
pkg-config 0.26-1
pkiclient 5.00.28-1
playonlinux 3.8.12-2
pm-quirks 0.20100619-1
pm-utils 1.4.1-3
polkit 0.101-2
polkit-kde 0.99.0-1
polkit-qt 0.99.0-1
poppler 0.16.7-1
poppler-data 0.4.4-1
poppler-qt 0.16.7-1
popt 1.16-3
postgresql-libs 9.0.4-4
powerpill 2010.08.26.1-1
ppl 0.11.2-1
ppp 2.4.5-2
printproto 1.0.5-1
procps 3.2.8-3
proftpd 1.3.3e-2
psmisc 22.14-1
pth 2.0.7-3
pycrypto 2.3-1
pycups 1.9.57-1
pygobject 2.28.4-1
pygobject-devel 2.28.4-1
pygtk 2.24.0-2
pyqt 4.8.4-1
pysmbc 1.0.11-1
python 3.2.1-1
python2 2.7.2-2
python2-cairo 1.10.0-1
python2-numpy 1.6.0-1
python2-pyqt 4.8.4-1
python2-sip 4.12.3-2
python2-zope-interface 3.6.3-1
python-urwid 0.9.9.1-2
qca 2.0.3-1
qca-ossl 2.0.0-3
qemu 0.14.1-1
qimageblitz 0.0.6-1
qingy 1.0.0-1
qingy-theme-arch 2.0-2
qjson 0.7.1-1
qscintilla 2.5.1-2
qt 4.7.3-3
qt3 3.3.8-20
qtemu 1.0.5-3
qtscriptgenerator 0.1.0-4
quesoglc 0.7.2-1
qwt 6.0.0-1
randrproto 1.3.2-1
raptor 2.0.3-3
raptor1 1.4.21-3
rarian 0.8.1-1
rasqal 1:0.9.26-1
rdesktop 1.7.0-2
readline 6.2.001-2
recode 3.6-6
recordproto 1.14.1-1
redland 1:1.0.13-4
redland-storage-virtuoso 1:1.0.13-4
reiserfsprogs 3.6.21-3
renderproto 0.11.1-1
resourceproto 1.1.1-1
rpcbind 0.2.0-3
rpmextract 1.0-4
rp-pppoe 3.10-7
rrdtool 1.4.5-3
rtmpdump 2.3-3
ruby 1.9.2_p290-1
run-parts 3.4.4-1
samba 3.5.9-2
sane 1.0.22-2
schroedinger 1.0.10-1
scrnsaverproto 1.2.1-1
sdl 1.2.14-6
sdl_image 1.2.10-2
sdl_mixer 1.2.11-2
sdl_net 1.2.7-3
sed 4.2.1-3
sg3_utils 1.30-1
shadow 4.1.4.3-2
shared-desktop-ontologies 0.6.0-1
shared-mime-info 0.90-1
silc-toolkit 1.1.10-1
sip 4.12.3-2
skype-kit 0.1-2
skype-staticqt 2.2.0.35-1
slim 1.3.2-5
slim-themes 1.2.3-4
smbclient 3.5.9-2
smbnetfs 0.5.3a-3
smpeg 0.4.4-5
smplayer 0.6.9-3
soprano 2.6.50git20110703-1
soundtouch 1.5.0-1
speech-dispatcher 0.7.1-5
speex 1.2rc1-1.1
splix 2.0.0-10
sqlite3 3.7.7.1-1
startup-notification 0.12-1
strigi 0.7.5-4
sudo 1.8.1.p2-1
sysfsutils 2.1.0-6
syslog-ng 3.2.4-3
system-config-printer-common 1.3.4-1
sysvinit 2.88-2
t1lib 5.1.2-2
taglib 1.7-1
taglib-extras 1.0.1-1
talloc 2.0.5-1
tar 1.26-1
tcl 8.5.10-1
tcp_wrappers 7.6-12
tdb 1.2.9-1
telepathy-farsight 0.0.19-1
telepathy-glib 0.14.9-1
telepathy-qt4 0.6.1-1
texinfo 4.13a-5
tk 8.5.10-1
transcode 1.1.5-5
transmission-gtk 2.33-1
transmission-qt 2.33-1
ttf-dejavu 2.33-1
ttf-freefont 20100919-1
ttf-liberation 1.07.0-1
tunepimp 0.5.3-8
tuxcmd 0.6.70-3
tuxcmd-modules 0.6.70-1
twisted 11.0.0-1
tzdata 2011h-1
udev 171-2
udev-compat 171-2
udisks 1.0.3-5
unixodbc 2.3.0-1
unrar 4.0.7-1
unzip 6.0-5
upower 0.9.12-1
upx 3.07-1
usbutils 003-1
util-linux 2.19.1-2
v4l-utils 0.8.4-1
vbetool 1.1-1
vcdimager 0.7.23-7
vde2 2.3.1-1
vi 1:050325-1
videoproto 2.3.1-1
virtualbox 4.1.0-2
virtualbox-additions 4.1.0-1
virtualbox-archlinux-additions 4.1.0-2
virtualbox-archlinux-modules 4.1.0-2
virtuoso 6.1.3-1
vlc 1.1.11-2
volwheel 0.2.8-1
vte 0.28.1-1
vte-common 0.28.1-1
warzone2100 2.3.8-1
wavpack 4.60.1-1
wget 1.12-7
which 2.20-4
wicd 1.7.0-10
wicd-gtk 1.7.0-10
wine 1.3.25-1
winetricks 20110629-1
wireless_tools 29-4
wireshark-cli 1.6.1-1
wireshark-gtk 1.6.1-1
wpa_supplicant 0.7.3-3
wv 1.2.7-1
wvdial 1.61-3
wvstreams 4.6.1-2
wxgtk 2.8.12-1
wxpython 2.8.12.0-1
x264 20110617-1
xbitmaps 1.1.1-1
xcb-proto 1.6-2
xcb-util 0.3.6-1
xcmiscproto 1.2.1-1
xdg-utils 1.1.0rc1-3
xextproto 7.2.0-1
xf86dgaproto 2.1-1
xf86driproto 2.1.1-1
xf86-input-evdev 2.6.0-3
xf86-input-synaptics 1.4.1-1
xf86-video-ati 6.14.1-1
xf86vidmodeproto 2.3.1-1
xfce4-mixer 4.8.0-1
xfce4-panel 4.8.5-1
xfconf 4.8.0-2
xfsprogs 3.1.5-1
xine-lib 1.1.19-2
xineramaproto 1.2.1-1
xinetd 2.3.14-7
xkeyboard-config 2.2.1-1
xmms 1.2.11-3
xmms-wma 1.0.5-5
xorg-bdftopcf 1.0.3-1
xorg-docs 1.6-1
xorg-fonts-100dpi 1.0.1-3
xorg-fonts-75dpi 1.0.1-3
xorg-fonts-alias 1.0.2-1
xorg-fonts-encodings 1.0.4-1
xorg-fonts-misc 1.0.1-1
xorg-font-util 1.2.0-1
xorg-font-utils 7.6-2
xorg-iceauth 1.0.5-1
xorg-luit 1.1.0-2
xorg-mkfontdir 1.0.6-2
xorg-mkfontscale 1.0.9-1
xorg-res-utils 1.0.3-3
xorg-server 1.10.3-1
xorg-server-common 1.10.3-1
xorg-sessreg 1.0.6-2
xorg-setxkbmap 1.2.0-2
xorg-twm 1.0.6-2
xorg-util-macros 1.15.0-1
xorg-utils 7.6-7
xorg-xauth 1.0.6-1
xorg-xbacklight 1.1.2-2
xorg-xcmsdb 1.0.3-2
xorg-xdpyinfo 1.2.0-2
xorg-xdriinfo 1.0.4-2
xorg-xev 1.1.0-2
xorg-xgamma 1.0.4-2
xorg-xhost 1.0.4-2
xorg-xinit 1.3.0-3
xorg-xinput 1.5.3-2
xorg-xkbcomp 1.2.3-1
xorg-xkbevd 1.1.2-2
xorg-xkbutils 1.0.3-2
xorg-xkb-utils 7.6-1
xorg-xkill 1.0.3-2
xorg-xlsatoms 1.1.0-2
xorg-xlsclients 1.1.2-1
xorg-xmessage 1.0.3-1
xorg-xmodmap 1.0.5-2
xorg-xprop 1.2.1-1
xorg-xrandr 1.3.5-1
xorg-xrdb 1.0.9-1
xorg-xrefresh 1.0.4-2
xorg-xset 1.2.1-2
xorg-xsetroot 1.1.0-2
xorg-xvinfo 1.1.1-2
xorg-xwininfo 1.1.2-1
xpdf 3.02_pl6-1
xplc 0.3.13-3
xproto 7.0.22-1
xscreensaver 5.14-1
xterm 270-1
xtrans 1.2.6-1
xulrunner 5.0-1
xvidcore 1.3.2-1
xxkb 1.11-3
xz 5.0.3-1
yajl 2.0.2-1
yaourt 0.10.1-2
zd1211-firmware 1.4-4
zip 3.0-2
zlib 1.2.5-3
zvbi 0.2.33-3

Offline

#20 2011-07-26 09:30:48

Tsynique
Member
Registered: 2010-05-19
Posts: 37

Re: [SOLVED] Symbol lookup error after update

After endless googling I managed to fix the problem. Before everything went south I installed packages called openct and pkiclient. One of them create a directory /usr/lib/eToken which contained the following files:

drwxr-xr-x  2 root root    4096 Jul 16 00:16 bin
-rwxr-xr-x  1 root root 1176544 Jul 16 00:16 libetPropBasic.so
-rwxr-xr-x  1 root root   35736 Jul 16 00:16 libMozilaStoreSync.so
-rwxr-xr-x  1 root root   70020 Jul 16 00:16 libPhysicalDevices.so
lrwxrwxrwx  1 root root      18 Jan 22  2009 libQtCore.so.4 -> libQtCore.so.4.2.3
-rwxr-xr-x  1 root root 1631928 Jul 16 00:16 libQtCore.so.4.2.3
lrwxrwxrwx  1 root root      17 Jan 22  2009 libQtGui.so.4 -> libQtGui.so.4.2.3
-rwxr-xr-x  1 root root 7740188 Jul 16 00:16 libQtGui.so.4.2.3
lrwxrwxrwx  1 root root      17 Jan 22  2009 libQtXml.so.4 -> libQtXml.so.4.2.3
-rwxr-xr-x  1 root root  289652 Jul 16 00:16 libQtXml.so.4.2.3
drwxr-xr-x  2 root root    4096 Jul 16 00:16 nss_tools
drwxr-xr-x  3 root root    4096 Jan 22  2009 plugins

I suppose the problem was that libQt* files conflicted with the original ones in the /usr/lib/ dir because after deleting /usr/lib/eToken everything went back to normal.
Thanks for the help guys!

Offline

#21 2011-11-06 16:26:26

vegihat
Member
Registered: 2011-10-09
Posts: 7

Re: [SOLVED] Symbol lookup error after update

i think i have the same problem.

$ chromium
/usr/lib/chromium: symbol lookup error :/usr/lib/libgtk-x11-2.0.so.0: undefined symbol :g_datalist_get_data

how could i fix it?

thanks in advance.

[solution]
i delete /etc/profile.d/locale.sh and then sudo pacman -Syu , sudo pacman -Rs chromium ,sudo pacman -S chromium

Last edited by vegihat (2011-11-06 16:47:01)

Offline

Board footer

Powered by FluxBB