You are not logged in.

#1 2011-07-03 23:53:56

Jabrick
Member
Registered: 2011-05-13
Posts: 79

[UNSOLVED AGAIN] Polipo and/or Privoxy Troubleshooting

After doing some more research it seems as though Polipo is a better choice over Privoxy for Tor so this is my failed attempt so far.

Out of the box polipo won't start
/etc/rc.d/polipo start    [FAIL]<

I followed the polipo wiki up to changing the /etc/rc.d/polipo
su -c "/usr/bin/$DAEMON $ARGS" -s /bin/sh polipo >/dev/null 2>&1

Now it just hangs on busy when i try to run as regular user
And it just fails when i sudo it. Help!

Ouput of sudo polipo -v |grep socks

socksParentProxy atom (none) SOCKS parent proxy (host:port)
socksProxyType atom socks5 One of socks4a or socks5
socksUserName atom (empty) SOCKS4a user name

Last edited by Jabrick (2011-07-05 02:02:06)

Offline

#2 2011-07-04 08:58:43

brenix
Member
From: California
Registered: 2008-03-05
Posts: 182

Re: [UNSOLVED AGAIN] Polipo and/or Privoxy Troubleshooting

You could try using the git package available on the aur..been working for me for a while.

Build the polipo-git aur package, but replace line 19 (the gitroot line) with the following:
_gitroot=git://git.wifi.pps.jussieu.fr/$_gitname

Offline

#3 2011-07-04 23:03:22

Jabrick
Member
Registered: 2011-05-13
Posts: 79

Re: [UNSOLVED AGAIN] Polipo and/or Privoxy Troubleshooting

I have tried the polipo-git from the AUR, but it gives me a build() error everytime.
So I tried downloading git clone git://git.wifi.pps.jussieu.fr/polipo, but I dont know how to start it. I did gitk, and a window for polipo setting came up.

Anyways I cleaned out all the polipo stuff and installed it through pacman again.
If I just type in polipo in command line this is the output I get.

Disabling disk cache: No such file or directory
Established listening socket on port 8123.

I tried configuring tor with
HTTP proxy:127.0.0.1 port:8123
SSL proxy :127.0.0.1 port:8123
Socks Host:127.0.0.1 port:9050
SOCKS v5.
But still isn't working.

/etc/rc.d/polipo start
Still gives me a fail message.

Can someone give me another hand?
Thanks

Also I resorted back in trying to get privoxy to work.
But everytime I try and view a webpage I get

This is Privoxy 3.0.17 on myhost.localdomain (127.0.0.1), port 8118, enabled
Privoxy was unable to socks4a-forward your request http://onemorelevel.com/ through localhost: connect_to failed: see logfile for details

When I check
/var/log/privoxy
It is empty

Last edited by Jabrick (2011-07-04 23:12:49)

Offline

#4 2011-07-04 23:49:04

Jabrick
Member
Registered: 2011-05-13
Posts: 79

Re: [UNSOLVED AGAIN] Polipo and/or Privoxy Troubleshooting

SOLVED!
Ok the polipo-git works perfectly, I got the build error because I forgot to edit line 19 as brenix mentioned.
Thank you so much.
Also I forgot to run the tor daemon.
Jeez I'm a fool.
Anyways thanks smile
Btw doesn't anyone know if polipo will get updated with Syu if I didn't download using pacman?

Offline

#5 2011-07-05 02:03:25

Jabrick
Member
Registered: 2011-05-13
Posts: 79

Re: [UNSOLVED AGAIN] Polipo and/or Privoxy Troubleshooting

Everything was working and now it is suddenly not able to load pages.
Firefox says the connection has timed out.
And just a few minute ago it was going at good speeds.
I did NOTHING at all except surf the web with tor + polipo.
Any ideas? This is getting very frustrating!
How can i troubleshoot to spot the problem? I've done nothing at all to for this problem to occur!!!! :@

UPDATE: vidalia is stuck at loading network status

Config for polipo from https://gitweb.torproject.org/torbrowse … olipo.conf

### Basic configuration
### *******************

# Uncomment one of these if you want to allow remote clients to
# connect:

# proxyAddress = "::0"        # both IPv4 and IPv6
# proxyAddress = "0.0.0.0"    # IPv4 only

proxyAddress = "127.0.0.1"
proxyPort = 8118

# If you do that, you'll want to restrict the set of hosts allowed to
# connect:

# allowedClients = "127.0.0.1, 134.157.168.57"
# allowedClients = "127.0.0.1, 134.157.168.0/24"

allowedClients = 127.0.0.1
allowedPorts = 1-65535

# Uncomment this if you want your Polipo to identify itself by
# something else than the host name:

proxyName = "localhost"

# Uncomment this if there's only one user using this instance of Polipo:

cacheIsShared = false

# Uncomment this if you want to use a parent proxy:

# parentProxy = "squid.example.org:3128"

# Uncomment this if you want to use a parent SOCKS proxy:

socksParentProxy = "localhost:9050"
socksProxyType = socks5


### Memory
### ******

# Uncomment this if you want Polipo to use a ridiculously small amount
# of memory (a hundred C-64 worth or so):

# chunkHighMark = 819200
# objectHighMark = 128

# Uncomment this if you've got plenty of memory:

# chunkHighMark = 50331648
# objectHighMark = 16384

chunkHighMark = 67108864

### On-disk data
### ************

# Uncomment this if you want to disable the on-disk cache:

diskCacheRoot = ""

# Uncomment this if you want to put the on-disk cache in a
# non-standard location:

# diskCacheRoot = "~/.polipo-cache/"

# Uncomment this if you want to disable the local web server:

localDocumentRoot = ""

# Uncomment this if you want to enable the pages under /polipo/index?
# and /polipo/servers?.  This is a serious privacy leak if your proxy
# is shared.

# disableIndexing = false
# disableServersList = false

disableLocalInterface = true
disableConfiguration = true

### Domain Name System
### ******************

# Uncomment this if you want to contact IPv4 hosts only (and make DNS
# queries somewhat faster):
#
# dnsQueryIPv6 = no

# Uncomment this if you want Polipo to prefer IPv4 to IPv6 for
# double-stack hosts:
#
# dnsQueryIPv6 = reluctantly

# Uncomment this to disable Polipo's DNS resolver and use the system's
# default resolver instead.  If you do that, Polipo will freeze during
# every DNS query:

dnsUseGethostbyname = yes


### HTTP
### ****

# Uncomment this if you want to enable detection of proxy loops.
# This will cause your hostname (or whatever you put into proxyName
# above) to be included in every request:

disableVia = true

# Uncomment this if you want to slightly reduce the amount of
# information that you leak about yourself:

# censoredHeaders = from, accept-language
# censorReferer = maybe

censoredHeaders = from,accept-language,x-pad,link
censorReferer = maybe

# Uncomment this if you're paranoid.  This will break a lot of sites,
# though:

# censoredHeaders = set-cookie, cookie, cookie2, from, accept-language
# censorReferer = true

# Uncomment this if you want to use Poor Man's Multiplexing; increase
# the sizes if you're on a fast line.  They should each amount to a few
# seconds' worth of transfer; if pmmSize is small, you'll want
# pmmFirstSize to be larger.

# Note that PMM is somewhat unreliable.

# pmmFirstSize = 16384
# pmmSize = 8192

# Uncomment this if your user-agent does something reasonable with
# Warning headers (most don't):

# relaxTransparency = maybe

# Uncomment this if you never want to revalidate instances for which
# data is available (this is not a good idea):

# relaxTransparency = yes

# Uncomment this if you have no network:

# proxyOffline = yes

# Uncomment this if you want to avoid revalidating instances with a
# Vary header (this is not a good idea):

# mindlesslyCacheVary = true

# Suggestions from Incognito configuration
maxConnectionAge = 5m
maxConnectionRequests = 120
serverMaxSlots = 8
serverSlots = 2
tunnelAllowedPorts = 1-655354

Last edited by Jabrick (2011-07-05 11:42:13)

Offline

#6 2011-07-31 01:07:48

whitethorn
Member
Registered: 2010-05-02
Posts: 153

Re: [UNSOLVED AGAIN] Polipo and/or Privoxy Troubleshooting

Well I found a part of the problem. The daemon keeps dying, I guess I could try to understand what's not working properly. If you run polipo -c /path/to/config then it starts and everything works find. Now to get the daemon up and running.

https://bbs.archlinux.org/viewtopic.php … 34#p967834

I think I've figured out the problem.

Last edited by whitethorn (2011-07-31 02:42:27)

Offline

Board footer

Powered by FluxBB