You are not logged in.

#101 2011-07-04 20:49:47

tjbp
Member
Registered: 2010-11-06
Posts: 39

Re: Broadcom wireless driver - brcm80211

Just to pitch in here - I'm running a BCM4313 in my Samsung netbook, and am experiencing kernel panics with the brcmsmac driver under 2.6.39.2-1. It seems to happen under any heavy network usage - if I stream music or upload a file somewhere it tends to happen. It will happily idle, however.

Ed: I can't provide any log info because I can't find a way to log the kernel panic trace, nor can I find any info in existing logs. If anyone can, please advise!

Last edited by tjbp (2011-07-04 20:52:54)

Offline

#102 2011-07-08 13:13:42

cshake
Member
Registered: 2007-12-19
Posts: 18

Re: Broadcom wireless driver - brcm80211

Just an update on my current status, which is that it's still locking up on my system (now brcmsmac).
I do get a new message in dmesg,

[   15.352890] brcmsmac: module is from the staging directory, the quality is unknown, you have been warned.

Everything is updated to the most recent packages in stable and community, I tried to run only testing after my last post but had some issues with oss sound - ALSA still doesn't have drivers for the intel hda chip in this netbook, at least that will use the headphone jack. OSS doesn't have official support either, but I can force headphones (no jack sensing).

Since I'm seeing some reports from others where this chipset is working perfectly, I just have to wonder what I'm doing differently - I'm on 64bit, using wpa_supplicant (with and without wpa_gui, crashes happen in both cases). Sound shouldn't be related, neither should the underlying filesystem, as I never get any crash problems when I'm using the system on a wired ethernet.

[vEX] wrote:

Anyone managed to connect to an AP with hidden SSID using brcm80211 (or brcmsmac as it's called now)? It just fails to authenticate with the router for me unless I broadcast the SSID. Other than that everything is working just fine and the driver seems stable enough. Though I would really like to not broadcast the SSID (yeah I know it's not increasing security) if possible.

I run a hidden SSID on my network in my apartment, it just requires adding "scan_ssid=1" to the entry for the network in /etc/wpa_supplicant.conf

network={
    ssid=$NETWORK_NAME
    scan_ssid=1
    psk=$NETWORK_PASSKEY
    proto=RSN
    key_mgmt=WPA-PSK
    pairwise=TKIP
    group=TKIP WEP104 WEP40
    auth_alg=OPEN
    priority=1
}

(where the $NETWORK_* are hardcoded in the actual file but redacted here and changed to variables)

Offline

#103 2011-08-01 05:06:04

dw
Member
From: Vienna, Austria
Registered: 2006-11-25
Posts: 157

Re: Broadcom wireless driver - brcm80211

hi everybody.

i own a dell vostro notebook that has an internal bcm4313 [14e4:4727] wireless card. the card works fine with latest kernel from core using netcfg scripts. the brcm* modules are loaded, connection is fast and stable.

trying the 3.0 kernel from testing leads to a regression. according to lsmod, the required modules are loaded but the device is not brought up (iwconfig | ifconfig -a) doesn't show the device.

after boot, /var/log/dmesg contains two lines with respect to the device:

brcmsmac: module is from the staging directory, the quality is unknown, you have been warned.

i have checked the contents of /etc/modprobe.d if by change anything important got blacklisted (nothing) and i have also checked bugtrackers but didn't find anything useful.

so my question is, if anyone having such a card is experiencing something similar?

Last edited by dw (2011-08-01 12:05:46)

Offline

#104 2011-08-01 11:25:40

tjbp
Member
Registered: 2010-11-06
Posts: 39

Re: Broadcom wireless driver - brcm80211

dw, do you get any brcmsmac-related output in dmesg if you unload the module? You should have something about brcmsmac and a PCI connection being disabled. As it happens, I'm running the exact same card with 3.0 in my laptop, and it's working fine.

Offline

#105 2011-08-01 13:51:10

dw
Member
From: Vienna, Austria
Registered: 2006-11-25
Posts: 157

Re: Broadcom wireless driver - brcm80211

tjbp wrote:

dw, do you get any brcmsmac-related output in dmesg if you unload the module? You should have something about brcmsmac and a PCI connection being disabled. As it happens, I'm running the exact same card with 3.0 in my laptop, and it's working fine.

strange.

i booted the 2.6.39 and did a grep brcms /var/log/messages which resulted in

Aug  1 14:49:25 localhost kernel: [   10.063579] brcmsmac: module is from the staging directory, the quality is unknown, you have been warned.
Aug  1 14:49:25 localhost kernel: [   10.071217] brcmsmac 0000:12:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17

removing the module gives the following line in messages.log

Aug  1 14:53:39 localhost kernel: [ 1886.366810] brcmsmac 0000:12:00.0: PCI INT A disabled

doing the same thing after installing 3.0-2 from testing gives only

Aug  1 15:02:23 localhost kernel: [   11.068226] brcmutil: module is from the staging directory, the quality is unknown, you have been warned.

after boot and removing the module (rmmod) doesn't trigger any log-message (i guess no log because the pci connection is not disabled since it has never been enabled in the first place...

hm, do you think this is an brcm bug or possibly an acpi bug?

Offline

#106 2011-08-01 15:28:55

kastor
Member
From: Mendoza - Argentina
Registered: 2006-06-18
Posts: 59
Website

Re: Broadcom wireless driver - brcm80211

dw wrote:

hi everybody.

i own a dell vostro notebook that has an internal bcm4313 [14e4:4727] wireless card. the card works fine with latest kernel from core using netcfg scripts. the brcm* modules are loaded, connection is fast and stable.

trying the 3.0 kernel from testing leads to a regression. according to lsmod, the required modules are loaded but the device is not brought up (iwconfig | ifconfig -a) doesn't show the device.

after boot, /var/log/dmesg contains two lines with respect to the device:

brcmsmac: module is from the staging directory, the quality is unknown, you have been warned.

i have checked the contents of /etc/modprobe.d if by change anything important got blacklisted (nothing) and i have also checked bugtrackers but didn't find anything useful.

so my question is, if anyone having such a card is experiencing something similar?

I have the same problem with a toshiba laptop bcm4313 using brcmsmac kernel module.. switching to 2.6

Offline

#107 2011-08-01 17:22:41

tjbp
Member
Registered: 2010-11-06
Posts: 39

Re: Broadcom wireless driver - brcm80211

I get an additional line in /var/log/messages:

bus 5 slot 0 func 0 irq 16

which comes immediately before the PCI INT A -> GSI (etc) line. Whether that bears any relevance I don't know. I'm running 64-bit; if you are too then I would have thought our output would be identical considering we're using the same kernel package.

Offline

#108 2011-08-01 17:36:38

dw
Member
From: Vienna, Austria
Registered: 2006-11-25
Posts: 157

Re: Broadcom wireless driver - brcm80211

tjbp wrote:

I get an additional line in /var/log/messages:

bus 5 slot 0 func 0 irq 16

which comes immediately before the PCI INT A -> GSI (etc) line. Whether that bears any relevance I don't know. I'm running 64-bit; if you are too then I would have thought our output would be identical considering we're using the same kernel package.

hi.

yeah, i am running 64-bit too but i don't have this line in any logfile. strange....

Offline

#109 2011-08-01 17:39:13

dw
Member
From: Vienna, Austria
Registered: 2006-11-25
Posts: 157

Re: Broadcom wireless driver - brcm80211

kastor wrote:

I have the same problem with a toshiba laptop bcm4313 using brcmsmac kernel module.. switching to 2.6

hi kastor, thx for your feedback. good to know that i am not alone with this problem.

another interesting thing. i just booted a beta version of opensuse  (also 64bit) from usb featuring some 3.0-rc kernel and the wireless-card was working well....

Last edited by dw (2011-08-02 04:57:41)

Offline

#110 2011-08-02 07:09:59

aehs29
Member
From: Chihuahua, Mexico
Registered: 2011-03-17
Posts: 7

Re: Broadcom wireless driver - brcm80211

Same problem here on 3.0.2 with card BCM43224 (14e4:4353), on Alienware M11x , same dmesg as dw on Arch x64, and probbly its an issue the guys from suse already solved???, or they never had it??

Offline

#111 2011-08-02 16:51:37

tjbp
Member
Registered: 2010-11-06
Posts: 39

Re: Broadcom wireless driver - brcm80211

Just upgraded to the latest 3.0 kernel in testing (3.0-2) to be sure and the stability is identical - plus I still have that extra line in /var/log/messages.log.

What are you guys using to manage your connections? Do you have anything configured in /etc/rc.conf? I have everything configured via NetworkManager.

Offline

#112 2011-08-02 16:57:53

dw
Member
From: Vienna, Austria
Registered: 2006-11-25
Posts: 157

Re: Broadcom wireless driver - brcm80211

tjbp wrote:

Just upgraded to the latest 3.0 kernel in testing (3.0-2) to be sure and the stability is identical - plus I still have that extra line in /var/log/messages.log.

What are you guys using to manage your connections? Do you have anything configured in /etc/rc.conf? I have everything configured via NetworkManager.

i am using netcfg to manage my connections. nothing else, just plain netcfg.

Offline

#113 2011-08-02 17:26:30

tjbp
Member
Registered: 2010-11-06
Posts: 39

Re: Broadcom wireless driver - brcm80211

dw wrote:
tjbp wrote:

Just upgraded to the latest 3.0 kernel in testing (3.0-2) to be sure and the stability is identical - plus I still have that extra line in /var/log/messages.log.

What are you guys using to manage your connections? Do you have anything configured in /etc/rc.conf? I have everything configured via NetworkManager.

i am using netcfg to manage my connections. nothing else, just plain netcfg.

Sorry, forgot your original post said the interface isn't there even with ifconfig -a. I believe that puts the problem outside of the network management spectrum.

The last thing I can think of is the firmware - what's your output for this?:

$ md5sum /lib/firmware/brcm/*.fw

Mine is:

96cf06e4ff9f0c04a0f26ebefdf32e3d  /lib/firmware/brcm/bcm43xx-0.fw
48882412db63b4e2dd9c26571a29a799  /lib/firmware/brcm/bcm43xx_hdr-0.fw

Offline

#114 2011-08-02 19:10:57

dw
Member
From: Vienna, Austria
Registered: 2006-11-25
Posts: 157

Re: Broadcom wireless driver - brcm80211

hi tjbp. i just checked the firmware.

the md5sums of the firmware from core:

96cf06e4ff9f0c04a0f26ebefdf32e3d  /lib/firmware/brcm/bcm43xx-0.fw
48882412db63b4e2dd9c26571a29a799  /lib/firmware/brcm/bcm43xx_hdr-0.fw

the md5sums of the firmware from testing

96cf06e4ff9f0c04a0f26ebefdf32e3d  /lib/firmware/brcm/bcm43xx-0.fw
48882412db63b4e2dd9c26571a29a799  /lib/firmware/brcm/bcm43xx_hdr-0.fw

so they are identical and match with yours. i don't have a clue what's going on here but i agree with you that its not about the network managment system because the device doesn't even show up...

but thanks a lot for taking your time and thinking about this (my|our) problem!

Offline

#115 2011-08-03 07:40:02

monojp
Member
From: Vienna, Austria
Registered: 2011-05-16
Posts: 13
Website

Re: Broadcom wireless driver - brcm80211

@dw: I seem to have the same card and problems like you on my new nf310 where I installed arch yesterday . There is no device showing up and I'm also running 64bit btw.
I will play around with it some more today and maybe report back because I'm new to this card, driver and netbook..
I haven't tested with older kernels yet. Just installed arch with X, gnome and some other stuff yesterday, activated testing and made a pacman -Syu

edit: nice to see someone else from vienna in here smile

UPDATE: I'm afraid that the only thing I found out today was, that my wlan IS working with the kernel26 and NOT working with the linux package. Which means that using kernel 2.6.39 my wlan-device shows up and with 3.0 it doesn't. It seems to be completely independent from the firmware package or something else. I just replaced the kernel..

Last edited by monojp (2011-08-03 21:11:19)

Offline

#116 2011-08-03 15:30:34

dutra.julio
Member
Registered: 2011-07-26
Posts: 8

Re: Broadcom wireless driver - brcm80211

Same problem here with macbook air.

Offline

#117 2011-08-04 04:52:48

aehs29
Member
From: Chihuahua, Mexico
Registered: 2011-03-17
Posts: 7

Re: Broadcom wireless driver - brcm80211

Weird thing just happened to me, i added brcmsmac to my modules list on my /etc/rc.conf and after i rebooted i had my wireless working again, i thought i had solved the problem, but now after another reboot my wireless is gone again

Offline

#118 2011-08-04 14:48:02

monojp
Member
From: Vienna, Austria
Registered: 2011-05-16
Posts: 13
Website

Re: Broadcom wireless driver - brcm80211

aehs29 wrote:

Weird thing just happened to me, i added brcmsmac to my modules list on my /etc/rc.conf and after i rebooted i had my wireless working again, i thought i had solved the problem, but now after another reboot my wireless is gone again

very interesting. I did basically the same thing and installed some packages since yesterday (mostly because of some warnings in my xorg or kernel log regarding brightness control or some special keys)

Maybe one of those could be relevant:

crda
acpi
acpid

Some other stuff I installed for the sake of completeness:

gksu
xf86-video-vesa
xf86-video-fbdev
telepathy
powertop
meld
texlive-most

Yeah and I made normal updates of course, which installed:

dbus-core
dbus
libmpeg2
mdadm
mime-types
modemmanager
libksba
dirmngr
file
gnupg2

I also added acpid to the daemons-array in rc.conf. After another restart wireless is still working for me. The loaded modules haven't changed btw
I don't really know what else could have triggered this. I will keep you updated for sure. Maybe the next reboots kill my wireless again smile

UPDATE: all the above info could be irrelevant because like aehs29 said I also noticed that my wireless just works if "brcmsmac" is in the module array and doesn't if it is not. It will be autoloaded but wireless doesn't work otherwise.. wondering now what's wrong with your wireless aehs29, mine seems to work perfect now even after several reboots

Last edited by monojp (2011-08-04 15:10:24)

Offline

#119 2011-08-04 17:12:31

aehs29
Member
From: Chihuahua, Mexico
Registered: 2011-03-17
Posts: 7

Re: Broadcom wireless driver - brcm80211

Ok now its working again, lol, i dont whats triggerin it, after another reboot it has shown up again

Offline

#120 2011-08-04 17:13:34

dw
Member
From: Vienna, Austria
Registered: 2006-11-25
Posts: 157

Re: Broadcom wireless driver - brcm80211

aehs29 wrote:

Weird thing just happened to me, i added brcmsmac to my modules list on my /etc/rc.conf and after i rebooted i had my wireless working again, i thought i had solved the problem, but now after another reboot my wireless is gone again

i can confirm that the device comes up after adding 'brcmsmac' to the modules array in rc.conf. i have since successfully rebooted, shutdown and restarted for about 15 times and the device always got up until now.

aehs29, monojp: do you also get verbose output for the device "phy0... messages" during the boot process?

Offline

#121 2011-08-04 17:24:51

monojp
Member
From: Vienna, Austria
Registered: 2011-05-16
Posts: 13
Website

Re: Broadcom wireless driver - brcm80211

dw wrote:

aehs29, monojp: do you also get verbose output for the device "phy0... messages" during the boot process?

yeah I get those messages too

Offline

#122 2011-08-04 18:40:31

aehs29
Member
From: Chihuahua, Mexico
Registered: 2011-03-17
Posts: 7

Re: Broadcom wireless driver - brcm80211

yeah i got em too

Offline

#123 2011-08-05 12:22:20

dutra.julio
Member
Registered: 2011-07-26
Posts: 8

Re: Broadcom wireless driver - brcm80211

Solved here.

Offline

#124 2011-08-05 12:31:11

dw
Member
From: Vienna, Austria
Registered: 2006-11-25
Posts: 157

Re: Broadcom wireless driver - brcm80211

hm, this is starting to get funny. i just came home from work and bootet and - surprise surprise - the device doesn't get up even i had rebooted yesterday for about 15 times and it came up every single time.

anyway, just tried 5 times and the card didn't come up even once, so i am back with 2.6 for now....

Offline

#125 2011-08-05 22:08:35

aehs29
Member
From: Chihuahua, Mexico
Registered: 2011-03-17
Posts: 7

Re: Broadcom wireless driver - brcm80211

im staying on 3.0 the card has shown up every reboot, just didnt that one time, but never happened again, so im staying , only weird thing si those messages about phy0 but i thiknk its safe to say its solved

Offline

Board footer

Powered by FluxBB