You are not logged in.

#1 2005-07-05 00:09:40

aquila_deus
Member
From: Taipei
Registered: 2005-07-02
Posts: 348
Website

I built wxMusik successfully!

Hi all!

I built wxMusik 0.4.1 successfully last night, but it uses a close-sourced library, so I dunno how to package it.

Here is the screenshot:
http://www.aquila-deus.no-ip.org/musik.png

Download:
http://www.aquila-deus.no-ip.org/wxMusi … in.tar.bz2

Dependency: sqllite2 wxgtk flac


Cheers!

Offline

#2 2005-07-05 02:12:07

wickedlester
Member
Registered: 2004-07-22
Posts: 133

Re: I built wxMusik successfully!

How did you add a directory to the library. I don't seem to be able to add anything. Also, thanks for building this. I tried but couldn't get it to work.

Offline

#3 2005-07-05 07:39:37

aquila_deus
Member
From: Taipei
Registered: 2005-07-02
Posts: 348
Website

Re: I built wxMusik successfully!

wickedlester wrote:

How did you add a directory to the library. I don't seem to be able to add anything.

It seems to be a bug in wxGtk, or some API part has been changed.

After first running, shut down it and add your paths (separated by newline) to ~/.Musik/musikpaths.dat, then run it and rebuild library.

e.g. musikpaths.dat:

/home/me/MusicCollections
/usr/share/MusicCollections
wickedlester wrote:

Also, thanks for building this. I tried but couldn't get it to work.

You have better to build it without the three optional dependencies. Some of them are too old.

Offline

#4 2005-07-25 16:31:00

aquila_deus
Member
From: Taipei
Registered: 2005-07-02
Posts: 348
Website

Re: I built wxMusik successfully!

Oh I found the solution to add new music directory - just right click on the bottom part of "Setup Library" dialog box. Clicking on the list doesn't work.

Offline

Board footer

Powered by FluxBB