You are not logged in.

#126 2011-08-24 13:23:43

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

framas wrote:
zephyr wrote:

This method has the drawback that if you boot using normal sysVinit/initscripts to init 5 (if you remove init=/bin/systemd
from kernel command line) a race will occur between agetty in tty1 and X so your CPU gets stuck at 100%.
If you have switched permanently to systemd this will not bother you I suppose.

To avoid it you can modify your /etc/inittab and disable getty on tty, I guess?

I have already tried that during my testing and commenting out the c1/tty1 agetty.
I also tried some other methods but the issue also appeared.

You can of course try it out for yourself.

UPDATE: Updated plymouth-systemd-git package and gdm-plymouth package in AUR.
                Tested GDM and Smooth transition works fine.

Last edited by zephyr (2011-08-24 14:20:34)

Offline

#127 2011-08-25 12:29:08

BasT
Member
Registered: 2010-08-28
Posts: 78

Re: Plymouth is working! How to have a great splash in your box

Zephir on AUR wrote:

Thanks for testing it BasT!

So Smooth transition to KDM works fine? That's good!

This does not interfere at all with KDE or anything else, apart from KDM.

Can you also please post your /usr/share/config/kdm/kdmrc e.g. to paste.kde.org (If you autologin, remove any user names/passwds) and the output of ls /etc/systemd/system/graphical.target.wants?

Can you log in to any other session? For instance, openbox, etc.

Zephir on AUR wrote:

@BasT

Did you switch from plymouth-git to this package? If yes, have you rebuilt the kernel initramfs with mkinitcpio? There are some minor differences between the plymouth package hooks.

If you reenable kdm.service and reboot does KDE startup normally?

First off, I've switched to method 2 now and it seems to work fine. So if you think the problem is due to an error on my part there's no need to concern yourself any further.

Here's the requested info for method 1:
kdmrc: http://paste.kde.org/114229/

$ ls /etc/systemd/system/graphical.target.wants
kdm-unpatched-plymouth.service

I previously hadn't rebuilt the initrd but now I have and these are my testresults:
I have 2 initrds, "default" with all the basic stuff and "plymouth" which is default+plymouth+v86d(uvesafb).

using method 1, kdm.service disabled, kdm-plymouth.service enabled:
plymouth-initrd: kdm starts fine with smooth transition. When trying to log in it either drops back to kdm or crashes with following error:

plymouthd: ply-boot-splash.c:724 ply_boot_splash_become_idle: Assertion 'splash->idle_trigger == ((void *)0)' failed.
error: unexpectedly disconnected from boot satus daemon

default-initrd: drops back to kdm

using method 1, kdm.service enabled, kdm-plymouth.service disabled:
plymouth-initrd: plymouth starts but when kdm is supposed to start the screen gets sent into standby. Not sure what happens "behind the scenes".
default-initrd: kdm starts, login is possible, but switching to tty via ctrl-alt-Fx doesn't work

Offline

#128 2011-08-25 13:44:04

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

BasT wrote:

First off, I've switched to method 2 now and it seems to work fine. So if you think the problem is due to an error on my part there's no need to concern yourself any further.

That's good BasT, Thanks for testing method 2 and I 'm glad it works for you smile

Thanks for the info you posted.
I actually should mention that the smooth transition needs KMS/FOSS drivers, so that the screen won't blank at all for boot.

The only thing that is different in our setups is uvesafb/v86d. I guess you have the nvidia binary drivers (I use nouveau).

I wouldn't worry so much if I were you about method 1/unpatched kdm since it is kind of "experimental".

I will edit the post to mention it as experimental method. The other method should just work, just like GDM needs to be compiled from AUR.

Offline

#129 2011-08-25 14:49:25

KlavKalashj
Member
Registered: 2008-10-09
Posts: 362

Re: Plymouth is working! How to have a great splash in your box

Speaking of smooth transitions and all, is there anyway to have a smooth transition without using systemd?

Offline

#130 2011-08-25 20:46:45

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

KlavKalashj wrote:

Speaking of smooth transitions and all, is there anyway to have a smooth transition without using systemd?

The smooth transition works also without systemd but there are issues that render it useless.
A race issue I mentioned before where X eats 100% cpu.

If someone manages to resolve this, then yes it should work fine.

Offline

#131 2011-08-26 07:42:25

stefano.facchini
Member
Registered: 2010-11-12
Posts: 24

Re: Plymouth is working! How to have a great splash in your box

I have a problem with GDM. If I use the gdm-plymouth.service unit file, GDM gets stuck just after starting, I can only see the spinning mouse cursor and a black background. Switching to other vts there is no login prompt at all (usually gettys are spawned automatically by systemd switching to any empty vt)... any suggestion on debugging this issue?

Of course, I'm using the gdm-plymouth package from AUR.

UPDATE:
If plymouth-quit.service is removed from the Conflicts section in gdm-plymouth.service, GDM starts correctly, but on tty2 and the transition isn't smooth (log messages are visible after the splash screen and before the GDM login screen)

Last edited by stefano.facchini (2011-08-26 10:37:48)

Offline

#132 2011-08-26 12:33:52

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

stefano.facchini wrote:

I have a problem with GDM. If I use the gdm-plymouth.service unit file, GDM gets stuck just after starting, I can only see the spinning mouse cursor and a black background. Switching to other vts there is no login prompt at all (usually gettys are spawned automatically by systemd switching to any empty vt)... any suggestion on debugging this issue?

Of course, I'm using the gdm-plymouth package from AUR.

Can I ask what driver you are using? If you are using intel you may need a package from AUR.
Autospawning of VTs works good here and should work.
Can you try the systemd command line options to have a more debugfull boot: systemd.log_level=debug systemd.log_target=kmsg
And remove quiet or loglevel=3

stefano.facchini wrote:

UPDATE:
If plymouth-quit.service is removed from the Conflicts section in gdm-plymouth.service, GDM starts correctly, but on tty2 and the transition isn't smooth (log messages are visible after the splash screen and before the GDM login screen)

Yes, the unit conflicts with plymouth-quit.service since the gdm-plymouth package i.e. GDM is responsible for stopping plymouth, once it starts.

Offline

#133 2011-08-26 12:46:07

BasT
Member
Registered: 2010-08-28
Posts: 78

Re: Plymouth is working! How to have a great splash in your box

About the patched kde package: will the relevant patches be merged upstream in future versions?

Offline

#134 2011-08-26 13:09:05

stefano.facchini
Member
Registered: 2010-11-12
Posts: 24

Re: Plymouth is working! How to have a great splash in your box

zephyr wrote:

Can I ask what driver you are using? If you are using intel you may need a package from AUR.
Autospawning of VTs works good here and should work.
Can you try the systemd command line options to have a more debugfull boot: systemd.log_level=debug systemd.log_target=kmsg
And remove quiet or loglevel=3

I'm using the r600g open source driver for an ATI card.

And I tried the command line options you suggest, in /var/log/everything.log there are a log of messages about plymouth, what do you need exactly? Anyway, gdm *is* started (as proved by the mouse cursor and the aforementioned logs), just it seems unable to stop plymouth. This would explain also why I can't get any getty on other vts: they are waiting for plymouth to exit!

There are some g_debug in gdm which could help, but I don't know where they are logged. In /var/log/gdm I can't find them...

Offline

#135 2011-08-26 13:12:50

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

BasT wrote:

About the patched kde package: will the relevant patches be merged upstream in future versions?

I don't know.

My guess is no. But it is up to fedora to push them upstream, I suppose.

Offline

#136 2011-08-26 13:18:23

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

stefano.facchini wrote:
zephyr wrote:

Can I ask what driver you are using? If you are using intel you may need a package from AUR.
Autospawning of VTs works good here and should work.
Can you try the systemd command line options to have a more debugfull boot: systemd.log_level=debug systemd.log_target=kmsg
And remove quiet or loglevel=3

I'm using the r600g open source driver for an ATI card.

And I tried the command line options you suggest, in /var/log/everything.log there are a log of messages about plymouth, what do you need exactly? Anyway, gdm *is* started (as proved by the mouse cursor and the aforementioned logs), just it seems unable to stop plymouth. This would explain also why I can't get any getty on other vts: they are waiting for plymouth to exit!

There are some g_debug in gdm which could help, but I don't know where they are logged. In /var/log/gdm I can't find them...

Can you try using xf86-video-ati-plymouth: https://aur.archlinux.org/packages.php?ID=51864
?

Apparently only nouveau has upstream support for -background none.

Last edited by zephyr (2011-08-26 13:19:59)

Offline

#137 2011-08-26 13:32:39

stefano.facchini
Member
Registered: 2010-11-12
Posts: 24

Re: Plymouth is working! How to have a great splash in your box

zephyr wrote:
stefano.facchini wrote:
zephyr wrote:

Can I ask what driver you are using? If you are using intel you may need a package from AUR.
Autospawning of VTs works good here and should work.
Can you try the systemd command line options to have a more debugfull boot: systemd.log_level=debug systemd.log_target=kmsg
And remove quiet or loglevel=3

I'm using the r600g open source driver for an ATI card.

And I tried the command line options you suggest, in /var/log/everything.log there are a log of messages about plymouth, what do you need exactly? Anyway, gdm *is* started (as proved by the mouse cursor and the aforementioned logs), just it seems unable to stop plymouth. This would explain also why I can't get any getty on other vts: they are waiting for plymouth to exit!

There are some g_debug in gdm which could help, but I don't know where they are logged. In /var/log/gdm I can't find them...

Can you try using xf86-video-ati-plymouth: https://aur.archlinux.org/packages.php?ID=51864
?

Apparently only nouveau has upstream support for -background none.

Mmhh no luck... with xf86-video-ati-plymouth the only difference is that the splash screen is retained when gdm starts, namely I have the mouse cursor with the splash image as background.

Offline

#138 2011-08-26 13:54:26

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

stefano.facchini wrote:
zephyr wrote:
stefano.facchini wrote:

I'm using the r600g open source driver for an ATI card.

And I tried the command line options you suggest, in /var/log/everything.log there are a log of messages about plymouth, what do you need exactly? Anyway, gdm *is* started (as proved by the mouse cursor and the aforementioned logs), just it seems unable to stop plymouth. This would explain also why I can't get any getty on other vts: they are waiting for plymouth to exit!

There are some g_debug in gdm which could help, but I don't know where they are logged. In /var/log/gdm I can't find them...

Can you try using xf86-video-ati-plymouth: https://aur.archlinux.org/packages.php?ID=51864
?

Apparently only nouveau has upstream support for -background none.

Mmhh no luck... with xf86-video-ati-plymouth the only difference is that the splash screen is retained when gdm starts, namely I have the mouse cursor with the splash image as background.

Well so, if the smooth transition works, plymouth gets killed correctly.

Can you login normally, click on the menu on the top right etc.? Maybe a theme setting? I have only used default settings on GDM.

About the VTs. If you do "systemctl enable getty@tty2.service" and reboot, tty2 should have a getty. Do the other VTs autospawn?

/var/log/gdm files should provide some clues, but I do not know much about GDM. Maybe enable the syslog-ng.service?

EDIT: Are you using the spinfinity theme? If yes can you try another theme e.g.  spinner? You may be hitting an upstream bug: https://bugzilla.redhat.com/show_bug.cgi?id=704658

EDIT 2: Does LXDM work properly? Allowing you to login etc.? It could be a bug in GDM plymouth's integration?

Last edited by zephyr (2011-08-26 14:15:49)

Offline

#139 2011-08-26 14:41:22

stefano.facchini
Member
Registered: 2010-11-12
Posts: 24

Re: Plymouth is working! How to have a great splash in your box

zephyr wrote:

EDIT: Are you using the spinfinity theme? If yes can you try another theme e.g.  spinner? You may be hitting an upstream bug: https://bugzilla.redhat.com/show_bug.cgi?id=704658

Good catch! the "spinner" theme works perfectly! Thank you very much for your help.

If you are interested, here are the warnings I got in gdm logs /var/log/gdm/:0-slave.log


gdm-simple-slave[651]: DEBUG(+): quitting plymouth with transition
gdm-simple-slave[651]: DEBUG(+): GdmSlave: Requesting timed login details
gdm-simple-slave[651]: WARNING: Failed to get timed login details: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
gdm-simple-slave[651]: DEBUG(+): GdmSimpleSlave: Running greeter
gdm-simple-slave[651]: DEBUG(+): GdmSimpleSlave: Creating greeter for :0
gdm-simple-slave[651]: DEBUG(+): GdmServer: Running helper /usr/lib/ConsoleKit/ck-get-x11-display-device --display :0

** (ck-get-x11-display-device:699): WARNING **: cannot open display: :0
gdm-simple-slave[651]: DEBUG(+): GdmServer: Got tty: ''

[...]

gdm-simple-slave[651]: DEBUG(+): GdmWelcomeSession: Registering session with ConsoleKit
gdm-simple-slave[651]: DEBUG(+): GdmWelcomeSession: Opening ConsoleKit session for user:120 x11-display:':0' x11-display-device:'' remote-host-name:'' is-local:1
gdm-simple-slave[651]: WARNING: Unable to open session: Failed to connect to socket /var/run/dbus/system_bus_socket: Connessione rifiutata

[...]

gdm-simple-slave[651]: DEBUG(+): GdmSimpleSlave: Creating new session
gdm-simple-slave[651]: DEBUG(+): GdmSessionDirect: Creating D-Bus server for session
gdm-simple-slave[651]: DEBUG(+): GdmSessionDirect: D-Bus server listening on unix:abstract=/tmp/gdm-session-wGunpSZe,guid=9d91d578b67b61d723c2838c00000029
gdm-simple-slave[651]: DEBUG(+): GdmSessionDirect: Setting display device:
gdm-simple-slave[651]: DEBUG(+): GdmSessionDirect: Registering /org/gnome/DisplayManager/Session1
gdm-simple-slave[651]: CRITICAL: error getting system bus: Failed to connect to socket /var/run/dbus/system_bus_socket: Connessione rifiutata

Offline

#140 2011-08-26 20:16:16

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

@stefano.facchini

That's great, I'm glad it works for you and thanks for testing!

That  means that ATI users should have this working by installing xf86-video-ati-plymouth.

@BasT

Where you also using spinfinity with method 1? It could be the same problem.
Can I also ask what driver you are using?

@anyone

Has anyone tried this with intel graphics drivers?

Offline

#141 2011-08-26 20:25:01

KlavKalashj
Member
Registered: 2008-10-09
Posts: 362

Re: Plymouth is working! How to have a great splash in your box

zephyr wrote:

@anyone

Has anyone tried this with intel graphics drivers?

I tried it. I installed systemd, plymouth-systemd-git, kdebase-workspace-plymouth and xf86-video-intel-plymouth, and had everything set up correctly according to instructions from wiki and here, but it did not work, so I gave up. Using KDE on x86_64, x4500MHD. I also tried changing the theme to 'spinner'.

Offline

#142 2011-08-26 20:36:05

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

KlavKalashj wrote:
zephyr wrote:

@anyone

Has anyone tried this with intel graphics drivers?

I tried it. I installed systemd, plymouth-systemd-git, kdebase-workspace-plymouth and xf86-video-intel-plymouth, and had everything set up correctly according to instructions from wiki and here, but it did not work, so I gave up. Using KDE on x86_64, x4500MHD. I also tried changing the theme to 'spinner'.

Thanks KlavKalashj!

I guess something is missing for intel users... If I find anything I will post it here.

EDIT: I have downgraded the xf86-video-intel-plymouth package to 2.15.0, the same as the repos and applied other patches.
It seems the intel-plymouth integration breaks quite often, and the last known working version must be 2.14 that is used in fedora/ubuntu latest.

I'm fresh out of ideas why it does not work for intel gfx.

Last edited by zephyr (2011-08-27 01:57:06)

Offline

#143 2011-08-27 20:56:59

KlavKalashj
Member
Registered: 2008-10-09
Posts: 362

Re: Plymouth is working! How to have a great splash in your box

zephyr wrote:
KlavKalashj wrote:
zephyr wrote:

@anyone

Has anyone tried this with intel graphics drivers?

I tried it. I installed systemd, plymouth-systemd-git, kdebase-workspace-plymouth and xf86-video-intel-plymouth, and had everything set up correctly according to instructions from wiki and here, but it did not work, so I gave up. Using KDE on x86_64, x4500MHD. I also tried changing the theme to 'spinner'.

Thanks KlavKalashj!

I guess something is missing for intel users... If I find anything I will post it here.

EDIT: I have downgraded the xf86-video-intel-plymouth package to 2.15.0, the same as the repos and applied other patches.
It seems the intel-plymouth integration breaks quite often, and the last known working version must be 2.14 that is used in fedora/ubuntu latest.

I'm fresh out of ideas why it does not work for intel gfx.

Ok, I'm back up on the horse! big_smile I realized my TV maybe mess things up, as xorg initially starts in another resolution than the KMS resolution. But even when laptop is disconnected from TV and xorg start at native resolution, it still doesn't work. I see the splash, then black screen with a "_" in top left corner, then KDE splash screen with no smooth transition. I am using your downgraded xf86-video-intel-plymouth. I'm also running out of ideas!

Edit: Hm, X seems to be running on tty2, not tty1. Could this be something?

Last edited by KlavKalashj (2011-08-27 22:52:47)

Offline

#144 2011-08-28 00:52:43

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

KlavKalashj wrote:
zephyr wrote:
KlavKalashj wrote:

I tried it. I installed systemd, plymouth-systemd-git, kdebase-workspace-plymouth and xf86-video-intel-plymouth, and had everything set up correctly according to instructions from wiki and here, but it did not work, so I gave up. Using KDE on x86_64, x4500MHD. I also tried changing the theme to 'spinner'.

Thanks KlavKalashj!

I guess something is missing for intel users... If I find anything I will post it here.

EDIT: I have downgraded the xf86-video-intel-plymouth package to 2.15.0, the same as the repos and applied other patches.
It seems the intel-plymouth integration breaks quite often, and the last known working version must be 2.14 that is used in fedora/ubuntu latest.

I'm fresh out of ideas why it does not work for intel gfx.

Ok, I'm back up on the horse! big_smile I realized my TV maybe mess things up, as xorg initially starts in another resolution than the KMS resolution. But even when laptop is disconnected from TV and xorg start at native resolution, it still doesn't work. I see the splash, then black screen with a "_" in top left corner, then KDE splash screen with no smooth transition. I am using your downgraded xf86-video-intel-plymouth. I'm also running out of ideas!

Edit: Hm, X seems to be running on tty2, not tty1. Could this be something?

Yes, for the smooth integration to work X must be started on tty1.
Can you try LXDM(It has minimal dependencies and starts on VT1)? See my original post for instructions, you need to edit /etc/lxdm/lxdm.conf.

There is also a fedora bug about the plymouth intel integration: https://bugzilla.redhat.com/show_bug.cgi?id=639088
It could be a problem with intel's kms. For smooth transition, there must not be a VT switch or a modeset(resolution) switch.

I hope I'll my hands on an intel system this week, so I could test this myself.

Last edited by zephyr (2011-08-28 00:53:16)

Offline

#145 2011-08-28 07:26:03

KlavKalashj
Member
Registered: 2008-10-09
Posts: 362

Re: Plymouth is working! How to have a great splash in your box

zephyr wrote:
KlavKalashj wrote:
zephyr wrote:

Thanks KlavKalashj!

I guess something is missing for intel users... If I find anything I will post it here.

EDIT: I have downgraded the xf86-video-intel-plymouth package to 2.15.0, the same as the repos and applied other patches.
It seems the intel-plymouth integration breaks quite often, and the last known working version must be 2.14 that is used in fedora/ubuntu latest.

I'm fresh out of ideas why it does not work for intel gfx.

Ok, I'm back up on the horse! big_smile I realized my TV maybe mess things up, as xorg initially starts in another resolution than the KMS resolution. But even when laptop is disconnected from TV and xorg start at native resolution, it still doesn't work. I see the splash, then black screen with a "_" in top left corner, then KDE splash screen with no smooth transition. I am using your downgraded xf86-video-intel-plymouth. I'm also running out of ideas!

Edit: Hm, X seems to be running on tty2, not tty1. Could this be something?

Yes, for the smooth integration to work X must be started on tty1.
Can you try LXDM(It has minimal dependencies and starts on VT1)? See my original post for instructions, you need to edit /etc/lxdm/lxdm.conf.

There is also a fedora bug about the plymouth intel integration: https://bugzilla.redhat.com/show_bug.cgi?id=639088
It could be a problem with intel's kms. For smooth transition, there must not be a VT switch or a modeset(resolution) switch.

I hope I'll my hands on an intel system this week, so I could test this myself.

Tried LXDM, same result. Doesn't work, with or without TV. It did start on tty1 though! smile Must be that bug... ?

Edit: I'm really close now. I removed initscripts-systemd and arch-units-systemd, now KDM starts on tty1.

Last edited by KlavKalashj (2011-08-28 09:58:51)

Offline

#146 2011-08-28 12:16:17

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

KlavKalashj wrote:
zephyr wrote:
KlavKalashj wrote:

Ok, I'm back up on the horse! :D I realized my TV maybe mess things up, as xorg initially starts in another resolution than the KMS resolution. But even when laptop is disconnected from TV and xorg start at native resolution, it still doesn't work. I see the splash, then black screen with a "_" in top left corner, then KDE splash screen with no smooth transition. I am using your downgraded xf86-video-intel-plymouth. I'm also running out of ideas!

Edit: Hm, X seems to be running on tty2, not tty1. Could this be something?

Yes, for the smooth integration to work X must be started on tty1.
Can you try LXDM(It has minimal dependencies and starts on VT1)? See my original post for instructions, you need to edit /etc/lxdm/lxdm.conf.

There is also a fedora bug about the plymouth intel integration: https://bugzilla.redhat.com/show_bug.cgi?id=639088
It could be a problem with intel's kms. For smooth transition, there must not be a VT switch or a modeset(resolution) switch.

I hope I'll my hands on an intel system this week, so I could test this myself.

Tried LXDM, same result. Doesn't work, with or without TV. It did start on tty1 though! :) Must be that bug... ?

Edit: I'm really close now. I removed initscripts-systemd and arch-units-systemd, now KDM starts on tty1.

Well, I have two ideas: It could be intel's KMS bug or a plymouth handoff bug.

You could try the intel driver 2.14.0, which is known to work in fedora. I have uploaded it to the AUR: xf86-video-plymouth: https://aur.archlinux.org/packages.php?ID=51858
If it works it is a problem with the patches for newer versions.

If it doesn't plymouth's log could provide a clue.
To enable debugging in plymouth from early start you have to:

edit /lib/initcpio/hooks/plymouth line 8:

Change from:   

/sbin/plymouthd --mode=boot --pid-file=/run/plymouth/pid

to: 

/sbin/plymouthd --mode=boot --debug --debug-file=/run/plymouth/plymouth-debug.log --pid-file=/run/plymouth/pid

And rebuild initramfs with mkinitcpio -p linux (or whatever kernel name preset you may use)

Plymouth's log should then be in /run/plymouth/plymouth-debug.log

Offline

#147 2011-08-28 12:58:15

KlavKalashj
Member
Registered: 2008-10-09
Posts: 362

Re: Plymouth is working! How to have a great splash in your box

zephyr wrote:
KlavKalashj wrote:
zephyr wrote:

Yes, for the smooth integration to work X must be started on tty1.
Can you try LXDM(It has minimal dependencies and starts on VT1)? See my original post for instructions, you need to edit /etc/lxdm/lxdm.conf.

There is also a fedora bug about the plymouth intel integration: https://bugzilla.redhat.com/show_bug.cgi?id=639088
It could be a problem with intel's kms. For smooth transition, there must not be a VT switch or a modeset(resolution) switch.

I hope I'll my hands on an intel system this week, so I could test this myself.

Tried LXDM, same result. Doesn't work, with or without TV. It did start on tty1 though! smile Must be that bug... ?

Edit: I'm really close now. I removed initscripts-systemd and arch-units-systemd, now KDM starts on tty1.

Well, I have two ideas: It could be intel's KMS bug or a plymouth handoff bug.

You could try the intel driver 2.14.0, which is known to work in fedora. I have uploaded it to the AUR: xf86-video-plymouth: https://aur.archlinux.org/packages.php?ID=51858
If it works it is a problem with the patches for newer versions.

If it doesn't plymouth's log could provide a clue.
To enable debugging in plymouth from early start you have to:

edit /lib/initcpio/hooks/plymouth line 8:

Change from:   

/sbin/plymouthd --mode=boot --pid-file=/run/plymouth/pid

to: 

/sbin/plymouthd --mode=boot --debug --debug-file=/run/plymouth/plymouth-debug.log --pid-file=/run/plymouth/pid

And rebuild initramfs with mkinitcpio -p linux (or whatever kernel name preset you may use)

Plymouth's log should then be in /run/plymouth/plymouth-debug.log

With the 2.14.0 driver I got the same result as with .15 and .16. The only difference I notice from the one in [core] is that the patched ones keep the plymouth background until login screen appears. With the one in [core] the screen repaints with black when X starts. It's actually very nice with the patched ones, but it is an instant switch from plymouth background to login screen, not a smooth transition. I think I'm gonna keep it this way for now, either I'm doing something wrong or there are bugs in the intel driver, kdm, X or plymouth, I don't know.

I tried to get a plymouth log, but failed again tongue The log file is never created, even if I touch it before, or change it to another directory. I can see some debug messages when I shut down, after X closes, but it flashes to fast for me to read anything useful.

So, thank you so much for all your help and quick replies, and I hope you and anyone else attempting this has better luck tongue

P.s: If you could upload the xf86-video-intel-plymouth v. 2.16.0 again it would be awesome, that one was a bit smoother inside KDE smile Thanks!

Offline

#148 2011-08-28 13:17:31

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

KlavKalashj wrote:
zephyr wrote:
KlavKalashj wrote:

Tried LXDM, same result. Doesn't work, with or without TV. It did start on tty1 though! smile Must be that bug... ?

Edit: I'm really close now. I removed initscripts-systemd and arch-units-systemd, now KDM starts on tty1.

Well, I have two ideas: It could be intel's KMS bug or a plymouth handoff bug.

You could try the intel driver 2.14.0, which is known to work in fedora. I have uploaded it to the AUR: xf86-video-plymouth: https://aur.archlinux.org/packages.php?ID=51858
If it works it is a problem with the patches for newer versions.

If it doesn't plymouth's log could provide a clue.
To enable debugging in plymouth from early start you have to:

edit /lib/initcpio/hooks/plymouth line 8:

Change from:   

/sbin/plymouthd --mode=boot --pid-file=/run/plymouth/pid

to: 

/sbin/plymouthd --mode=boot --debug --debug-file=/run/plymouth/plymouth-debug.log --pid-file=/run/plymouth/pid

And rebuild initramfs with mkinitcpio -p linux (or whatever kernel name preset you may use)

Plymouth's log should then be in /run/plymouth/plymouth-debug.log

With the 2.14.0 driver I got the same result as with .15 and .16. The only difference I notice from the one in [core] is that the patched ones keep the plymouth background until login screen appears. With the one in [core] the screen repaints with black when X starts. It's actually very nice with the patched ones, but it is an instant switch from plymouth background to login screen, not a smooth transition. I think I'm gonna keep it this way for now, either I'm doing something wrong or there are bugs in the intel driver, kdm, X or plymouth, I don't know.

I tried to get a plymouth log, but failed again tongue The log file is never created, even if I touch it before, or change it to another directory. I can see some debug messages when I shut down, after X closes, but it flashes to fast for me to read anything useful.

So, thank you so much for all your help and quick replies, and I hope you and anyone else attempting this has better luck tongue

P.s: If you could upload the xf86-video-intel-plymouth v. 2.16.0 again it would be awesome, that one was a bit smoother inside KDE smile Thanks!

So let me get this straight, just so that we are on the same page:

Even with xf86-video-intel-plymouth 2.16 or 2.15, you boot up, plymouth comes up with Wallpaper no.1. Then the Xcursor appears without the screen ever turning black and a sudden switch to the new KDM's wallpaper happens? Meaning you have no black screen at all during boot?

If yes, then congrats it is working as expected. I thought you were getting a black screen in-between plymouth->X even with the patched intel drivers.
AFAIK only GDM has at the moment a fade animation between plymouth -> X. KDM does not have that effect yet.

I'm terribly sorry for not clearing this up sooner, I thought you were getting a black screen in-between plymouth->X.

I will upload xf86-video-intel-plymouth 2.16.0 to AUR soon! smile

EDIT: My workaround for a smoothest experience would be to use the same wallpaper with plymouth/KDM/ksplash. I currently have it set up this way  and it actually is pretty nice.

Last edited by zephyr (2011-08-28 13:19:55)

Offline

#149 2011-08-28 13:43:11

KlavKalashj
Member
Registered: 2008-10-09
Posts: 362

Re: Plymouth is working! How to have a great splash in your box

zephyr wrote:
KlavKalashj wrote:
zephyr wrote:

Well, I have two ideas: It could be intel's KMS bug or a plymouth handoff bug.

You could try the intel driver 2.14.0, which is known to work in fedora. I have uploaded it to the AUR: xf86-video-plymouth: https://aur.archlinux.org/packages.php?ID=51858
If it works it is a problem with the patches for newer versions.

If it doesn't plymouth's log could provide a clue.
To enable debugging in plymouth from early start you have to:

edit /lib/initcpio/hooks/plymouth line 8:

Change from:   

/sbin/plymouthd --mode=boot --pid-file=/run/plymouth/pid

to: 

/sbin/plymouthd --mode=boot --debug --debug-file=/run/plymouth/plymouth-debug.log --pid-file=/run/plymouth/pid

And rebuild initramfs with mkinitcpio -p linux (or whatever kernel name preset you may use)

Plymouth's log should then be in /run/plymouth/plymouth-debug.log

With the 2.14.0 driver I got the same result as with .15 and .16. The only difference I notice from the one in [core] is that the patched ones keep the plymouth background until login screen appears. With the one in [core] the screen repaints with black when X starts. It's actually very nice with the patched ones, but it is an instant switch from plymouth background to login screen, not a smooth transition. I think I'm gonna keep it this way for now, either I'm doing something wrong or there are bugs in the intel driver, kdm, X or plymouth, I don't know.

I tried to get a plymouth log, but failed again tongue The log file is never created, even if I touch it before, or change it to another directory. I can see some debug messages when I shut down, after X closes, but it flashes to fast for me to read anything useful.

So, thank you so much for all your help and quick replies, and I hope you and anyone else attempting this has better luck tongue

P.s: If you could upload the xf86-video-intel-plymouth v. 2.16.0 again it would be awesome, that one was a bit smoother inside KDE smile Thanks!

So let me get this straight, just so that we are on the same page:

Even with xf86-video-intel-plymouth 2.16 or 2.15, you boot up, plymouth comes up with Wallpaper no.1. Then the Xcursor appears without the screen ever turning black and a sudden switch to the new KDM's wallpaper happens? Meaning you have no black screen at all during boot?

If yes, then congrats it is working as expected. I thought you were getting a black screen in-between plymouth->X even with the patched intel drivers.
AFAIK only GDM has at the moment a fade animation between plymouth -> X. KDM does not have that effect yet.

I'm terribly sorry for not clearing this up sooner, I thought you were getting a black screen in-between plymouth->X.

I will upload xf86-video-intel-plymouth 2.16.0 to AUR soon! smile

EDIT: My workaround for a smoothest experience would be to use the same wallpaper with plymouth/KDM/ksplash. I currently have it set up this way  and it actually is pretty nice.

Haha, yes, that's exactly how I get it! I thought there was gonna be a fade-in similar to ksplash -> desktop. I guess we'll have to wait for that, then smile I will look into changing the plymouth background, thanks for the tip!

Offline

#150 2011-08-28 13:54:32

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

KlavKalashj wrote:

Haha, yes, that's exactly how I get it! I thought there was gonna be a fade-in similar to ksplash -> desktop. I guess we'll have to wait for that, then smile I will look into changing the plymouth background, thanks for the tip!

No worries, I had that expectation too at first big_smile:D

Reuploaded xf86-video-intel-plymouth 2.16.0 again, get it from AUR.

Another tip, if you want to reinstall systemd-arch-units and initscripts-systemd, woul be to edit kdmrc and switch "ServerVTs=-1" to "ServerVTs=1" although the -1 should work by itself with kdebase-workspace-plymouth.

I have a plymouth theme here based on a gnome one that integrates nicely with my ksplash theme (I autologin to KDE). Once I finish it, I will upload it somewhere and package it soon.
It is really easy to replace its wallpaper. More info when I finish it. smile

Offline

Board footer

Powered by FluxBB