You are not logged in.

#1 2011-09-03 02:55:50

fast_rizwaan
Member
Registered: 2010-04-01
Posts: 65

[SOLVED] Whirring noise in recording via mic - will HW mixing help?

I'm getting whirring noise in mic recording (adjustng mic and mic-boost does not help) it also happens on ubuntu 11.04; so I guess it is a hardware issue. Strangely, I hear no noise in Windows XP in recording (sound recorder). Whereas in Archlinux, skype, audacity, arecord, gnome-sound-recorder all are having whirring noise.

I guess, it might have something to do with Intel Audio, so I'm planning to buy Creative Sound Blaster Live 5.1 (emu10k1), which has Hardware Mixing feature supported by Alsa.

Do you know any way to "suppress noise" and "echo cancellation" in arch for microphone recording?

Please advise.


We can hear the noise (unamplified/no mic boost) test-mic.wav recorded

arecord -f cd -d 5 test-mic.wav
  

http://www.mediafire.com/?e6n9t2sr6vwpv73

lspci wrote:

00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 10)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 10)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 01)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation G92 [GeForce 9800 GT] (rev a2)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)

Last edited by fast_rizwaan (2011-09-08 00:29:10)

Offline

#2 2011-09-03 13:08:24

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,627

Re: [SOLVED] Whirring noise in recording via mic - will HW mixing help?

That noise is probably caused by some other hardware in your computer. Built-in cards are not known for their sound quality, not because the sound controller and codec are bad but because they are not sufficiently isolated and shielded from interference from other components inside the computer/laptop. Record a few seconds of silence, open the wav file in audacity (can be other program) and ask it to plot the spectrum, you will see peaks around 5KHz, near 10KHz and near 15KHz, that is consistent with interference generated from a pwm source, with all the peaks around it maybe generated by aliasing in the sampling or other less noisy sources.

Why it doesn't manifest itself when using windows ... I have no clue.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#3 2011-09-07 23:34:23

fast_rizwaan
Member
Registered: 2010-04-01
Posts: 65

Re: [SOLVED] Whirring noise in recording via mic - will HW mixing help?

hi archers,

I went to the computre hardware market today to buy 'Creative Sound Blaster Live 5.1 with emu10k1 chipset'.

I thought that having hardware mixing (HWMIX) will fix noise, as the sound card is shielded from interference.

But, unfortunately or fortunately, the SBS 5.1 is not available in the market. only SBS 5.1VX model which has a different chipset is available.

So, I retured a bit disappointed thinking that the evil microsoft has caused the soundcard manufactureres to stop support  to non MS OS, oh my poor linux hardware!

Based on the following, http://www.voxforge.org/home/docs/faq/f … pling-rate

I tried fiddling with sample rate, and you know what, the whirring noise is gone. It's like  Windows (without fan noise suppression and echo cancellation but no static noise)

HURRAY I FOUND THE SOLUTION: setting the sound-card sampling-rate to 96000 (for my intel sound card) fixes the noise!

Here's HOWTO fix microphone noise problem in linux which was bugging me for many years!

1. Determine soundcards in the system

    $  arecord --list-devices
output wrote:

**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 2: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

soudcar  is hw:0,0

2. Determine Sound card's sampling-rate of the sound card

arecord -f dat -r 60000 -D hw:0,0 -d 5 test.wav
output wrote:

"Recording WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 60000 Hz, Stereo
Warning: rate is not accurate (requested = 60000Hz, got = 96000Hz)
         please, try the plug plugin

Now that we got the max-sampling-rate to 96000, we should set this in pulseaudio's configuration file /etc/pulse/daemon.conf. So first test it:

Just a quick test

  arecord -f dat -r 96000 -D hw:0,0 -d 5 test.wav 

And surprise, surprise, no whirring static noise in the mic recording in linux. Hurray again!

3. Setting the soundcard's sampling rate into pulse audio configuration
the default sample-rate in pulseaudio is

cat /etc/pulse/daemon.conf|grep sample-rate
output wrote:

; default-sample-rate = 44100

we got 44100 and which is disabled

Let's set that to our hardware specific settings:

su -c "sed 's/; default-sample-rate = 44100/default-sample-rate = 96000/g' -i /etc/pulse/daemon.conf"

let's verify the changes to deamon.conf

cat /etc/pulse/daemon.conf|grep sample-rate
output wrote:

default-sample-rate = 96000

It's done

4. Restart pulseaudio to apply the new settings

pulseaudio --kill
pulseaudio --start

That's it, now Skype, and all microphone related application will have neat audio! Thanks Archers. hope it helps.

Is there a way to suppress fan noise in pulseaudio, cause the fan noise is bothering me now at forvo.com smile

I also updated the pulseaudio wiki https://wiki.archlinux.org/index.php/Pu … _Recording

Last edited by fast_rizwaan (2011-09-08 00:27:53)

Offline

#4 2015-03-27 00:18:39

Jhackler
Member
Registered: 2014-01-27
Posts: 4

Re: [SOLVED] Whirring noise in recording via mic - will HW mixing help?

Mine was 48000 for correct sample rate but still have static even added pulse audio noise cancelling module didn't make a difference sad Just bought a mod mic for better quality and was left with a background hiss that exist even without mic plugged in. sad

Offline

#5 2015-03-27 00:52:27

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,810
Website

Re: [SOLVED] Whirring noise in recording via mic - will HW mixing help?

Welcome to the forums Jhackler.  Please note the dates of posts and avoid "necrobumping" old threads - especially solved ones.  Things change quickly in archlinux: 4 years is a long time.  Also, as the OP hasn't even been online in almost 3 years, I doubt this thread will go anywhere.

Feel free to open your own thread if you need help - you can link to this one if you think it's related.  But I'll close this one.

Closed.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

Board footer

Powered by FluxBB