You are not logged in.

#1 2011-09-03 08:11:32

Compulsed
Member
Registered: 2011-08-24
Posts: 44

tightVNC not loading properly

Hey I've just installed tight VNC  today and I've had everything working until I rebooted.
When I load my interface I get a blank screen with a startx looking interface with no models rather then my old xfce4 one.

My xstartup file

#!/bin/sh

#xrdb $HOME/.Xresources
#xsetroot -solid grey
#xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#twm &

export XKL_XMODMAP_DISABLE=1
#exec ck-launch-session startlxde	#for an lxde session
#exec ck-launch-session gnome-session	#for a gnome-session
#exec ck-launch-session openbox-session	#for an openbox desktop
exec ck-launch-session startxfce4	#for an xfce desktop
#exec ck-launch-session icewm	#for an icewm desktop
#exec ck-launch-session startkde	#for a kde desktop

My log files with errors

Couldn't open RGB_DB '/usr/share/X11/rgb'
03/09/11 06:00:15 Xvnc version TightVNC-1.3.10
03/09/11 06:00:15 Copyright (C) 2000-2009 TightVNC Group
03/09/11 06:00:15 Copyright (C) 1999 AT&T Laboratories Cambridge
03/09/11 06:00:15 All Rights Reserved.
03/09/11 06:00:15 See http://www.tightvnc.com/ for information on TightVNC
03/09/11 06:00:15 Desktop name 'X' (Archy:1)
03/09/11 06:00:15 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
03/09/11 06:00:15 Listening for VNC connections on TCP port 5901
03/09/11 06:00:15 Listening for HTTP connections on TCP port 5801
03/09/11 06:00:15   URL http://Archy:5801
/usr/bin/startxfce4: X server already running on display :1
ssh-agent is already running
Xlib:  extension "RANDR" missing on display ":1".

** ERROR **: Another session manager is already running
aborting...
/etc/xdg/xfce4/xinitrc: line 221:  1838 Aborted                 xfce4-session

03/09/11 06:00:24 Got connection from client 127.0.0.1
03/09/11 06:00:24 Using protocol version 3.8
03/09/11 06:00:25 Enabling TightVNC protocol extensions
03/09/11 06:00:27 Full-control authentication passed by 127.0.0.1
03/09/11 06:00:27 Pixel format for client 127.0.0.1:
03/09/11 06:00:27   32 bpp, depth 24, little endian
03/09/11 06:00:27   true colour: max r 255 g 255 b 255, shift r 16 g 8 b 0
03/09/11 06:00:27   no translation needed
03/09/11 06:00:27 Using tight encoding for client 127.0.0.1
03/09/11 06:00:27 rfbProcessClientNormalMessage: ignoring unknown encoding 8
03/09/11 06:00:27 Enabling X-style cursor updates for client 127.0.0.1
03/09/11 06:00:27 Enabling cursor position updates for client 127.0.0.1
03/09/11 06:00:27 Using image quality level 6 for client 127.0.0.1
03/09/11 06:00:27 Enabling LastRect protocol extension for client 127.0.0.1
03/09/11 06:00:27 rfbProcessClientNormalMessage: ignoring unknown encoding -223
03/09/11 06:00:30 Client 127.0.0.1 gone
03/09/11 06:00:30 Statistics:
03/09/11 06:00:30   key events received 0, pointer events 20
03/09/11 06:00:30   framebuffer updates 1, rectangles 15, bytes 1068
03/09/11 06:00:30     LastRect markers 1, bytes 12
03/09/11 06:00:30     cursor shape updates 1, bytes 82
03/09/11 06:00:30     cursor position updates 1, bytes 12
03/09/11 06:00:30     tight rectangles 12, bytes 962
03/09/11 06:00:30   raw bytes equivalent 3145740, compression ratio 3270.000000

With a particular interest in this line of code

** ERROR **: Another session manager is already running
aborting...
/etc/xdg/xfce4/xinitrc: line 221:  1838 Aborted                 xfce4-session

Thanks in advance!

Last edited by Compulsed (2011-09-03 08:15:11)

Offline

#2 2011-09-03 13:45:08

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: tightVNC not loading properly

Can you show us your /etc/xdg/xfce4/xinitrc?

Offline

#3 2011-09-07 00:34:57

Compulsed
Member
Registered: 2011-08-24
Posts: 44

Re: tightVNC not loading properly

Yeah, once I get home sorry for the late reply I've had problems with my internet connection.

Last edited by Compulsed (2011-09-07 00:35:08)

Offline

#4 2011-09-07 10:30:14

Compulsed
Member
Registered: 2011-08-24
Posts: 44

Re: tightVNC not loading properly

 

/etc/xdg/xfce4/xinitrc  /etc/xdg/xfce4/xinitrc  /etc/xdg/xfce4/xinitrc  /etc/xdg/xfce4/xinitrc  /etc/xdg/xfce4/xinitrc  
[ -d "$XDG_CONFIG_HOME" ] || mkdir "$XDG_CONFIG_HOME"

# $XDG_CACHE_HOME defines the base directory relative to which user specific
# non-essential data files should be stored. If $XDG_CACHE_HOME is either not
# set or empty, a default equal to $HOME/.cache should be used.
if test "x$XDG_CACHE_HOME" = "x" ; then
  XDG_CACHE_HOME=$HOME/.cache
fi
[ -d "$XDG_CACHE_HOME" ] || mkdir "$XDG_CACHE_HOME"


# set up XDG user directores.  see
# http://freedesktop.org/wiki/Software/xdg-user-dirs
if which xdg-user-dirs-update >/dev/null 2>&1; then
    xdg-user-dirs-update
fi

if test -f "$XDG_CONFIG_HOME/user-dirs.dirs"; then
    . "$XDG_CONFIG_HOME/user-dirs.dirs"
    # i'm deliberately not 'export'-ing the XDG_ vars, because you shouldn't
    # rely on the env vars inside apps, since the file could be changed at
    # any time by the user.  this is solely here for migration purposes.

    # a bit of user dir migration...
    if test -d "$HOME/Desktop" -a ! -L "$HOME/Desktop" \
            -a "$XDG_DESKTOP_DIR" \
            -a "$HOME/Desktop" != "$XDG_DESKTOP_DIR"
    then
        echo "Migrating $HOME/Desktop to $XDG_DESKTOP_DIR..."
        test -d "$XDG_DESKTOP_DIR" && rmdir "$XDG_DESKTOP_DIR"
        mv "$HOME/Desktop" "$XDG_DESKTOP_DIR" || echo "Desktop migration failed" >&2
    fi

    if test -d "$HOME/Templates" -a ! -L "$HOME/Templates" \
            -a "$XDG_TEMPLATES_DIR" \
            -a "$HOME/Templates" != "$XDG_TEMPLATES_DIR"
    then
        echo "Migrating $HOME/Templates to $XDG_TEMPLATES_DIR..."
        test -d "$XDG_TEMPLATES_DIR" && rmdir "$XDG_TEMPLATES_DIR"
        mv "$HOME/Templates" "$XDG_TEMPLATES_DIR" || echo "Templates migration failed" >&2
    fi
fi


# Modify libglade and glade environment variables so that
# it will find the files installed by Xfce
LIBGLADE_MODULE_PATH="$LIBGLADE_MODULE_PATH:"
GLADE_CATALOG_PATH="$GLADE_CATALOG_PATH:"
GLADE_PIXMAP_PATH="$GLADE_PIXMAP_PATH:"
GLADE_MODULE_PATH="$GLADE_MODULE_PATH:"
export LIBGLADE_MODULE_PATH
export GLADE_CATALOG_PATH
export GLADE_PIXMAP_PATH
export GLADE_MODULE_PATH

# Export GTK_PATH so that GTK+ can find the Xfce theme engine
# https://bugzilla.xfce.org/show_bug.cgi?id=7483
#GTK_PATH="$GTK_PATH:/usr/lib/gtk-2.0"
#export GTK_PATH

# For now, start with an empty list
XRESOURCES=""

# Has to go prior to merging Xft.xrdb, as its the "Defaults" file
test -r "/etc/xdg/xfce4/Xft.xrdb" && XRESOURCES="$XRESOURCES /etc/xdg/xfce4/Xft.xrdb"
test -r $HOME/.Xdefaults && XRESOURCES="$XRESOURCES $HOME/.Xdefaults"

BASEDIR=$XDG_CONFIG_HOME/xfce4
if test -r "$BASEDIR/Xft.xrdb"; then
  XRESOURCES="$XRESOURCES $BASEDIR/Xft.xrdb"
elif test -r "$XFCE4HOME/Xft.xrdb"; then
  mkdir -p "$BASEDIR"
  cp "$XFCE4HOME/Xft.xrdb" "$BASEDIR"/
  XRESOURCES="$XRESOURCES $BASEDIR/Xft.xrdb"
fi

# merge in X cursor settings
test -r "$BASEDIR/Xcursor.xrdb" && XRESOURCES="$XRESOURCES $BASEDIR/Xcursor.xrdb"

# ~/.Xresources contains overrides to the above
test -r "$HOME/.Xresources" && XRESOURCES="$XRESOURCES $HOME/.Xresources"

# load all X resources (adds /dev/null to avoid an empty list that would hang the process)
cat /dev/null $XRESOURCES | xrdb -nocpp -merge -

# load local modmap
test -r $HOME/.Xmodmap && xmodmap $HOME/.Xmodmap

# Use dbus-launch if installed.
if test x"$DBUS_SESSION_BUS_ADDRESS" = x""; then
    if which dbus-launch >/dev/null 2>&1; then
		eval `dbus-launch --sh-syntax --exit-with-session`
        # some older versions of dbus don't export the var properly
        export DBUS_SESSION_BUS_ADDRESS
    else
        echo "Could not find dbus-launch; Xfce will not work properly" >&2
	fi
fi

# launch gpg-agent or ssh-agent if enabled.
ssh_agent_enabled=`xfconf-query -c xfce4-session -p /startup/ssh-agent/enabled 2> /dev/null`
if test "$ssh_agent_enabled" != "false"; then
    # if the user has pam_ssh installed, it will start ssh-agent for us, but
    # of course won't start gpg-agent.  so, if ssh-agent is already running,
    # but we want gpg-agent (and that's not running yet) start gpg-agent
    # without ssh support

    ssh_agent_type=`xfconf-query -c xfce4-session -p /startup/ssh-agent/type 2> /dev/null`
    if test -z "$ssh_agent_type"; then
        if which gpg-agent >/dev/null 2>&1; then
            ssh_agent_type=gpg-agent
        else
            ssh_agent_type=ssh-agent
        fi
    fi

    # ignore stale ssh-agents
    if test "$SSH_AGENT_PID"; then
        if ! kill -0 $SSH_AGENT_PID; then
            unset SSH_AGENT_PID
            unset SSH_AUTH_SOCK
        fi
    fi

    case "$ssh_agent_type" in
        gpg-agent)
            if test -z "$SSH_AGENT_PID"; then
                eval `gpg-agent --daemon --enable-ssh-support --write-env-file $XDG_CACHE_HOME/gpg-agent-info`
                ssh_agent_kill_cmd="kill -INT $SSH_AGENT_PID; rm -f $XDG_CACHE_HOME/gpg-agent-info"
            elif test -z "$GPG_AGENT_INFO"; then
                echo "ssh-agent is already running; starting gpg-agent without ssh support"
                eval `gpg-agent --daemon --write-env-file $XDG_CACHE_HOME/gpg-agent-info`
                ssh_agent_kill_cmd="pkill -INT ^gpg-agent\$; rm -f $XDG_CACHE_HOME/gpg-agent-info"
            else
                echo "gpg-agent is already running"
            fi
            ;;

        ssh-agent)
            if test -z "$SSH_AGENT_PID"; then
                eval `ssh-agent -s`
                ssh_agent_kill_cmd="ssh-agent -s -k"
            else
                echo "ssh-agent is already running"
            fi
            ;;

        *)
            echo "Unrecognized agent type '$ssh_agent_type'" >&2
            ;;
    esac
fi


# launch a screensaver if enabled.  do not launch if we're root or if
# we're in a VNC session.
screensaver_enabled=`xfconf-query -c xfce4-session -p /startup/screensaver/enabled 2> /dev/null`
if test $UID -gt 0 -a -z "$VNCSESSION" -a "$screensaver_enabled" != "false"; then
    screensaver_type=`xfconf-query -c xfce4-session -p /startup/screensaver/type 2> /dev/null`

    case "$screensaver_type" in
        xscreensaver)
            xscreensaver -no-splash &
            ;;

        gnome-screensaver)
            gnome-screensaver &
            ;;

        *)
            if test x"`which xscreensaver 2>/dev/null`" != x""; then
                xscreensaver -no-splash &
            elif test x"`which gnome-screensaver 2>/dev/null`" != x""; then
                gnome-screensaver &
            fi
            ;;
    esac
fi


# Run xfce4-session if installed
if which xfce4-session >/dev/null 2>&1; then
    xfce4-session

    if test "$ssh_agent_kill_cmd"; then
        echo "running '$ssh_agent_kill_cmd'"
        eval "$ssh_agent_kill_cmd"
    fi

    exit 0
fi


##################
# IMPORTANT NOTE #
##################

# Everything below here ONLY gets executed if you are NOT using xfce4-session
# (Xfce's session manager).  If you are using the session manager, everything
# below is handled by it, and the code below is not executed at all.  If you're
# not sure if you're using the session manager, type 'ps -e|grep xfce4-session'
# in a terminal while Xfce is running.

##################


# this is only necessary when running w/o xfce4-session
xsetroot -solid black -cursor_name watch

# or use old-fashioned startup script otherwise

xfsettingsd &
xfwm4 --daemon

# start up stuff in $XDG_CONFIG_HOME/autostart/, as that looks to be
# the new standard.  if that directory doesn't exist, try the old
# ~/Desktop/Autostart method.  we're not going to do any migration here.
if test -d "$XDG_CONFIG_HOME/autostart"; then
  for i in ${XDG_CONFIG_HOME}/autostart/*.desktop; do
    grep -q -E "^Hidden=true" "$i" && continue
    if grep -q -E "^OnlyShowIn=" "$i"; then
      # need to test twice, as lack of the line entirely means we still run it
      grep -E "^OnlyShowIn=" "$i" | grep -q 'XFCE;' || continue
    fi
    grep -E "^NotShowIn=" "$i" | grep -q 'XFCE;' && continue

    # check for TryExec
    trycmd=`grep -E "^TryExec=" "$i" | cut -d'=' -f2`
    if test "$trycmd"; then
      which "$trycmd" >/dev/null 2>&1 || continue
    fi

    cmd=`grep -E "^Exec=" "$i" | cut -d'=' -f2`
    if test "$cmd" && which "$cmd" >/dev/null 2>&1; then
      $cmd &
    fi
  done
elif test -d "$HOME/Desktop/Autostart"; then
  for i in `ls -1 -L ${HOME}/Desktop/Autostart/ 2>/dev/null`; do
    if test -x $HOME/Desktop/Autostart/$i; then
      $HOME/Desktop/Autostart/$i &
    fi
  done
fi

xfdesktop&
orage &

panel=`which xfce4-panel`
case "x$panel" in
	x|xno*)
		;;
	*)
		$panel
		ret=$?
		while test $ret -ne 0; do
			xmessage -center -file - -timeout 20 -title Error <<EOF
A crash occured in the panel
Please report this to the xfce4-dev@xfce.org list
or on http://bugs.xfce.org
Meanwhile the panel will be restarted
EOF
			cat >&2 <<EOF
A crash occured in the panel
Please report this to the xfce4-dev@xfce.org list
or on http://bugs.xfce.org
Meanwhile the panel will be restarted
EOF
			$panel
			ret=$?
		done
		;;
esac

if test "$ssh_agent_kill_cmd"; then
	eval "$ssh_agent_kill_cmd"
fi

xsetroot -bg white -fg red  -solid black -cursor_name watch

If you can figure this out, wow would I be so grateful.

Offline

#5 2011-09-08 00:45:30

Compulsed
Member
Registered: 2011-08-24
Posts: 44

Re: tightVNC not loading properly

I figured that I could open a VNC connection if the server doesn'y have a instance of XFCE4 running, and the VNC would run perfectly. I'm not completely sure if it's normal that I can't open two instances of XFCE4(1 for the server and 1 for the connecting computer), but if there is an alternate way around it I'd be grateful to find out. 

Noting when I first installed tightVNC I could run both,  then after a reboot I have that error, not allowing me to.

Offline

#6 2011-09-08 08:59:11

Compulsed
Member
Registered: 2011-08-24
Posts: 44

Re: tightVNC not loading properly

I figured out that I can run a GUI vnc connection and a desktop connection so long as I open the vnc connection first.

Thanks to all who have had a look.

Offline

#7 2011-09-08 18:01:57

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: tightVNC not loading properly

If you figured it all out, please mark the thread as solved.

Offline

Board footer

Powered by FluxBB