You are not logged in.

#1 2011-09-11 06:02:47

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

GNOME 3.2 beta2 available in gnome-unstable

As promised multiple times on forums, GNOME 3.2 beta2 was just released and guess what? We got it! Shinier and full of new features, noticeable are gdm’s brand new look, gnome-online-accounts, gnome-contacts, gnome-documents, epiphany web application support, new user menu and better chat integration. Along with that, nautilus received a new file previewer named sushi, feature that I like the most.

To use this new version you need to enable gnome-unstable repository, as top repository to pacman.conf:

    [gnome-unstable]
    Include = /etc/pacman.d/mirrorlist 

Have fun testing these packages. Like always packaging bugs should be reported on our bugtracker, anything else considered bugs should be reported to GNOME bugzilla.

NVIDIA users be aware that xorg-server 1.11 from testing is incompatible with the current nvidia driver, even with IgnoreABI. You can switch to nouveau or add xf86-input-evdev xf86-input-synaptics xorg-server-common xorg-server to Ignorepkg.


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#2 2011-09-11 06:40:56

bwat47
Member
Registered: 2009-10-07
Posts: 637

Re: GNOME 3.2 beta2 available in gnome-unstable

So tempted to try this because a lot of gnome 3.2's changes look awesome, but at the same time my current desktop is working so well!

Does anyone know if anti-aliased window borders for will be landing (or has landed) in 3.2?

edit: Just checked out sushi, that looks awesome!

Last edited by bwat47 (2011-09-11 06:45:41)

Offline

#3 2011-09-11 09:19:57

jaco
Member
From: Toulouse, France
Registered: 2011-03-17
Posts: 149

Re: GNOME 3.2 beta2 available in gnome-unstable

Good news!

Works here but i've a problem with gdm (i don't see them in bugzilla so i suspect there are related to my configuration). I don't know if it's the right place to report problems but, just in case...

Impossible to login via gdm : i enter my login and my password and gdm doesn't recognize me (BTW: the User administration tab in System parameters doesn't work either : it quits as soon as i try to edit the avatar and no login name is displayed for my account... I think it's related).
I've tried with a brand new account: same thing

I succeed to start gnome-session with startx or with slim.

Last edited by jaco (2011-09-11 09:20:49)

Offline

#4 2011-09-11 09:33:45

thanos
Member
From: Greece
Registered: 2008-11-22
Posts: 22

Re: GNOME 3.2 beta2 available in gnome-unstable

I upgraded to beta2 but i can't login with gdm,showing me a black screen with the cursor.

During the gtk3 upgrade,i had this message:

gtk3 warning: undefined reference to <schema id='org.gnome.desktop.default-applications.at'/>

and for gdm

warning: directory permissions differ on var/lib/gdm/.config/dconf/
filesystem: 755  package: 700

.xsession-errors
http://pastebin.com/hDcBi4WP

Offline

#5 2011-09-11 10:15:21

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: GNOME 3.2 beta2 available in gnome-unstable

@jaco get the logs from gdm and paste them. /var/log/gdm/:0-greeter.log and :0-slave.log. also be sure you don't have any pacnew in /etc/pam.d

@thanos the gtk3 warning is fine and can be ignored, gdm as well. now lets talk about your real problem.

did you at least restarted dbus or even better rebooted? if yes, then can you try this two commits for gnome-session?
http://git.gnome.org/browse/gnome-sessi … 2e2cb827e8
http://git.gnome.org/browse/gnome-sessi … 98ec4e2136

both of you, be sure you don't have packages from aur that replaced stock packages


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#6 2011-09-11 10:28:36

jaco
Member
From: Toulouse, France
Registered: 2011-03-17
Posts: 149

Re: GNOME 3.2 beta2 available in gnome-unstable

@wonder : my :0-greeter.log = http://pastebin.com/6PdtEL3V
                      :0-slave.log  = http://pastebin.com/fhFzhyuG

I've no .pacnew in /etc/pam.d and no aur package replacing standard ones

Last edited by jaco (2011-09-11 10:33:46)

Offline

#7 2011-09-11 10:31:13

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,449
Website

Re: GNOME 3.2 beta2 available in gnome-unstable

Thank you wonder!  Can anyone running this (I'm not that brave) confirm that the memory leak affecting gnome-shell has been fixed in this release?


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#8 2011-09-11 10:34:04

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: GNOME 3.2 beta2 available in gnome-unstable

graysky wrote:

Thank you wonder!  Can anyone running this (I'm not that brave) confirm that the memory leak affecting gnome-shell has been fixed in this release?

for me, gnome-shell didn't leak so fast but still leaks


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#9 2011-09-11 11:21:43

Pank
Member
From: IT
Registered: 2009-06-13
Posts: 370

Re: GNOME 3.2 beta2 available in gnome-unstable

Dumb question: How do I `enable' Adwaita dark? I have

gtk-application-prefer-dark-theme = true

in my .config/gtk-3.0/settings.ini-file.

It used to work and the new release seems to contain dark Adwaita. . .


Arch x64 on Thinkpad X200s/W530

Offline

#10 2011-09-11 12:01:14

jaco
Member
From: Toulouse, France
Registered: 2011-03-17
Posts: 149

Re: GNOME 3.2 beta2 available in gnome-unstable

Well... I think i've found the reason of my problem with GDM authentification and the crash of User administration...

To use a nfs mount on my NAS, i've changed my UID on Arch (changing from 1000 to 500).
Looking at /etc/pam.d/gdm-password, i've seen the line:

auth            sufficient      pam_succeed_if.so uid >= 1000 quiet

So i've updated my Arch UID to use 1000 and, now, all is fine with GDM and User Administration.

Now, i have to solve this problem of uid mapping between my NAS and my Arch   smile

Last edited by jaco (2011-09-11 12:59:46)

Offline

#11 2011-09-11 12:44:26

thanos
Member
From: Greece
Registered: 2008-11-22
Posts: 22

Re: GNOME 3.2 beta2 available in gnome-unstable

wonder wrote:

@thanos the gtk3 warning is fine and can be ignored, gdm as well. now lets talk about your real problem.

did you at least restarted dbus or even better rebooted? if yes, then can you try this two commits for gnome-session?
http://git.gnome.org/browse/gnome-sessi … 2e2cb827e8
http://git.gnome.org/browse/gnome-sessi … 98ec4e2136

both of you, be sure you don't have packages from aur that replaced stock packages

Yes i rebooted.I tested it with these 2 commits and here we are:

.xession-errors
http://pastebin.com/BLJvQSHC

and

greeter.log http://pastebin.com/DNQe2WR1
slave.log     http://pastebin.com/bUnurR9q

(if this matters) the output is the same black screen etc etc

Last edited by thanos (2011-09-11 12:44:45)

Offline

#12 2011-09-11 15:06:42

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: GNOME 3.2 beta2 available in gnome-unstable

@thanos something is fishy in your system.
gdm-welcome][863]: pam_unix(gdm-welcome:account): account gdm has expired (account expired)

try to remove and install gdm again, greeter.log is kinda small. in ~/.xsession-errors i see a lot of warnings related to your profile. have you tried to add a new user and see if is working?


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#13 2011-09-11 15:24:20

themusicalduck
Member
Registered: 2011-07-04
Posts: 82

Re: GNOME 3.2 beta2 available in gnome-unstable

I've upgraded to 3.2, rebooted and after removing GDM managed to get into the desktop.

Apart from a few small differences in the theme I don't seem to have all of the new features. For instance nothing featured in this video is working - http://www.youtube.com/watch?&v=y-8K8d_ak24 (like quicklists, or that library tab). The only zeitgeist related package I could find was libqzeitgeist. I read it was supposed to have integrated search on the dashboard too, but I'm not sure how to enable that.

I managed to get sushi to work by installing it, but can't figure it out for the other things.

Offline

#14 2011-09-11 15:30:06

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: GNOME 3.2 beta2 available in gnome-unstable

themusicalduck wrote:

I've upgraded to 3.2, rebooted and after removing GDM managed to get into the desktop.

so gdm is broken for you as well? wtf

Apart from a few small differences in the theme I don't seem to have all of the new features. For instance nothing featured in this video is working - http://www.youtube.com/watch?&v=y-8K8d_ak24 (like quicklists, or that library tab). The only zeitgeist related package I could find was libqzeitgeist. I read it was supposed to have integrated search on the dashboard too, but I'm not sure how to enable that.

stop looking at videos upload by noname users. zeitgeist is not in gnome  and i believe never will be.

I managed to get sushi to work by installing it, but can't figure it out for the other things.

to use sushi, select a file in nautilus and press space


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#15 2011-09-11 15:45:40

jaco
Member
From: Toulouse, France
Registered: 2011-03-17
Posts: 149

Re: GNOME 3.2 beta2 available in gnome-unstable

...

Last edited by jaco (2011-09-11 15:46:48)

Offline

#16 2011-09-11 16:48:46

thanos
Member
From: Greece
Registered: 2008-11-22
Posts: 22

Re: GNOME 3.2 beta2 available in gnome-unstable

wonder wrote:

@thanos something is fishy in your system.
gdm-welcome][863]: pam_unix(gdm-welcome:account): account gdm has expired (account expired)

try to remove and install gdm again, greeter.log is kinda small. in ~/.xsession-errors i see a lot of warnings related to your profile. have you tried to add a new user and see if is working?

themusicalduck wrote:

I've upgraded to 3.2, rebooted and after removing GDM managed to get into the desktop.

So,
I created a new user
I installed gnome-session package with the patches from the 2 commits
I re-installed gdm
Restart dbus but gnome-shell crashes all time "Oh no something has gone wrong etc.." It prompted me to check the shell extensions for conflicts (and disable them) but they were disabled by default.

Do you want any logs to upload ?

Last edited by thanos (2011-09-11 17:33:56)

Offline

#17 2011-09-11 17:49:08

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: GNOME 3.2 beta2 available in gnome-unstable

~/.xsession-errors


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#18 2011-09-11 19:25:47

themusicalduck
Member
Registered: 2011-07-04
Posts: 82

Re: GNOME 3.2 beta2 available in gnome-unstable

wonder wrote:

stop looking at videos upload by noname users. zeitgeist is not in gnome  and i believe never will be.

The video is uploaded by Seif Lofty who I thought was a Gnome developer now.

Actually details of putting Zeitgeist and Tracker into Gnome 3 are here - https://live.gnome.org/ThreePointOne/Fe … dReminding but it says 'Obsolete' at the top, so perhaps they left it out in the end.

Last edited by themusicalduck (2011-09-11 19:33:51)

Offline

#19 2011-09-11 19:46:03

ilike
Member
From: Germany
Registered: 2011-09-01
Posts: 15
Website

Re: GNOME 3.2 beta2 available in gnome-unstable

Good news, but if you don't want to see sushi in action, I don't think it's worth upgrading on a "running system" yet. smile The new GDM seems to be buggy (and the shutdown/restart option is missing there now) and the online account-feature (Google-Account integration with calendar, gnome-contacts, gnome-documents) didn't work for me.
I also noticed that there's a problem with a Python3/PyGI-Script I wrote now:

Traceback (most recent call last):
  File "pptool.py", line 15, in <module>
    from gi.repository import Gtk, Gdk, Pango, GObject

(pacman -S extra/py3gobject extra/gobject-introspection fixed that)

There are some nice new ideas like better ability to resize windows or the notifications for removable devices, but nothing essential imho so far. Things like the new overview-design are not included yet.

Besides, sometimes a process (called something like gd-tracker-gdat..) often appears in conky and uses 50-100% of my cpu. hmm Does someone know where this comes from/how to disable it?

Offline

#20 2011-09-11 19:51:42

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: GNOME 3.2 beta2 available in gnome-unstable

ilike wrote:

Good news, but if you don't want to see sushi in action, I don't think it's worth upgrading on a "running system" yet. smile The new GDM seems to be buggy (and the shutdown/restart option is missing there now)

know upstream bug

and the online account-feature (Google-Account integration with calendar, gnome-contacts, gnome-documents) didn't work for me.

know bug. for now you need to start at least once evolution to work

I also noticed that there's a problem with a Python3/PyGI-Script I wrote now:

Traceback (most recent call last):
  File "pptool.py", line 15, in <module>
    from gi.repository import Gtk, Gdk, Pango, GObject

(pacman -S extra/py3gobject extra/gobject-introspection fixed that)

that is not a proper fix. now you might have a broken gnome 3.2 because is a gobject-introspection 1.29.17 it's a hard dependency.

maybe you should fix try to fix your code to work with python-gobject 2.90.3 (be aware that it cannot be installed right now along with python2-gobject 2.90.3 because of https://bugzilla.gnome.org/show_bug.cgi?id=658174 )

Last edited by wonder (2011-09-11 19:53:05)


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#21 2011-09-11 20:32:35

ilike
Member
From: Germany
Registered: 2011-09-01
Posts: 15
Website

Re: GNOME 3.2 beta2 available in gnome-unstable

wonder wrote:

know bug. for now you need to start at least once evolution to work

Okay, thanks, I thought it already works without evolution...

wonder wrote:

maybe you should fix try to fix your code to work with python-gobject 2.90.3 (be aware that it cannot be installed right now along with python2-gobject 2.90.3 because of https://bugzilla.gnome.org/show_bug.cgi?id=658174 )

Hmh, it was supposed to work with python-gobject (since i'm a gtk-newbie, used the same syntax as in the gnome screencasts (from gi.repository import Gtk, ...) to include the modules - isn't this going to work in 3.2?). I know that this isn't a good solution but I'm a little bit confused because before the upgrade python-gobject was installed and I can't reinstall it:

resolving dependencies...
looking for inter-conflicts...
:: python-gobject and python2-gobject are in conflict. Remove python2-gobject? [y/N] Y
error: failed to prepare transaction (could not satisfy dependencies)
:: caribou: requires python2-gobject
:: gedit: requires python2-gobject
:: gnome-tweak-tool: requires python2-gobject
:: pyatspi: requires python2-gobject

Why do these dependencies need python2-gobject now and not Python 3 like the packages in extra?
Thanks for enlightenment. ;p

Offline

#22 2011-09-11 20:56:27

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: GNOME 3.2 beta2 available in gnome-unstable

well, the ones from extra needed pygobject(renamed python2-gobject2 to accommodate pygobject 3) and nothing depends on py3gobject (renamed python-gobject2)

I did this because pygobject 3.0 is out and can be installed in parallel with pygobject 2.28. in theory because python2-gobject2 2.28 from gnome-unstable doesn't include any gi support and only python-gobject 2.90.3 has, because the gi support conflict each other and upstream suggests to disable gi in 2.28.

I think you have problems because of that and you need python-gobject which you cannot use right now.

I think apps depending on python2-gobject can run fine with python-gobject (python3 version) but i never tested. I prefer python2 because gobject-introspection is python2 only and is better tested and It doesn't download another python version(bloat)

I'm still waiting that bug report to be fixed to make python2/python3 version installable in parallel. If this won't happen, i think i'll split the pkgconfig files out in separate packages instead of conflicting the main packages.(this is what opensuse and fedora do right now)


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#23 2011-09-12 05:36:14

bluewanders
Member
Registered: 2011-09-01
Posts: 14

Re: GNOME 3.2 beta2 available in gnome-unstable

Just out of curiosity... has anyone figured out how to prevent empathy from automatically logging in when you have used the online accounts feature with chat?

Even going into the settings for empathy and unchecking "connect automatically on startup" does not prevent empathy from logging on and setting status to "available" in the background as soon as user has logged into gdm. 

Am I missing a setting somewhere or is this a bug?

Offline

#24 2011-09-12 05:51:20

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: GNOME 3.2 beta2 available in gnome-unstable

sounds like a bug. report it upstream


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#25 2011-09-12 08:36:26

thanos
Member
From: Greece
Registered: 2008-11-22
Posts: 22

Re: GNOME 3.2 beta2 available in gnome-unstable

wonder wrote:

~/.xsession-errors

http://pastebin.com/8n7YGTXk

Offline

Board footer

Powered by FluxBB