You are not logged in.

#1 2009-11-13 03:58:02

securitybreach
Member
From: In front of my computers
Registered: 2007-11-18
Posts: 410
Website

Grub2 Disable welcome message

Anyone know how disable the

Grub loading...Welcome to Grub

dialog that appears for a split second before Grub2 loads? I cannot find anything on it and I am usually pretty good with finding things. I would like to shave that useless one second off of my boot if it is not needed.

Thanks


"Every normal man must be tempted at times to spit upon his hands, hoist the black flag, and begin slitting throats." -- H.L. Mencken
Website      Configs
Forum Admin: Bruno's All Things Linux   
securitybreach<a>archlinux.us

Offline

#2 2011-09-12 16:13:20

maloy
Member
From: San José, Costa Rica
Registered: 2011-07-07
Posts: 14

Re: Grub2 Disable welcome message

A PKGBUILD for grub2-bios-ubuntu with no messages ('Welcome to Grub2... etc.' and 'loading') is now in AUR:

https://aur.archlinux.org/packages.php?ID=52336

Offline

#3 2012-05-01 18:12:35

Gen2ly
Member
From: Sevierville, TN
Registered: 2009-03-06
Posts: 1,529
Website

Re: Grub2 Disable welcome message

From what I've seen it's in the code and there is no option to remove it.


Setting Up a Scripting Environment | Proud donor to wikipedia - link

Offline

#4 2013-09-28 05:49:56

rabexc
Member
Registered: 2013-09-28
Posts: 1

Re: Grub2 Disable welcome message

smile this thread seems to be getting a reply per year, so here's mine!

There are a few patches around to do this, but you need to recompile grub, which is unfortunate sad.

You could also try grub-shusher: it's a bit of a hack, but it basically modifies your grub binary so that the message is not displayed, without patching the source code.
You can find it here: https://github.com/ccontavalli/grub-shusher. I posted a more complete description of how to use it here: http://rabexc.org/posts/grub-shush

Offline

#5 2016-12-20 12:37:18

mis
Member
Registered: 2016-03-16
Posts: 230

Re: Grub2 Disable welcome message

Sorry for necro bumping, but I think this could be useful for others finding this thread.

My solution (efi system) was to open grub.efi and/or grubia32.efi in a hex editor, search for the "Welcome to GRUB" string and zero it.

Offline

#6 2016-12-20 13:22:22

securitybreach
Member
From: In front of my computers
Registered: 2007-11-18
Posts: 410
Website

Re: Grub2 Disable welcome message

mis wrote:

Sorry for necro bumping, but I think this could be useful for others finding this thread.

My solution (efi system) was to open grub.efi and/or grubia32.efi in a hex editor, search for the "Welcome to GRUB" string and zero it.


Thanks but I have no used Grub in years. I have been using Syslinux for about 5 years now.


"Every normal man must be tempted at times to spit upon his hands, hoist the black flag, and begin slitting throats." -- H.L. Mencken
Website      Configs
Forum Admin: Bruno's All Things Linux   
securitybreach<a>archlinux.us

Offline

#7 2016-12-20 13:32:11

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 7,407
Website

Re: Grub2 Disable welcome message

Thanks for sharing, mis. I'm going to go ahead and close this old topic now.


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Making lemonade from lemons since 2015.

Online

Board footer

Powered by FluxBB