You are not logged in.

#1 2011-02-03 01:09:25

Anilm3
Member
Registered: 2011-02-03
Posts: 1

Aspire One D255 Microphone

Hello Everyone,

I've been trying to configure the internal microphone on the AOD255 but I haven't had any luck. Things I've tried are playing with every possible configuration using alsamixer and modifying modprobe.conf with the line "options snd-hda-intel model=acer-aspire" or "model=acer". Ubuntu shows no problem with the internal microphone.

Has anyone had any luck with it?

Thanks in advance

Offline

#2 2011-03-03 00:38:36

machinecrusade
Member
From: Victoria, Canada
Registered: 2010-09-12
Posts: 11

Re: Aspire One D255 Microphone

bump

trying to get skype to hear me...

i dont have the line "options snd-hda-intel model=acer-aspire" in modprobe conf... i have it in /etc/modprobe.d/alsa.conf,  same diffrence i guess.

same model .. aspire one  D255-2520

Offline

#3 2011-03-03 01:21:52

lagagnon
Member
From: an Island in the Pacific...
Registered: 2009-12-10
Posts: 1,083
Website

Re: Aspire One D255 Microphone

Show us the output of "amixer", or at least check it carefully and see if you in fact have a mic device listed and whether it is on or muted.


Philosophy is looking for a black cat in a dark room. Metaphysics is looking for a black cat in a dark room that isn't there. Religion is looking for a black cat in a dark room that isn't there and shouting "I found it!". Science is looking for a black cat in a dark room with a flashlight.

Offline

#4 2011-03-03 13:17:46

kgas
Member
From: Qatar
Registered: 2008-11-08
Posts: 718

Re: Aspire One D255 Microphone

another easy and lazy method is boot with Ubuntu CD and check your mike is working. If ok transfer the asound.conf file to your modprobe.conf and reboot. I got the mike issue settled with my acer aspire 5738G laptop with this method. smile

Offline

#5 2011-03-06 01:55:47

machinecrusade
Member
From: Victoria, Canada
Registered: 2010-09-12
Posts: 11

Re: Aspire One D255 Microphone

ok i got it,  here is my amixer ouput:

dh923 ~ $ amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 44 [69%] [-20.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 64 [100%] [0.00dB] [on]
  Front Right: Playback 64 [100%] [0.00dB] [on]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 64 [100%] [0.00dB] [on]
  Front Right: Playback 64 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Mic',1
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Mic Boost',1
  Capabilities: volume penum
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%]
  Front Right: 0 [0%]
Simple mixer control 'Beep',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 23 [74%] [0.00dB] [off]
  Front Right: Playback 23 [74%] [0.00dB] [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 13 [42%] [3.00dB] [on]
  Front Right: Capture 13 [42%] [3.00dB] [on]
Simple mixer control 'Capture',1
  Capabilities: cvolume cswitch penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 0 [0%] [-16.50dB] [off]
  Front Right: Capture 0 [0%] [-16.50dB] [off]
Simple mixer control 'Digital',0
  Capabilities: cvolume penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 83 [69%] [11.50dB]
  Front Right: Capture 83 [69%] [11.50dB]

this is working with the built in mic. 

notice that my 'Mic' 1 microphone and micboost are muted and at zero.  i think thats for the pink 'mic' input phono jack,  but i not sure.  what we are concerned with is the bottom,  Capture 0 needs to be about halfway,  my capture 1 is off,  and the last one,  Digital 0 needs to be about half way as well.  now i am making test calls to that nice british girl who works at skype,  my /modprobe.d/alsa.conf still reads as it did in my previous post, ...  options snd-hda-intel model=acer-aspire

lol  read the output of amixer CAREFULLY...

ps     i like this little conputer.. except for the keys are too close togeather,   its hard to type fast,    my wife has a dell net book,  and its way way way easier to type on.

Offline

#6 2011-03-09 05:17:54

sironitomas
Member
From: Cordoba, Argentina
Registered: 2009-11-28
Posts: 174
Website

Re: Aspire One D255 Microphone

Same problem here in a AAO D260. A solution would be appreciated!

Offline

#7 2011-09-11 04:38:18

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: Aspire One D255 Microphone

@machinecrusade

Can you provide a screenshot of your alsamixer settings. I'm having the same problem and didn't figure it out yet.

Thanks!

Offline

#8 2011-09-16 02:55:08

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: Aspire One D255 Microphone

I finally solved the microphone issue. Essentially you have to use pulse over alsa to get it working. Several sources provide more information on it.

Fixing the Microphone settings
You need to install pavcontrol

sudo apt-get install pavucontrol
pavucontrol

Then open the control panel, and in the Input tab, set one of the microphone sliders to zero, and the other one to something between 70, 100%.
Then never, ever again touch the microphone general volume or you will mess up your configuration, and you will have to reconfigure again. For skype, you have to disable the "allow skype to adjust the volume for me" option, or it will mess up your settings and the microphone will not work.
This was the only way I found for now to enable the microphone, unfortunately you can't touch the general mic volume, and you are always closed to pavucontrol

See http://almlys.org/archives/847

I briefly followed this guideline by slightly adapting it to my system. Eventually I came up with the settings which you can see in the screenshots.

Regards

pavucontrol.png
alsamixer_pulse.png
alsamixer_hdaintel.png

Offline

Board footer

Powered by FluxBB