You are not logged in.

#151 2011-08-28 17:43:49

PhotonX
Member
From: Munich
Registered: 2008-08-10
Posts: 431

Re: Plymouth is working! How to have a great splash in your box

I'm quite new to using Plymouth and have following problem: If Plymouth is activated, shutdown doesn't work at all, it shows the splash screen but doesn't turn off. I can, however, change the TTY and look where it gets stuck, it's after "Remounting Root Filesystem Read-only   [DONE]" (without Plymouth it turns off after this message). It's an Intel 945GM graphics chip (Thinkpad X60t) and the -plymouth inter driver from the AUR is installed (it was the same behavior with the standard driver though).


Desktop: http://www.sysprofile.de/id15562, Arch Linux    |    Notebook: Thinkpad X200 Tablet, Manjaro

The very worst thing you can do with free software is to download it, see that it doesn't work for some reason, leave it, and tell your friends that it doesn't work.  -  Tuomas Lukka

Offline

#152 2011-08-31 15:31:53

sidneyk
Member
From: Bonner Springs, KS. USA
Registered: 2011-04-22
Posts: 129

Re: Plymouth is working! How to have a great splash in your box

Hi Zephyr, I'm using your pkgs. with Gnome3/Gnome-shell/gdm and the bootup is mostly seamless. I keep 2 kernel versions and a Windows option in the grub2 menu. As soon as I hit the option for one of the linux's, for example linux-lqx, I see the 6 penquins at top indicating my 6 core cpu is initialized then the plymouth bootsplash appears and a smooth transition to Gnome-shell happens where I have auto-login enabled. The issue that I am seeing is when I reboot. Usually, I just choose restart from inside my Gnome-shell session without logging out first. What happens then is that the screen goes black for a very brief bit then I see console output for about a half second then the plymouth splash reappears until I'm back at my BIOS init screen. Is there any way to eliminate the flash of console output on reboot? I can live with it the way it is, but the other way would definitely look nicer. Thanks in advance and forgive me if this has already been covered somewhere.

Last edited by sidneyk (2011-08-31 15:33:24)

Offline

#153 2011-08-31 16:19:36

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

sidneyk wrote:

Hi Zephyr, I'm using your pkgs. with Gnome3/Gnome-shell/gdm and the bootup is mostly seamless. I keep 2 kernel versions and a Windows option in the grub2 menu. As soon as I hit the option for one of the linux's, for example linux-lqx, I see the 6 penquins at top indicating my 6 core cpu is initialized then the plymouth bootsplash appears and a smooth transition to Gnome-shell happens where I have auto-login enabled. The issue that I am seeing is when I reboot. Usually, I just choose restart from inside my Gnome-shell session without logging out first. What happens then is that the screen goes black for a very brief bit then I see console output for about a half second then the plymouth splash reappears until I'm back at my BIOS init screen. Is there any way to eliminate the flash of console output on reboot? I can live with it the way it is, but the other way would definitely look nicer. Thanks in advance and forgive me if this has already been covered somewhere.

I totally agree with you sidneyk. It also bothers me a bit. smile
You could try recompiling the plymouth-systemd package without the --enable-systemd-integration line (also delete the \ in the previous line), rebuilding your initramfs.
But I believe the problem lies deeper in systemd/plymouth. I have also tried most of the systemd kernel command line parameters with no luck. But YMMV.

If I find anything, I will of course post it.


(If you don't want to see the penguins in your custom kernels, you could edit the kernel's config and unset CONFIG_LOGO)

Offline

#154 2011-08-31 16:29:29

sidneyk
Member
From: Bonner Springs, KS. USA
Registered: 2011-04-22
Posts: 129

Re: Plymouth is working! How to have a great splash in your box

zephyr wrote:
sidneyk wrote:

Hi Zephyr, I'm using your pkgs. with Gnome3/Gnome-shell/gdm and the bootup is mostly seamless. I keep 2 kernel versions and a Windows option in the grub2 menu. As soon as I hit the option for one of the linux's, for example linux-lqx, I see the 6 penquins at top indicating my 6 core cpu is initialized then the plymouth bootsplash appears and a smooth transition to Gnome-shell happens where I have auto-login enabled. The issue that I am seeing is when I reboot. Usually, I just choose restart from inside my Gnome-shell session without logging out first. What happens then is that the screen goes black for a very brief bit then I see console output for about a half second then the plymouth splash reappears until I'm back at my BIOS init screen. Is there any way to eliminate the flash of console output on reboot? I can live with it the way it is, but the other way would definitely look nicer. Thanks in advance and forgive me if this has already been covered somewhere.

I totally agree with you sidneyk. It also bothers me a bit. smile
You could try recompiling the plymouth-systemd package without the --enable-systemd-integration line (also delete the \ in the previous line), rebuilding your initramfs.
But I believe the problem lies deeper in systemd/plymouth. I have also tried most of the systemd kernel command line parameters with no luck. But YMMV.

If I find anything, I will of course post it.


(If you don't want to see the penguins in your custom kernels, you could edit the kernel's config and unset CONFIG_LOGO)

The Liquorix kernel so far is the only one that does the penguin thing and that don't really bother me. I just installed the linux-mainline kernel which doesn't have the penguins and builds a whole lot faster than the lqx one. So far it seems pretty good. I'll keep digging and reading and playing with systemd config files to see if I can figure anything out on the reboot thing and post back if I succeed at anything. Thanks.

Last edited by sidneyk (2011-08-31 16:30:09)

Offline

#155 2011-08-31 21:13:35

KlavKalashj
Member
Registered: 2008-10-09
Posts: 362

Re: Plymouth is working! How to have a great splash in your box

Hm, why does Plymouth depend on gtk2? Is it possible to remove it somehow?

Edit: Should have googled first.
https://bbs.archlinux.org/viewtopic.php … 05#p948805
http://paste.org/pastebin/view/34913

Last edited by KlavKalashj (2011-08-31 21:18:24)

Offline

#156 2011-09-02 01:32:23

vredfreak
Member
Registered: 2004-11-20
Posts: 66

Re: Plymouth is working! How to have a great splash in your box

Just in case anyone here is using the proprietary Nvidia drivers, but still wants to get native resolution with plymouth and KMS, it is possible to run plymouth using the nouveau driver and then remove it before X starts and automatically loads the nvidia module. The following is what worked for me.  I am using Arch 64bit, gnome 3, and GDM as the display manager.  I am also using the normal Arch init system.  I have not got this working with systemd yet, though I am trying to. This also assumes that you have the proprietary Nvidia driver and plymouth already installed and configured.  If not, check the wiki for instructions.

First, make sure you have the xf86-video-nouveau package installed.
Enable early start KMS by adding "nouveau" to the Modules line in /etc/mkinitcpio.conf
Rebuild the kernel image with "mkinitcpio -p linux" (for stock kernel)

I then created a file in /usr/local/bin called nvidia-driver-swap.sh, and added the following lines (make sure the file is executable):

#!/bin/bash
chvt 2
echo 0 > /sys/class/vtconsole/vtcon1/bind
rmmod nouveau
rmmod ttm
rmmod drm_kms_helper
rmmod drm

The above commands were taken from this page.  Look under the section Deactivating KMS and unloading Nouveau.
This only worked for me when I changed tty's, hence the "chvt 2" command.

Now add the following to /etc/rc.local:

/usr/local/bin/nvidia-driver-swap.sh

Reboot.  Hopefully you will get a full screen resolution plymouth theme, and then kms and nouveau get deactivated and the proprietary nvidia drivers are automatically loaded when X kicks in.
Hope someone finds this useful.


Hi.  I'm a sig.  What are you?

Offline

#157 2011-09-02 02:41:59

turjuque
Member
Registered: 2011-08-29
Posts: 9

Re: Plymouth is working! How to have a great splash in your box

vredfreak wrote:

Just in case anyone here is using the proprietary Nvidia drivers, but still wants to get native resolution with plymouth and KMS, it is possible to run plymouth using the nouveau driver and then remove it before X starts and automatically loads the nvidia module. The following is what worked for me.  I am using Arch 64bit, gnome 3, and GDM as the display manager.  I am also using the normal Arch init system.  I have not got this working with systemd yet, though I am trying to. This also assumes that you have the proprietary Nvidia driver and plymouth already installed and configured.  If not, check the wiki for instructions.

First, make sure you have the xf86-video-nouveau package installed.
Enable early start KMS by adding "nouveau" to the Modules line in /etc/mkinitcpio.conf
Rebuild the kernel image with "mkinitcpio -p linux" (for stock kernel)

I then created a file in /usr/local/bin called nvidia-driver-swap.sh, and added the following lines (make sure the file is executable):

#!/bin/bash
chvt 2
echo 0 > /sys/class/vtconsole/vtcon1/bind
rmmod nouveau
rmmod ttm
rmmod drm_kms_helper
rmmod drm

The above commands were taken from this page.  Look under the section Deactivating KMS and unloading Nouveau.
This only worked for me when I changed tty's, hence the "chvt 2" command.

Now add the following to /etc/rc.local:

/usr/local/bin/nvidia-driver-swap.sh

Reboot.  Hopefully you will get a full screen resolution plymouth theme, and then kms and nouveau get deactivated and the proprietary nvidia drivers are automatically loaded when X kicks in.
Hope someone finds this useful.

Huge Thanks to you man! I was trying to pass the black square bug with the wiki method but it didnt work and your solution works well with full res plymouth smile.

Offline

#158 2011-09-02 11:44:47

vredfreak
Member
Registered: 2004-11-20
Posts: 66

Re: Plymouth is working! How to have a great splash in your box

turjuque wrote:

Huge Thanks to you man! I was trying to pass the black square bug with the wiki method but it didnt work and your solution works well with full res plymouth smile.

Glad it worked for you.  The downside is that you don't have plymouth on shutdown.  But that is extremely brief on my PC and I can live with it.


Hi.  I'm a sig.  What are you?

Offline

#159 2011-09-02 22:57:46

DoctorPepper
Member
Registered: 2011-08-31
Posts: 2

Re: Plymouth is working! How to have a great splash in your box

First of all thanks  Zephyr for your hard work for the integration of systemd and plymouth.
using  intel GME965/GLE960  with the xf86-video-intel-plymouth package , i cant get the smooth transition between  grub => plymouth   and plymouth => kdm  .  in both cases i have a black screen
note that my setup is based on encrypted  lvm.

here is some information  about the setup :
mkinitcpio.conf hooks: HOOKS="base udev autodetect  plymouth  pata scsi sata keymap plymouth-encrypt lvm2 filesystems usbinput"
package installed :  initscripts-systemd  ,  systemd  , systemd-arch-units  ,  xf86-video-intel-plymouth | kde workspce patched

Offline

#160 2011-09-03 00:56:34

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

@KlavKalashj

I'll look into the gtk2 dependency issue soon.

@DoctorPepper

Hi, first of all about the grub->plymouth transition, it isn't supposed to be smooth afaik. Only IF you use grub2 with some tweaks gfxpayload=keep and your vbios supports your panels max resolution it could work.
But I don't know much about it, I use plain old grub.

With your current setup, does X/KDE load on tty1? If it does, there might be a problem in the upstream patch for the intel driver. Also take a look in the previous two pages for misc tips, e.g. do not use spinfinity as a theme.

I believe systemd can handle encrypted partitions with and without plymouth by itself, so you shouldn't need the plymouth-encrypt hook, only the normal encrypth hook.
If you can boot succesfully without plymouth and plymouth-encrypt with systemd init (but with encrypt hook on) in your HOOKS array, i.e. systemd prompts on the console for a password, then you can can try if booting with the foolowing hooks array works fine for you (it should work fine with systemd, but of course with plain init it may not):

mkinitcpio.conf hooks: HOOKS="base udev autodetect  plymouth  pata scsi sata keymap encrypt lvm2 filesystems usbinput"

I got my hands on a netbook with an Intel GME945 and it apparently was unable to keep the framebuffer contents. It seemed to do a weird transition, so I guess the xf86-video-intel-plymouth driver and the "upstream" patch for it works only for certain intel GFX chips.

@PhotonX

I had the same problem with a netbook and normal init. I can't help you much, but with systemd on that machine the problem went away.

Offline

#161 2011-09-03 01:20:34

DoctorPepper
Member
Registered: 2011-08-31
Posts: 2

Re: Plymouth is working! How to have a great splash in your box

@Zephyr on fedora  the  grub to plymouth transition works wonderfully  and they  use grub legacy
as for the the plymouth to grub i am using spininfinty so i am going to change it  test and give you feedback .
thanks for your help

Offline

#162 2011-09-03 01:28:15

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

DoctorPepper wrote:

@Zephyr on fedora  the  grub to plymouth transition works wonderfully  and they  use grub legacy
as for the the plymouth to grub i am using spininfinty so i am going to change it  test and give you feedback .
thanks for your help

You could use grub-legacy-fedora-git and see if that works for you smile:
https://aur.archlinux.org/packages.php?ID=47959

I might try this package as well.

Offline

#163 2011-09-12 23:43:48

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

sidneyk wrote:

Hi Zephyr, I'm using your pkgs. with Gnome3/Gnome-shell/gdm and the bootup is mostly seamless. I keep 2 kernel versions and a Windows option in the grub2 menu. As soon as I hit the option for one of the linux's, for example linux-lqx, I see the 6 penquins at top indicating my 6 core cpu is initialized then the plymouth bootsplash appears and a smooth transition to Gnome-shell happens where I have auto-login enabled. The issue that I am seeing is when I reboot. Usually, I just choose restart from inside my Gnome-shell session without logging out first. What happens then is that the screen goes black for a very brief bit then I see console output for about a half second then the plymouth splash reappears until I'm back at my BIOS init screen. Is there any way to eliminate the flash of console output on reboot? I can live with it the way it is, but the other way would definitely look nicer. Thanks in advance and forgive me if this has already been covered somewhere.

Hi sidneyk!

Could you please update plymouth-systemd-git and install systemd-quiet[1] from AUR? wink big_smile

Also remember to add fastboot (and quiet or loglevel=3) to your kernel parameters.

[1] https://aur.archlinux.org/packages.php?ID=52351

(BTW I've dumped grub for GRUB2, with three patches to make it stfu, and I only see the text cursor for 1 second after post screen smile
A totally smooth grub2 to plymouth could be possible if your max framebuffer resolution matches your panel's native res. Even if it doesn't it's just a modeset from black to black. Thought it might be interesting for someone.)

EDIT: I think I will also add that GTK2 dependency drop patch. (DONE) Thanks KlavKalashj!

Last edited by zephyr (2011-09-13 00:00:52)

Offline

#164 2011-09-13 10:11:08

sidneyk
Member
From: Bonner Springs, KS. USA
Registered: 2011-04-22
Posts: 129

Re: Plymouth is working! How to have a great splash in your box

zephyr wrote:
sidneyk wrote:

Hi Zephyr, I'm using your pkgs. with Gnome3/Gnome-shell/gdm and the bootup is mostly seamless. I keep 2 kernel versions and a Windows option in the grub2 menu. As soon as I hit the option for one of the linux's, for example linux-lqx, I see the 6 penquins at top indicating my 6 core cpu is initialized then the plymouth bootsplash appears and a smooth transition to Gnome-shell happens where I have auto-login enabled. The issue that I am seeing is when I reboot. Usually, I just choose restart from inside my Gnome-shell session without logging out first. What happens then is that the screen goes black for a very brief bit then I see console output for about a half second then the plymouth splash reappears until I'm back at my BIOS init screen. Is there any way to eliminate the flash of console output on reboot? I can live with it the way it is, but the other way would definitely look nicer. Thanks in advance and forgive me if this has already been covered somewhere.

Hi sidneyk!

Could you please update plymouth-systemd-git and install systemd-quiet[1] from AUR? wink big_smile

Also remember to add fastboot (and quiet or loglevel=3) to your kernel parameters.

[1] https://aur.archlinux.org/packages.php?ID=52351

(BTW I've dumped grub for GRUB2, with three patches to make it stfu, and I only see the text cursor for 1 second after post screen smile
A totally smooth grub2 to plymouth could be possible if your max framebuffer resolution matches your panel's native res. Even if it doesn't it's just a modeset from black to black. Thought it might be interesting for someone.)

EDIT: I think I will also add that GTK2 dependency drop patch. (DONE) Thanks KlavKalashj!

That seems to be pretty good. I noticed the patch that removes x11 renderer and gtk dependency or what have you after trying to install the plymouth-systemd pkg and then running mkinitcpio -p linux, I was getting the error about it not finding x11.so module right after the plymouth part. So, I had to comment out line 33 in /lib/initcpio/install/plymouth where that module was being loaded. I don't know if using the -R option when setting plymouth's default theme would have worked, I didn't try that. But, now after making that change and getting the 2 pieces installed in the proper order it seems to be doing fine. I'm on my laptop now, I'll apply this on my desktop when I get home later and let you know how it goes. I'm already using grub2 and only had to add the fastboot option, already had quiet splash in there. What are the 3 patches for grub2 that you speak of? Thanks. smile

[EDIT]  I just installed both of these on my much faster 6 core desktop and, making the same change as above, the only ugliness at all that I see is the mode switch between grub2 and plymouth. It looks like a flash of a couple colored thin bars across mid screen. At reboot from within my Gnome-shell session I see about a second of black screen after Gnome disappears and before plymouth comes up, no console messages at all. Good work Zephyr.

Last edited by sidneyk (2011-09-13 13:56:52)

Offline

#165 2011-09-13 15:25:44

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

Thanks for testing that sidneyk.

I have corrected the initcpio so that it does not try to include the x11 renderer.

I also get those thin colored lines on grub2 modeswitch, I didn't have any time to look into it, but I suppose it has something to do with GRUB_GFXPAYLOAD_LINUX=keep.

I just recompiled grub2 from ABS with the following patches:

2 patches from ubuntu, one of them disables the "Welcome to GRUB" and "Booting to" message and the other the "Grub loading..." message:

http://bazaar.launchpad.net/~ubuntu-bra … uiet.patch
http://bazaar.launchpad.net/~ubuntu-bra … ding.patch

The other one is just to remove the echo lines on kernel and initrd load by default (you can also comment these in /boot/grub/grub.cfg on normal grub2):

--- util/grub.d/10_linux.in.orig        2011-09-04 02:25:23.842328087 +0300
+++ util/grub.d/10_linux.in     2011-09-04 02:26:43.908998065 +0300
@@ -115,13 +115,11 @@
   fi
   message="$(gettext_printf "Loading Linux %s ..." ${version})"
   cat << EOF
-       echo    '$message'
        linux   ${rel_dirname}/${basename} root=${linux_root_device_thisversion} ro ${args}
 EOF
   if test -n "${initrd}" ; then
     message="$(gettext_printf "Loading initial ramdisk ...")"
     cat << EOF
-       echo    '$message'
        initrd  ${rel_dirname}/${initrd}
 EOF
   fi

EDIT: I also have

GRUB_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT=1
GRUB_HIDDEN_TIMEOUT_QUIET=true

in my /etc/default/grub so that the grub menu does not come up unless I press/hold the escape key on boot.

Last edited by zephyr (2011-09-13 15:28:26)

Offline

#166 2011-09-13 16:17:05

sidneyk
Member
From: Bonner Springs, KS. USA
Registered: 2011-04-22
Posts: 129

Re: Plymouth is working! How to have a great splash in your box

I may try those grub2 settings, but it will require me retraining my Windows-centric, Facebook games addicted wife to hold down ESC if she reboots. wink Then I can just set the machine to boot automatically to arch. I'll let you know how that goes.

Offline

#167 2011-09-16 21:12:25

KlavKalashj
Member
Registered: 2008-10-09
Posts: 362

Re: Plymouth is working! How to have a great splash in your box

Thank you so much for all your work, Zephyr! I now have a silky smooth boot process and a system free of gtk. Thank you!

Offline

#168 2011-09-20 18:07:25

Demon
Member
From: Republic of Srpska, BA
Registered: 2008-03-02
Posts: 225

Re: Plymouth is working! How to have a great splash in your box

I'm glad someone made a use of my no-gtk2 patches for plymouth. smile

I used some of the Zephyr's patches for kde-workspace, here's the final result of my plymouth boot process:

http://www.youtube.com/watch?v=pmX_yamudhc

I would to know what do other people think about this, do you think it can be better?

Offline

#169 2011-09-20 18:28:49

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

Demon wrote:

I'm glad someone made a use of my no-gtk2 patches for plymouth. smile

I used some of the Zephyr's patches for kde-workspace, here's the final result of my plymouth boot process:

http://www.youtube.com/watch?v=pmX_yamudhc

I would to know what do other people think about this, do you think it can be better?

Hi Demon, thanks for your no-gtk2 patch big_smile

Can I ask what video card driver you are using and on what tty X is running? (X should be on tty1 and unfortunately intel gfx cards support for smooth transition are hit and miss depending on what card you have, although I guess that for the majority of Intel Graphics cards it does not work.)

From your video I see that there is a brief black screen between plymouth and KDM.
For me it is a completely transparent process. I can only understand that X is up when my cursor pops up, since my plymouth/ksplash themes use the same background. In plymouth I have an Arch logo and when ksplash comes up the Arch logo morphs to the KDE logo with no black screen in-between.

Unfortunately, my phone's camera cannot capture my boot process nicely because of the bright backlight. However, I will post my plymouth and ksplash themes soon, I just need a bit of time to do that.:)

Offline

#170 2011-09-20 18:35:57

Demon
Member
From: Republic of Srpska, BA
Registered: 2008-03-02
Posts: 225

Re: Plymouth is working! How to have a great splash in your box

zephyr wrote:

Hi Demon, thanks for your no-gtk2 patch big_smile

Can I ask what video card driver you are using and on what tty X is running? (X should be on tty1 and unfortunately intel gfx cards support for smooth transition are hit and miss depending on what card you have, although I guess that for the majority of Intel Graphics cards it does not work.)

From your video I see that there is a brief black screen between plymouth and KDM.
For me it is a completely transparent process. I can only understand that X is up when my cursor pops up, since my plymouth/ksplash themes use the same background. In plymouth I have an Arch logo and when ksplash comes up the Arch logo morphs to the KDE logo with no black screen in-between.

Unfortunately, my phone's camera cannot capture my boot process nicely because of the bright backlight. However, I will post my plymouth and ksplash themes soon, I just need a bit of time to do that.:)

Wow, thanks for quick answer.

It's ATI Radeon HD3650, r600g driver. I did have some troubles making X start at tty1, but now it works (with "ServerVTs=1"). However, that brief black screen as you've said it's what bugging me. Perhaps I need a patch for xorg-server or something? Also, you might have noticed black screen between Grub2 and plymouth start (the black screen with two Arch logos at the upper left of the screen) - I would liked to get rid of that, too. smile

Offline

#171 2011-09-20 18:49:36

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

Demon wrote:
zephyr wrote:

Hi Demon, thanks for your no-gtk2 patch big_smile

Can I ask what video card driver you are using and on what tty X is running? (X should be on tty1 and unfortunately intel gfx cards support for smooth transition are hit and miss depending on what card you have, although I guess that for the majority of Intel Graphics cards it does not work.)

From your video I see that there is a brief black screen between plymouth and KDM.
For me it is a completely transparent process. I can only understand that X is up when my cursor pops up, since my plymouth/ksplash themes use the same background. In plymouth I have an Arch logo and when ksplash comes up the Arch logo morphs to the KDE logo with no black screen in-between.

Unfortunately, my phone's camera cannot capture my boot process nicely because of the bright backlight. However, I will post my plymouth and ksplash themes soon, I just need a bit of time to do that.:)

Wow, thanks for quick answer.

It's ATI Radeon HD3650, r600g driver. I did have some troubles making X start at tty1, but now it works (with "ServerVTs=1"). However, that brief black screen as you've said it's what bugging me. Perhaps I need a patch for xorg-server or something? Also, you might have noticed black screen between Grub2 and plymouth start (the black screen with two Arch logos at the upper left of the screen) - I would liked to get rid of that, too. smile

Have you followed this post?:
https://bbs.archlinux.org/viewtopic.php … 40#p979940

Yes, you should use xf86-video-ati-plymouth from AUR, it has a one-liner patch to add smooth transition support to the driver. You should also edit kdmrc to add the "background none" if you don't have it in ServerArgs=. (It should be in the kdmrc from kdebase-workspace-plymouth). Again see the post above for more info.
These should make plymouth->DM smooth with no black screen in-between.

For GRUB2, things are different, since I believe you need grub_gfx_payload=keep which I believe is enabled by default BUT the graphics mode/screen resolution used by grub should be the same with the KMS one, your panel's native resolution that is.
I believe that very few vbioses support any res higher than 1280x1024. Maybe those EFI machines do not have that kind of limitations but I again do not know that much about it.
To workaround that I personally have no grub_background, so I have a black screen until KMS and plymouth kick in.

Hope these help:)

Offline

#172 2011-09-20 19:50:12

Demon
Member
From: Republic of Srpska, BA
Registered: 2008-03-02
Posts: 225

Re: Plymouth is working! How to have a great splash in your box

zephyr, yes I did all that, however, I'm not using systemd. And I'm using inittab to start kdm (not kdm service), maybe that has something to do with?

Edit: nope, the same thing happened.

Last edited by Demon (2011-09-20 19:58:44)

Offline

#173 2011-09-20 20:46:39

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

Demon wrote:

zephyr, yes I did all that, however, I'm not using systemd. And I'm using inittab to start kdm (not kdm service), maybe that has something to do with?

Edit: nope, the same thing happened.

I see. Don't you have a race issue between X and getty@tty1 with normal initscripts? Meaning X consumes a lot of CPU, probably up to 100% on one core? If not smooth transition is not working for you, that is why I suggest systemd over initscripts, because with initscripts if it works X consumes 100% cpu.

Can you try with lxdm and post your kdmrc? See the post I linked for lxdm configuration info.

Offline

#174 2011-09-20 21:26:30

Demon
Member
From: Republic of Srpska, BA
Registered: 2008-03-02
Posts: 225

Re: Plymouth is working! How to have a great splash in your box

zephyr wrote:

Don't you have a race issue between X and getty@tty1 with normal initscripts? Meaning X consumes a lot of CPU, probably up to 100% on one core?

It did have happened occasionally. I've commented tty1 line in /etc/inittab, but still there's a black screen.

zephyr wrote:

Can you try with lxdm and post your kdmrc? See the post I linked for lxdm configuration info.

Ok, I will. Here's current

inittab

$ cat /etc/inittab
#
# /etc/inittab
#

#  Runlevels:
#    0    Halt
#    1(S)       Single-user
#    2    Not used
#    3    Multi-user
#    4    Not used
#    5    X11
#    6    Reboot

## Only one of the following two lines can be uncommented!
# Boot to console
#id:3:initdefault:
# Boot to X11
id:5:initdefault:

rc::sysinit:/etc/rc.sysinit
rs:S1:wait:/etc/rc.single
rm:2345:wait:/etc/rc.multi
rh:06:wait:/etc/rc.shutdown
su:S:wait:/sbin/sulogin -p

# -8 options fixes umlauts problem on login
#c1:2345:respawn:/sbin/agetty -8 -s 38400 tty1 linux
c2:2345:respawn:/sbin/agetty -8 -s 38400 tty2 linux
c3:2345:respawn:/sbin/agetty -8 -s 38400 tty3 linux
c4:2345:respawn:/sbin/agetty -8 -s 38400 tty4 linux
#c5:2345:respawn:/sbin/agetty -8 -s 38400 tty5 linux
#c6:2345:respawn:/sbin/agetty -8 -s 38400 tty6 linux

# Serial Virtual Console for KVM and others VMs
#s0:2345:respawn:/sbin/agetty -8 -s 9600 ttyS0 linux

# Hypervisor Virtual Console for Xen and KVM
#h0:2345:respawn:/sbin/agetty -8 -s 38400 hvc0 linux

ca::ctrlaltdel:/sbin/shutdown -t3 -r now

# Example lines for starting a login manager
#x:5:respawn:/usr/bin/xdm -nodaemon
#x:5:respawn:/usr/sbin/gdm -nodaemon
x:5:respawn:/usr/bin/kdm -nodaemon
#x:5:respawn:/usr/bin/slim >/dev/null 2>&1

# End of file

and kdmrc

$ cat /usr/share/config/kdm/kdmrc 
[General]
ConfigVersion=2.4
StaticServers=:0
ReserveServers=:1,:2,:3
ServerVTs=1
ConsoleTTYs=tty2,tty3,tty4
PidFile=/var/run/kdm.pid
GreeterUID=kdm

[Xdmcp]
Enable=false

[Shutdown]
HaltCmd=/sbin/halt
RebootCmd=/sbin/reboot
BootManager=Grub2

[X-*-Core]
AutoReLogin=false
AllowRootLogin=false
AllowNullPasswd=false
AllowShutdown=Root
Setup=/usr/share/config/kdm/Xsetup
Startup=/usr/share/config/kdm/Xstartup
Reset=/usr/share/config/kdm/Xreset
Session=/usr/share/config/kdm/Xsession
SessionsDirs=/usr/share/config/kdm/sessions,/usr/share/apps/kdm/sessions
ClientLogFile=.xsession-errors-%d

[X-*-Greeter]
AntiAliasing=true
ColorScheme=OxygenCold
FaceSource=PreferUser
FailFont=Sans Serif,10,-1,5,75,0,0,0,0,0
ForgingSeed=1281562998
GUIStyle=QtCurve
GreetFont=Serif,20,-1,5,50,0,0,0,0,0
GreetString=Добро дошли у %s на %n
GreeterPos=50,50
HiddenUsers=
Language=sr_RS
LogoArea=Logo
LogoPixmap=/usr/share/apps/kdm/pics/kdelogo.png
MaxShowUID=65000
MinShowUID=500
PluginsLogin=classic
Preloader=/usr/bin/preloadkde
SelectedUsers=Gost
ShowUsers=NotHidden
SortUsers=true
StdFont=Sans Serif,10,-1,5,50,0,0,0,0,0
Theme=/usr/share/apps/kdm/themes/sprky
UseBackground=true
UseTheme=true
UserCompletion=false
UserList=true
NumLock=On

[X-:*-Core]
ServerCmd=/usr/bin/X
ServerArgsLocal=-nolisten tcp -background none
AllowNullPasswd=true
AllowShutdown=All
NoPassEnable=true
NoPassUsers=Gost

[X-:*-Greeter]
PreselectUser=Default
LoginMode=DefaultLocal
AllowClose=true
FocusPasswd=true
DefaultUser=Gost

[X-:0-Core]
AutoLoginEnable=false
AutoLoginLocked=false
AutoLoginUser=
ClientLogFile=.xsession-errors

Offline

#175 2011-09-20 21:45:13

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: Plymouth is working! How to have a great splash in your box

Well kdmrc seems fine. You don't autologin to KDE right?

Maybe the black screen is due to a resolution change.

Could you also try with another theme like spinner?

Offline

Board footer

Powered by FluxBB