You are not logged in.

#1 2011-09-10 16:26:50

new2arch
Member
Registered: 2008-02-25
Posts: 235

[Solved] "Run" (Alt + F2) in LXDE/ Openbox - runs in the background

Hi all,

I'm running LXDE and Openbox.

When I press the keyboard combo Alt + F2, the "Run" dialogue pops up but it runs in the background.
Doesn't matter if I have any windows open or not.
I have to immediately use Alt + Tab to activate the "Run" dialogue window.

Didn't have the issue until I upgraded to most recent packages (openbox, obconf).

Anyone knows how to get rid of the problem?

Thanks.

Last edited by new2arch (2011-09-20 08:22:15)

Offline

#2 2011-09-11 10:59:42

Firestone
Member
From: Amsterdam
Registered: 2009-07-26
Posts: 20

Re: [Solved] "Run" (Alt + F2) in LXDE/ Openbox - runs in the background

The update modified the rc.xml too probably.
I don't know how, or if, LXDE handles this, but on a sole Openbox I use the above layer and the focus option:

 <application name="bashrun">
	<desktop>all</desktop>
	<decor>no</decor>  # switch to yes if you prefer a bordered window
	<focus>yes</focus>
	<skip_pager>yes</skip_pager>
	<layer>above</layer>
 </application>

Offline

#3 2011-09-11 18:40:55

new2arch
Member
Registered: 2008-02-25
Posts: 235

Re: [Solved] "Run" (Alt + F2) in LXDE/ Openbox - runs in the background

Firestone wrote:

The update modified the rc.xml too probably.
I don't know how, or if, LXDE handles this, but on a sole Openbox I use the above layer and the focus option:

 <application name="bashrun">
	<desktop>all</desktop>
	<decor>no</decor>  # switch to yes if you prefer a bordered window
	<focus>yes</focus>
	<skip_pager>yes</skip_pager>
	<layer>above</layer>
 </application>

Thanks for the tip.
In my rc.xml for openbox, I don't have those options.
Here is a snippet from lxde-rc.xml :

    <keybind key="A-F2">
      <action name="Execute">
        <command>lxpanelctl run</command>
      </action>
    </keybind>

Offline

#4 2011-09-12 01:45:44

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: [Solved] "Run" (Alt + F2) in LXDE/ Openbox - runs in the background

Does it still open in the background if you try "lxpanelctl run" from a terminal? Do other launchers open in the background?

Offline

#5 2011-09-12 06:22:03

made_in_nz
Member
From: Wellington, New Zealand
Registered: 2010-01-04
Posts: 48

Re: [Solved] "Run" (Alt + F2) in LXDE/ Openbox - runs in the background

I also have the same issue described by the OP.  When I run "lxpanelctl run" from the terminal the run dialog opens behind any other open windows, the same as when using the keyboard shortcut.  I did notice that if I hit the F2 twice, that is ALT-F2-F2, on the second F2 the run dialog is brought to the front (a second run dialog is not opened).

Offline

#6 2011-09-12 06:38:59

new2arch
Member
Registered: 2008-02-25
Posts: 235

Re: [Solved] "Run" (Alt + F2) in LXDE/ Openbox - runs in the background

anonymous_user wrote:

Does it still open in the background if you try "lxpanelctl run" from a terminal? Do other launchers open in the background?

If I choose "Run" from the main menu it opens in the foreground. But "lxpanelctl run" from terminal it opens in the background.

Perhaps OT but I have the same issues when I use keyboard shortcuts to open PCMANFM.
Strange enough, the terminal opens in the foreground...

Offline

#7 2011-09-12 06:40:01

new2arch
Member
Registered: 2008-02-25
Posts: 235

Re: [Solved] "Run" (Alt + F2) in LXDE/ Openbox - runs in the background

made_in_nz wrote:

[snip] I did notice that if I hit the F2 twice, that is ALT-F2-F2, on the second F2 the run dialog is brought to the front (a second run dialog is not opened).

Nice discovery there. Much better than using Alt+Tab.

Offline

#8 2011-09-18 07:24:55

xitrumch
Member
Registered: 2011-08-28
Posts: 2

Re: [Solved] "Run" (Alt + F2) in LXDE/ Openbox - runs in the background

For those who still having that issue, please add the following lines into your lxde-rc.xml file:

<application name="lxpanel">
        <focus>yes</focus>
</application>
<application name="pcmanfm">
        <focus>yes</focus>
</application>

Where lxpanel is for Alt+F2 and pcmanfm is for your PCMANFM. This line is inserted just before the closing tag of </applications> and </openbox_config>, which is at the end of the file. After that, do a: openbox --reconfigure to apply the settings.
The same thing is apply for any application that is not opened at the top layer (foreground).

Last edited by xitrumch (2011-09-18 09:02:07)

Offline

#9 2011-09-19 13:47:49

new2arch
Member
Registered: 2008-02-25
Posts: 235

Re: [Solved] "Run" (Alt + F2) in LXDE/ Openbox - runs in the background

xitrumch wrote:

For those who still having that issue, please add the following lines into your lxde-rc.xml file:

<application name="lxpanel">
        <focus>yes</focus>
</application>
<application name="pcmanfm">
        <focus>yes</focus>
</application>

Where lxpanel is for Alt+F2 and pcmanfm is for your PCMANFM. This line is inserted just before the closing tag of </applications> and </openbox_config>, which is at the end of the file. After that, do a: openbox --reconfigure to apply the settings.
The same thing is apply for any application that is not opened at the top layer (foreground).

Don't know if I got it right but it doesn't work :

-->
  </applications>
<application name="lxpanel">
        <focus>yes</focus>
</application>
<application name="pcmanfm">
        <focus>yes</focus>
</application>
</openbox_config>

Offline

#10 2011-09-19 14:29:54

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: [Solved] "Run" (Alt + F2) in LXDE/ Openbox - runs in the background

The code has to be before (above) the </applications> tags.

Last edited by anonymous_user (2011-09-19 14:30:05)

Offline

#11 2011-09-20 08:21:31

new2arch
Member
Registered: 2008-02-25
Posts: 235

Re: [Solved] "Run" (Alt + F2) in LXDE/ Openbox - runs in the background

anonymous_user wrote:

The code has to be before (above) the </applications> tags.

Thanks a bunch!

Offline

#12 2011-10-06 22:28:55

newarch2011
Member
Registered: 2011-09-18
Posts: 41

Re: [Solved] "Run" (Alt + F2) in LXDE/ Openbox - runs in the background

new2arch wrote:
xitrumch wrote:

For those who still having that issue, please add the following lines into your lxde-rc.xml file:

<application name="lxpanel">
        <focus>yes</focus>
</application>
<application name="pcmanfm">
        <focus>yes</focus>
</application>

Where lxpanel is for Alt+F2 and pcmanfm is for your PCMANFM. This line is inserted just before the closing tag of </applications> and </openbox_config>, which is at the end of the file. After that, do a: openbox --reconfigure to apply the settings.
The same thing is apply for any application that is not opened at the top layer (foreground).

Don't know if I got it right but it doesn't work :

-->
  </applications>
<application name="lxpanel">
        <focus>yes</focus>
</application>
<application name="pcmanfm">
        <focus>yes</focus>
</application>
</openbox_config>

i have the same issue as the op and i did this for lxpanel and it comes to the front but isnt focused. it is set allt he way at the bottom right above </applications> but my run dialog when it shows up isnt focused correctly.

Offline

Board footer

Powered by FluxBB