You are not logged in.

#1 2003-11-20 10:45:47

toffe
Member
Registered: 2003-11-20
Posts: 18

Setting up modem

Hi all,

Being a Linux newbie I'm very happy that I managed to install Arch and to do some basic configurations. But I don't know how to get my modem working.


I have a PCI winmodem that I believe is set up properly. (I installed drivers from www.linuxant.com/drivers/ and the install script told me "Your HCF modem should now be accessible as /dev/ttySHCF0")

Now I do not have a clue about how to configure it to call my ISP (that doesn't offer Linux support). The problem is that they do not use PAP or CHAP, but check what phone number I am calling from.


I am a total newbie and don't know how to write /etc/ppp/options files or configure my network.


I am greatful for any suggestions or pointers to web resources.
Thanks,

toffe

Offline

#2 2003-11-20 11:39:34

zen_guerrilla
Member
From: Greece
Registered: 2002-12-22
Posts: 259

Re: Setting up modem

$ pacman -S pppconfig
$ pppconfig 

Then copy-paste these files in :

/usr/local/bin/pon

#!/bin/sh

case "$1" in
  -*)
      echo "Usage: pon [provider] [arguments]"
      exit 0
      ;;
esac

if [ -z "$1" -a ! -f /etc/ppp/peers/provider ]; then
  cat << EOF
  
Please configure /etc/ppp/peers/provider or use a command line 
argument to use another file in /etc/ppp/peers/ directory.

EOF
  exit 1
fi

if [ "$1" -a ! -f "/etc/ppp/peers/$1" ]; then
  echo "The file /etc/ppp/peers/$1 does not exist."
  exit 1
fi

exec /usr/sbin/pppd call ${@:-provider}

/usr/local/bin/poff

#!/bin/sh

PID=/var/run/ppp0.pid

if [ -f $PID ]; then
  kill -15 $( cat $PID ) 2>/dev/null
  rm -f $PID
else
  echo "pppd is not running"
  exit 1
fi

'chmod +x' them & pon should bring up your connection, poff should bring it down.
As for the winmodem it should work, I don't have enough experience with them I only managed to setup my crappy laptop's hsf modem using linuxant drivers, so I can't help with it.

Offline

#3 2003-11-20 21:28:48

toffe
Member
Registered: 2003-11-20
Posts: 18

Re: Setting up modem

Thank you for all help -- it got me started.

Unfortunately is this all I get:

[root@myhost root]# /usr/local/bin/pon t2
Using interface ppp0
local  IP address 10.64.64.64
remote IP address 10.112.112.112    <----- it hangs here
Terminating on signal 2.
[root@myhost root]#

It hangs at the remote IP line (I waited surely 10 minutes before pressing Ctrl-C).
I do not know if it is a hardware error or a misconfiguration error.
The strange part is that the modem doesn't "beep".
Is there a way to tell if the modem is working?


Cheers,
toffe

Offline

#4 2003-11-20 21:50:45

zen_guerrilla
Member
From: Greece
Registered: 2002-12-22
Posts: 259

Re: Setting up modem

toffe wrote:

local  IP address 10.64.64.64
remote IP address 10.112.112.112

I guess that you have enabled the demand option on pppd, so remove it. Check 'man pppd' for description of 'demand'.

Offline

#5 2003-11-20 22:26:30

toffe
Member
Registered: 2003-11-20
Posts: 18

Re: Setting up modem

Nope.

Demand is disabled in pppconfig.

-toffe

Offline

#6 2003-11-20 22:29:51

zen_guerrilla
Member
From: Greece
Registered: 2002-12-22
Posts: 259

Re: Setting up modem

Check if it is enabled in /etc/ppp/options or /etc/ppp/peers/t2.

Offline

#7 2003-11-21 08:18:27

toffe
Member
Registered: 2003-11-20
Posts: 18

Re: Setting up modem

Thanks a lot!  I found the demand line in t2.
Now the modem connects to my ISP.

Unfortunately, they do not seem to understand each other.
I believe this is because my ISP doesn't use PAP or CHAP, but merely checks which phone number I am dialing from.
Any suggestions?

[root@myhost root]# /usr/local/bin/pon t2
Serial connection established.
using channel 1
Using interface ppp0
Connect: ppp0 <--> /dev/ttySHCF0
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xd47fd584>]

rcvd [LCP ConfReq id=0xf9 <asyncmap 0xa0000> <magic 0xb0b3b564> <pcomp>
<accomp>]
sent [LCP ConfRej id=0xf9 <pcomp> <accomp>]
rcvd [LCP ConfReq id=0xfa <asyncmap 0xa0000> <magic 0xb0b3b564>]
sent [LCP ConfAck id=0xfa <asyncmap 0xa0000> <magic 0xb0b3b564>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xd47fd584>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xd47fd584>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xd47fd584>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xd47fd584>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xd47fd584>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xd47fd584>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xd47fd584>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xd47fd584>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xd47fd584>]
Modem hangup
Connection terminated.


This is my t2 file if it is to any help:

# This optionfile was generated by pppconfig 2.1.1.
#
#
hide-password
noauth
connect "/usr/sbin/chat -v -f /etc/chatscripts/t2"
debug
/dev/ttySHCF0
115200
defaultroute
noipdefault
user "login"
remotename t2
ipparam t2


toffe

Offline

#8 2003-11-21 14:01:22

zen_guerrilla
Member
From: Greece
Registered: 2002-12-22
Posts: 259

Re: Setting up modem

IMHO your ISP uses MS-CHAP, try adding the following in /etc/ppp/peers/t2:

passive
asyncmap 0

and make sure you selected CHAP in pppconfig. Then,

 cat /etc/ppp/chap-secrets >> /etc/ppp/pap-secrets

The last one may sound stupid but it is what did the job while I was trying to connect to a crappy ISP.

Offline

#9 2003-11-22 09:41:30

toffe
Member
Registered: 2003-11-20
Posts: 18

Re: Setting up modem

Still no success, I am afraid.

When I connect now I don't even get the "IP-lines":

[root@myhost root]# /usr/local/bin/pon t2
Connect script failed
[root@myhost root]#

Fom /var/log/messages:
Nov 22 10:22:18 myhost pppd[200]: pppd 2.4.1 started by root, uid 0
Nov 22 10:22:19 myhost chat[206]: abort on (BUSY)
Nov 22 10:22:19 myhost chat[206]: abort on (NO CARRIER)
Nov 22 10:22:19 myhost chat[206]: abort on (VOICE)
Nov 22 10:22:19 myhost chat[206]: abort on (NO DIALTONE)
Nov 22 10:22:19 myhost chat[206]: abort on (NO DIAL TONE)
Nov 22 10:22:19 myhost chat[206]: abort on (NO ANSWER)
Nov 22 10:22:19 myhost chat[206]: abort on (DELAYED)
Nov 22 10:22:19 myhost chat[206]: send (ATZ^M)
Nov 22 10:22:19 myhost chat[206]: expect (OK)
Nov 22 10:22:19 myhost chat[206]: ATZ^M^M
Nov 22 10:22:19 myhost chat[206]: OK
Nov 22 10:22:19 myhost chat[206]:  -- got it
Nov 22 10:22:19 myhost chat[206]: send (ATDT0780101010^M)
Nov 22 10:22:19 myhost chat[206]: expect (dc)
Nov 22 10:22:19 myhost chat[206]: ^M
Nov 22 10:22:48 myhost chat[206]: ATDT0780101010^M^M
Nov 22 10:22:48 myhost chat[206]: CONNECT 115200 ^M
Nov 22 10:22:54 myhost chat[206]: ~^?}#@!}!0} }4}"}&} }*} }
}%}&}-*sb}'}"}(}"kg~
~^?}#@!}!1} }4}"}&} }*} } }%}&}-*sb}
Nov 22 10:22:58 myhost chat[206]: '}"}(}""t~~^?}#@!}!2} }4}"}&} }*} }
}%}&}-*sb}
'}"}(}"hI~~^?}#@!}!3} }4}"}&} }*} }
Nov 22 10:23:02 myhost chat[206]: }%}&}-*sb}'}"}(}"!Z~~^?}#@!}!4} }4}"}&}
}*} }
}%}&}-*sb}'}"}(}"m:~~^?}#@!}!5} }4}"
Nov 22 10:23:04 myhost chat[206]: alarm
Nov 22 10:23:04 myhost chat[206]: Failed
Nov 22 10:23:05 myhost pppd[200]: Exit.


I have probably something really stupid in one of the config files, so I posted all I thought were important at http://www.dtek.chalmers.se/~toffe/ppp/.


toffe

Offline

#10 2003-11-22 10:06:24

zen_guerrilla
Member
From: Greece
Registered: 2002-12-22
Posts: 259

Re: Setting up modem

Replace your /etc/ppp/options with :

# General configuration options for PPPD:
lock
defaultroute
noipdefault
modem
/dev/ttySHCF0
115200
crtscts
# Uncomment the line below for more verbose error reporting:
#debug
noauth
passive
asyncmap 0

and make sure to the read the man page of pppd, to find out yourself why the options included in your options file weren't useful smile.

Offline

#11 2003-11-23 10:26:24

toffe
Member
Registered: 2003-11-20
Posts: 18

Re: Setting up modem

I am probably really really stupid but I still can't get the modem to connect!

I changed options the way you suggested.
Now I do not get the "connect script failed" line, but otherwise it looks the same to me.

[root@myhost root]# /usr/local/bin/pon t2
Connect script failed
[root@myhost root]#


From /var/log/messages/

Nov 23 10:44:32 myhost pppd[171]: pppd 2.4.1 started by root, uid 0
Nov 23 10:44:33 myhost chat[172]: abort on (BUSY)
Nov 23 10:44:33 myhost chat[172]: abort on (NO CARRIER)
Nov 23 10:44:33 myhost chat[172]: abort on (VOICE)
Nov 23 10:44:33 myhost chat[172]: abort on (NO DIALTONE)
Nov 23 10:44:33 myhost chat[172]: abort on (NO DIAL TONE)
Nov 23 10:44:33 myhost chat[172]: abort on (NO ANSWER)
Nov 23 10:44:33 myhost chat[172]: abort on (DELAYED)
Nov 23 10:44:33 myhost chat[172]: send (ATZ^M)
Nov 23 10:44:33 myhost chat[172]: expect (OK)
Nov 23 10:44:33 myhost chat[172]: ATZ^M^M
Nov 23 10:44:33 myhost chat[172]: OK
Nov 23 10:44:33 myhost chat[172]:  -- got it
Nov 23 10:44:33 myhost chat[172]: send (ATDT0780101010^M)
Nov 23 10:44:33 myhost chat[172]: expect (dc)
Nov 23 10:44:33 myhost chat[172]: ^M
Nov 23 10:45:02 myhost chat[172]: ATDT0780101010^M^M
Nov 23 10:45:02 myhost chat[172]: CONNECT 115200 ^M
Nov 23 10:45:08 myhost chat[172]: ~^?}#@!}!%} }4}"}&} }*} } }%}&;h}"A}'}"}(}"-S~~^?}#@!}!&} }4}"}&} }*} } }%}&;h}"A}
Nov 23 10:45:12 myhost chat[172]: '}"}(}"gn~~^?}#@!}!'} }4}"}&} }*} } }%}&;h}"A}'}"}(}".}]~~^?}#@!}!(} }4}"}&} }*} }
Nov 23 10:45:16 myhost chat[172]:  }%}&;h}"A}'}"}(}"n'~~^?}#@!}!)} }4}"}&} }*} } }%}&;h}"A}'}"}(}"'4~~^?}#@!}!*} }4}
Nov 23 10:45:18 myhost chat[172]: alarm
Nov 23 10:45:18 myhost chat[172]: Failed
Nov 23 10:45:19 myhost pppd[171]: Exit.


What on earth do the lines with with "~^?}#@!}...." mean?

-toffe

Offline

#12 2003-11-23 11:04:39

zen_guerrilla
Member
From: Greece
Registered: 2002-12-22
Posts: 259

Re: Setting up modem

2 suggestions :
- Your modem is not functioning as it should, under linux.
- Your ISP doesn't use either CHAP or PAP but terminal auth.

Check it out or even better contact their tech support for more info. I don't think I can help you more.

Offline

#13 2003-11-23 15:17:58

toffe
Member
Registered: 2003-11-20
Posts: 18

Re: Setting up modem

OK, thanks for your patience with me and all suggestions!

-toffe

Offline

#14 2003-11-26 02:09:25

rasat
Forum Fellow
From: Finland, working in Romania
Registered: 2002-12-27
Posts: 2,176
Website

Re: Setting up modem

I have EDITED this post (asking help about Kppp jaming my dial tune) related to topic in General Discussion:
http://bbs.archlinux.org/viewtopic.php?t=1721

I got my Kppp (KDE dialer) to work. If it was because of the new update of ppp (ver. 2.4.1-4) with libpcap-0.7.2-1 or my new external serial 56k modem, I am not sure. Whatever, the update has more configure files.

Here is a simple Wvdial configure website:
http://support.real-time.com/linux/dial … #configure

Offline

#15 2003-11-26 12:30:57

zen_guerrilla
Member
From: Greece
Registered: 2002-12-22
Posts: 259

Re: Setting up modem

rasat wrote:

If it was because of the new update of ppp (ver. 2.4.1-4) with libpcap-0.7.2-1 or my new external serial 56k modem, I am not sure. Whatever, the update has more configure files.

The libpcap depend is used to enable active-filtering (man pppd for more info about it).

toffe: Upgrade to the new ppp, removing/renaming your old options file first & try again.

Offline

Board footer

Powered by FluxBB